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Can Combustor
This tutorial creates a mesh for a can combustor, which can be found in gas turbine engines. The geo-
metry is complex and consists of five separate solid bodies. It will be imported as a complete geometry
from a Parasolid file.

The diagram below shows the geometry schematically with part of the outer wall cut away.

1
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The following geometry and meshing features are illustrated:

• Parasolid import

• Multibody part formation

• Named Selection creation

• Program Controlled inflation

Preparation

This tutorial requires you to have a copy of the Parasolid file Combustor.x_t.

To prepare for running this tutorial:

1. Set up a working folder on the computer you will be using.

2. Download the cancombustor.zip file here.

3. Unzip the cancombustor.zip file you have downloaded to your working folder.

You can proceed to Tutorial Setup (p. 3).

Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
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Tutorial Setup

The following sections describe the steps for creating the project and importing the geometry:

Creating the Project

Importing the Geometry

Creating the Project

1. Open Ansys Workbench and add a standalone Mesh system to the Project Schematic. Save the
project as Combustor.wbpj.

2. Now add geometry to the project.

On the Project Schematic, right-click the Geometry cell in the Mesh system and select New
DesignModeler Geometry... to open the DesignModeler application.

3. In the main menu of the DesignModeler application, choose Units>Centimeter.

Importing the Geometry

The geometry is imported complete, from a Parasolid file.

1. Import the geometry.

a. Select File > Import External Geometry File... from the main menu.

b. In the file browser that opens, locate and open the file Combustor.x_t.

c. Click Generate  to import the combustor.

2. Create a multibody part.

The Tree Outline should now show that you have 5 Parts, 5 Bodies. To produce a single mesh
that contains all of the bodies rather than one mesh per body, the parts must be combined into
a multibody part.

a. On the toolbar at the top of the window, click Selection Filter: Bodies . This means that
you can select only solid bodies in the next operation, which helps to make the selection
process easier.

b. Click Select Mode  and select Box Select from the drop-down menu.

c. In the Geometry window, select all five bodies by holding down the left mouse button and
dragging a box from left to right across the whole geometry to select all five bodies. To be
selected, all of the entities must lie completely within the box that you have drawn. When
you release the mouse button, the status bar located along the bottom of the window
should change to show that 5 Bodies are selected.

When using Box Select, the direction that you drag the mouse from the starting point de-
termines which items are selected. Dragging to the right to form the box selects entities

3
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that are completely enclosed by the box, while dragging to the left to form the box selects
all entities that intersect, or touch, the box.

d. Right-click in the Geometry window and select Form New Part.

The Tree Outline should now show that you have 1 Part, 5 Bodies.

The geometry does not need further modifications. It is now complete. From the DesignModeler ap-
plication's main menu, select File > Save Project to save the project and then File > Close Design-
Modeler to return to the Project Schematic. Notice the Geometry cell appears in an up-to-date state

.

Now that the geometry is complete, you can proceed to Generating the Mesh (p. 4).

Generating the Mesh

The following sections describe the steps for generating the mesh:

Launching the Meshing Application

Creating Named Selections

Setting Up the Mesh

Setting Up Inflation

Generating the Mesh

Launching the Meshing Application

On the Project Schematic, right-click the Mesh cell in the Mesh system and select Edit... to launch
the Meshing application.

Creating Named Selections

You will create five Named Selections in this tutorial. Detailed instructions are provided for creating
the first Named Selection. Less detailed instructions are provided for creating the subsequent Named
Selections, but you should create them in a similar fashion, using additional zoom and/or rotation
options from the toolbar as needed.

1. To create a Named Selection for the fuel inlet, select the six tiny faces on the cone near the
bottom of the combustor. The easiest way to select them is as follows:

a. Click over the axes in the bottom right corner of the Geometry window in the position
shown in the figure below. As you move the cursor into this position, the black “-Z”-axis will
appear (it is not shown by default). This will put the geometry into a good position for
picking the required faces.

b. On the toolbar, click Box Zoom .

Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
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c. In the Geometry window, zoom the geometry by holding down the left mouse button and
dragging a box across the area where the six tiny faces are located. Then release the mouse
button.

d. On the toolbar, click Face .

e. Press and hold the Ctrl key while picking the six faces, which are shown in green in the
figure below (the colors in your geometry may differ from those shown in this tutorial).

f. After selecting all six faces, release the Ctrl key. Right-click in the Geometry window and
select Create Named Selection from the menu.

g. In the Selection Name dialog box, type fuel_inlet and click OK.

2. To create a Named Selection for the air inlet, select the eight faces at the very bottom of the
geometry having the lowest Z-coordinate, as shown below. Name this Named Selection air_inlet.

5
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3. To create a Named Selection for the secondary air inlet, select the six small circular faces on the
main body of the combustor, as shown below. These introduce extra air to aid combustion. Name
this Named Selection secondary_air_inlet.

4. To create a Named Selection for the outlet, select the rectangular face with the highest Z-coordin-
ate. Name this Named Selection outlet.

5. Create the last Named Selection, internal.

The faces that you need to select for this Named Selection are not easily seen. The next several
steps help to make the selection process easier.

a. In the Tree Outline, click the Named Selection called air_inlet. In the Details View, change
the value of Visible to No.

Look into the combustor inlet. You should see eight curved vanes surrounding the fuel inlet,
as shown below. Rotate the view slightly and note that every other vane passage is blocked
by faces.
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b. From the main menu, select Tools> Options. In the left pane of the Options dialog box,
click the plus sign to expand the Mechanical options. Highlight Graphics, and then in the
right pane, set Highlight Selection to Both Sides and click OK.

c. On the toolbar, click Face .

d. Press and hold the Ctrl key while picking the eight faces of the vanes, as shown below.

e. After selecting all eight faces, release the Ctrl key. Right-click in the Geometry window and
select Hide Face(s) from the menu.

f. To create the last Named Selection, select the four faces that block the vane passages, as
shown below. Name this Named Selection internal.
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Note:

You are done creating Named Selections. The next step toggles visibility of all faces
back on.

6. Restore the visibility of all faces.

a. In the Tree Outline, click the Named Selection called air_inlet. In the Details View, change
the value of Visible to Yes.

b. Right-click in the Geometry window and select Show Hidden Face(s) from the menu.

Setting Up the Mesh

This is a complex geometry which will be used to run a simulation with complex physics. To keep
the computational time down for the purposes of the tutorial, the default sizing settings will be retained
and a very coarse mesh will be generated. If you wanted to get accurate results for the geometry, a
much finer mesh and a much longer solution time would be required.

1. In the Tree Outline, click the Mesh object.

2. In the Details View, set Physics Preference to CFD and Solver Preference to CFX.

3. In the Details View, click to expand the Sizing group of controls and notice the default sizing
settings.

Setting Up Inflation

It is a good idea to put inflation on the walls.

1. In the Details View, click to expand the Inflation group of controls.

2. Set Use Automatic Inflation to Program Controlled.
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As a result of this setting, all faces in the model are selected to be inflation boundaries, with a few
exceptions. For the purposes of this tutorial, the important exception is Named Selections—the faces
in Named Selections will not be selected to be inflation boundaries.

Generating the Mesh

1. Generate the mesh by right-clicking Mesh in the Tree Outline and selecting Generate Mesh.
After a few moments, the meshed model appears in the Geometry window, as shown below.

2. Activate a section plane to view a section cut through the model. Select Show Whole Elements

 to view the mesh as shown.
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This completes the mesh generation. Note that you may have received a warning about a problem
with inflation layer generation. This warning is common when using an automated inflation setup
with coarse mesh as the inflation layers do not have adequate room for orthogonal inflation layer
growth. This warning(s) can generally be ignored unless you are very concerned with near wall
physics. Should this be the case, more selective inflation and/or the use of local size functions should
resolve the issue.

From the Meshing application's main menu, select File > Save Project to save the project and then
File > Close Meshing to return to the Project Schematic.

You can exit Ansys Workbench by selecting File > Exit from the main menu.
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Single Body Inflation
This tutorial demonstrates various ways to apply single body inflation. The 3D inflation capability
provided by the Meshing application is mainly used in CFD/Fluids meshing. It provides high quality
mesh generation close to wall boundaries to resolve changes in physical properties.

Essentially, there are two methods for applying inflation: globally, using Named Selections; and locally,
by scoping an inflation method. This tutorial covers using these methods along with various other settings
for defining inflation on a single body.

The following topics are covered:

• Comparing two Collision Avoidance settings (Layer Compression and Stair Stepping), which de-
termine the approach that is to be taken in areas of proximity

• Previewing inflation, which can be used to examine proximity handling, determine the quality of in-
flation layers, and detect potential quality issues

• Creating a new Named Selection, and automatically applying inflation to all the faces in it

• Scoping inflation to a body and selecting a Named Selection as the inflation boundary

• Comparing three Inflation settings (Smooth Transition, Total Thickness, and Last Aspect Ratio),
which determine the heights of the inflation layers

• Changing Solver Preference and how its value affects default inflation behaviors

Preparation

This tutorial requires you to have a copy of the Ansys Workbench project file newquart.wbpj and
the project folder newquart_files and its contents.

To prepare for running this tutorial:

1. Set up a working folder on the computer you will be using.

2. Download the newquart.zip file here.

3. Unzip the newquart.zip file you have downloaded to your working folder.

You can proceed to Tutorial Setup (p. 11).

Tutorial Setup

1. Open Ansys Workbench.
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2. Select File > Open... from the main menu.

3. In the file browser that opens, locate and open the file newquart.wbpj.

Now that the tutorial is set up, you can proceed to Generating the Mesh (p. 12).

Generating the Mesh

The following sections describe the steps for generating the mesh:

Launching the Meshing Application

Setting the Unit System

Program Controlled Inflation Using the Fluent Solver

Program Controlled Inflation Using the Ansys CFX-Solver

Program Controlled Inflation Scoped to All Faces in a Named Selection

Scoped Inflation

Launching the Meshing Application

On the Project Schematic, right-click the Mesh cell in the Mesh system and select Edit... to launch
the Meshing application.

Setting the Unit System

On the main menu, click Units and select Metric (mm, kg, N, s, mV, mA).

Program Controlled Inflation Using the Fluent Solver

This part of the tutorial demonstrates the use of Program Controlled inflation with the Fluent solver.

Notice that three Named Selections are defined already: Symmetry, Inlet, and Outlet. You will create
a fourth later in this tutorial.

1. In the Tree Outline, click the Mesh object.

In the Details View, notice that Solver Preference is set to Fluent.

2. Click to expand the Sizing group of controls and change Curvature Normal Angle to 12.

3. Click to expand the Inflation group of controls.

Notice that Program Controlled and Smooth Transition are selected and Transition Ratio is
set to 0.272 by default.

With Program Controlled inflation, inflation will be added to all external faces for which a Named
Selection has not been defined.

When Solver Preference is Fluent, the default Transition Ratio is 0.272 because the solver
uses a cell-centered scheme. This is in contrast to the CFX Solver Preference, which is covered
later in this tutorial.
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4. Change Maximum Layers to 5.

5. In the Tree Outline, right-click Mesh and select Preview > Inflation. Previewing inflation helps
to identify possible problems with inflation before generating a full mesh.

After a few moments, a preview of the inflation layers appears in the Geometry window, as
shown below.

Because the Fluent solver was used, the meshing process used the Layer Compression method
for Collision Avoidance by default.

Note:

Notice that the mesh is colored pink. Because the pre-inflation mesh is not a final
mesh, it is considered “obsolete", and will remain obsolete until a new mesh is gener-
ated. The mesh coloring helps to differentiate between partial and final meshes when
you have a fully meshed set of parts and apply pre-inflation or other new boundaries
on some of the parts.

6. Zoom and reposition the model to get a better view of the compressed layers in the area of in-
terest.
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Notice the heights of the inflation layers, which are determined by the setting of the Inflation
Option control. The Smooth Transition option, which was used here, uses the local tetrahedral
element size to compute each local initial height and total height so that the rate of volume
change is smooth.

Each triangle that is being inflated will have an initial height that is computed with respect to
its area, averaged at the nodes. This means that for a uniform mesh, the initial heights will be
roughly the same, while for a varying mesh, the initial heights will vary.

7. On the toolbar, click Zoom To Fit .

8. In the Tree Outline, right-click Mesh and select Clear Generated Data.

9. Click Yes to clear the data.

Program Controlled Inflation Using the Ansys CFX-Solver

This part of the tutorial demonstrates the use of Program Controlled inflation with the CFX solver.

1. In the Details View, change Solver Preference to CFX.

Notice the value of Transition Ratio has changed from 0.272 to 0.77 automatically.

When Solver Preference is CFX, the default Transition Ratio is 0.77 because the solver uses a
vertex-centered scheme. Increasing the ratio creates a thicker boundary layer.
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2. In the Tree Outline, right-click Mesh and select Generate Mesh.

After a few moments, the mesh appears in the Geometry window, as shown below.

The inflation layers look different in this mesh because the CFX solver uses the Stair Stepping
method of Collision Avoidance by default.

3. Zoom and reposition the model to get a better view of the stair stepped layers in the narrow
region.
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4. On the toolbar, click Zoom To Fit .

5. In the Tree Outline, right-click Mesh and select Clear Generated Data.

6. Click Yes to clear the data.

Program Controlled Inflation Scoped to All Faces in a Named Selection

This part of the tutorial demonstrates the use of Program Controlled inflation scoped to all faces in
a Named Selection that you create.

1. Create the Named Selection.

a. Rotate the body so that it is positioned as shown below.
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There are 10 faces that you need to select in all.

b. Select the first eight faces, as shown below.

i. Click Face .

ii. On the keyboard, press and hold Ctrl.

iii. Select the first eight faces, as shown below.
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c. To select the remaining two faces, rotate the body so that it is positioned as shown below.

Note:

The model you see may look different than what is shown in the image below.
The differences are explained in the next steps.
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When the image above was captured, the Draw Face Mode option was set to Auto Face
Draw (the default). The Draw Face Mode option determines whether face culling is turned
on or off:

• Auto Face Draw (default) - Turning back-face culling on or off is program controlled.

• Draw Front Faces - Face culling is forced to stay on. Back-facing faces are not drawn.

• Draw Both Faces - Back-face culling is turned off. Both front-facing and back-facing faces
are drawn.

In the image above, the default setting resulted in face culling being forced to stay on, so
that back-facing faces were not drawn (that is, it is behaving the same way that the Draw
Front Faces setting would behave). This makes it easier to identify the faces that still need
to be selected. However, because the default setting is program controlled based on other
features and options you may have set, you may or may not need to manually select Draw
Front Faces to proceed with this tutorial. That is, if the model you see looks like this:
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i. Click Face .

ii. Press and hold Ctrl.

iii. Select the last two faces as shown below.
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d. Right-click in the Geometry window and select Create Named Selection.

e. In the Selection Name dialog box, type Wall and click OK.

2. In the Tree Outline, click Wall to display the new Named Selection in the Geometry window.

3. In the Tree Outline, click Mesh.

4. In the Details View, change Solver Preference to Fluent.

5. In the Inflation group, change Use Automatic Inflation to All Faces in Chosen Named Selection.

6. For Named Selection, select Wall.

7. Change Inflation Option to Total Thickness.

The Total Thickness option creates constant inflation layers using the values of the Number of
Layers and Growth Rate controls to obtain a total thickness as defined by the Maximum
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Thickness control. Unlike inflation with the Smooth Transition option, with Total Thickness
the thickness of the first inflation layer and each subsequent layer is constant.

8. Set Maximum Thickness to 5.

9. In the Tree Outline, right-click Mesh and select Generate Mesh.

After a few moments, the mesh appears in the Geometry window, as shown below.

10. Zoom and reposition the model to get a better view of the inflation layers in the narrow region.
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11. On the toolbar, click Zoom To Fit .

12. In the Tree Outline, right-click Mesh and select Clear Generated Data.

13. Click Yes to clear the data.

Scoped Inflation

This section of the tutorial demonstrates scoping inflation to a body and selecting a Named Selection
to act as the inflation boundary.

1. In the Tree Outline, click Mesh.

2. On the toolbar, click Body .

3. Select the body in the Geometry window.

4. Right-click in the Geometry window and select Insert > Inflation.

In the Details View, notice that inflation will be scoped to 1 Body.

5. In the Details View, set Boundary Scoping Method to Named Selections.
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6. From the Boundary drop-down menu, select Wall by highlighting it in the drop-down menu
and then pressing Enter.

7. Change Inflation Option to Last Aspect Ratio.

The Last Aspect Ratio option creates inflation layers using the values of the First Layer Height,
Maximum Layers, and Aspect Ratio (Base/Height) controls. With this option, the heights of
the inflation layers are determined by the aspect ratio of the inflations that are extruded from
the inflation base. The aspect ratio is defined as the ratio of the local inflation base size to the
inflation layer height.

8. Set First Layer Height to 0.5.

9. You are now finished setting the scoped (local) inflation controls. In the Tree Outline, click Mesh
to return to the global inflation controls.

10. In the Details View, change Solver Preference to CFX.

11. Change Use Automatic Inflation to None.

12. In the Tree Outline, right-click Mesh and select Preview > Inflation.

After a few moments, the mesh appears in the Geometry window, as shown below.
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13. Zoom and reposition the model to get a better view of the inflation layers.
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This completes the tutorial. From the Meshing application's main menu, select File > Save Project
to save the project and then File > Close Meshing to return to the Project Schematic.

You can exit Ansys Workbench by selecting File > Exit from the main menu.
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Mesh Controls and Methods
This tutorial creates a mesh for a piston. The geometry will be imported as a complete geometry from
a Parasolid file. The tutorial uses the model of the piston to demonstrate various mesh controls and
methods that are available in the Meshing application.

The following topics are covered:

• Parasolid import

• Batch meshing

• Automatic mesh method (Patch Conforming Tetrahedral and Sweep)

• Defeaturing and local (scoped) sizing

• Mapped face meshing

• MultiZone mesh method

• Section planes

Preparation

This tutorial requires you to have a copy of the Parasolid file PISTON.x_t.

To prepare for running this tutorial:

1. Set up a working folder on the computer you will be using.

2. Download the piston.zip file here.

3. Unzip the piston.zip file you have downloaded to your working folder.

You can proceed to Tutorial Setup (p. 27).

Tutorial Setup

The following sections describe the steps for creating the project and importing the geometry:

Creating the Project

Importing the Geometry

Creating the Project

1. Open Ansys Workbench and add a standalone Mesh system to the Project Schematic.
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The Mesh system contains a Mesh system header and two cells. Notice the system name that is
located below the system defaults to Mesh.

2. To change the system name, right-click the Mesh system header and select Rename. The name
that appears below the system is now editable. Type Piston and press Enter to rename the
system Piston.

3. Save the project as Piston.wbpj.

Importing the Geometry

The geometry is imported complete, from a Parasolid file.

1. Now add geometry to the project. On the Project Schematic, right-click the Geometry cell in the
Mesh system and select Import Geometry > Browse....

2. In the file browser that opens, locate and open the file PISTON.x_t.

The geometry is complete and does not need modifications. Notice the Geometry cell in the Mesh

system has an up-to-date state .

Now that the tutorial is set up, you can proceed to Generating the Mesh (p. 28).

Generating the Mesh

The following sections describe the steps for generating the mesh:

Running the Meshing Application in Batch Mode

Launching the Meshing Application

Setting the Unit System

Showing Sweepable Bodies

Using Defeaturing and Local Sizing

Defining Mapped Face Meshing

Using the MultiZone Mesh Method

Defining a Section Plane

Running the Meshing Application in Batch Mode

Meshing in batch mode requires less RAM.

On the Project Schematic, right-click the Mesh cell in the Mesh system and select Update to mesh
the geometry in batch mode.

After a short wait, the meshing process is complete. Notice the Mesh cell in the Mesh system has an

up-to-date state .

Launching the Meshing Application

Launch the Meshing application to view the mesh and define mesh controls.
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1. Right-click the Mesh cell in the Mesh system and select Edit....

2. When the Meshing application opens, click the Mesh object in the Tree Outline to view the
meshed model in the Geometry window as shown below.

Since no mesh controls have been set, the Automatic mesh method was used by default. When
the Automatic method is used, bodies are swept if possible, and the remaining bodies are meshed
with the Patch Conforming Tetrahedral mesh method.

Setting the Unit System

On the main menu, click Units and select Metric (m, kg, N, s, V, A).

Showing Sweepable Bodies

This part of the tutorial demonstrates how to view the bodies that were swept. As an alternative, you
can view sweepable bodies prior to meshing.

1. In the Tree Outline, right-click Mesh and select Show > Sweepable Bodies.

The sweepable bodies are highlighted in the Geometry window.

2. To hide all non-sweepable bodies for a better view of the sweepable bodies, right-click on the
Geometry window and select Hide All Other Bodies.
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Only the bodies that were meshed with the sweep method appear in the Geometry window,
as shown below.

3. Right-click in the Geometry window and select Show All Bodies.

All bodies re-appear in the Geometry window.

4. In the Tree Outline, right-click Mesh and select Show > Sweepable Bodies again.

5. Right-click the Geometry window and select Hide Body.

Now only the sweepable bodies are hidden. Those bodies that remain in the Geometry window
were meshed with the Patch Conforming Tetrahedral method.

Using Defeaturing and Local Sizing

Thin regions of the model can create poor quality mesh and/or increase the mesh size. This part of
the tutorial demonstrates how to use local sizing and defeaturing to get a better quality mesh on
regions of interest.

1. On the toolbar, click Body .

2. In the Geometry window, select the top of the piston as shown below.
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3. Right-click in the Geometry window and select Hide All Other Bodies.

4. Rotate and zoom in on the underside of the geometry so that the model is positioned as shown
below. Notice the thin regions at the bottom of the model and how the mesh conforms to the
small patches..
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5. Use local sizing with defeaturing to generate better quality elements.

a. In the Tree Outline, right-click Mesh and select Insert > Sizing.

b. On the toolbar, click Face .

c. On the keyboard, press and hold Ctrl.

d. In the Geometry window, select the faces as shown below.

Note that double-clicking a face will select that face and the attached ones up to the angle.
Rotate the model to select the faces on the other side.
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e. In the Details View, click to Apply the selection. Verify that the Sizing is scoped to 20 Faces.

f. Set Defeature Size to 0.002 m.

6. In the Tree Outline, right-click Mesh and select Update .

7. In the Tree Outline, click Mesh.

Notice the defeaturing removed the thin, poor quality mesh, thereby reducing the element count.
Also, the narrow faces are defeatured.
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8. Right-click the Geometry window and select Show All Bodies.

9. On the triad located in the lower right corner of the Geometry window, click the sphere to return
the view to isometric.

Defining Mapped Face Meshing

This part of the tutorial demonstrates how to use Face Meshing controls to create a mapped face
meshing. Face Meshing controls for mapped meshing attempt to generate a mapped mesh on selected
faces. The Meshing application determines a suitable number of divisions for the edges on the
boundary face automatically. If you specify the number of divisions on the edge with a Sizing control,
the Meshing application attempts to enforce those divisions.

1. On the toolbar, click Body .

2. In the Geometry window, select the bottom of the piston as shown below.
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3. Right-click in the Geometry window and select Hide All Other Bodies.

4. Rotate and zoom the geometry so that the model is positioned as shown below.

5. In the Tree Outline, right-click Mesh and select Insert >Face Meshing. In the Details View,
Mapped Mesh is set to Yes as the default.

a. In the Geometry window, select the face as shown below.
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b. In the Details View, click Apply.

c. In the Tree Outline, right-click Mesh and select Update.

Notice the changes in the mesh.

6. In the Tree Outline, right-click Mesh and select Insert > Face Meshing again.

a. In the Geometry window, select the small face as shown below.

b. In the Details View, click Apply.

c. In the Tree Outline, right-click Mesh and select Update.

Notice the changes in the mesh.
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7. In the Geometry window, right-click and select Show All Bodies.

8. On the triad located in the lower right corner of the Geometry window, click the sphere to return
the view to isometric.

Using the MultiZone Mesh Method

This part of the tutorial demonstrates how to obtain a MultiZone mesh for one of the bodies in the
piston.

1. Select the bolt on the bottom left.

a. On the toolbar, click Body .

b. In the Geometry window, select the bolt as shown below.
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c. Right-click in the Geometry window and select Hide All Other Bodies.

d. Rotate and zoom the geometry so that the model is positioned as shown below.
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2. Insert virtual cells.

a. In the Tree Outline, right-click Model (A3) and select Insert > Virtual Topology.

b. Click Face .

c. On the keyboard, press and hold Ctrl.

d. Select the top three faces as shown below.

e. Right-click in the Geometry window and select Insert > Virtual Cell.
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f. Rotate the bolt so that it is positioned as shown below.

g. Click Face .

h. On the keyboard, press and hold Ctrl.

i. Select the bottom and bottom ridge of the top of the bolt as shown below. There are five
faces to select—one for the bottom and four that make up the ridge.

j. Right-click in the Geometry window and select Insert > Virtual Cell.

k. Position the bolt as shown below.
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l. Click Face .

m. On the keyboard, press and hold Ctrl.

n. Select the bottom three faces of the bolt as shown below.

o. Right-click in the Geometry window and select Insert > Virtual Cell.
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3. Set up the MultiZone method for the bolt

a. In the Tree Outline, right-click Mesh and select Insert > Method.

b. In the Geometry window, select the bolt.

c. In the Details View, click Apply.

d. In the Details View, change Method to MultiZone.

e. Change Src/Trg Selection to Manual Source.

There are three source faces to select.

i. Click Face .

ii. On the keyboard, press and hold Ctrl.

iii. Select the first two faces as shown below.

iv. Reposition the bolt so you will be able to pick the topmost face.

v. Click Face .

vi. On the keyboard, press and hold Ctrl.

vii. Select the third face as shown below.
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viii. In the Details View, click to Apply your selections.

4. On the toolbar, click Update .

5. In the Tree Outline, click Mesh.

Notice the changes to the mesh. By inserting the MultiZone method for the bolt, a mesh composed
of mostly hexahedral elements was obtained. The mesh obtained is rather coarse. Next, define
a local sizing control for a finer mesh and increased solution accuracy.

6. Define local sizing.

a. In the Tree Outline, right-click Mesh and select Insert > Sizing.

b. On the toolbar, click Body .

c. In the Geometry window, select the bolt.

d. In the Details View, click Apply.

e. Set Element Size to 0.001.

f. In the Tree Outline, right-click Mesh and select Update.

Notice the changes to the mesh.
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Defining a Section Plane

This part of the tutorial demonstrates how to activate a section plane to view a section cut through
the bolt.

1. Reposition the bolt as shown below.
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2. On the toolbar, click New Section Plane .

3. Press the left mouse button and drag a line down the center of the bolt to slice it in half. Rotate
the geometry to view the section cut.

This completes the tutorial. From the Meshing application's main menu, select File > Save Project
to save the project and then File > Close Meshing to return to the Project Schematic.

You can exit Ansys Workbench by selecting File > Exit from the main menu.
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Sizing Options
This tutorial illustrates the use of the Meshing application's Sizing Options. This feature allows for
greater control over global sizing options, including the following properties:

• Angles between normals for adjacent mesh elements (Curvature-type sizing)

• Number of mesh elements employed in the gaps between two geometric entities (Proximity-type
sizing)

• Gradation between minimum and maximum sizes based on a specified growth rate

During the tutorial, the influence of each of the following sizing options on a mesh will be demonstrated:

• Uniform

• Proximity

• Curvature

• Proximity and Curvature

Preparation

This tutorial requires you to have a copy of the Ansys Workbench project file nacelle.wbpj and the
project folder nacelle_files and its contents.

To prepare for running this tutorial:

1. Set up a working folder on the computer you will be using.

2. Download the nacelle.zip file here.

3. Unzip the nacelle.zip file you have downloaded to your working folder.

You can proceed to Tutorial Setup (p. 47).

Tutorial Setup

1. Open Ansys Workbench.

2. Select File > Open... from the main menu.

3. In the file browser that opens, locate and open the file nacelle.wbpj.

Now that the tutorial is set up, you can proceed to Generating the Mesh (p. 48).
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Generating the Mesh

The following sections describe the steps for generating the mesh:

Launching the Meshing Application

Setting the Unit System

Expanding the Sizing Controls

Adaptive Sizing

Using Uniform Sizing

Using Proximity-Based Sizing

Using Curvature-Based Sizing

Using Both Proximity and Curvature-Based Sizing

Launching the Meshing Application

On the Project Schematic, right-click the Mesh cell in the Mesh system and select Edit... to launch
the Meshing application.

Setting the Unit System

On the main menu, click Units and select Metric (m, kg, N, s, V, A).

Expanding the Sizing Controls

1. In the Tree Outline, click Mesh.

2. In the Details View, click to expand the Sizing group of controls. Notice that Use Adaptive Sizing
is set to No and Capture Curvature is enabled. Capture Curvature is the default when Physics
Preference is set to CFD and Solver Preference is set to Fluent.

Adaptive Sizing

When Use Adaptive Sizing is set to Yes, the mesher uses the value of the element size to determine
a starting point for the mesh size. The value of the element size can either be computed by the
mesher automatically or be user-defined.

It is not recommended to use Adaptive sizing as the resulting mesh quality is not as good as mesh
generated using other sizing options.

Using Uniform Sizing

In this part of the tutorial, you will use Uniform sizing. With this setting, the following factors contribute
to the final mesh distribution:

• Max Size

• Growth Rate
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1. In the Details View, set Capture Curvature to No.

Ensure that Capture Proximity is also set to No.

2. Insert a sizing control.

a. In the Tree Outline, right-click Mesh and select Insert > Sizing.

b. Rotate the geometry so that it is positioned as shown below.

c. Zoom the geometry as shown below.
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d. On the toolbar, click Face .

e. Select the narrow face as shown below.

f. In the Details View, click Apply to complete the selection.

g. Set Element Size to 0.01.

h. Set Behavior to Hard.
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3. Insert a second sizing control. In the Tree Outline, right-click Mesh and select Insert > Sizing.

a. Reposition the geometry so that it is positioned as shown below.

b. Click Face .

c. On the keyboard, press and hold Ctrl.

d. There are eight faces that you need to select. Click the first three faces, as shown below.

e. To select the remaining five faces, rotate the geometry so that it is positioned as shown
below.
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f. Click Face .

g. Press and hold Ctrl.

h. Select the remaining five faces as shown below.

i. In the Details View, click Apply to complete the selection.

In the Details View, the Geometry field should contain the text 8 Faces.

j. Set Element Size to 0.05.

k. Set Growth Rate to 1.2.

4. In the Tree Outline, right-click Mesh and select Generate Mesh.

After a few moments, the mesh appears in the Geometry window, as shown below.
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5. Rotate the geometry so that it is positioned as shown below.

Notice how the element size is relatively uniform on the faces that were selected for the second
sizing control.

6. Click Box Zoom  and zoom the geometry as shown below.
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Notice how the element size is relatively uniform on the faces that were selected for the first
sizing control.

7. On the triad located in the lower right corner of the Geometry window, click the sphere to return
the view to isometric.

8. To get ready for the next part of the tutorial, you need to delete the sizing controls.

In the Tree Outline, right-click Face Sizing and select Delete. Answer Yes when prompted.

Repeat for Face Sizing 2.

Using Proximity-Based Sizing

In this part of the tutorial, Capture Proximity is set to Yes. This setting lets you specify the minimum
number of element layers created in regions that constitute gaps in the model, where a gap is defined
in one of two ways:

• The internal volumetric region between two faces

• The area between two opposing boundary edges of a face

1. In the Details View, set Capture Proximity to Yes.

2. Set Num Cells Across Gap to 2.

3. In the Tree Outline, right-click Mesh and select Generate Mesh.

After a few moments, the mesh appears in the Geometry window.
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4. Rotate the geometry so that it is positioned as shown below.

5. Click Box Zoom  and zoom the geometry as shown below.

Notice that there are two elements across the gap.

6. Rotate the geometry so that it is positioned as shown below.

Notice how the curved surface is meshed.
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7. Do not reposition the geometry. Continue with the next part of the tutorial.

Using Curvature-Based Sizing

In this part of the tutorial, Capture Curvature is set to Yes. The mesher examines curvature on edges
and faces and computes element sizes on these entities such that the size will not violate the maximum
size or the curvature normal angle, which are either computed by the mesher automatically or user-
defined.

1. In the Details View, set Capture Curvature to Yes.

2. Set Capture Proximity to No.

3. In the Tree Outline, right-click Mesh and select Generate Mesh.

After a few moments, the mesh appears in the Geometry window, as shown below.

Notice that the curvature is well resolved now.
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4. Rotate the geometry so that it is positioned as shown below.

Notice that the curvature is well resolved here as well.

5. On the triad located in the lower right corner of the Geometry window, click the sphere to return
the view to isometric.
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Using Both Proximity and Curvature-Based Sizing

In this part of the tutorial, both Capture Curvature and Capture Proximity are set to Yes. With these
settings you can obtain the combined effect of both the proximity and curvature sizing. You can use
all of the proximity and curvature sizing parameters to define the setting.

1. In the Details View, set both Capture Curvature and Capture Proximity to Yes.

2. In the Tree Outline, right-click Mesh and select Generate Mesh.

After a few moments, the mesh appears in the Geometry window.

3. Click Box Zoom  and zoom the geometry as shown below.

Notice that the curvature is well resolved.

4. Rotate the geometry so that it is positioned as shown below.

Notice that there are two elements across the gap.
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5. Rotate the geometry so that it is positioned as shown below.

Notice that the curvature is well resolved.

This completes the tutorial. From the Meshing application's main menu, select File > Save Project
to save the project and then File > Close Meshing to return to the Project Schematic.

You can exit Ansys Workbench by selecting File > Exit from the main menu.
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