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Chapter 1: Introduction to the Tutorials
The tutorials are designed to introduce the capabilities of CFD-Post. The following tutorials are available:

• Postprocessing Fluid Flow and Heat Transfer in a Mixing Elbow (p. 9) illustrates how to use CFD-
Post to visualize a three-dimensional turbulent fluid flow and heat transfer problem in a mixing elbow.

• Turbo Postprocessing (p. 47) demonstrates the turbomachinery postprocessing capabilities of CFD-
Post to visualize flow in a centrifugal compressor.

• Quantitative Postprocessing (p. 65) demonstrates the quantitative postprocessing capabilities of CFD-
Post using a 3D model of a circuit board with a heat-generating electronic chip mounted on it.

Using Help

To open the Ansys Help, from the menu bar select Help > Contents.

You may also use context-sensitive help, which is provided for many of the details views and other
parts of the interface. To invoke the context-sensitive help for a particular details view or other feature,
ensure that the feature is active, place the mouse pointer over it, then press F1. Not every area of the
interface supports context-sensitive help.
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Chapter 2: Postprocessing Fluid Flow and Heat
Transfer in a Mixing Elbow
This tutorial illustrates how to use CFD-Post to visualize a three-dimensional turbulent fluid flow and
heat transfer problem in a mixing elbow. The mixing elbow configuration is encountered in piping
systems in power plants and process industries. It is often important to predict the flow field and tem-
perature field in the area of the mixing region in order to properly design the junction.

This tutorial demonstrates how to do the following:

2.1. Problem Description

2.2. Preparing the Working Directory

2.3. Setting the Working Directory and Starting CFD-Post

2.4. Display the Solution in CFD-Post

2.5. Save Your Work

2.6. Generated Files

2.1. Problem Description

The problem to be considered is shown schematically in Figure 2.1: Problem Specification (p. 10). A
cold fluid at 20° C flows into the pipe through a large inlet and mixes with a warmer fluid at 40° C that
enters through a smaller inlet located at the elbow. The pipe dimensions are in inches, but the fluid
properties and boundary conditions are given in SI units. The Reynolds number for the flow at the larger
inlet is 50,800, so the flow has been modeled as being turbulent.

Note:

This tutorial is derived from an existing Fluent case. The combination of SI and Imperial units
is not typical, but follows a Fluent example.

Because the geometry of the mixing elbow is symmetric, only half of the elbow is modeled.
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Figure 2.1: Problem Specification

If this is the first tutorial you are working with, it is important to review Introduction to the Tutori-
als (p. 7) before beginning.

2.2. Preparing the Working Directory

1. Create a working directory.

CFD-Post uses a working directory as the default location for loading and saving files for a particular
session or project.

2. Download the mixing_elbow.zip file here.

3. Unzip mixing_elbow.zip to your working directory.

Ensure that the following tutorial input files are in your working directory:

• elbow_tracks.xml

• elbow1.cas.gz

• elbow1.cdat.gz

• elbow3.cas.gz
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• elbow3.cdat.gz

2.3. Setting the Working Directory and Starting CFD-Post

Before you start CFD-Post, set the working directory. The procedure for setting the working directory
and starting CFD-Post depends on whether you launch CFD-Post stand-alone, from the Ansys CFX
Launcher, or from Ansys Workbench:

• To run CFD-Post stand-alone

– On Windows:

1. From the Start menu, right-click All Programs > Ansys 2021 R2 > Fluid Dynamics > CFD-
Post 2021 R2 and select Properties.

2. Type the path to your working directory in the Start in field and click OK.

3. Click All Programs > Ansys 2021 R2 > Fluid Dynamics > CFD-Post 2021 R2 to launch CFD-
Post.

– On Linux, enter cfdpost in a terminal window that has its path set up to run CFD-Post. The path
will be something similar to /usr/ansys_inc/v212/CFD-Post/bin.

• To run Ansys CFX Launcher

1. Start the launcher.

You can run the launcher in any of the following ways:

– On Windows:

→ From the Start menu, select All Programs > Ansys 2021 R2 > Fluid Dynamics > CFX 2021
R2.

→ In a Command Prompt that has its path set up correctly to run Ansys CFX, enter
cfx5launch. If the path is not set up correctly, you will need to type the full pathname
of the cfx5launch command, which will be something similar to C:\Program
Files\ANSYS Inc\v212\CFX\bin.

– On Linux, enter cfx5launch in a terminal window that has its path set up to run Ansys CFX.
The path will be something similar to /usr/ansys_inc/v212/CFX/bin.

2. Set the working directory.

3. Click the CFD-Post 2021 R2 button.

• Ansys Workbench

1. Start Ansys Workbench.
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2. From the menu bar, select File > Save As and save the project file to the directory that you
want to be the working directory.

3. Open the Component Systems toolbox and double-click Results. A Results system opens in the
Project Schematic.

4. Right-click the A2 Results cell and select Edit. CFD-Post opens.

2.4. Display the Solution in CFD-Post

In the steps that follow, you will explore the solution using CFD-Post.

2.4.1. Prepare the Case and Set the Viewer Options

2.4.2. Become Familiar with the Viewer Controls

2.4.3. Create an Instance Reflection

2.4.4. Show Velocity on the Symmetry Plane

2.4.5. Show the Flow Distribution in the Elbow

2.4.6. Show the Vortex Structure

2.4.7. Show Volume Rendering

2.4.8. Compare a Contour Plot to the Display of a Variable on a Boundary

2.4.9. Review and Modify a Report

2.4.10. Create a Custom Variable and Animate the Display

2.4.11. Load and Compare the Results to Those in a Refined Mesh

2.4.12. Display Particle Tracks

2.4.1. Prepare the Case and Set the Viewer Options

1. Load the simulation from the data file (elbow1.cdat.gz) from the menu bar by selecting File
> Load Results. In the Load Results File dialog box, select elbow1.cdat.gz and click Open.

Ignore any message boxes that appear regarding global variable ranges or solution history by
clicking OK.

The mixing elbow appears in the 3D Viewer in an isometric orientation. The wireframe appears
in the view and there is a check mark beside User Location and Plots > Wireframe in the
Outline tree view; the check mark indicates that the wireframe is visible in the 3D Viewer.

2. Optionally, set the viewer background to white:

a. Right-click the viewer and select Viewer Options.

b. In the Options dialog box, select CFD-Post > Viewer.

c. Set:

• Background > Color Type to Solid.
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• Background > Color to white. To do this, click the bar beside the Color label to cycle
through 10 basic colors. (Click the right-mouse button to cycle backwards.) Alternatively,

you can choose any color by clicking  to the right of the Color option.

• Text Color to black (as above).

• Edge Color to black (as above).

d. Click OK to have the settings take effect.

e. Experiment with rotating the object by clicking on the arrows of the triad in the 3D Viewer.
This is the triad:

In the picture of the triad above, the cursor is hovering in the area opposite the positive Y
axis, which reveals the negative Y axis.

Note:

The viewer must be in "viewing mode" for you to be able to click the triad. You
set viewing mode or select mode by clicking the icons in the viewer toolbar:

When you have finished experimenting, click the cyan (ISO) sphere in the triad to return to
the isometric view of the object.

3. Set CFD-Post to display objects in the units you want to see. These display units are not neces-
sarily the same types as the units in the results files you load; however, for this tutorial you will
set the display units to be the same as the solution units for consistency. As mentioned in the
Problem Description (p. 9), the solution units are SI, except for the length, which is measured
in inches.

a. Right-click the viewer and select Viewer Options.

b. In the Options dialog box, select Common > Units.
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c. Notice that System is set to SI. In order to be able to change an individual setting (length,
in this case) from SI to imperial, set System to Custom. Now set Length to in (inches) and
click OK.

Note:

• The display units you set are saved between sessions and projects. This means that
you can load results files from diverse sources and always see familiar units displayed.

• You have set only length to inches; volume will still be reported in meters. To change
volume as well, in the Options dialog box, select Common > Units, then click More
Units to find the full list of settings.
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2.4.2. Become Familiar with the Viewer Controls

Optionally, take a few moments to become familiar with the viewer controls. These icons switch the
mouse from selecting items in the viewer to controlling the orientation and display of the view. First,
the sizing controls:

1. Click Zoom Box

2. Click and drag a rectangular box over the geometry.

3. Release the mouse button to zoom in on the selection.

The geometry zoom changes to display the selection at a greater resolution.

4. Click Fit View  to re-center and re-scale the geometry.

Now, the rotation functions:

1. Click Rotate  on the viewer toolbar.

2. Click and drag repeatedly within the viewer to test the rotation of the geometry. Notice how the
mouse cursor changes depending on where you are in the viewer, particularly near the edges:
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Figure 2.2: Orientation Control Cursor Types

The geometry rotates based on the direction of movement. If the mouse cursor has an axis (which
happens around the edges), the object rotates around the axis shown in the cursor. The axis of
rotation is through the pivot point, which defaults to be in the center of the object.

Now explore orientation options:

1. Right-click a blank area in the viewer and select Predefined Camera > View From -X.

2. Right-click a blank area in the viewer and select Predefined Camera > Isometric View (Z Up).

3. Click the "Z" axis of triad in the viewer to get a side view of the object.

4. Click the three axes in the triad in turn to see the vector objects in all three planes; when you
are done, click the cyan (ISO) sphere.

Now explore the differences between the orienting controls you just used and select mode.

1. Click  to enter select mode.
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2. Hover over one of the wireframe lines and notice that the cursor turns into a box.

3. Click a wireframe line and notice that the details view for the wireframe appears.

4. Right-click away from a wireframe line and then again on a wireframe line. Notice how the menu
changes:

Figure 2.3: Right-click Menus Vary by Cursor Position

5. In the Outline tree view, select the elbow1 > fluid > wall check box; the outer wall of the elbow
becomes solid. Notice that as you hover over the colored area, the cursor again becomes a box,
indicating that you can perform operations on that region. When you right-click the wall, a new
menu appears.

6. Click the triad and notice that you cannot change the orientation of the viewer object. (The triad
is available only in viewing mode, not select mode.)

7. In the Outline tree view, clear the elbow1 > fluid > wall check box; the outer wall of the elbow
disappears.

2.4.3. Create an Instance Reflection

Create an instance reflection on the symmetry plane so that you can see the complete case:
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1. With the 3D Viewer toolbar in viewing mode, click the cyan (ISO) sphere in the triad. This will
make it easy to see the instance reflection you are about to create.

2. Right-click one of the wireframe lines on the symmetry plane. (If you were in select mode, the
mouse cursor would have a "box" image added when you are on a valid line. As you are in
viewing mode there is no change to the cursor to show that you are on a wireframe line, so you
may see the general shortcut menu, as opposed to the shortcut menu for the symmetry plane.)
See Figure 2.3: Right-click Menus Vary by Cursor Position (p. 17).

3. From the shortcut menu, select Reflect/Mirror. If you see a dialog box prompting you for the
direction of the normal, choose the Z axis. The mirrored copy of the wireframe appears.

Tip:

If the reflection you create is on an incorrect axis, click the Undo  toolbar icon twice.

2.4.4. Show Velocity on the Symmetry Plane

Create a contour plot of velocity on the symmetry plane:

1. From the menu bar, select Insert > Contour. In the Insert Contour dialog box, accept the default
name, and click OK.

2. In the details view for Contour 1, set the following:

ValueSettingTab

symmetry [a]LocationsGeometry

Velocity [b]Variable

a. You could also create a slice plane at a location of your choice and define the contour to
be at that location. The available locations are highlighted in the viewer as you move the
mouse over the objects in the Locations drop-down list.

b. Velocity is just an example of a variable you can use.

3. Click Apply. The contour plot for velocity appears and a legend is automatically generated.

4. The coloring of the contour plot may not correspond to the colors on the legend because the
viewer has a light source enabled by default. There are several ways to correct this:

• You can change the orientation of the objects in the viewer.

• You can experiment with changing the position of the light source by holding down the Ctrl
key and dragging the cursor with the right mouse button.

• You can disable lighting for the contour plot. To disable lighting, click the Render tab and
clear the check box beside Lighting, then click Apply.
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Disabling the lighting is the method that provides you with the most flexibility, so change that
setting now.

5. Click the Z on the triad to better orient the geometry (the 3D Viewer must be in viewing mode,
not select mode, to do this).

Figure 2.4: Velocity on the Symmetry Plane

6. Improve the contrast between the contour regions:

a. On the Render tab, select Show Contour Lines and click the plus sign to view more options.

b. Select Constant Coloring.

c. Set Color Mode to User Specified and Line Color to black (if necessary, click the bar
beside Line Color until black appears).

d. Click Apply.
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Figure 2.5: Velocity on the Symmetry Plane (Enhanced Contrast)

7. Hide the contour plot by clearing the check box beside User Locations and Plots > Contour 1
in the Outline tree view.

Tip:

You can also hide an object by right-clicking on its name in the Outline tree view
and selecting Hide.

2.4.5. Show the Flow Distribution in the Elbow

Create a vector plot to show the flow distribution in the elbow:

1. From the menu bar, select Insert > Vector.

2. Click OK to accept the default name. The details view for the vector appears.
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3. On the Geometry tab, set Domains to fluid and Locations to symmetry.

4. Click Apply.

5. On the Symbol tab, set Symbol Size to 4.

6. Click Apply and notice the changes to the vector plot.

Figure 2.6: Vector Plot of Velocity

7. Change the vector plot so that the vectors are colored by temperature:

a. In the details view for Vector 1, click the Color tab.

b. Set Mode to Variable.

The Variable field becomes enabled.

c. Click the down arrow  beside the Variable field to set it to Temperature.

d. Click Apply and notice the changes to the vector plot.
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8. Optionally, change the vector symbol. In the details view for the vector, go to the Symbol tab
and set Symbol to Arrow3D. Click Apply.

9. Hide the vector plot by right-clicking on a vector symbol in the plot and selecting Hide.

In this example you will create streamlines to show the flow distribution by velocity and color those
streamlines to show turbulent kinetic energy. CFD-Post uses the Variable setting on the Geometry
tab to determine how to calculate the streamlines (that is, location). In contrast, the Variable setting
on the Color tab determines the color used when plotting those streamlines.

1. From the menu bar select Insert > Streamline. Accept the default name and click OK.

2. In the details view for Streamline 1, choose the points from which to start the streamlines. Click

the down arrow  beside the Start From drop-down widget to see the potential starting points.
Hover over each point and notice that the area is highlighted in the 3D Viewer. It would be best
to show how streamlines from both inlets interact, so, to make a multi-selection, click Location

editor . The Location Selector dialog box appears.

3. In the Location Selector dialog box, hold down the Ctrl key and click velocity inlet 5
and velocity inlet 6 to select both locations, then click OK.

4. Click Preview Seed Points to see the starting points for the streamlines.

5. On the Geometry tab, ensure that Variable is set to Velocity.

6. Click the Color tab and make the following changes:

a. Set Mode to Variable. The Variable field becomes enabled.

b. Set Variable to Turbulence Kinetic Energy.

c. Set Range to Local.

7. Click Apply. The streamlines show the flow of massless particles through the entire domain.
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Figure 2.7: Streamlines of Turbulence Kinetic Energy

8. Select the check box beside Vector 1. The vectors appear, but are largely hidden by the stream-
lines. To correct this, select Streamline 1 in the Outline tree view and press Delete. The
vectors are now clearly visible, but the work you did to create the streamlines is gone. Click the

Undo icon  to restore Streamline 1.

9. Hide the vector plot and the streamlines by clearing the check boxes beside Vector 1 and
Streamline 1 in the Outline tree view.

2.4.6. Show the Vortex Structure

CFD-Post displays vortex core regions to enable you to better understand the processes in your sim-
ulation. In this example you will look at helicity method for vortex cores, but in your own work you
would use the vortex core method that you find most instructive.

1. In the Outline tree view:

a. Under User Locations and Plots, clear the check box for Wireframe.

b. Under Cases > elbow1 > fluid, select the check box for wall.
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c. Double-click wall to edit its properties.

d. On the Render tab, set Transparency to 0.75.

e. Click Apply.

This makes the pipe easy to see while also making it possible to see objects inside the pipe.

2. From the menu bar, select Insert > Location > Vortex Core Region and click OK to accept the
default name.

3. In the details view for Vortex Core Region 1 on the Geometry tab, set Method to Absolute
Helicity and Level to .01.

4. On the Render tab, set Transparency to 0.2. Click Apply.

The absolute helicity vortex that is displayed is created by a mixture of effects from the walls,
the curve in the main pipe, and the interaction of the fluids. If you had chosen the vorticity
method instead, wall effects would dominate.

5. On the Color tab, click the colored bar in the Color field until the bar is green. Click Apply.

This improves the contrast between the vortex region and the blue walls.

6. Right-click in the 3D Viewer and select Predefined Camera > Isometric View (Y up).

7. In the Outline tree view, select the check box beside Streamline 1. This shows how the
streamlines are affected by the vortex regions.
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Figure 2.8: Absolute Helicity Vortex

8. Clear the check boxes beside wall, Streamline 1 and Vortex Core Region 1. Select the check
box beside Wireframe.

2.4.7. Show Volume Rendering

CFD-Post displays volume rendering to enable you to better understand the processes in your simu-
lation.

1. From the menu bar, select Insert > Volume Rendering and click OK to accept the default name.

2. In the details view for Volume Rendering 1 on the Geometry tab, set Variable to Temperature.

3. On the Color tab, set Mode to Variable and Variable to Temperature. Click Apply.

4. If necessary to orient the simulation as shown below, right-click in the 3D Viewer and select
Predefined Camera > Isometric View (Y up).
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Figure 2.9: Volume Rendering of Temperature

5. Hide the Volume Rendering object by clearing the check box beside Volume Rendering 1 in
the Outline tree view.

2.4.8. Compare a Contour Plot to the Display of a Variable on a Boundary

A contour plot with color bands has discrete colored regions while the display of a variable on a
locator (such as a boundary) shows a finer range of color detail by default. The instructions that follow
will illustrate a variable at the outlet and create a contour plot that displays the same variable at that
same location.

1. To do the comparison, split the 3D Viewer into two viewports by using the Viewport Layout
toolbar in the 3D Viewer toolbar:
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2. Right-click in both viewports and select Predefined Camera > View From -Y.

3. In the Outline tree view, double-click pressure outlet 7 (which is under elbow1 > fluid).
The details view of pressure outlet 7 appears.

4. Click in the View 1 viewport.

5. In the details view for pressure outlet 7 on the Color tab:

a. Change Mode to Variable.

b. Ensure that Variable is set to Pressure.

c. Ensure that Range is set to Local.

d. Click Apply. The plot of pressure appears and the legend shows a smooth spectrum that
goes from blue to red. Notice that this happens in both viewports; this is because Synchronize

visibility in displayed views  is selected.

e. Click Synchronize visibility in displayed views  to disable this feature.

Now, add a contour plot at the same location:

1. Click in View 2 to make it active; the title bar for that viewport becomes highlighted.

2. In the Outline tree view, clear the check box beside fluid > pressure outlet 7.

3. From the menu bar, select Insert > Contour.

4. Accept the default contour name and click OK.

5. In the details view for the contour, ensure that Locations is set to pressure outlet 7 and
Variable is set to Pressure.

6. Set Range to Local.
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7. Click Apply. The contour plot for pressure appears and the legend shows a spectrum that steps
through 10 levels from blue to red.

8. Compare the two representations of pressure at the outlet. Pressure at the Outlet is on the left
and a Contour Plot of pressure at the Outlet is on the right:

Figure 2.10: Boundary Pressure vs. a Contour Plot of Pressure

9. Enhance the contrast on the contour bands:

a. In the Outline tree view, right-click User Locations and Plots > Contour 2 and select Edit.

b. In the details view for the contour, on the Render tab, select Show Contour Lines > Con-
stant Coloring, set Color Mode to User Specified, and click Apply.

c. Click the Labels tab and select Show Numbers. Click Apply.

10. Explore the viewer synchronization options:

a. In View 1, click the cyan (ISO) sphere in the triad so that the two viewports show the elbow
in different orientations.

b. In the 3D Viewer toolbar, click Synchronize camera in displayed views . Both viewports
take the camera orientation of the active viewport.

c. Clear the Synchronize camera in displayed views  icon and click the Z arrow head of the
triad in View 1. The object again moves independently in the two viewports.
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d. In the 3D Viewer toolbar, click Synchronize visibility in displayed views .

e. In the Outline tree view, right-click fluid > wall and select Show. The wall becomes visible
in both viewports. (Synchronization applies only to events that take place after you enable
the synchronize visibility function.)

11. When you are done, use the viewport controller to return to a single viewport. The synchronization
icons disappear.

2.4.9. Review and Modify a Report

As you work, CFD-Post automatically updates a report, which you can see in the Report Viewer. At
any time you can publish the report to an HTML file. In this section you will add a picture of the elbow
and produce an HTML report:

1. Click the Report Viewer tab at the bottom of the viewer to view the current report.

2. In the Outline tree view, double-click the Report > Title Page. In the Title field on the Content
tab of the Details of Report Title Page, type: Analysis of Heat Transfer in a
Mixing Elbow

3. Click Apply, then Refresh Preview to update the contents of the Report Viewer.

4. In the Outline tree view, ensure that only User Location and Plots > Contour 1, Default Legend
View 1, and Wireframe are visible, then double-click Contour 1. On the Geometry tab, set
Variable to Temperature and click Apply.

5. On the menu bar, select Insert > Figure. The Insert Figure dialog box appears. Accept the default
name and click OK.

6. In the Outline tree view, double-click Report > Figure 1. In the Caption field, type Temperature
on the Symmetry Plane and click Apply.

7. Click the 3D Viewer, then click the cyan (ISO) sphere in the triad.

8. Click the Report Viewer tab.

9. In the top frame of the Report Viewer, click Refresh . The report is updated with a
picture of the mixing elbow at the end of the report.

10. Optionally, click Publish to create an HTML version of the report. In the Publish Report dialog
box, click OK.

The report is written to Report.htm in your working directory.

11. Right-click in the Outline tree view and select Hide All.

2.4.10. Create a Custom Variable and Animate the Display

In this section you will generate an expression using the CFX Expression Language (CEL), which you
can then use in CFD-Post in place of a numeric value. You will then associate the expression with a
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variable, which you will also create. Finally, you will create a plane that displays the new variable,
then move the plane to see how the values for the variable change.

1. Define a custom expression for the dynamic head formula (rho|V|^2)/2 as follows:

a. On the tab bar at the top of the workspace area, select Expressions. Right-click in the Ex-
pressions area and select New.

b. In the New Expression dialog box, type: DynamicHeadExp

c. Click OK.

d. In the Definition area, type in this definition:

Density * abs(Velocity)^2 / 2

where:

• Density is a variable

• abs is a CEL function (abs is unnecessary in this example, it simply illustrates the use of
a CEL function)

• Velocity is a variable

Tip:

You can learn which predefined functions, variables, expression, locations, and
constants are available by right-clicking in the Definition area.

e. Click Apply.

2. Associate the expression with a variable (as the plane you define in the next step can display
only variables):

a. On the tab bar at the top of the workspace area, select Variables. Right-click in the Variables
area and select New.

b. In the New Variable dialog box, type: DynamicHeadVar

c. Click OK.

d. In the details view for DynamicHeadVar, click the drop-down arrow beside Expression and
choose DynamicHeadExp. Click Apply.

3. Create a plane and animate it:

a. Click the 3D Viewer tab.

b. Right-click the wireframe and select Insert > YZ Plane.
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c. If you see a dialog box that asks in which direction you want the normal to point, choose
the direction appropriate for your purposes.

A plane that maps the distribution of the default variable (Pressure) appears.

d. On the Color tab, set Variable to "DynamicHeadVar". On the Render tab, clear Lighting.
Click Apply.

The plane now maps the dynamic head distribution.

e. In the 3D Viewer with the mouse cursor in select mode, click the plane and drag it to various
places in the object to see how the location changes the DynamicHeadVar values displayed.

f. Right-click the plane and select Animate. The Animation dialog box appears and the plane
moves through the entire domain, displaying changes to the DynamicHeadVar values as it
moves.

g. In the Animation dialog box, click Stop , then click Close.

Tip:

You can define multiple planes and animate them concurrently. First, stop any anim-
ations currently running, then create a new plane. To animate both planes, hold down

Ctrl to select multiple planes in the Animation dialog box and click Play .

4. In the upper-left corner of the 3D Viewer, click the down arrow beside Figure 1 and change it
to View 1.

5. In the Outline tree view, right-click User Locations and Plots > Contour 1 and select Hide All.

2.4.11. Load and Compare the Results to Those in a Refined Mesh

To this point you have been working with a coarse mesh. In this section you will compare the results
from that mesh to those from a refined mesh:

1. Select File > Load Results. The Load Results File dialog box appears

2. On the Load Results File dialog box, select Keep current cases loaded and keep the other
settings unchanged.

3. Select elbow3.cdat.gz (or elbow3.cdat) and click Open.

In the 3D Viewer, there are now two viewports: in the title bar for View 1 you have elbow1,
and in View 2 you have elbow3. In the Outline tree view under Cases you have elbow1 and
elbow3; all boundaries associated with each case are listed separately and can be controlled
separately. You also have a new entry: Cases > Case Comparison.

4. In the Toolbar, select Synchronize camera in displayed views .
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If the two cases are not oriented in the same way, clear the Synchronize camera in displayed views

 icon and then select it again.

Examine the operation of CFD-Post when the two views are not synchronized and when they are
synchronized:

1. In the viewer toolbar, clear Synchronize visibility in displayed views .

2. With the focus in View 1, select Insert > Contour and create a contour of pressure on pressure
outlet 7 that displays values in the local range.

Note that the contour appears only in View 1. When visibility is not synchronized, changes you
make to User Location and Plots settings apply only to the currently active view.

3. In either view (while in viewing mode), click the Z axis on the triad. Both views show their cases
from the perspective of the Z axis.

4. In the viewer toolbar, select Synchronize visibility in displayed views .

5. With the focus on the view that contains elbow3, select Insert > Contour. Accept the default
name and click OK.

6. Define the contour such that it displays temperature on the symmetry plane:

ValueSettingTab

symmetryLocationsGeometry

TemperatureVariable

LocalRange

Show Contour BandsRender

(Cleared)> Lighting

Click Apply.

Note that the contour appears in both views. You can see the differences between the coarse
and refined meshes:
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Figure 2.11: Comparing Contour Plots of Temperature on Two Mesh Densities

You can now compare the differences between the coarse and refined meshes:

1. In the Outline tree view, double-click Cases > Case Comparison.

2. In the Case Comparison details view, select Case Comparison Active and click Apply. The dif-
ferences between the values in the two cases appear in a third view. Click the Z axis of the triad
to restore the orientation of the views.
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Figure 2.12: Displaying Differences in Contour Plots of Temperature on Two Mesh Densities

Now, revert to a single view that shows the original case:

1. To remove the Difference view, clear Case Comparison Active and click Apply.

2. To remove the refined mesh case, in the Outline tree view, right-click elbow3 and select Unload.

3. In the Outline tree view, right-click User Locations and Plots > Contour 1 and select Hide All.

2.4.12. Display Particle Tracks

You can export an XML file of Particle Tracks from Fluent and display the tracks in CFD-Post.
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To display particle tracks:

1. With only elbow1.cdat loaded, load the particle track file elbow_tracks.xml:

• Select File > Import > Import Fluent Particle Track File.

2. In the Import Fluent Particle Track File dialog box, select: elbow_tracks.xml

3. Click Open.

4. Click OK.

Particle tracks appear in the 3D Viewer. The tracks stretch from the two inlets to the outlet.

Make only the particle tracks from the large inlet visible:

1. In the Outline tree view, double-click User Locations and Plots> Fluent PT for Anthracite to
see the details view for the particle tracks.

2. In the details view, click the drop-down arrow beside the Injections field so that you can see
the names of the two sets of particle tracks.
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3. Select injection-0.

4. Click Apply.

Display both sets of particle tracks, each set in a different color:

1. First, display both sets of particle tracks again:

a. Click the drop-down arrow beside the Injections field.

b. Select injection-0,injection-1.

c. Click Apply.

2. Click the Color tab.

3. Set Mode to Variable.

4. Set Variable to Anthracite.Injection.

5. Click Apply.
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Show fewer particle tracks:

1. Click the Geometry tab.

2. Click the drop-down arrow beside the Reduction Type field and select Reduction Factor.

3. To display only half of the tracks, set Reduction to 2.

4. Click Apply.
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5. Display all tracks again by setting Reduction to 1 and clicking Apply.

Animate symbols running along the particle track lines:

1. Right-click a particle track and select Animate.

The animation begins automatically.

2. Click Stop the animation , then click Options.

3. On the Options dialog box, set Symbol Size to 2 and Symbol to Fish3D. Click OK.

4. In the Animations dialog box, click Play the animation .
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5. When you have finished viewing the animation, click Stop the animation , then close the
Animation dialog box.

Create a vector plot:

1. Select Insert > Vector.

2. In the Insert Vector dialog box, click OK to accept the default name for the vector.

3. On the Geometry tab, set:

• Locations to Fluent PT for Anthracite

• Reduction to Reduction Factor

• Factor to 20
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• Variable to Anthracite.Particle Velocity

Tip:

You need to click the More Variables  icon to see Anthracite.Particle Velocity.

• Click the Symbol tab, and set Symbol Size to 2.

• Click Apply.

• In the Outline tree, clear User locations and Plots > Fluent PT for Anthracite.

4. After viewing the vector plot, clear User locations and Plots > Vector 2 and select User locations
and Plots > Fluent PT for Anthracite in order to view the particle tracks only.

Color the particle tracks by particle time:

1. Click the Color tab.

2. Ensure that Mode is set to Variable.

3. Set Variable to Anthracite.Particle Time.

4. Click Apply.
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Create a chart of particle time vs. particle velocity Y for a single track:

1. On the Geometry tab, click the drop-down arrow beside the Injections field and select injec
tion-0.

2. Click Apply.

3. On the Symbol tab, select Show Track Numbers and click Apply.

4. On the Geometry tab:

a. Enable the Filter option.

b. Select Track.

c. In the Track field, type 54.

d. Click Apply.
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5. Create a chart of a particle's velocity over time:

a. From the menu bar, select Insert > Chart.

b. In the Insert Chart dialog box, type: Particle 54 and click OK.

The details view for the chart appears, and the Chart Viewer appears.

c. In the Title field, type: Particle Time vs. Particle Velocity

d. On the Data Series tab, select Series 1 and set Location to Fluent PT for Anthra
cite.

e. On the X Axis tab, set Variable to Anthracite.Particle Time.

f. On the Y Axis tab, set Variable to Anthracite.Particle Y Velocity.

g. Click Apply.
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Interpolate a field variable onto the track:

1. On the Y Axis tab, set Variable to Pressure.

2. On the General tab, change the Title to Particle Time vs. Pressure.

3. Click Apply.

Use the Function Calculator to calculate lengthAve of Pressure on the track:

1. From the menu bar, select Tools > Function Calculator.

2. In the Function Calculator, set Function to lengthAve.

3. Ensure that Location is set to Fluent PT for Anthracite.

4. Ensure that Variable is set to Pressure.
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5. Enable Show equivalent expression.

6. Click Calculate.

The value of lengthAve(Pressure)@Fluent PT for Anthracite appears.

2.5. Save Your Work

When you began this tutorial, you loaded a solver results file. When you save the work you have done
in CFD-Post, you save the current state of CFD-Post into a CFD-Post State file (.cst).

1. How you save your work depends on whether you are running CFD-Post stand-alone or from
within Ansys Workbench:

• From CFD-Post stand-alone:

1. From the menu bar, select File > Save State.

This operation saves the expression, custom variable, and the settings for the objects in a
.cst file and saves the state of the animation in a .can file. The .cas.gz and .cdat.gz
files remain unchanged.

2. A Warning dialog box asks if you want to save the animation state. Click Yes.

3. Optionally, confirm the state file's contents: close the current file from the menu bar by se-
lecting File > Close (or press Ctrl+W) then reload the state file (select File > Load State
and choose the file that you saved in step 1.)

• From Ansys Workbench:

1. From the CFD-Post menu bar, select File > Quit. Ansys Workbench saves the state file
automatically.

2. In the Ansys Workbench Project Schematic, double-click the Results cell. CFD-Post re-opens
with the state file loaded.

2. Save a picture of the current state of the simulation: In the Outline tree view, show Contour 1.

With the focus in the 3D Viewer, click Save Picture  from the toolbar. In the Save Picture dialog
box, click Save. A PNG file of the current state of the viewer is saved to <casename>.png (el-
bow1.png) in your working directory.

3. You can recreate the animation you made previously and save it to a file:

a. Click the cyan (ISO) sphere in the triad to orient the elbow to display Plane 1.

b. In the Outline tree view, clear Contour 1 and Fluent PT for Anthracite; show Plane 1.

c. Right-click Plane 1 in the 3D Viewer and select Animate. The Animation dialog box appears
and the plane moves through the entire domain.
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d. Click the stop icon .

e. If necessary, display the full animation control set by clicking .

f. The Repeat is set to infinity; change the value to 1 by clicking the infinity button. The Repeat
field becomes selected and by default is set to one.

g. Select Save Movie to save the animation to the indicated file.

h. Click Play the animation .

The plane moves through one cycle.

You can now go to your working directory and play the animation file in an appropriate
viewer.

4. Click Close to close the Animation dialog box.

5. Close CFD-Post: from the toolbar select File > Quit. If prompted, you may save your changes.
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2.6. Generated Files

As you worked through this tutorial you generated the following files in your working directory (default
names are given):

• elbow1.cst, the state file, and elbow1.can, the animation associated with that state file

• elbow1.wmv, the animation

• elbow1.png, a picture of the contents of the 3D Viewer

• Report.htm, the report.
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Chapter 3: Turbo Postprocessing
This tutorial demonstrates the turbomachinery postprocessing capabilities of CFD-Post.

In this example, you will read Fluent case and data files (without doing any calculations) and perform
a number of turbomachinery-specific postprocessing operations.

This tutorial demonstrates:

• Display the Solution in CFD-Post (p. 50)

• Initialize the Turbomachinery Components (p. 52)

• Compare the Blade-to-Blade, Meridional, and 3D Views (p. 54)

• Display Pressure on Meridional Isosurfaces (p. 55)

• Display a 360-Degree View (p. 57)

• Calculate and Display Values of Variables (p. 57)

• Display the Inlet to Outlet Chart (p. 60)

• Generate and View a Turbo Report (p. 62)

3.1. Problem Description

This tutorial considers the problem of a centrifugal compressor shown schematically in Figure 3.1: Problem
Specification (p. 48). The model is composed of a single 3D sector of the compressor to take advantage
of the circumferential periodicity in the problem. The flow of air through the compressor is simulated
and the postprocessing capabilities of CFD-Post are used to display realistic, full 360° images of the
solution obtained.
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Figure 3.1: Problem Specification

If this is the first tutorial you are working with, it is important to review Introduction to the Tutori-
als (p. 7) before beginning.

3.2. Preparing the Working Directory

1. Create a working directory.

CFD-Post uses a working directory as the default location for loading and saving files for a particular
session or project.

2. Download the turbo.zip file here.

3. Unzip turbo.zip to your working directory.

Ensure that the following tutorial input files are in your working directory:

• turbo.cas.gz

• turbo.cdat.gz
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3.3. Setting the Working Directory and Starting CFD-Post

Before you start CFD-Post, set the working directory. The procedure for setting the working directory
and starting CFD-Post depends on whether you run CFD-Post stand-alone, from the Ansys CFX
Launcher, or from Ansys Workbench:

• To run CFD-Post stand-alone

– On Windows:

1. From the Start menu, right-click All Programs > Ansys 2021 R2 > Fluid Dynamics > CFD-
Post 2021 R2 and select Properties.

2. Type the path to your working directory in the Start in field and click OK.

3. Click All Programs > Ansys 2021 R2 > Fluid Dynamics > CFD-Post 2021 R2 to launch CFD-
Post.

– On Linux, enter cfdpost in a terminal window that has its path set up to run CFD-Post. The path
will be something similar to /usr/ansys_inc/v212/CFD-Post/bin.

• To run Ansys CFX Launcher

1. Start the launcher.

You can run the launcher in any of the following ways:

– On Windows:

→ From the Start menu, select All Programs > Ansys 2021 R2 > Fluid Dynamics > CFX 2021
R2.

→ In a Command Prompt that has its path set up correctly to run CFX, enter cfx5launch. If
the path is not set up correctly, you will need to type the full pathname of the cfx command,
which will be something similar to C:\Program Files\ANSYS Inc\v212\CFX\bin.

– On Linux, enter cfx5launch in a terminal window that has its path set up to run CFX. The
path will be something similar to /usr/ansys_inc/v212/CFX/bin.

2. Set the working directory.

3. Click the CFD-Post 2021 R2 button.

• Ansys Workbench

1. Start Ansys Workbench.

2. From the menu bar, select File > Save As and save the project file to the directory that you
want to be the working directory.

3. Open the Component Systems toolbox and double-click Results. A Results system opens in the
Project Schematic.
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4. Right-click the A2 Results cell and select Edit. CFD-Post opens.

3.4. Display the Solution in CFD-Post

In the steps that follow, you will explore the solution using CFD-Post.

3.4.1. Prepare the Case and Set the Viewer Options

3.4.2. Initialize the Turbomachinery Components

3.4.3. Compare the Blade-to-Blade, Meridional, and 3D Views

3.4.4. Display Pressure on Meridional Isosurfaces

3.4.5. Display a 360-Degree View

3.4.6. Calculate and Display Values of Variables

3.4.7. Display the Inlet to Outlet Chart

3.4.8. Generate and View a Turbo Report

3.4.1. Prepare the Case and Set the Viewer Options

1. Load the CDAT file (turbo.cdat.gz) from the menu bar by selecting File > Load Results. In
the Load Results File dialog box, select turbo.cdat.gz and click Open.

2. If you see a message that discusses Global Variables Ranges, it can be ignored. Click OK.

The turbo blade appears in the viewer in an isometric orientation. The Wireframe appears in
the 3D Viewer and there is a check mark beside Wireframe in the Outline workspace; the check
mark indicates that the wireframe is visible in the 3D Viewer.

3. Set CFD-Post to display the units you want to see. These display units are not necessarily the
same types as the units in the results files you load; however, for this tutorial you will set the
display units to be the same as the solution units.

a. Right-click the viewer and select Viewer Options.

b. In the Options dialog box, select Common > Units.

c. Set System to SI and click OK.

Note:

The display units you set are saved between sessions and projects. This means that
you can load results files from diverse sources and always see familiar units displayed.

4. Double-click Wireframe in the Outline workspace to see the details view. To display the mesh,
set Edge Angle to 0 degrees and click Apply. The edge angle determines how much of the
surface mesh is visible. If the angle between two adjacent faces is greater than the edge angle,
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then that edge is drawn. If the edge angle is set to 0°, the entire surface mesh is drawn. If the
edge angle is large, then only the most significant corner edges of the geometry are drawn.

Tip:

With the mouse focus on CFD-Post and the mouse over the Details of Wireframe
editor, press F1 to see help about the Wireframe object.

On the Wireframe details view, click Defaults and Apply to restore the original settings.

5. Optionally, set the viewer background to white:

a. Right-click the viewer and select Viewer Options.

b. In the Options dialog box, select CFD-Post > Viewer.

c. Set:

• Background > Color Type to Solid.

• Background > Color to white. To do this, click the bar beside the Color label to cycle
through 10 basic colors. (Click the right-mouse button to cycle backwards.) Alternatively,

you can choose any color by clicking  icon to the right of the Color option.

• Text Color to black (as above).

• Edge Color to black (as above).

d. Click OK to have the settings take effect.
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3.4.2. Initialize the Turbomachinery Components

Before you can start using the Turbo workspace features, you need to initialize the components of
the loaded case (such as hub, blade, periodics, and so on). Among other things, initialization generates
span, a (axial), r (radial), and Theta coordinates for each component.

You need to initialize Fluent case and data files manually (automatic initialization is available only for
CFX files produced by the Turbo wizard in CFX-Pre). To initialize the components:

1. Click the Turbo tab in the upper-left pane of the CFD-Post window. The Turbo workspace appears
as does a Turbo initialization dialog box that offers to auto-initialize all turbo components. Click
No.

2. In the Turbo workspace under Initialization, double-click fluid (fluid). The details view
of Fluid appears.

3. On the Definition tab, the regions of the geometry are listed under Turbo Regions. However,
not all regions are listed; correct this as follows:
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a. Click Location editor  to the right of the Hub region.

b. Hold down the Ctrl key and in the Location Selector select wall diffuser hub, wall
hub, and wall inlet hub.

c. Click OK.

The Hub field now lists all three hub locations.

d. Repeat the previous steps for the Shroud region, selecting wall diffuser shroud,
wall inlet shroud, and wall shroud.

e. Repeat the previous steps for the Blade region, selecting only wall blade.

f. Repeat the previous steps for the Inlet region, selecting only inlet.

g. Repeat the previous steps for the Outlet region, selecting only outlet.

h. Repeat the steps for the Periodic 1 region, selecting periodic.33, periodic.34, and
periodic.35.

You do not need to initialize the periodic.*shadow regions; the periodic.* nodes
provide the information that the turbo reports require.

4. Click the Instancing tab.

a. Ensure that Number of Graphical Instances is set to 1.

b. Ensure that Axis Definition is set to Custom, that Method is set to Principal Axis,
and that Axis is set to Z.

c. Set Instance Definition to Custom.

d. Select Full Circle.

5. Click Initialize. This generates variables that you will use later to create reports.

Tip:

If the turbo topology is not correctly defined, an error message is generated and the
initialization does not occur. To resolve such an error:

a. Ensure that the rotational axis is correct.

b. Ensure that the turbo regions are correctly set, and that they enclose the passage
without any gaps.

6. Double-click Initialization at the top of the Turbo tree view. The Initialization editor appears.
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7. Click the Calculate Velocity Components button. This generates velocity variables that you will
also use in your reports.

The initialization process has created a variety of plots automatically; you will access these from the
Turbo tab in the sections that follow.

3.4.3. Compare the Blade-to-Blade, Meridional, and 3D Views

To compare the Blade-to-Blade, Meridional, and 3D Views:

• In the Turbo workspace, select the Three Views option at the bottom of the Initialization editor.
In the 3D Viewer you can see the Turbo Initialization View, the Blade to Blade View, and the
Meridional View.

The CFD-Post Blade to Blade View is equivalent to the Fluent "2D contour on a spanwise surface".
By default, the variable shown is Pressure. To change this to velocity and to make the image more
like the default Fluent equivalent:

1. In the Blade to Blade View, right-click the colored area shown in the viewport and select Edit.
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2. In the details view for the Blade-to-Blade Plot, change the Plot Type from Color to Contour
(this changes the continuous gradation found in Color to the discrete color bands found in
Contour).

3. Change Variable to Velocity.

4. Change the # of Contours to 21.

5. Click Apply.

The CFD-Post Meridional View is equivalent to the Fluent "contour averaged in the circumferential
direction". To make the image more like the default Fluent equivalent:

1. In the Meridional View, right-click the colored area shown in the viewport and select Edit.

2. In the details view for the Meridional Plot, change the Plot Type from Color to Contour.

3. Change the # of Contours to 21.

4. Click Apply.

3.4.4. Display Pressure on Meridional Isosurfaces

In this example you will define six meridional isosurfaces colored by pressure.

1. Return to the original orientation of the case:

a. In the Tree view, double-click Plots and select Single View.

b. Double-click 3D View.

2. From the menu bar select Insert > Location > Isosurface and accept the default name.

3. Set the following values on the details view for the isosurface:

ValueFieldTab

fluidDomainsGeometry

Linear BA Streamwise
Location

Variable

[a]

.01Value

VariableModeColor

PressureVariable

User SpecifiedRange

72800 [Pa]Min

186000 [Pa]Max

(Cleared)LightingRender

a. Click the Variable Editor  to access this variable.
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4. Click Apply to define the isosurface.

5. Right-click Isosurface 1 in the Tree view and select Duplicate, then change Geometry > Value
to .2 and click Apply.

6. Create other duplicates for geometry values .4, .6, .8, and .99.

Note:

You can set locator variables other than Linear BA (Blade Aligned) Streamwise Location.
For example, edit Isosurface 5 and change Linear BA Streamwise Location
to M Length Normalized to see how the isosurface changes.
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3.4.5. Display a 360-Degree View

To display a 360° view of the turbomachinery:

1. In the Outline tree view, right-click any object under User Locations and Plots that has
a visibility check box, then select Hide All.

2. Under User Locations and Plots, ensure that the check box beside Wireframe is selected.

3. Under Cases > turbo, double-click fluid to edit that domain.

4. On the Instancing tab:

a. Set Number of Graphical Instances to 20.

b. Ensure that Instance Definition is set to Custom and that Full Circle is selected.

c. Ensure that Axis Definition is set to Custom, that Method is set to Principal Axis,
and that Axis is set to Z.

5. Click Apply.

6. If necessary, click the Fit View  icon so that you can see the whole case.

3.4.6. Calculate and Display Values of Variables

You can calculate the values of variables at locations in the case and display these results in a table.
First, use the Function Calculator to see how to create a function.

1. From the menu bar, select Tools > Function Calculator. The Calculators tab appears with the
Function Calculator displayed.

2. Use the Function Calculator to calculate the mass flow average of pressure at the inlet as follow:

a. Use the Function drop-down arrow to select massFlowAve.

b. Use the Location drop-down arrow to select inlet.

c. Use the Variable drop-down arrow to select Pressure.

d. At the bottom of the Function Calculator select Show equivalent expression.

e. Click Calculate and the expression and results appear:
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The Function Calculator not only makes it easy to create and calculate a function, it also
enables you to see the syntax for functions, which you will use in the subsequent steps.

3. To display functions like this in a table, click the Table Viewer tab (at the bottom of the viewer
area). The Table Viewer appears.

4. In the toolbar at the top of the Table Viewer, click New Table . The New Table dialog box
appears. Type in Inlet and Outlet Values and click OK.

5. Type the following text to make cell headings:

• In cell B1: Inlet

• In cell C1: Outlet

• In cell A2: Mass Flow

• In cell A3: Average Pressure

6. Now, create functions:

a. Click in cell B2, then in the Table Viewer toolbar, select Function > CFD-Post > massFlow.
The definition =massFlow()@ appears.
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b. With the text cursor after the @ symbol, click Location > inlet.

c. Press Enter; the value of the mass flow at the inlet appears.

d. Repeat the above steps for cell C2, but use Location > outlet.

e. For cell B3, select Function > CFD-Post > massFlowAve. With the text cursor between the
parentheses, select Variable > Pressure. With the text cursor after the @ symbol, click
Location > inlet. Press Enter; the value of the mass flow average of pressure at the inlet
appears.

f. Repeat the previous step for cell C3, but use Location > outlet.

Your table should be similar to this:

7. Format the cells to make the table easier to read.

a. Click in cell A1 and, while holding down Shift, click in cell C1. Now the operations you per-
form will apply to A1 through C1.

b. Click  to make the heading font bold, then click  to center the heading text. Click

 to apply a background color to those cells.

c. Click in cell A2 and, while holding down Shift, click in cell A3. Click  to make the row

description bold, then click  to right-align the text.

d. Manually resize the cells.

Your table should be similar to this:
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8. Click the Report Viewer tab and then click Refresh in the Report Viewer toolbar. The table
data appears at the bottom of the report.

3.4.7. Display the Inlet to Outlet Chart

In CFD-Post, displaying the Inlet to Outlet chart is equivalent to displaying averaged XY plots in Fluent.
To display the Inlet to Outlet chart:

1. In the Turbo workspace's Turbo Charts area, double-click Inlet to Outlet.

2. Now, change the chart to compare temperature to streamwise location (the latter being called
"meridional location" in Fluent) and make the chart look more like the Fluent default:

a. Set the following:

ValueSetting

fluidDomains

60Samples/Comp

Y Axis

Temperature> Variable

b. Click Apply. The chart appears:
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3. Click the Report Viewer tab at the bottom of the viewer area.

4. In the Report Viewer toolbar, click the Refresh button. The Inlet to Outlet Chart appears in
the User Data section of the report.

Tip:

You can also explore the other Turbo Charts:

• Blade Loading

• Circumferential

• Hub to Shroud
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3.4.8. Generate and View a Turbo Report

Turbo reports give performance results, component data summary tables, meanline 1D charts, stage
plots, and spanwise loading charts for the blade.

Note:

The Turbo report is generated from the values set when you initialized the case, so if there
were any changes required to those values, you would make them now and run the initial-
ization procedure again. For this tutorial, that will not be necessary.

To generate a Turbo report:

1. Create a new variable that the report expects (which would be available with CFX results files
for rotating machinery applications, but which is not available from Fluent case and data files).

a. From the toolbar, click Variable . The Insert Variable dialog box appears.

b. In the Name field, type Rotation Velocity and click OK.

The details view for Rotation Velocity appears.

c. In the Expression field, type Radius * abs(omega) / 1 [rad] and click Apply. This
expression calculates the angular speed (in units of length per unit time) as a product of
the local radius and the rotational speed.

2. In the 3D Viewer toolbar, click Fit View . This ensures that the graphics will not be truncated
in the report you are about to generate.

3. In the Outline tree view, right-click Report and select Report Templates. The Report Templates
dialog box appears.

4. Select an appropriate report template; in this case, select Centrifugal Compressor Report.

5. Click Load. The Report Templates dialog box disappears and you can watch the report's progress
in the status bar in the bottom-right corner of CFD-Post.

Note:

A dialog box appears that warns that hybrid values do not exist and that conservative
values will be used. This is expected behavior when using data loaded from Fluent.
An error about "Mach Number in Stn Frame" is also mentioned; this prevents a line
in the report from appearing. Click OK.

When the report has been generated, there are new entries in the Outline tree view under Report.

6. Under User Locations and Plots, double-click fluid Instance Transform. This is an in-
stance transform generated by the report to facilitate showing two blades in the figures that
show blade-to-blade views.
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7. Ensure that Number of Passages is set to 20 and click Apply.

8. Click the Expressions tab. Double-click the expression fluid Components in 360 to edit it.
Change the definition to 20 and click Apply.

To view the Turbo report:

1. In the Report Viewer, click Refresh. The turbo report appears.

2. Optionally, you can remove pieces from the report by clearing the appropriate check boxes in
the Report section of the Outline tree. When you have made your selections, return to the Report
Viewer and click Refresh (in the Report Viewer toolbar). The edited version of the turbo report
appears.

3. To produce an HTML version of the report that you can share with others, click Publish (at the
top of the viewer area). The report is saved in a filename of your choosing in your working dir-
ectory (by default).
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Chapter 4: Quantitative Postprocessing
This tutorial demonstrates the quantitative postprocessing capabilities of CFD-Post using a 3D model
of a circuit board with a heat-generating electronic chip mounted on it. The flow over the chip is lam-
inar and involves conjugate heat transfer.

The heat transfer involves conduction in the chip and conduction and convection in the surrounding
fluid. The physics of conjugate heat transfer such as this is common in many engineering applications,
not just the design and cooling of electronic components.

In this tutorial, you will read the case and data files and perform a number of postprocessing exercises.

This tutorial demonstrates how to do the following:

4.1. Problem Description

4.2. Preparing the Working Directory

4.3. Setting the Working Directory and Starting CFD-Post

4.4. Display the Solution in CFD-Post

Note:

These tutorials are prepared on a Windows system. The screen shots in the tutorials may be
slightly different than the appearance on your system, depending on the operating system
or graphics card.

4.1. Problem Description

The problem is shown schematically in Figure 4.1: Problem Specification (p. 66). The configuration
consists of a series of side-by-side electronic chips, or modules, mounted on a circuit board. Air flow,
confined between the circuit board and an upper wall, cools the modules. To take advantage of the
symmetry present in the problem, the model will extend from the middle of one module to the plane
of symmetry between it and the next module.

As shown in the figure, each half-module is assumed to generate 2.0 Watts and to have a bulk conduct-

ivity of 1.0 W/m2K. The circuit board conductivity is assumed to be one order of magnitude lower: 0.1

W/m2K. The air flow enters the system at 298 K with a velocity of 1 m/s. The Reynolds number of the
flow, based on the module height, is about 600. The flow is therefore treated as laminar.
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Figure 4.1: Problem Specification

If this is the first tutorial you are working with, it is important to review Introduction to the Tutori-
als (p. 7) before beginning.

4.2. Preparing the Working Directory

1. Create a working directory.

CFD-Post uses a working directory as the default location for loading and saving files for a particular
session or project.

2. Download the quantitative.zip file here.

3. Unzip quantitative.zip to your working directory.

Ensure that the following tutorial input files are in your working directory:

• chip.cas.gz

• chip.cdat.gz

4.3. Setting the Working Directory and Starting CFD-Post

Before you start CFD-Post, set the working directory. The procedure for setting the working directory
and starting CFD-Post depends on whether you run CFD-Post stand-alone, from the Ansys CFX
Launcher, or from Ansys Workbench:

• To run CFD-Post stand-alone

– On Windows:

1. From the Start menu, right-click All Programs > Ansys 2021 R2 > Fluid Dynamics > CFD-
Post 2021 R2 and select Properties.
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2. Type the path to your working directory in the Start in field and click OK.

3. Click All Programs > Ansys 2021 R2 > Fluid Dynamics > CFD-Post 2021 R2 to launch CFD-
Post.

– On Linux, enter cfdpost in a terminal window that has its path set up to run CFD-Post. The path
will be something similar to /usr/ansys_inc/v212/CFD-Post/bin.

• To run Ansys CFX Launcher

1. Start the launcher.

You can run the launcher in any of the following ways:

– On Windows:

→ From the Start menu, select All Programs > Ansys 2021 R2 > Fluid Dynamics > CFX 2021
R2.

→ In a Command Prompt that has its path set up correctly to run CFX, enter cfx5launch. If
the path is not set up correctly, you will need to type the full pathname of the cfx command,
which will be something similar to C:\Program Files\ANSYS Inc\v212\CFX\bin.

– On Linux, enter cfx5launch in a terminal window that has its path set up to run CFX .The
path will be something similar to /usr/ansys_inc/v212/CFX/bin.

2. Set the working directory.

3. Click the CFD-Post 2021 R2 button.

• Ansys Workbench

1. Start Ansys Workbench.

2. From the menu bar, select File > Save As and save the project file to the directory that you
want to be the working directory.

3. Open the Component Systems toolbox and double-click Results. A Results system opens in the
Project Schematic.

4. Right-click the A2 Results cell and select Edit. CFD-Post opens.

4.4. Display the Solution in CFD-Post

In the steps that follow, you will explore the solution using CFD-Post.

4.4.1. Prepare the Case and CFD-Post

4.4.2.View and Check the Mesh

4.4.3.View Simulation Values Using the Function Calculator

4.4.4. Create a Line
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4.4.5. Create a Chart

4.4.6. Add a Second Line

4.4.7. Create a Chart

4.4.8. Create a Table to Show Heat Transfer

4.4.9. Publish a Report

4.4.1. Prepare the Case and CFD-Post

Before you perform various quantitative analyses of the case, prepare the case and CFD-Post:

1. Start CFD-Post now and load the CDAT file (chip.cdat.gz) from the menu bar by selecting
File > Load Results. In the Load Results File dialog box, select chip.cdat.gz and click Open.

2. Set CFD-Post to display the units you want to see. These display units are not necessarily the
same types as the units in the results files you load; however, for this tutorial you will set the
display units to be the same as the solution units.

a. Right-click the viewer and select Viewer Options.

b. In the Options dialog box, select Common > Units.

c. Set System to SI and click OK.

Note:

The display units you set are saved between sessions and projects. This means that
you can load results files from diverse sources and always see familiar units displayed.

3. Optionally, set the viewer background to white:

a. Right-click the viewer and select Viewer Options.

b. In the Options dialog box, select CFD-Post > Viewer.

c. Set:

• Background > Color Type to Solid.

• Background > Color to white. To do this, click the bar beside the Color label to cycle
through 10 basic colors. (Click the right-mouse button to cycle backwards.) Alternatively,

you can choose any color by clicking  icon to the right of the Color option.

• Text Color to black (as above).

• Edge Color to black (as above).

d. Click OK to have the settings take effect.
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4.4.2. View and Check the Mesh

There are two ways to view the mesh: you can use the wireframe for the entire simulation or you can
view the mesh for a particular portion of the simulation.

To view the mesh for the entire simulation:

1. Right-click a line of the wireframe in the 3D Viewer and select Show surface mesh to display
the mesh.

2. Click the "Z" axis of triad in the viewer to get a side view of the object.

Note:

The 3D Viewer toolbar has to be in viewing mode for you to be able to select the
triad elements.

Figure 4.2: The Hexahedral Grid for the Simulation

3. In the Outline tree view, double-click User Locations and Plots > Wireframe to display the
wireframe's editor.

Tip:

Click the Details of Wireframe editor and press F1 to see help about the Wireframe
object.
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4. On the Wireframe details view, click Defaults and Apply to restore the original settings.

To view the mesh for a particular portion of the simulation (in this case, the chip (wall 4 shadow)):

1. In the Outline tree view, select the check box beside Cases > chip > fluid 8 > wall 4 shadow,
then double-click wall 4 shadow to edit its properties in its details view.

2. In the details view:

a. On the Render tab, clear Show Faces.

b. Select Show Mesh Lines.

c. Ensure that Edge Angle is set to 0 [degree].

d. Click Apply.
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The mesh appears and is similar to the mesh shown by the previous procedure, except that
the mesh is shown only on the chip.

e. Now, clear the display of the chip wireframe. In the details view:

i. Clear Render > Show Mesh Lines.

ii. Select Show Faces.

iii. Click Apply.

The chip reappears.

3. In the Outline tree view, clear the check box beside Cases > chip > fluid 8 > wall 4 shadow.

To check the mesh:

1. Select the Calculators tab at the top of the workspace area, then double-click Mesh Calculator.
The Mesh Calculator appears.

2. Using the drop-down arrow beside the Function field, select a function such as Maximum Face
Angle.

3. Click Calculate. The results of the calculation appear.

4. Repeat the previous steps for other functions, such as Mesh Information.

4.4.3. View Simulation Values Using the Function Calculator

You can view values in the simulation by using the Function Calculator:
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1. In the Calculators view, double-click Function Calculator. The Function Calculator appears.

2. In the Function field, select minVal as the function to evaluate.

3. In the Location field, select wall 4.

4. Beside the Variable field, select X in the Variable Selector dialog box.

5. Clear the Clear previous results on calculate setting and select Show equivalent expression.

6. Click Calculate to see the result of the calculation of the minimum X value of the chip.

7. Repeat the operation, but in the Function field, select maxVal as the function to evaluate. Click
Calculate to see the result of the calculation of the maximum X value of the chip.

You will use these values in subsequent steps.

4.4.4. Create a Line

Lines can be used to display quantitative results of your CFD simulations. Here, you will create a line
along which to plot the temperature distribution along the top center of the chip.
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1. Select Insert > Location > Line.

2. For the name, type topcenterline and click OK.

3. On the Details of topcenterline > Geometry tab:

a. Set Method to Two Points.

b. Set Point 1 to 0.0508, 0.01, 0.

c. Set Point 2 to 0.06985, 0.01, 0.

d. Ensure that Line Type is set to Sample.

Those coordinates define a line along the top center of the chip.

4. On the Color tab:

a. Set Mode to Variable.

b. Set Variable to Temperature.

These steps will color the line by temperature and cause the legend to be displayed.

5. Click Apply.
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4.4.5. Create a Chart

Here you will plot the temperature distribution along a line along the top center of the chip.

1. Select Insert > Chart.

2. For the name, type Chip Temperatures and click OK.

The Details of Chip Temperatures view appears.

3. On the General tab:

a. Set Title to Temperature Along the Top of the Chip.

b. Set Caption to Graph of the Temperature Along the Top of the Chip.

4. On the Data Series tab

a. Set Location to topcenterline.

b. Change the name Series 1 to Chip-Top Temperatures.

5. On the X Axis tab, set Variable to Chart Count.

6. On the Y Axis tab, set Variable to Temperature.

7. On the Line Display tab, select Chip-Top Temperatures and set Symbols to Rectangle.

8. Make the Symbol Color a darker shade of green: beside the Symbol Color field, click Color Se-

lector , select a new shade of green, and click OK.

9. Click Apply.
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4.4.6. Add a Second Line

Here you will create a second line near the bottom of the chip so that you can compare that to the
temperature distribution along the top center of the chip.

1. Select Insert > Location > Line.

2. For the name, type bottomsideline and click OK.

3. On the Details of bottomsideline > Geometry tab:

a. Set Method to Two Points.

b. Set Point 1 to 0.0508, 0.0027, 0.

c. Set Point 2 to 0.06985, 0.0027, 0.

d. Set Line Type to Sample.

Those coordinates define a line near board level beside the chip.

4. Click Apply.
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4.4.7. Create a Chart

Here you will plot the temperature distribution along the second line.

1. In the Report area of the Tree view, double-click Chip Temperatures.

2. On the General tab, change Title to Temperature Differences on the Chip and
Caption to Graph of the Temperature Along the Top and Bottom of the
Chip.

3. On the Data Series tab:

a. Click New  to create Series 2.

b. Set Location to bottomsideline.

c. Change the name Series 2 to Board-Level Temperatures.

4. On the Line Display tab, select Board-Level Temperatures and set Symbols to Rectangle.

5. Beside the Symbol Color field, click Color Selector , select a new shade of green, and click OK.

6. Click Apply.
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4.4.8. Create a Table to Show Heat Transfer

You can create a table to show how values change at different locations, provided that the locations
have been defined. In this section you will create three planes along the mixing region and measure
the temperatures on those planes. You will then create a table and define functions that show tem-
perature minimums and maximums, and the differences between those values.

1. In the 3D Viewer, ensure that only the wireframe is visible.

2. Click the cyan-colored ball on the triad to make it easier for you to see the temperature planes
that you will create.

3. From the toolbar, select Location > Plane. In the Insert Plane dialog box, type Table Plane
1 and click OK.

4. In the details view for Table Plane 1, set the following values:

ValueFieldTab

fluid
8

DomainsGeometry

YZ
Plane

Definition

>
Meth-
od

0.051
[m]

Definition

>
X

VariableModeColor

TemperatureVariable

LocalRange

(Cleared)LightingRender

5. Click Apply.

6. Right-click Table Plane 1 and select Duplicate. The Duplicate dialog box appears.

In the Duplicate dialog box, accept the default name Table Plane 2 and click OK.

In the Outline tree view, double-click Table Plane 2 and on the Geometry tab change Definition
> X to 0.0605. Click Apply.

7. Repeat the previous step, duplicating Table Plane 2 to make Table Plane 3 and changing
Definition > X to 0.0697. Click Apply.
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Now, create a table:

1. From the menu bar, select Insert > Table. Accept the default table name and click OK.

The Table Viewer opens.

2. Type in the following headings:

DCBA

DifferenceMax.
Temperature

Min.
Temperature

Distance Along
Chip

1

3. For the "Distance Along Chip" column, create an equation that gives the distance from the be-
ginning of the chip (which is available from "wall 4" in "solid 2"). Click cell A2, then in the Table
Viewer's Insert bar, select Function > CFD-Post > minVal. In the cell definition field you see
=minVal()@, which will be the base of the equation. With the cursor between the parentheses,
type X. Move the cursor after the @ sign and either type Table Plane 1 or select Insert >
Location > Table Plane 1.

=minVal(X)@Table Plane 1 - minVal(X)@wall 4
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When you click away from cell A2, the equation is solved.

Note:

The expressions in the equation are what you created in the Function Calculator. You
can copy expressions from the Function Calculator and paste them into table cells,
adding other characters in the cell definition field as required.

4. Complete the rest of the table by entering the following cell definitions:

Cell A2

=minVal(X)@Table Plane 1 - minVal(X)@wall 4

Cell A3

=minVal(X)@Table Plane 2 - minVal(X)@wall 4

Cell A4

=minVal(X)@Table Plane 3 - minVal(X)@wall 4

Cell B2

=minVal(T)@Table Plane 1

Cell B3

=minVal(T)@Table Plane 2

Cell B4

=minVal(T)@Table Plane 3

Cell C2

=maxVal(T)@Table Plane 1

Cell C3

=maxVal(T)@Table Plane 2

Cell C4

=maxVal(T)@Table Plane 3

Cell D2

=maxVal(T)@Table Plane 1 - minVal(T)@Table Plane 1

Cell D3

=maxVal(T)@Table Plane 2 - minVal(T)@Table Plane 2
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Cell D4

=maxVal(T)@Table Plane 3 - minVal(T)@Table Plane 3

As you complete the table, notice that the minimum temperature values stay constant, but the
maximum values increase as the chip heats the passing air.

5. The default format for cell data is appropriate for some variables, but it is not appropriate here.
Click cell A2, then while depressing the Shift key, click in the lower-right cell (D4). Click the

Number Formatting  icon in the Table Viewer toolbar. In the Cell Formatting dialog box, set
Precision to 2, change Scientific to Fixed, and click OK.

6. Optionally, apply some formatting to the table.

You can view the table in three places: in the Table Viewer (where you can apply formatting),
in the Report Viewer (where some of the formatting you applied in the Table Viewer will be
visible), and in the published report (which has default formatting for tables that you cannot see
in either the Table Viewer or the Report Viewer, but which are overridden by any formatting
changes you make in the Table Viewer). It is useful to view the published report (see Publish a
Report (p. 81)) before applying formatting in the Table Viewer.

To format the table as shown above:

a. For cells A1-D1: Apply bold font, background color, and text centering. Manually resize cell

widths individually.

b. For cells A2-D4: Right-justified text.
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4.4.9. Publish a Report

To save a report as an HTML file:

1. Click the Report Viewer tab.

2. Click Publish at the top of the Report Viewer.

3. In the Publish Report dialog box, specify a meaningful name for the report, such as IC_Cool
ing_Simulation.htm.

Tip:

Click the Browse icon in the Publish Report dialog box to control where the report
is stored.

4. Click OK.
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