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Chapter 1: Computational Fluid Dynamics
Computational Fluid Dynamics (CFD) is a computer-based tool for simulating the behavior of systems
involving fluid flow, heat transfer, and other related physical processes. It works by solving the equations
of fluid flow (in a special form) over a region of interest, with specified (known) conditions on the
boundary of that region.

This chapter discusses:

1.1.The History of CFD

1.2.The Mathematics of CFD

1.3. Uses of CFD

1.4. CFD Methodology

1.5. Further Background Reading

1.1. The History of CFD

Computers have been used to solve fluid flow problems for many years. Numerous programs have been
written to solve either specific problems, or specific classes of problems. From the mid-1970s, the
complex mathematics required to generalize the algorithms began to be understood, and general
purpose CFD solvers were developed. These began to appear in the early 1980s and required what
were then very powerful computers, as well as an in-depth knowledge of fluid dynamics, and large
amounts of time to set up simulations. Consequently, CFD was a tool used almost exclusively in research.

Recent advances in computing power, together with powerful graphics and interactive 3D manipulation
of models, have made the process of creating a CFD model and analyzing results much less labor in-
tensive, reducing time and, hence, cost. Advanced solvers contain algorithms that enable robust solutions
of the flow field in a reasonable time.

As a result of these factors, Computational Fluid Dynamics is now an established industrial design tool,
helping to reduce design time scales and improve processes throughout the engineering world. CFD
provides a cost-effective and accurate alternative to scale model testing, with variations on the simulation
being performed quickly, offering obvious advantages.

1.2. The Mathematics of CFD

The set of equations that describe the processes of momentum, heat and mass transfer are known as
the Navier-Stokes equations. These partial differential equations were derived in the early nineteenth
century and have no known general analytical solution but can be discretized and solved numerically.

Equations describing other processes, such as combustion, can also be solved in conjunction with the
Navier-Stokes equations. Often, an approximating model is used to derive these additional equations,
turbulence models being a particularly important example.
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There are a number of different solution methods that are used in CFD codes. The most common, and
the one on which CFX is based, is known as the finite volume technique.

In this technique, the region of interest is divided into small sub-regions, called control volumes. The
equations are discretized and solved iteratively for each control volume. As a result, an approximation
of the value of each variable at specific points throughout the domain can be obtained. In this way,
one derives a full picture of the behavior of the flow.

Additional information on the Navier-Stokes equations and other mathematical aspects of the CFX
software suite is available in Basic Solver Capability Theory in the CFX-Solver Theory Guide.

1.3. Uses of CFD

CFD is used by engineers and scientists in a wide range of fields. Typical applications include:

• Process industry: Mixing vessels, chemical reactors

• Building services: Ventilation of buildings, such as atriums

• Health and safety: Investigating the effects of fire and smoke

• Motor industry: Combustion modeling, car aerodynamics

• Electronics: Heat transfer within and around circuit boards

• Environmental: Dispersion of pollutants in air or water

• Power and energy: Optimization of combustion processes

• Medical: Blood flow through grafted blood vessels

1.4. CFD Methodology

CFD can be used to determine the performance of a component at the design stage, or it can be used
to analyze difficulties with an existing component and lead to its improved design.

For example, the pressure drop through a component may be considered excessive:
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The first step is to identify the region of interest:

The geometry of the region of interest is then defined. If the geometry already exists in CAD, it can be
imported directly. The mesh is then created. After importing the mesh into the preprocessor, other
elements of the simulation including the boundary conditions (inlets, outlets, and so on) and fluid
properties are defined.
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The flow solver is run to produce a file of results that contains the variation of velocity, pressure and
any other variables throughout the region of interest.

The results can be visualized and can provide the engineer an understanding of the behavior of the
fluid throughout the region of interest.

This can lead to design modifications that can be tested by changing the geometry of the CFD model
and seeing the effect.

The process of performing a single CFD simulation is split into four components:

1. Creating the Geometry/Mesh (p. 9)

2. Defining the Physics of the Model (p. 9)
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3. Solving the CFD Problem (p. 9)

4. Visualizing the Results in the Postprocessor (p. 10)

1.4.1. Creating the Geometry/Mesh

This interactive process is the first preprocessing stage. The objective is to produce a mesh for input
to the physics preprocessor. Before a mesh can be produced, a closed geometric solid is required.
The geometry and mesh can be created in the Meshing application or any of the other geometry/mesh
creation tools. The basic steps involve:

1. Defining the geometry of the region of interest.

2. Creating regions of fluid flow, solid regions and surface boundary names.

3. Setting properties for the mesh.

This preprocessing stage is now highly automated. In CFX, geometry can be imported from most
major CAD packages using native format, and the mesh of control volumes is generated automatically.

1.4.2. Defining the Physics of the Model

This interactive process is the second pre-processing stage and is used to create input required by
the Solver. The mesh files are loaded into the  physics preprocessor, CFX-Pre.

The physical models that are to be included in the simulation are selected. Fluid properties and
boundary conditions are specified.

1.4.3. Solving the CFD Problem

The component that solves the CFD problem is called the Solver. It produces the required results in
a non-interactive/batch process. A CFD problem is solved as follows:

1. The partial differential equations are integrated over all the control volumes in the region of in-
terest. This is equivalent to applying a basic conservation law (for example, for mass or momentum)
to each control volume.

2. These integral equations are converted to a system of algebraic equations by generating a set
of approximations for the terms in the integral equations.

3. The algebraic equations are solved iteratively.

An iterative approach is required because of the nonlinear nature of the equations, and as the solution
approaches the exact solution, it is said to converge. For each iteration, an error, or residual, is reported
as a measure of the overall conservation of the flow properties.

How close the final solution is to the exact solution depends on a number of factors, including the
size and shape of the control volumes and the size of the final residuals. Complex physical processes,
such as combustion and turbulence, are often modeled using empirical relationships. The approxim-
ations inherent in these models also contribute to differences between the CFD solution and the real
flow.
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The solution process requires no user interaction and is, therefore, usually carried out as a batch
process.

The solver produces a results file that is then passed to the post-processor.

1.4.4. Visualizing the Results in the Postprocessor

The postprocessor is the component used to analyze, visualize and present the results interactively.
Post-processing includes anything from obtaining point values to complex animated sequences.

Examples of some important features of postprocessors are:

• Visualization of the geometry and control volumes

• Vector plots showing the direction and magnitude of the flow

• Visualization of the variation of scalar variables (variables that have only magnitude, not direction,
such as temperature, pressure and speed) through the domain

• Quantitative numerical calculations

• Animation

• Charts showing graphical plots of variables

• Hard copy and online output.

1.5. Further Background Reading

The following is a selection of books related to fluids, thermodynamics, CFD and computing:

• An Introduction to Computational Fluid Dynamics, The Finite Volume Method

H K Versteeg and W Malalasekera; Longman, 1995. An excellent introduction to the theory of CFD
with well-presented derivations of the equations.

• Using Computational Fluid Dynamics

C T Shaw; Prentice Hall, 1992. An introduction to the practical aspects of using CFD.

• Numerical Heat Transfer and Fluid Flow

S V Patankar; Taylor & Francis, 1980. A standard text on the details of numerical methods.

• Engineering Thermodynamics: Work and Heat Transfer

G F C Rogers and Y R Mayhew; Longman, 1996. An undergraduate thermodynamics text book.

• Mechanics of Fluids

Bernard Massey, Spon Press, 1998. An undergraduate fluid mechanics text book.

• Viscous Fluid Flow
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F M White; McGraw Hill, 2005. An advanced text on fluid dynamics.

• Perry’s Chemical Engineer’s Handbook (7th Edition)

McGraw Hill Professional Publishing, 1997. A superb reference for the physical properties of fluids.

• An Album of Fluid Motion

Milton Van Dyke, The Parabolic Press, 1982. Fluid flow phenomena demonstrated in pictures.
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Chapter 2: Overview of Ansys CFX
Ansys CFX is a general purpose Computational Fluid Dynamics (CFD) software suite that combines an
advanced solver with powerful preprocessing and postprocessing capabilities. It includes the following
features:

• An advanced coupled solver that is both reliable and robust.

• Full integration of problem definition, analysis, and results presentation.

• An intuitive and interactive setup process, using menus and advanced graphics.

Ansys CFX is capable of modeling:

• Steady-state and transient flows

• Laminar and turbulent flows

• Subsonic, transonic and supersonic flows

• Heat transfer and thermal radiation

• Buoyancy

• Non-Newtonian flows

• Transport of non-reacting scalar components

• Multiphase flows

• Combustion

• Flows in multiple frames of reference

• Particle tracking.

This chapter discusses:

2.1.The Ansys Product Improvement Program

2.2.The Structure of Ansys CFX

2.3. Running Ansys CFX

2.4.The Directory Structure of Ansys CFX

2.5. Ansys CFX File Types

2.6. Starting Ansys CFX Components from the Command Line

2.7. 3Dconnexion Product Support

2.8. Compatibility with File Hosting Services
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2.1. The Ansys Product Improvement Program

This product is covered by the Ansys Product Improvement Program, which enables Ansys, Inc., to collect
and analyze anonymous usage data reported by our software without affecting your work or product
performance. Analyzing product usage data helps us to understand customer usage trends and patterns,
interests, and quality or performance issues. The data enable us to develop or enhance product features
that better address your needs.

How to Participate

The program is voluntary. To participate, select Yes when the Product Improvement Program dialog
appears. Only then will collection of data for this product begin.

How the Program Works

After you agree to participate, the product collects anonymous usage data during each session. When
you end the session, the collected data is sent to a secure server accessible only to authorized Ansys
employees. After Ansys receives the data, various statistical measures such as distributions, counts,
means, medians, modes, etc., are used to understand and analyze the data.

Data We Collect

The data we collect under the Ansys Product Improvement Program are limited. The types and amounts
of collected data vary from product to product. Typically, the data fall into the categories listed here:

Hardware: Information about the hardware on which the product is running, such as the:

• brand and type of CPU

• number of processors available

• amount of memory available

• brand and type of graphics card

System: Configuration information about the system the product is running on, such as the:

• operating system and version

• country code

• time zone

• language used

• values of environment variables used by the product

Session: Characteristics of the session, such as the:

• interactive or batch setting

• time duration
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• total CPU time used

• product license and license settings being used

• product version and build identifiers

• command line options used

• number of processors used

• amount of memory used

• errors and warnings issued

Session Actions: Counts of certain user actions during a session, such as the number of:

• project saves

• restarts

• meshing, solving, postprocessing, etc., actions

• times the Help system is used

• times wizards are used

• toolbar selections

Model: Statistics of the model used in the simulation, such as the:

• number and types of entities used, such as nodes, elements, cells, surfaces, primitives, etc.

• number of material types, loading types, boundary conditions, species, etc.

• number and types of coordinate systems used

• system of units used

• dimensionality (1-D, 2-D, 3-D)

Analysis: Characteristics of the analysis, such as the:

• physics types used

• linear and nonlinear behaviors

• time and frequency domains (static, steady-state, transient, modal, harmonic, etc.)

• analysis options used

Solution: Characteristics of the solution performed, including:

• the choice of solvers and solver options

• the solution controls used, such as convergence criteria, precision settings, and tuning options
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• solver statistics such as the number of equations, number of load steps, number of design points,
etc.

Specialty: Special options or features used, such as:

• user-provided plug-ins and routines

• coupling of analyses with other Ansys products

Data We Do Not Collect

The Product Improvement Program does not collect any information that can identify you personally,
your company, or your intellectual property. This includes, but is not limited to:

• names, addresses, or usernames

• file names, part names, or other user-supplied labels

• geometry- or design-specific inputs, such as coordinate values or locations, thicknesses, or other
dimensional values

• actual values of material properties, loadings, or any other real-valued user-supplied data

In addition to collecting only anonymous data, we make no record of where we collect data from. We
therefore cannot associate collected data with any specific customer, company, or location.

Opting Out of the Program

You may stop your participation in the program any time you wish. To do so, select Ansys Product
Improvement Program from the Help menu. A dialog appears and asks if you want to continue parti-
cipating in the program. Select No and then click OK. Data will no longer be collected or sent.

The Ansys, Inc., Privacy Policy

All Ansys products are covered by the Ansys, Inc., Privacy Policy.

Frequently Asked Questions

1. Am I required to participate in this program?

No, your participation is voluntary. We encourage you to participate, however, as it helps us create
products that will better meet your future needs.

2. Am I automatically enrolled in this program?

No. You are not enrolled unless you explicitly agree to participate.

3. Does participating in this program put my intellectual property at risk of being collected or discovered
by Ansys?

No. We do not collect any project-specific, company-specific, or model-specific information.
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4. Can I stop participating even after I agree to participate?

Yes, you can stop participating at any time. To do so, select Ansys Product Improvement Program
from the Help menu. A dialog appears and asks if you want to continue participating in the program.
Select No and then click OK. Data will no longer be collected or sent.

5. Will participation in the program slow the performance of the product?

No, the data collection does not affect the product performance in any significant way. The amount
of data collected is very small.

6. How frequently is data collected and sent to Ansys servers?

The data is collected during each use session of the product. The collected data is sent to a secure
server once per session, when you exit the product.

7. Is this program available in all Ansys products?

Not at this time, although we are adding it to more of our products at each release. The program
is available in a product only if this Ansys Product Improvement Program description appears in the
product documentation, as it does here for this product.

8. If I enroll in the program for this product, am I automatically enrolled in the program for the other Ansys
products I use on the same machine?

Yes. Your enrollment choice applies to all Ansys products you use on the same machine. Similarly,
if you end your enrollment in the program for one product, you end your enrollment for all Ansys
products on that machine.

9. How is enrollment in the Product Improvement Program determined if I use Ansys products in a cluster?

In a cluster configuration, the Product Improvement Program enrollment is determined by the host
machine setting.

10. Can I easily opt out of the Product Improvement Program for all clients in my network installation?

Yes. Perform the following steps on the file server:

a. Navigate to the installation directory: [Drive:]\v212\commonfiles\globalsettings

b. Open the file ANSYSProductImprovementProgram.txt.

c. Change the value from "on" to "off" and save the file.

2.2. The Structure of Ansys CFX

Ansys CFX consists of four software modules that take a geometry and mesh and pass the information
required to perform a CFD analysis:
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Ansys CFX File Types (p. 21) show the file types involved in this data flow.

2.2.1. CFX-Pre

The next-generation physics pre-processor, CFX-Pre, is used to define simulations.

Multiple meshes may be imported, allowing each section of complex geometries to use the most
appropriate mesh.

Analyses, which consist of flow physics, boundary conditions, initial values, and solver parameters,
are also specified. A full range of boundary conditions, including inlets, outlets and openings, together
with boundary conditions for heat transfer models and periodicity, are all available in Ansys CFX
through CFX-Pre; for details, see CFX-Pre Basics in the CFX-Pre User's Guide.

Complex simulations are assembled from one or more configurations, each of which combines an
analysis definition with other related tasks such as remeshing. Control over the configuration execution
order and inter-configuration solution dependencies then facilitates the setup of relatively common
simulations, such as those involving the initialization of a transient analysis using results from a steady-
state analysis. Use of multiple configurations and control also facilitates the setup of increasingly
complex simulations of, for example, performance curves for turbo-machines or internal combustion
engines with evolving geometry and physics.
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2.2.2. CFX-Solver

CFX-Solver solves all the solution variables for the simulation for the problem specification generated
in CFX-Pre.

One of the most important features of Ansys CFX is its use of a coupled solver, in which all the hydro-
dynamic equations are solved as a single system. The coupled solver is faster than the traditional se-
gregated solver and fewer iterations are required to obtain a converged flow solution.

Additional information on the CFX-Solver models is available; for details, see Basic Capabilities Mod-
eling in the CFX-Solver Modeling Guide.

2.2.3. CFX-Solver Manager

The CFX-Solver Manager module provides greater control to the management of the CFD task. Its
major functions are:

• Specify the input files to the CFX-Solver.

• Start/stop the CFX-Solver.

• Monitor the progress of the solution.

• Set up the CFX-Solver for a parallel calculation.

Additional information on the CFX-Solver Manager is available; for details, see CFX-Solver Manager
Basics in the CFX-Solver Manager User's Guide.

2.2.4. CFD-Post

CFD-Post provides state-of-the-art interactive postprocessing graphics tools to analyze and present
the Ansys CFX simulation results.

Important features include:

• Quantitative post-processing

• Report generation (see Report in the CFD-Post User's Guide)

• Command line, session file, or state file input (see File Types Used and Produced by CFD-Post in
the CFD-Post User's Guide)

• User-defined variables

• Generation of a variety of graphical objects where visibility, transparency, color, and line/face ren-
dering can be controlled (see CFD-Post Insert Menu in the CFD-Post User's Guide)

• Power Syntax to allow fully programmable session files (see Power Syntax in Ansys CFX in the CFX
Reference Guide).

Additional information on CFD-Post is available; for details, see Overview of CFD-Post in the CFD-Post
User's Guide.
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2.3. Running Ansys CFX

To run Ansys CFX:

Do this:On this operating
system:

Enter cfx5 in a terminal window.UNIX

From the Start menu select Ansys 2021 R2 > CFX 2021 R2.Windows

This opens the Ansys CFX Launcher, from which all other components of Ansys CFX can be accessed.
You will usually want to start by setting your Working Directory (where all files will be written to) and
then opening CFX-Pre by clicking the CFX-Pre 2021 R2 button. See Using the Ansys CFX Launcher (p. 31)
for more information about using the launcher.

Note:

• You can also start Ansys components from the command line (Starting Ansys CFX Com-
ponents from the Command Line (p. 22)) or Ansys Workbench (Ansys CFX in Ansys
Workbench (p. 33)).

• For CFX, TurboGrid and CFD-Post applications, the graphics viewer, which is based on
OpenGL 4.5, will work with Microsoft Windows Remote Desktop Connection only if you
are using Nvidia Quadro graphics cards with appropriate drivers for Windows 10. If you
see an empty (black) viewer, try setting the environment variable QT_OPENGL=desktop
on the remote machine before starting the application. To work around this issue you may
launch the CFX application prior to making the remote connection, or use one of the
other Ansys-supported remote display methods.

• If you are running CFX-Pre/CFD-Post/TurboGrid on a Linux machine that does not have a
compatible OpenGL driver installed, you can try starting the CFX application with software
rendering enabled by adding the command line parameter: -gr mesa.

2.3.1. Valid Syntax in Ansys CFX

Valid Syntax for Named Objects

The names of objects must be no more than 80 characters in length. Any of the following characters
are allowed to name new objects: A-Z a-z 0-9 <space> (however, the first character must
be A-Z or a-z). Multiple spaces are treated as single space characters, and spaces at the end of
a name are ignored. In general, object names must be unique within the physics setup.

Valid Decimal Separator

In Ansys CFX, only a period is allowed to be used as a decimal delimiter in fields that accept
floating-point input. Depending on your system configuration, fields that accept numeric input
will either accept a comma but return an error, or not accept a comma at all.
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Ansys Workbench accepts commas as decimal delimiters, but translates these to periods when
passing data to Ansys CFX.

Note:

CFX will not function correctly on a Linux system with the environment variable
"LC_ALL" set to a locale which uses a comma delimiter. The environment variable
"LANG" can usually be used to set the locale instead.

Valid Network Path

UNC paths are not supported in Ansys CFX. You should use drive letters when opening Ansys
CFX products over a network installation.

2.4. The Directory Structure of Ansys CFX

In this documentation, <CFXROOT> refers to the path to your installation of Ansys CFX, for example
C:\Program Files\ANSYS Inc\V212\CFX on Windows. The path to <CFXROOT> is release-
specific to enable you to have more than one release of Ansys CFX installed.

Some of the important directories immediately under <CFXROOT> are:

Contains executable programs for starting Ansys CFX software components.bin

Contains the host definition file for Ansys CFX software.config

Contains various data files common to all supported system types.etc

Contains sample files, including C source code files that can be used as the basis
of custom executables. User Fortran examples are also provided.

examples

Contains header files used by parts of the Ansys CFX software.include

Contains libraries needed to relink the CFX-Solver for user-defined mesh import
or mesh export.

lib

Contains software tools such as cygwin, perl, and qt.tools

2.5. Ansys CFX File Types

During the process of creating the model, running the CFX-Solver and analyzing the results, a number
of different files are created by the various modules of the software. This section describes some of
these files and their purposes.

The use of these files with their default extension is shown in the following flowchart. The standard
files used and produced are indicated with solid black lines; other possible uses are indicated with
dotted lines.
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Details of the main file types can be found in:

• CFX-Pre File Types in the CFX-Pre User's Guide

• CFX-Solver Files in the CFX-Solver Manager User's Guide

• File Types Used and Produced by CFD-Post in the CFD-Post User's Guide

• Supported Mesh File Types in the CFX-Pre User's Guide

For information on producing files for input into other post-processors, see File Export Utility in the
CFX-Solver Manager User's Guide.

2.6. Starting Ansys CFX Components from the Command Line

The components of Ansys CFX can all be started from the command line. A command consists of the
path to the command, the command name, and various arguments, many of which are optional.

For example, to start up CFX-Pre and play a session file named StaticMixer.pre, open a terminal
window and enter the command:

<CFXROOT>/bin/cfx5pre -play StaticMixer.pre
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where <CFXROOT> is the path to your installation of CFX, for example C:\Program Files\ANSYS
Inc\V212\CFX on Windows.

The following table lists some of the commands you can use to start Ansys CFX components:

ArgumentsCommandComponent

See Starting the Ansys CFX Launcher (p. 32).cfx5Ansys CFX
Launcher

or

cfx5launch

See Starting CFX-Pre from the Command Line in the
CFX-Pre User's Guide.

cfx5preCFX-Pre

See Starting the CFX-Solver from the Command Line in
the CFX-Solver Manager User's Guide.

cfx5solveCFX-Solver
Manager

See Starting CFD-Post from the Command Line in the
CFD-Post User's Guide.

cfdpostCFD-Post

Tip:

• To display a full list of all the possible arguments and a short description for any command,
type the command followed by -help. For example:

cfdpost -help

• Typing the argument -verbose after a command launches the software specified and
displays a summary of the currently set environment variables.

• Ansys CFX Launcher provides a command line with a preset path to the Ansys CFX execut-
ables. From the launcher, select Tools > Command Line. For details, see Command Line.

• You can append the path to the Ansys CFX executables to your Windows PATH.

1. Right-click My Computer and select Properties.

2. Click the Advanced tab.

3. Click Environment Variables.

4. In the System variables pane, select Path and click Edit.

5. Append the path to the Ansys CFX executables to the Variable value field. For ex-
ample:

C:\Program Files\ANSYS Inc\v212\CFX\bin;

6. Click OK as required to set the new path and close the dialog boxes.

• You can append the path to the Ansys CFX executables to your UNIX search path.
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2.6.1. Obtaining System Information with the cfx5info Command

You can use the command cfx5info to obtain information about your installation and your system.
The optional command arguments are given in the following table:

UsageArgument

Displays the long architecture string for the current machine.-arch

Prints the location of some common commands, if they can be found
in the PATH.

-cmds

If any site-specific or user-specific configuration files are in use, this
option will display their locations and contents.

-config

Displays a full report on the installation and configuration of Ansys CFX,
suitable for emailing to the Ansys CFX Support desk. This includes the
output of the -inst and -system options.

-full

Shows available command line options and descriptions.-help

Displays the current host name.-host

Looks up the named <host> in the network database, and displays some
information about it.

-host-addr
<host>

Displays information about the installation directory, and available
versions of Ansys CFX. This is the default if no arguments are passed.

-inst

Displays the short architecture string for the current machine.-os

Displays the release type, which will be "development," "prerelease" or
"release."

-reltype

Shows information about which subsets are installed. This option is valid
only for UNIX platforms.

-subsets

Displays information about the system on which Ansys CFX is running.-system

Prints information about the environment variables that are currently
set. The alternative form for this argument is -v

-verbose

Displays all available versions of <cmd>, as found on the PATH. This
option can be repeated.

-whereis
<cmd>

2.7. 3Dconnexion Product Support

See the Platform Support section of the Ansys Website for a complete list of 3Dconnexion products
certified with the current release of Ansys applications.

Note:

Note: The 3D Viewer in CFX/CFD-Post/TurboGrid does not support the buttons of a 3Dcon-
nexion device. However it might be possible to use the software provided with the device
to configure the buttons so that they send key sequences that trigger 3D Viewer actions.
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2.8. Compatibility with File Hosting Services

Files written by Ansys products do not support synchronization with Microsoft’s OneDrive file hosting
service.
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Chapter 3: Customizing Ansys CFX
This chapter discusses:

3.1. Ansys CFX Resource Configuration Files

3.1. Ansys CFX Resource Configuration Files

When Ansys CFX starts up, it reads several resource configuration files. By creating your own local and
site-wide configuration files, you can modify the behavior of Ansys CFX to meet your needs. A common
use for configuration files is to set the path to the license file or the license server.

3.1.1. The Site-wide Configuration Files

If you are accessing your Ansys CFX files from a remote file system, your System Administrator may
create site-wide resource configuration files. Ansys CFX first looks for such files in the following order:

1. <CFXROOT>/config/cfx5rc-<host>.txt

2. <CFXROOT>/config/cfx5rc-<arch>.txt

3. <CFXROOT>/config/cfx5rc-<os>.txt

4. <CFXROOT>/config/cfx5rc.txt

5. <CFXROOT>/config/cfx5rc-site.txt

where:

• host is the hostname of the machine on which Ansys CFX is running.

• arch is the architecture of the machine on which Ansys CFX is running.

• os is the operating system of the machine on which Ansys CFX is running.

You can find the value of host, arch, and os by selecting Show > Show System from the menu bar
of the Ansys CFX Launcher. On Windows, the value of os is winnt.

Note:

Any resources set in these files will affect all users of Ansys CFX, unless users override these
variables in their personal user’s Ansys CFX resource configuration files.

27
Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.



3.1.2. User’s Configuration Files

After searching for site-wide configuration files, Ansys CFX looks for the following user’s configuration
files:

• cfx5rc-<host>.txt

• cfx5rc-<arch>.txt

• cfx5rc-<os>.txt

• cfx5rc.txt

(and for the same files without .txt appended) in the following directories:

• On Windows: %USERPROFILE%\Application Data\CFX-5\21.2\ if it exists, otherwise
%HOMEDRIVE%\%HOMEPATH%\.cfx\21.2\ where %USERPROFILE%, %HOMEDRIVE% and
%HOMEPATH% are environment variables.

• On Linux: ~/.cfx/21.2/ and ~/CFX/21.2/

where ~ means your home directory (if you have one).

3.1.3. Syntax of CFX Resource Configuration Files

Ansys CFX resource configuration files should consist only of:

• Lines beginning with # (which are comments).

• Variable assignments such as: CFX5EDITOR="textedit"

The right hand side of an assignment may include references to previously assigned variables by
prefixing the variable name with $; for example,

CFX5BROWSER="$CFX5EDITOR"

Note:

In previous releases of Ansys CFX, these files could contain arbitrary Bourne shell commands.
These are no longer supported.

3.1.3.1. Resource Names

Ansys CFX software makes use of variable names that start with the following strings:

• CFDS_

• CFX_

• CFX4

• CFX5
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• CUE_

You must not set any variable of your own with a name beginning with these letters.

3.1.4. Resources Set in cfx5rc Files

You can find out which Ansys CFX resources have been set by using the Show > Show Variables
option from the menu bar of the Ansys CFX Launcher. This displays a list of all the resources that
have been set. Although you can change the values of most of the resources shown in this list, it is
generally useful to change only a few of them. These few are described in the following table:

DescriptionResource

Sets the program to use when browsing files in Ansys CFX.CFX5BROWSER

On Windows, the default browser is Notepad.

On Linux, the default value is system-dependent, but the Common
Desktop Environment file browser, dtpad, is used if possible. The
command must start its own X window, so if you wanted to use view,
for example, you could only do so by setting

CFX5BROWSER="xterm -e view"

Sets the program to use when editing files in Ansys CFX.CFX5EDITOR

On Windows, the default editor is Notepad.

On Linux, the default value is system-dependent but the Common
Desktop Environment file editor, dtpad, is used if possible. The
command must start its own X window, so if you wanted to use vi,
for example, you could only do so by setting

CFX5EDITOR="xterm -e vi"

Creates a window to interact with the operating system.CFX5XTERM

On Windows, the default window is a Windows command prompt set
up to run the Ansys CFX commands.

On Linux, the default value is system-dependent but the Common
Desktop Environment terminal emulator, dtterm, is used if possible.

If set to F, this command causes Ansys CFX programs to write
formatted CFX-Solver input and results files instead of binary files.

CFX_FORMAT

If set to U, then the files generated will be in binary format, but not
compressed.

If not set, then the files generated will be binary and compressed.
This is the default.

Sets the name of the user-defined executable for CFX Volume Mesh
Import.

CFX_IMPORT_EXEC
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DescriptionResource

Can be used to identify a license server machine or license file. If set,
this specification is used before any other license path information.

ANSYSLMD_LI
CENSE_FILE

See Ansys Client Settings Utility in the Ansys, Inc. Licensing Guide for
precedence information.

The default port number assigned to Ansys, Inc. is 1055. Therefore, if
your server has the hostname alpha1 and the IP address of 10.3.1.69,
you can identify the server to use as 1055@alpha1 or 1055@10.3.1.69.

Note:

The FLEXlm environment variable LM_LICENSE_FILE is not
supported with the Ansys, Inc. License Manager.

Used to identify the server machine for the Licensing Interconnect.
Set to port@host. The default port is 2325. This setting takes
precedence over settings specified in the ansyslmd.ini file.

ANSYSLI_SERVERS

This is a colon-separated list of directories that will be searched to
look for shared libraries on HP systems. If you have installed system

SHLIB_PATH

libraries in directories that are not included in this list, then add them
to it.

3.1.4.1. Setting Environment Variables

You should set the variables in your cfx5rc file. You must not create environment variables that
start with CFX.
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Chapter 4: Using the Ansys CFX Launcher
CFX can be run in two modes:

• CFX stand-alone, which refers to CFX running as a stand-alone application independent of the Ansys
Workbench software

• CFX in Workbench, which refers to CFX running as a component inside of the Ansys Workbench
software. This is described in Ansys CFX in Ansys Workbench (p. 33).

Note:

For CFX, TurboGrid and CFD-Post applications, the graphics viewer, which is based on OpenGL
4.5, will work with Microsoft Windows Remote Desktop Connection only if you are using
Nvidia Quadro graphics cards with appropriate drivers for Windows 10. If you see an empty
(black) viewer, try setting the environment variable QT_OPENGL=desktop on the remote
machine before starting the application. To work around this issue you may launch the CFX
application prior to making the remote connection, or use one of the other Ansys-supported
remote display methods.

Note:

If you are running CFX-Pre/CFD-Post/TurboGrid on a Linux machine that does not have a
compatible OpenGL driver installed, you can try starting the CFX application with software
rendering enabled by adding the command line parameter: -gr mesa.

Ansys CFX stand-alone has the launcher, which makes it easy to run all the modules of CFX without
having to use a command line. The launcher enables you to:

• Set the working directory for your simulation.

• Start CFX and Ansys products.

• Access various other tools, including a command window that enables you to run other utilities.

• Access the online help and other useful information.

• Customize the behavior of the launcher to start your own applications.

The launcher automatically searches for installations of CFX and Ansys products including the license
manager. Depending on the application, the search includes common installation directories, directories
pointed to by environment variables associated with CFX and Ansys products, and the Windows registry.
In the unlikely event that a product is not found, you can configure the launcher using steps outlined
in Customizing the Ansys CFX Launcher in the CFX Reference Guide.
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This chapter discusses Starting the Ansys CFX Launcher (p. 32). For more information about the
launcher, see Ansys CFX Launcher in the CFX Reference Guide.

4.1. Starting the Ansys CFX Launcher

You can run the Ansys CFX Launcher in any of the following ways:

• On Windows:

– From the Start menu, select Ansys 2021 R2 > CFX 2021 R2.

– In a Command Prompt that has its path set up correctly to run Ansys CFX, enter: cfx5

If the path has not been set, you need to type the full path to the cfx5 command; typically this
is:

C:\Program Files\ANSYS Inc\V212\CFX\bin\cfx5.exe

• On Linux, open a terminal window that has its path set up to run Ansys CFX and enter: cfx5

If the path has not been set, you need to type the full path to the cfx5 command; typically this is:

/usr/ansys_inc/v212/CFX/bin/cfx5.exe

Note:

When you start Ansys CFX Launcher, the displayed Working Directory is not the directory
the launcher was started in; the directory is defined by the settings stored in CFXPrefer-
ences.ccl. To default the working directory to the current directory at start-up, set the
CFX_LAUNCH_START_IN_CWD environment variable to 1.
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Chapter 5: Ansys CFX in Ansys Workbench
Ansys CFX components can be run in two modes:

• As stand-alone applications started from the Ansys CFX Launcher and independent of the Ansys
Workbench software. This mode is described in Using the Ansys CFX Launcher (p. 31).

• As applications launched from Ansys Workbench.

Note:

For CFX, TurboGrid and CFD-Post applications, the graphics viewer, which is based on OpenGL
4.5, will work with Microsoft Windows Remote Desktop Connection only if you are using
Nvidia Quadro graphics cards with appropriate drivers for Windows 10. If you see an empty
(black) viewer, try setting the environment variable QT_OPENGL=desktop on the remote
machine before starting the application. To work around this issue you may launch the CFX
application prior to making the remote connection, or use one of the other Ansys-supported
remote display methods.

This chapter describes using Ansys CFX in Ansys Workbench:

5.1.The Ansys Workbench Interface

5.2. Data Flow Within and Between Systems

5.3. An Example Fluid Flow Setup

5.4. Default File Locations

5.5.Working with CFX in Workbench

Note:

This chapter assumes that you are familiar with using Ansys CFX in stand-alone mode. You
should consult the Ansys Workbench help for more detailed information on Ansys Workbench.

Important:

CFX in Ansys Workbench does not support the use of filenames or project names that contain
multiple consecutive spaces, or the "$", "#", or "," characters anywhere in their filepath.

5.1. The Ansys Workbench Interface

To launch Ansys Workbench on Windows, click the Start menu, then select All Programs > ANSYS
2021 R2 > Workbench 2021 R2.
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To launch Ansys Workbench on Linux, open a command line interface, type the path to "runwb2" (for
example, "~/ansys_inc/v212/Framework/bin/Linux64/runwb2"), then press Enter.

The Ansys Workbench interface is organized to make it easy to choose a system (a group of components)
that will enable you to solve particular types of problems. Once you have chosen a system from the
Toolbox and moved it into the Project Schematic, supporting features such as Properties and Messages
provide orienting information. These features and the status indicators in the system cells guide you
through the completion of the System steps.

The figure that follows shows Ansys Workbench with a TurboGrid component system and a Fluid Flow
(CFX) analysis system open and linked together. The properties of cell A1 (TurboGrid) are displayed in
the Properties pane:

The following sections describe the main Ansys Workbench features.

5.1.1. Toolbox

The Toolbox shows the systems available to you:
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Analysis Systems

Systems that match the workflow required to solve particular types of problems. For example,
the Fluid Flow (CFX) system contains tools for creating the geometry, performing the meshing,
setting up the solver, using the solver to derive the solution, and viewing the results.

Component Systems

Software elements upon which Analysis Systems are based. For example, the CFX component
system contains Setup (CFX-Pre), Solution (CFX-Solver Manager), and Results (CFD-Post). The
Results component system contains only Results (CFD-Post).

Custom Systems

Systems that combine separate analysis systems. For example, the FSI: Fluid Flow (CFX) > Static
Structural system combines Ansys CFX and the Mechanical application to perform a unidirectional
(that is, one-way) Fluid Structure Interaction (FSI) analysis.

Design Exploration

Systems that enable you to see parametric change of outputs in relation to changing inputs.

Note:

Which systems are shown in the Toolbox depends on the licenses that exist on your system.
You can hide systems by enabling View > Toolbox Customization and clearing the check
box beside the name of the system you want to hide.

To begin using a system, drag it into the Project Schematic area.

5.1.2. Project Schematic

The Project Schematic enables you to manage the process of solving your CFD problem. It keeps
track of your files and shows the actions available as you work on a project. At each step you can
select the operations that process or modify the case you are solving.

When you move a system from the Analysis Systems toolbox to the Project Schematic, you will see
a set of tools similar to the following:

35
Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

The Ansys Workbench Interface



Each white cell represents a step in solving a problem. Right-click the cell to see what options are
available for you to complete a step.

Many cells launch specialized software that enables you to perform the task required by that step.
For example, in a Fluid Flow (CFX) system:

• Geometry > New Geometry launches DesignModeler.

• Mesh > Edit launches the Meshing Application.

• Setup > Edit launches CFX-Pre.

• Solution > Edit launches CFX-Solver Manager.

• Results > Edit launches CFD-Post.

However, the system cells are not simply launching other software, they operate to advance the
workflow. For example, if the Mesh cell is in the state Update required, you will not be able to launch
CFX-Pre from the Setup cell until the Mesh cell has been updated.

5.1.3. Workspace Tabs

Systems such as Engineering Data, DesignXplorer, and Parameters, can be placed in the Project
Schematic and can be opened in arrangements of views, called workspaces. Native workspaces are
edited directly within Workbench. Each native workspace is shown in its own tab with its Outline,
Properties, Table, and Chart panes displayed when appropriate. Tabs can be opened by editing a
system cell from the Project Schematic. You can switch between workspaces by selecting their re-
spective tabs. For more details on tabs and the panes available within tabs, see Tabs in Workbench
in the Workbench User's Guide and Panes within Tabs in the Workbench User's Guide.
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5.1.4. View Menu

You control which panes are displayed by opening the View menu and setting a check mark beside
the pane you want to display. If you minimize that pane, it appears as a tab above the Status Bar and
the check box is cleared from the View menu.

5.1.5. Properties Pane

The Properties pane is a table whose entries describe the status of a system. These entries vary
between system cells and are affected by the status of the cell. Some entries in the Properties area
are writable; others are for information only.

To display the Properties for a particular cell, right-click the cell and select Properties. Once the
Properties pane is open, simply selecting a cell in the Project Schematic will display that cell's
properties.

The following properties are specific to Ansys CFX components:

Setup Cell Properties

Provides information about the current settings in Ansys CFX-Pre and describes
how to adjust them. This information includes details on any physics validation

Physics Status

errors that require attention before the solution can update (which is the same
information that is available in the CFX-Pre physics validation summary).

Solution Cell Properties

Choose True (the default, unless you change the Workbench preference
for this property) to automatically, after updating the Solution cell, delete

Keep Latest Solution
Data Only

any associated old solution data (in effect, performing Clear Old Solution
Data > All Old Data). This is useful for reducing the total disk space used
by the project.

The default, which applies to newly created systems, can be changed via
a Workbench preference. For details, see CFX in the Workbench User's
Guide.

Choose False to retain old solution data when updating the Solution
cell. This is the behavior for Release 16.2 and prior releases.

The default, which applies to newly created systems, can be changed via
a Workbench preference. For details, see CFX in the Workbench User's
Guide.

Choose True to retain cached solution data for non-current Design Points
(in addition to the current Design Point) after they are solved. This allows

Cache Solution Data

for faster Design Point restarts, and is especially useful when updating
multiple Design Points after making a small non-parametric change to
the case; the cached solution data is used to provide initial conditions.
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The default can be changed via a Workbench preference. For details, see
CFX in the Workbench User's Guide.

Note:

The Cache Solution Data property acts as if set to False
when running a multiple configuration case.

Choose False (the default, unless you change the Workbench preference
for this property) to automatically, after solving the current Design Point,
delete any associated cached solution data (in effect, performing Clear
Cached Solution Data > Current Design Point Only). This is useful for
reducing the total disk space used by the project.

Note that, for this choice (False), solving all Design Points has the effect
of deleting the associated cached solution data for all Design Points.

The default can be changed via a Workbench preference. For details, see
CFX in the Workbench User's Guide.

AutomaticInitialization Option
[a] [b]

This option is intended to use the best available solution data to initialize
the solution.

The data for initializing the solution is found according to the following
order of precedence:

1. Restart

2. Cached solution data

3. Current solution data or previous updated solution data, depending
on the Design Point initiation.

4. Upstream solution data

5. Initial conditions

Note:

Cached solution data is not available when running a multiple
configuration case.

Update from cached solution data if possible

The data for initializing the solution is found according to the following
order of precedence:

• Restart

• Cached solution data
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• Upstream solution data

• Initial conditions

Note:

• Cached solution data is not available when running a
multiple configuration case.

• Note that Update from cached solution data if
possible behaves in a similar way to Update from
current solution data if possible except that
it is not influenced by Design Point initiation.

Update from current solution data if possible

The data for initializing the solution is found according to the following
order of precedence:

1. Restart

2. Current solution data or previous updated solution data, depending
on the Design Point initiation.

3. Upstream solution data

4. Initial conditions

Note:

• This option (Update from current solution data
if possible) is the default (unless you change the
Workbench preference for this property) and is not desirable
for:

– Starting from initial conditions provided by another system

– A situation in which you have divergent results and do
not want to start an update from those bad results.

The default can be changed via a Workbench preference.
For details, see CFX in the Workbench User's Guide.

• A Results Error file (.res.err) produced by CFX-Solver
during a failed run is treated as current cell data by the
Solution cell; however, the Solution cell will not be marked
as being up-to-date. These files may not be usable for
initializing a subsequent update when the initialization option
Update from current solution data if pos
sible is selected. In these situations, update from the
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originally defined initial conditions by selecting Clear Gen-
erated Data, or by changing the Initialization Option
property of the Solution cell.

Update from initial conditions

The data for initializing the solution is found according to the following
order of precedence:

• Restart

• Upstream solution data

• Initial conditions

Note:

• For cases involving System Coupling, and for cases involving
multiple configurations, the Initialisation Option property
must be set to Update from initial conditions.

• In order to avoid using restart data (that is, to avoid having
the run continue from the previous results), the Solution cell
must not be in an up-to-date state or an interrupted state.
To achieve this, clear any generated data by right-clicking
the Solution cell and selecting Clear Generated Data.

If you add or change Execution Control in CFX-Pre in a way that is
perceived to conflict with the Execution Control settings stored in the

Execution Control
Conflict Option

Solution cell, by default an error message appears when you attempt to
update the Solution cell. From the Properties pane you can choose to set
Workbench to:

• Warn

This is the default (unless you change the Workbench preference for
this property), which enables you to decide on a case-by-case basis by
using the Solution cell's context menu.

When there is a perceived conflict between the two sources of execution
control settings, a warning message appears. This enables you to resolve
the conflict by right-clicking the Solution cell and selecting Edit Run
Definition. You can then choose to use the execution control settings
from either the Setup cell or the Solution cell for either this run or for
all subsequent runs (until you change the Workbench preference for
this setting).

• Use Setup Cell Execution Control causes the execution
control specified by the Setup cell to be used. Selecting the
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corresponding Workbench preference for this setting is equivalent to
right-clicking the Solution cell and selecting Using execution control
from Setup cell always.

• Use Solution Cell Execution Control causes the execution
control specified by the Solution cell to be used. Selecting the
corresponding Workbench preference for this setting is equivalent to
right-clicking the Solution cell and selecting Using execution control
from Solution cell always.

The default can be changed via a Workbench preference. For details, see
CFX in the Workbench User's Guide.

See Resolving Execution Control Conflicts (p. 69) for details.

Choose Last results only to load only the last configuration of a
multi-configuration results file, or only the last results from a results file
that contains a run history, into CFD-Post.

Load Option [c]

Choose Complete history as a single case to load all
configurations of a multi-configuration run as a single case, or all of the
results history from a results file that contains a run history. In either case,
only one set of results will appear in the CFD-Post viewer, but you can
use the timestep selector to move between results. This option is not fully
supported.

Note:

When multi-configuration files are loaded as a single sequence,
the solution expressions (Reference Pressure, and so on)
represent the last configuration, no matter which configuration
is currently viewed.

Choose Complete history as separate cases to load all
configurations from a multi-configuration run into separate cases. If a
results file with run history is loaded, CFD-Post loads the results from this
file and the results for any results file in its run history as separate cases.
Each result appears as a separate entry in the tree.

Controls how the update proceeds. The options are:Update Option

• Run in Background

• Run in Foreground

• Submit to Remote Solve Manager

• During a foreground update, the user interface strictly limits what you
can do. For example, you cannot edit other cells, save, or quit.

• During a background update, the user interface allows other operations
and updates on other cells to take place, and you can also save and
quit the project.
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After saving and quitting, the solver run will still continue. You can
re-open the project and use the Reconnect button to access data that
was put into batch mode.

• If you select Submit to Remote Solve Manager, you need to
specify the Solve Manager (use localhost for a local parallel run on a
machine that has the appropriate parallel processing software installed
and configured) and the Queue (which you define using the Remote
Solve Manager software). See Using CFX with the Remote Solve
Manager (p. 60) for details.

Note:

The run mode for the update to the Solution cell is set on
the CFX-Solver Manager's Define Run dialog box. If you
specify a remote host, you must ensure that the run mode
you choose is supported on that host.

For a project that has been saved, a foreground update that is in progress
can be made into a background update by using the Switch Active
Solution to Background context menu option. This action will not change
the Update Option setting for the next run.

Results Cell Properties

Select this check box to automatically publish a report. The location of
the report is displayed in the Files pane.

Generate Report

When running in Workbench, CFX-Solver Manager has, in its Define Run dialog box, on
the Initial Values tab, an Initialization Option setting that synchronizes interactively with

[a]

changes in the Initialization Option property of the Solution cell. For details on the Initial
Values tab, see Initial Values Tab in the CFX-Solver Manager User's Guide.

For cases involving System Coupling, and for cases involving multiple configurations, this
property must be set to Update from initial conditions.

[b]

For details, see Configurations in the CFX-Pre User's Guide.[c]

5.1.6. Files Pane

The Files pane shows the files that are in the current project. The project files are updated constantly,
and any "save" operation from the Ansys CFX components will save all files associated with the project.

Important:

Although the Files pane reveals the data files that make up a project, you should not at-
tempt to manipulate these files directly, as project data management will proceed unaware
of your changes and with unpredictable results.

5.1.6.1. Ansys CFX Files in Ansys Workbench

Ansys Workbench associates data with system cells. This data may be stored in different ways, in-
cluding as part of the Ansys Workbench project file or as separate files. When files are generated,
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they appear in the Files pane. This pane can be used to identify which files are associated with
each cell.

The table that follows associates cell types with file types and gives typical extensions for those file
types.

File Extension ExamplesFile TypeSystem
Cell

.agdbGeometry FileGeometry

.cmdb (CFX-Mesh)[a]Mesh FileMesh

.mshdb (Mesh Database File)

.cfxCFX-Pre Case FileSetup

.def[a], .mdef[a]CFX-Solver Input File

.out[a]CFX-Solver Output FileSolution

.res[a], .mres[a]CFX-Solver Results File

.trn (Transient Results File)[a]

.cstCFD-Post State FileResults

AnsysReportLogo.png[a]CFD-Post Output Files[b]

Report.html[a]

Generated file (Generated files are not copied when you duplicate a system and are removed
when you run the Clear Generated Data command.)

[a]

Does not include animation files or the output of Save Picture commands.[b]

5.1.7. Sidebar Help

In addition to having a visual layout that guides you through
completing your project, you can also access Sidebar Help by
pressing F1 while the mouse focus is anywhere on Ansys
Workbench. Sidebar Help is a dynamically generated set of links
to information appropriate for helping you with questions you
have about any of the tools and systems you currently have open.
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5.1.8. Context Menu Commands

You can access commonly used commands by right-clicking in most areas of Ansys Workbench. These
commands are described in Context Menus in the Workbench User's Guide. In addition, there are
commands that are specific to Ansys CFX:

Recreate Deleted Cells

When you import a mesh file into CFX-Pre from a Fluid Flow (CFX) system and no geometry or
mesh exists in the upstream cells, the Mesh and Geometry cells are automatically deleted. You
can restore these cells by right-clicking the system header and selecting Recreate Deleted Cells.

There are also commands that are specific to CFX Solution cells:

Display Monitors

Opens the CFX-Solver Manager and shows either the monitors of the run in progress or, if there
is no run in progress, the results of the latest solver run associated with the cell.

If you are monitoring the progress of a Remote Solve Manager run, by default the progress reports
update every 30 seconds. However, you can adjust this through the Progress Download Interval
setting in the Solution cell Properties. See Submitting Solutions to Remote Solve Manager in the
Workbench User's Guide for details.

Note:

If running using RSM you cannot use the CFX-Solver Manager to edit, interrupt, or stop
the run in progress, or to trigger a manual backup file.

Import Solution

Displays the most recent CFX Solver Results files imported (if any) and enables you to browse for
such files using the Open dialog box, where you can specify the CFX Solver Results file to load.
When the results file is loaded, the system will display only the Solution cell and the Results cell.

Continue Calculation

Performs an update of the Solution cell, completing a previously stopped run (if one is available),
or otherwise restarts the current run.

Clear Execution Control

When you start a solver run or when you click Save Settings on the Define Run dialog box of
the CFX-Solver Manager, the settings from the Define Run dialog box are stored for the Solution
cell that launched the solver. These are the execution control settings for that cell; the Clear Exe-
cution Control command removes those settings.

Note:

You should not clear the execution control settings while the CFX-Solver Manager is
running as this can make file paths in the Define Run dialog box inaccurate.
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Clear Old Solution Data

Enables you to reduce the use of disk space. There are two options:

Data Not Referenced by Current Solution

Deletes all the results files except the most recent one and any results files to which it refers.

All Old Data

Deletes all the results files except the most recent one.

Note that there is no change to cache data for any Design Point.

Clear Cached Solution Data

Enables you to reduce the use of disk space. There are two options:

Current Design Point Only

Deletes the associated cached solution data for the current Design Point, but not for the non-
current Design Points.

All Design Points

Deletes the associated cached solution data for all Design Points in the project.

5.2. Data Flow Within and Between Systems

The cells in a system communicate status with each other. For example, when you change a mesh in
the Mesh cell, the Setup cell will report that its software (CFX-Pre) requires a refresh to re-read the
"upstream" data.

Similarly, the same type of data flow occurs between systems. For example, if you have an FSI: Fluid
Flow system (as shown in the image below), data and status from the Fluid Flow (CFX) Geometry cell
will flow both to the Fluid Flow (CFX) Mesh cell and the Static Structural Geometry cell. Data flow
between systems is shown by interconnecting lines:
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5.3. An Example Fluid Flow Setup

This section walks through an example of using Ansys CFX in Ansys Workbench to perform a fluid-flow
analysis. This walkthrough assumes familiarity with the basic Ansys Workbench and Ansys CFX applications
and does not discuss the details of the steps within each application.

The data flow between cells (and systems) drives the workflow.

1. You begin by launching Ansys Workbench, which opens as an unsaved project and displays the
available Analysis Systems.

2. In your file system you create a directory in which to store your project files. You then select File
> Save As and save your new project to that directory. This automatically sets your working directory
for this project.

3. In the Analysis Systems toolbox, double-click Fluid Flow (CFX) to create a fluid-analysis system
in the Project Schematic. (Notice that if you "hover" over systems in the Toolbox, a tooltip appears.)
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The fluid-analysis system in the Project Schematic shows the steps in performing a fluid analysis:

1. Create or import a geometry.

2. Create a mesh for the geometry.

3. Set up the analysis that will be sent to the solver.

4. Control and monitor the solver to achieve a solution.

5. Visualize the results in a post-processor and create a report.

4. In addition to showing those steps in appropriately named cells, each cell can launch a tool that
will enable you to perform the task it names. Right-click the Geometry cell to see your options for
adding a geometry to your project:
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5. As you move through the cells from Geometry to Results, you can choose to launch the tool that
will enable you to complete the cell's step:

a. Create a new geometry with the DesignModeler application (Geometry cell).

b. Create a new mesh with the Meshing application (Mesh cell).

c. Edit the case with CFX-Pre (Setup cell).

d. Run the solver by updating the Solution cell, or optionally edit the Solution cell and use the
Define Run dialog box from CFX-Solver Manager.

Note:

The Custom Solver Options (Custom Executable and Solver Arguments), which
are available in the CFX-Solver Manager in stand-alone mode, are not available in
CFX-Solver Manager launched from Ansys Workbench.
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e. Display of the results with CFD-Post (Results cell).

Note:

You could open a Fluid Flow (CFX) system and go immediately to the Setup cell to import
an existing case. When the case is loaded, the now-unnecessary Geometry and Mesh
cells disappear.

6. When the analysis is complete and the project is finished, you save the project (and therefore the
associated files). Once a project has been saved, it can be re-opened at a later date for review or
modification of any aspect of the simulation.

Important:

Saving a project enables you to re-open the project on the machine that originally created
it. To make the project available on another machine, you need to use File > Archive to
create a project archive. To open the project on a different machine, run File > Restore
Archive on that machine.

5.4. Default File Locations

Ansys CFX applications launched from Ansys Workbench have default locations for file operations that
are appropriate for Ansys Workbench:

• Save operations default to the user_files directory. The user_files directory appears under
the directory that holds the Project file (<projectfile_name>/user_files/).

If the default directory has already been set, changing the save location in a file dialog box also
changes the default save directory. If a change is made to the project directory through Ansys
Workbench, that will also reset the default directory.

Note:

A change in defaults is held only for the duration of the Ansys CFX application session
(that is, an exit and re-edit of an Ansys CFX application) will reset the defaults back to
project user_files for export operations and to the permanent files directory for import
operations.

• Open operations default to the permanent files directory. The permanent files directory holds the
Project file.

• Export operations initially default to the user_files directory, but change to the last directory
used for an export operation during a session.

In addition, there is an icon in the directory tree that takes you to the user_files, and all recent
directory selections are available from the directory path drop-down selector.
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5.5. Working with CFX in Workbench

The following topics are discussed:

5.5.1.Tips on Using Ansys Workbench

5.5.2.Working with CFX/Fluid Flow Systems

5.5.3.Working with Parameters and Design Exploration

5.5.4. Using CFX with the Remote Solve Manager

5.5.5. Using Journaling and Scripting with CFX in Workbench

5.5.6. Performing System Coupling Simulations Using CFX in Workbench

5.5.7. Archiving CFX Projects

5.5.8.Troubleshooting

5.5.9. Running Ansys CFX Tutorials in Ansys Workbench

5.5.1. Tips on Using Ansys Workbench

The following sections contain tips for the general use of Ansys CFX in Ansys Workbench:

5.5.1.1. Ansys Workbench Interface

A lot of important functionality is available in the context menu (cells, parameter bar, and so on).
Also, you should enable the View > Properties pane and investigate options for each cell.

5.5.1.2. Setting Units

Ansys Workbench units and options are not passed to Ansys CFX applications; this could require
you to set units twice.

5.5.1.3. Files Pane

Use the Files pane to determine which files were created for each cell/system. This can be very
useful if you need to do some runs or change some settings outside of Ansys Workbench, or if you
want to manually delete some but not all files associated with a particular cell. It is easiest to find
files associated with a specific cell by sorting the pane by Cell ID. This will sort the list by system
and then by cell.

5.5.1.4. Ansys Workbench Preferences: Named Selections

The Tools > Options > Geometry Import settings include a Named Selections option and a Fil-
tering Prefixes text field. In order to make sure that any named selections specified in DesignModeler
propagate through to the meshing stage, ensure that Named Selections is selected and that the
Filtering Prefixes text field is cleared.

Note:

If you select a language other than English under Regional and Language Options,
use of Symmetry and Enclosure operations in DesignModeler can lead to non-ASCII
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characters, which are not supported by Ansys CFX, being included in automatically
generated named selections. You can prevent such named selections from being created
by either:

• Using Meshing as part of a Fluid Flow (CFX) system (rather than a separate
Mesh component system), or

• Changing, under the Geometry cell properties, Advanced Geometry Options >
Enclosure and Symmetry Processing to No.

5.5.1.5. Mesh Modifications in CFX-Pre in Ansys Workbench

If you perform any mesh modifications (such as transformations, renaming, glue/unglue, delete)
within CFX-Pre on meshes provided by the Project Schematic, avoid any further changes to the
Mesh and Geometry cells providing these meshes.

During a refresh of upstream mesh data, CFX-Pre will require that the same series of mesh modific-
ations and transformations on the new mesh be successfully reapplied. If any of these transformations
fail (possibly due to topological changes, or changes to regions and named selections that the
transformations operate on), CFX-Pre will issue an error message, and revert to the previous mesh
data. Workbench will report the error as an "Application Error" during the mesh refresh, however
the Project Schematic state for the Setup cell will indicate that the refresh was done successfully
by being marked as Up-to-date.

To correct this mesh refresh error, the geometry or mesh changes that caused the error should be
reverted, or (if possible) the Mesh cell should be disconnected and the Setup cell refreshed again
before reconnecting the Mesh cell.

5.5.1.6. Loading .cmdb Files

To import a .cmdb file, you have to use the File > Import option on the main Ansys Workbench
toolbar. This will import the geometry and mesh settings and create a .mshdb file.

It is not possible to read a mesh file without any reference to a geometry file, even when you select
File > Import and select a .cmdb file. A Mesh system that includes a Geometry cell appears (the
Geometry cell has a green tick and a red circle with "!"). If you try to link or duplicate such a system,
problems are observed.

It is also not possible to read a mesh file without any reference to a geometry file when creating
a mesh component system first – you cannot right-click the Mesh cell and select a command to
import a .cmdb file; only .gtm and .cfx files are possible choices.

5.5.1.7. Ansys Workbench Connections

When selecting a system in the toolbox, Ansys Workbench will highlight the cells in any systems
already in the Project Schematic to which a valid connection can be made.

Connections between systems in Ansys Workbench are direction-dependent. This has implications
in one-way and two-way FSI cases. For example, in a one-way case you need to transfer the data
from the CFX system to the Static Structural system. As a consequence, the CFX system will be
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positioned to the left of the Static Structural system on the schematic. For two-way FSI, the Static
Structural system will be positioned to the left of the CFX system on the schematic.

Connections are not supported from the Setup cells of Steady-State and Transient Thermal analyses
systems to the Setup cell of the Fluid Flow systems (for example, thermal two-way FSI).

Using multi-configuration CFX cases as part of a one-way FSI calculation is not supported. The
Project Schematic will permit the connection, but the calculation will fail.

5.5.2. Working with CFX/Fluid Flow Systems

The following sections contain tips for the use of CFX/Fluid Flow systems in Ansys Workbench:

5.5.2.1. Changes in Behavior

5.5.2.2. Duplicating Systems

5.5.2.3. Renaming Systems

5.5.2.4. Updating Cells

5.5.2.5. Setup Cell

5.5.2.6. Solution Cell

5.5.2.7. Results Cell

5.5.2.8. Recovering After Deleting Files

5.5.2.9. Backwards Compatibility When Ansys CFX Files Exist in the Original Project

5.5.2.10. License Sharing

5.5.2.1. Changes in Behavior

The ability to play session files is missing in Ansys Workbench for Ansys CFX applications.

The undo stack is cleared in CFX-Pre/CFD-Post after the application receives commands from Ansys
Workbench.

You cannot launch Ansys CFX products from one another in Ansys Workbench; you must use the
system cells.

Ansys Workbench "remembers" previous locations of imported files / projects. Ansys CFX, however,
displays different behavior for loading or saving any files, always using the directory specified in
the Tools > Options > Default Folder for Permanent Files in Ansys Workbench.

Duplicate node removal for importing Fluent meshes into CFX-Pre is always ON in Ansys Workbench,
regardless of any settings in the Ansys CFX preferences file. CFX-Pre does not read this file when
run in Ansys Workbench.

5.5.2.2. Duplicating Systems

If you have a Fluid Flow (CFX) system, and you want to duplicate the system in such a way that
the duplicate shares Geometry and Mesh with the original system, then right-click the Setup cell
of the original Fluid Flow system (not the system header) and choose Duplicate. The CFX data as-
sociated with the original Setup cell is copied to the duplicated Setup cell, ready for you to modify
it.
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If you create a set up by duplicating an existing one, the run files associated with the first schem-
atic are named according to the name of the schematic; in this release it is not possible to control
the name of the run files in the duplicate schematics.

Duplication normally involves only user files (files for which you have specified settings). For Ansys
CFX, these are the .cfx and .cst files. Other files, which are considered to be "generated" (for
instance, the .def, .res, and .out files), are not duplicated.

5.5.2.3. Renaming Systems

Rename all your CFX and Fluid Flow (CFX) systems to something unique and meaningful that reflects
the contents of the system, especially if there are multiple systems. The names of the files associated
with the system cells will incorporate this system name when the files are first created, making it
easier for you to identify the files in the Files pane. Furthermore, CFD-Post will take the system
name (by default "Fluid Flow" for a Fluid Flow system) as the case name of the results in CFD-Post.
Note that it is best to rename the systems as soon as they are placed on the Project Schematic,
as the generated file names and/or the CFD-Post case names will not necessarily be updated if a
system is renamed after the appropriate cells already have associated data (for example, a .cfx
file with the Setup cell). It may be useful to reset the Results cell to update the CFD-Post case name
if the system is renamed, but you will lose any existing CFD-Post settings and objects by doing this.

5.5.2.4. Updating Cells

When you connect an up-to-date Mesh cell to the Setup cell of a CFX or a Fluid Flow (CFX) system,
the Mesh cell becomes out-of-date because the relevant data must be created. You must update
the Mesh cell.

If a second identical component system is added (CFX+CFX or Fluent+Fluent), there is no need to
update the project again. An update of the project is required if a different system component is
added (CFX+Fluent or Fluent+CFX).

5.5.2.5. Setup Cell

Changing the Mesh Import options (for example, relating to Names Selections or Contact settings)
for importing a mesh from a Mesh cell into a Setup cell (CFX-Pre) is not straightforward. The Setup
cell will use whatever options are stored in your preferences file at the time when the mesh is im-
ported. You can change these settings by using Tools > Options or by using the Mesh Import form
in stand-alone CFX-Pre (choosing Use settings next time). The next time you refresh the Setup
cell with a new Mesh, CFX-Pre will use the new mesh import settings. In some circumstances this
could lead to unexpected results, for example if you were relying on a specific set of Named Selection
options to identify your regions but changed these settings when working on another project.
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If you make changes to the execution control in CFX-Pre while you have CFX-Solver Manager open,
you need to click the Refresh button on the Define Run dialog box in order to make sure that the
CFX-Solver Manager re-reads the new information from the CFX-Solver Input file.

Note:

Ansys Workbench supports only one connection from Static Structural or Transient
Structural systems' Setup cells to a single CFX or Fluid Flow (CFX) Setup cell for two-way
FSI.

5.5.2.6. Solution Cell

When you edit the Solution cell, the Define Run dialog box of the CFX-Solver Manager has a Save
Settings button. Clicking this button associates the settings on the dialog box with the Solution
cell and closes the dialog box. You must now update the Solution cell to run the CFX-Solver.

Always check that the Initialization Option property is set correctly for each Solution cell in any
CFX-related system. This can be viewed and set using:

• The Properties pane on the Solution cell.

• CFX-Solver Manager’s Define Run dialog box, Initial Values tab.

When running in Workbench, CFX-Solver Manager has, in its Define Run dialog box, on the Initial
Values tab, an Initialization Option setting that synchronizes interactively with changes in the
Initialization Option property of the Solution cell.

The default value for the Initialization Option property is Update from current solution
data if possible unless you change the Workbench preference for this property. Details of
the Initialization Option property are given in Properties Pane (p. 37).

• If you have performed a solver run and want to re-run it with initialization provided by the results
of the first solver run, then you can leave the Initialization Option property set to Update
from current solution data if possible.

• If you have performed a solver run and want to re-run it with the original initialization then perform
at least one of the following actions before re-running:

– Set the Initialization Option property to Update from initial conditions.

– Right-click the Solution cell and select Clear Generated Data.

• If you have performed a solver run and want to re-run it with specified initialization then perform
all of the following actions before re-running:

– Specify the new initial values.

– Set the Initialization Option property to Update from initial conditions.

– Right-click the Solution cell and select Clear Generated Data.

Clearing the generated data prevents the Solution cell from being in an up-to-date state or in
an interrupted state, thereby preventing restart data from being used.
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After running the CFX solver multiple times within the same system, for example when updating
the solution or continuing the calculation, you may accumulate unwanted results files from the
previous runs. Consider using Reset or Clear Generated Data on the Solution cell before re-running
the CFX-Solver on this cell. These delete all the files from any previous run on that cell (for example,
all CFX-Solver Results and CFX-Solver Output files), and prevent the project from getting too large.
If you do not want to clear all the files, but want to clear some of them, consider using Clear Old
Solution Data or Clear Cached Solution Data on the Solution cell. If you want to delete specific
files:

1. Open the Files pane (Ansys Workbench View > Files).

2. Sort the list by Cell ID (which is actually the cell coordinates, not the ID).

3. Scroll down to the results file(s) for the desired Solution cell ID.

Note that you cannot directly delete the files from this pane.

4. Right-click a result file and select Open Containing Folder.

This opens your operating system's file browser at the directory containing the result file.

5. Remove the unwanted files using the browser.

After doing this, you may want to remove the obsolete file references from the list in the Files pane.
Multi-select all the red files (sort by ascending size to get them all together) and choose to Remove
<file> from List to get Ansys Workbench to remove them from the Files pane completely.

If you set the CFX-Solver to Background mode and shut down Ansys Workbench, upon restarting
Ansys Workbench and reopening the project, if the solver run has not completed, you will need to
use the Reconnect button to continue monitoring the solver run.

The information at end of a CFX-Solver Output file shows only the temporary location for the CFX-
Solver Results file, not the final location. The correct locations can be found in the Files pane.

CFX-Solver Results files (in particular the .res files) are associated with the Solution cell, not the
Results cell. This means that a CFX-Solver Results file cannot be imported onto a Results cell; it can
be imported onto a Solution cell of a Fluid Flow or CFX system. Similarly, resetting the Results cell
will not remove the CFX-Solver Results file.

Ansys Workbench permits you to import data from a Polyflow Solution cell into the Solution cell
of a CFX system; however, the CFX-Solver execution will fail when the Solution cell of the CFX system
is updated.

For simulations involving multiple configurations, initializing a Solution cell of either a Fluid Flow
(CFX) analysis system or a CFX component system from another Solution cell is not supported. At-
tempts to update the downstream Solution cell will result in an error. You must define initialization
conditions for each configuration manually.

5.5.2.7. Results Cell

In Ansys Workbench, the state of CFD-Post is associated with the Results cell. To maintain multiple
states, you must generate multiple Results systems. For your convenience, you can provide a unique
name for each system.
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To perform a file comparison in CFD-Post, drag a Solution cell from another system to the Results
cell.

You can have CFD-Post generate report output at every update (by setting Generate Reports in
Results cell Properties pane). The .html file is visible in the Files pane: right-click it, select Open
containing folder, and double-click the file in the explorer to see the report in a browser.

When updating existing Results cell data (with CFD-Post open) where a turbo chart with an averaged
variable was used (for example, turbo reports), a warning dialog box may appear reporting that
"No data exists for variable …" This warning can be ignored.

You can change the CFD-Post multi-configuration load options (available on the Load Results
panel of CFD-Post when in stand-alone mode) by editing the Properties of the Solution cell. This
is a property of the Solution cell, rather than the Results cell.

5.5.2.8. Recovering After Deleting Files

If you accidentally delete the current .def, .res or .out files for a CFX system and the Solution
cell status is up-to-date, you may get errors when trying to display the solution monitor or edit the
Results cell. In this case you will need to replace the files in the File Manager, or Reset the Solution
cell, and update the system. If the .def file is missing, you may also need to Clear Generated
Data for the Setup cell before updating the system.

5.5.2.9. Backwards Compatibility When Ansys CFX Files Exist in the Original
Project

When importing a .wbdb file (that contains .agdb, .cmdb, .cfx, and .res files), only a Mesh
system is imported instead of a "Fluid Flow (CFX)" analysis system. You need to drag a CFX system
and associate the files with this system.

Pointers to the original CFX files are present in the Files pane. Using the right-click option Import
Onto Schematic, a copy of the file is taken and an associated system is generated with the copy
- however the Files pane now seems to have two versions of the same file.

You can drag a CFX system and associate the files with this system, manually importing the file into
the correct cell.

Ansys Workbench does not support directly importing legacy FSI cases, so you have to create a
CFX system from the legacy CFX-Solver Results file, manually link it to the Static Structural system,
suppress the old load in Static Structural, and update it to import the load in the proper format
from the CFX system.

Files that are moved or deleted and that were previously associated with a cell in the Project
Schematic will be highlighted in red in the Files pane. There are right-click options to Remove or
Repair the files. You should be aware that Ansys Workbench will ensure that the file is repaired
using a file of a similar type but not necessarily the same name (or contents). If the contents of the
repaired file do not match those of the original file, unexpected results may be produced or the
case will fail.
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5.5.2.10. License Sharing

If you are using license sharing in Ansys Workbench, you can use only one license for CFX-Pre/CFD-
Post even if you have more available. This has implications if, for example, you want to run a long
animation in CFD-Post and use CFX-Pre at the same time. If you know you are going to be working
with CFX-Pre and CFD-Post at the same time, you need to change the license-sharing setting before
starting your project.

5.5.3. Working with Parameters and Design Exploration

Design Exploration enables you to modify the geometry and physics of your project so that you can
determine the influence of selected design parameters defined in your model. You do this by declaring
design input parameters in CFX-Pre (see Outline Tree View Shortcut Menu Commands in the CFX-Pre
User's Guide) and input parameters and output parameters in CFD-Post (see Expressions Tree View in
the CFD-Post User's Guide), then running a Design Exploration study with Ansys CFX in Ansys Workbench.

You can apply a DesignXplorer study to a converged project by opening the project in Ansys Work-
bench and double-clicking a Design Exploration system from the left pane. This displays the design
exploration system under the Parameter Set bar in the Project Schematic.
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Note:

• A sample tutorial describing how to use design exploration in Ansys CFX is available.

• For more information on using design exploration in Ansys Workbench, see DesignXplorer
User's Guide.

The following sections contain tips for the use of parameters and design exploration:

5.5.3.1. Retaining and Exporting Design Points

5.5.3.2. Number of Design Points

5.5.3.3. Obtaining Solutions for Design Points

5.5.3.4.The CFX-Solver Background Mode

5.5.3.5. Limitations When Using Parameters and Design Points with Ansys CFX
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5.5.3.1. Retaining and Exporting Design Points

By default (depending on the Solution cell property Cache Solution Data, described in Properties
Pane (p. 37)), only data associated with the current Design Point is stored, whereas data associated
with non-current Design Points is not.

For information on accessing data associated with non-current Design Points, see Retaining Design
Point Data and Exporting Design Points to New Projects in the Workbench User's Guide.

5.5.3.2. Number of Design Points

During a parametric study, the original set of files used to set a problem up is copied for each
Design Point, using file space. To minimize the use of file space, minimize the number of unnecessary
Design Points.

When working with exported Design Points, you should limit the Project Schematic only to systems
that are involved in the Design Point changes. Having other systems (for example, a CFX system)
in the project that are not involved in the Design Point update will mean duplication of these sys-
tems' database/results files for every exported Design Point, and this can use a significant amount
of disk space.

If you generate a large number of Design Points in a Design of Experiments (DOE), it is possible
that a small proportion of them will fail to update, preventing the DOE cell from becoming up-to-
date. In such a case, you cannot continue with the rest of this design exploration analysis. The DOE
can be modified to remove these failing Design Points by selecting Design of Experiments > Type
> Custom and then manually deleting the Design Points that failed to update successfully. Provided
that sufficient Design Points remain for adequate analysis, then the DOE can be updated and you
can continue with the analysis

5.5.3.3. Obtaining Solutions for Design Points

When running Design Points with a CFX system with a specified solver maximum residual criterion,
you should always set the minimum solution iterations to at least 3 in the Solver Control panel. If
this setting is left at the default "1", the solver may stop after one or two iterations, falsely believing
convergence has been reached.

If you have selected the solution to Update from Current Solution Data (default setting), you may
need to choose the input parameter values wisely for the Current Design Point because it will be
the starting solution for all other Design Points. To avoid this situation, set Update from Initial
Conditions as an Initialization Option in the CFX-Solver Manager before updating the Design
Points.

5.5.3.4. The CFX-Solver Background Mode

In a Design Points study, if you have set the CFX-Solver to Background mode[1], none of the Design
Points will become up-to-date until all the solver jobs have finished. This is not the case when the
CFX-Solver has been set to Foreground mode (the default setting), where each Design Point becomes

Note that an adequate number of licenses are required for this.[1]
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up-to-date before the next one commences updating. The former option, though, can prove more
efficient in terms of speed, especially in the case of long runs on multi-core configurations.

Note:

When the Licensing Interconnect sharing mode is used, the Update of Design Points in
background mode will not work.

5.5.3.5. Limitations When Using Parameters and Design Points with Ansys CFX

• Although the names of design parameters can be modified using the Parameter Manager within
Ansys Workbench, this is not recommended, because the new names will not be reflected within
the CFX application user interfaces.

• In a design points study, when you have some up-to-date design points, you should avoid editing
the Results cell and running CFD-Post interactively. Most editing and viewing actions result in
an underlying state change and therefore make the design points appear out-of-date, requiring
another update.

• If an input parameter is defined in CFX-Pre directly in the physics setup (that is, not using an
expression) then it should be removed by clearing the parameterization check box next to the
parameter setting before any physics changes are made that would make the parameter not
applicable. If it is not removed, then any attempt to change the value of this parameter through
Workbench, or run multiple design points, will result in a physics error of the form: "The
parameter <parameter name> is present in the object <path> but it
is not physically valid.", referring to the parameter that was set as a Workbench input
parameter. If this occurs, then one way to remove the input parameter is to enter the following
into the Command Editor: delete /PARAMETERIZATION/INPUT FIELD: <parameter
name> where <parameter name> is the input parameter name. Once the parameterization
has been removed, the new physics settings can be re-applied in CFX-Pre to remove the physics
error and allow the design point update to complete successfully.

• When running a design point study, the User Location Regeneration setting is effectively set
to All, meaning that all parameterized user locations are updated for each design point. For
details, see Solver Tab in the CFX-Pre User's Guide.

5.5.4. Using CFX with the Remote Solve Manager

Remote Solve Manager (RSM) enables you to configure queues containing compute servers (machines
that will run partitions of a job). A serial run is one in which there is one partition, a local parallel run
is one in which all of the partitions are executed on the same compute servers (not necessarily your
local machine), and a distributed parallel run is one in which partitions are distributed and run across
multiple hosts. When runs on remote hosts are completed, the resulting files are automatically sent
back to your local machine.

CFX Distributed Parallel is supported via RSM for batch queuing systems.

Remote Solve Manager generally enables you to solve on remote machines as many types of runs as
can be solved on your local machine, but with various restrictions that are generally related to the
availability of external files (files that you have manually specified for certain features in CFX applica-
tions) on the remote machine. For remote runs, where external files may not be available using the
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same path as the machine on which the run was set up, RSM has to identify the location of any ex-
ternal files and then copy them to the remote location. Not all external files can be treated correctly
at the current release. The restrictions include:

• Solver models that include user-defined remeshing may not be reliably run in RSM mode if the
External Command refers to a command that is not available in the same location as that specified
in the External Command parameter.

• The following are unsupported:

– Directory structures (unsupported, but may work)

– Custom Solvers

– User-defined remeshing

– TASCFlow Real Gas Properties

– Manual specification of Initial Values files (not set up through the Workbench Project Schematic)

– Files referenced from within another non-CFX file (for example, a file referenced by an Ansys Input
File)

– User Fortran source code or libraries (unsupported, but may work)

– Any file manually specified in CFX-Solver Manager

Some unsupported features may work if the file paths for external files on the remote machine are
the same as on the machine that set up the case.

To learn how to configure Remote Solve Manager, see Getting Started with Distributed Compute
Gateway in the Distributed Compute Gateway User's Guide.

5.5.4.1. Configuring CFX over Remote Solve Manager

To configure a local parallel run for a CFX/Fluid Flow (CFX) case using a previously configured
Remote Solve Manager in either serial mode or with previously installed parallel processing software
(such as Intel MPI):

1. Start Workbench.

2. Drag either a CFX or a Fluid Flow (CFX) system into the Project Schematic.

3. Load the case into the Setup cell.

4. Select View > Properties on the Solution cell to set the following Solution Process options:

a. Set Update Option to Submit to Remote Solve Manager.

b. Set Solve Manager from the drop-down menu. (The available hosts are determined by
the queue.)

c. Set Queue to a queue listed in the drop-down menu. (Use Remote Solve Manager to add
queues and Compute Servers.)
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d. Set the Solution Process as desired. Note that:

• Serial runs are always supported.

• Intel MPI Local Parallel is supported on all platforms that support RSM, and therefore
is the safest choice.

• Distributed parallel processing is supported only when the RSM Client is also the RSM
Manager and acts as one of the Compute Servers (remote machines can also act as
Compute Servers in this configuration).

5. Update the Solution cell. A dialog box appears that gives the status of the update.

5.5.4.2. Limitations When Using Remote Solve Manager with Ansys CFX

Ansys CFX has the following limitations when used with Remote Solve Manager:

• You cannot edit, interrupt, or stop a run that is in progress using the CFX-Solver Manager. You
can, however, interrupt the run using the Workbench progress bar.

• You cannot create a manual backup file using the Backup button in the CFX-Solver Manager.

• By default the CFX-Solver Manager will update its monitors only every 30 seconds, rather than
continuously. However, you can adjust this through the Progress Download Interval setting in
the Solution cell Properties. See Submitting Solutions to Remote Solve Manager in the Workbench
User's Guide for details.

• Using the Cache Solution Data option in conjunction with the Remote Solve Manager may result
in a large number of data files (all the cached data) being submitted to the Remote Solve Manager
when each design point is calculated. This can lead to a significant slowdown in the overall cal-
culation.

5.5.5. Using Journaling and Scripting with CFX in Workbench

Journaling is the capturing of Workbench actions (creating a project, opening a system, and so on)
to a file. For CFX applications, CCL and command actions are embedded within Workbench actions.

Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.62

Ansys CFX in Ansys Workbench



Scripting refers to the processes of editing and running a journal file in Workbench. With scripting,
you could, for example, implement a prescribed workflow.

This section describes how to acquire, edit, and run script files that have commands that affect CFX
components. For more general information, see Using Journals and Scripts in the Workbench User's
Guide.

Note:

• Journal actions such as a CFD-Post Export or the loading of a static .res file record the
path of the file. You may need to manually adjust this filepath before attempting to rerun
the journal, particularly if you have created the journal using an unsaved project. More
generally, when you create a project, you should save the project immediately to set
file paths that Workbench uses (rather than require Workbench to use file paths that
have temporary directories, as happens before the project is saved).

• The handling of file paths described in File Path Handling in Ansys Workbench in the
Workbench Scripting Guide applies to file references that are made outside of CCL and
command actions.

• Journal files must not contain an Undo command from a CFX application.

5.5.5.1. Acquiring a Journal File with CFX in Workbench

The basic workflow for acquiring a journal file with CFX in Workbench is as follows:

1. Start Workbench.

2. Save the project. (This enables Workbench to set file paths that will be usable when you play
back journal operations that involve the loading or exporting of files.)

3. Start journaling: Select File > Scripting > Record Journal and set a name for the journal file.

4. From Toolbox panel, open a CFX system (such as Component System > CFX).

5. Create and run a CFX simulation. The actions you perform are captured by the Journaling
process and written to the .wbjn file that you named in step 2.

6. Stop journaling: File > Scripting > Stop Recording Journal.

7. Optionally, edit the journal file (this is the process of scripting).

8. Run File > Scripting > Run Script File and select a .wbjn file.

5.5.5.1.1. Journal of an Operation That Uses CFX-Pre

When you record a journal file of an operation that uses CFX-Pre, the contents will be similar to
the following code snippets. In these snippets, a user has opened Workbench and recorded a
session that created a CFX system, opened CFX-Pre, imported a mesh file (SYS-1.cmdb), created
an inlet boundary, created an outlet boundary, and saved the project as saveJou.wbpj:
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Create the CFX system

template1 = GetTemplate(TemplateName="CFX")
system1 = template1.CreateSystem(Position="Default")

Edit the Setup cell and import a mesh (SYS-1.cmdb)

setup1 = system1.GetContainer(ComponentName="Setup")
setup1.Edit()
setup1.SendCommand(Command=r">gtmImport filename=C:\SYS-1.cmdb, \
type=GTM_DSDB, genOpt= -names 'CFXMesh ACMO_Simulation' \
-contact read -relative 0.001, units=m, nameStrategy= Assembly")

Note:

The setup1.SendCommand command above must be entered as a single line;
multiple lines are shown here for readability.

Create an inlet boundary (in1)

setup1.SendCommand(Command="""FLOW: Flow Analysis 1
  DOMAIN: Default Domain
&replace     BOUNDARY: in1
      Boundary Type = INLET
      Interface Boundary = Off
      Location = F18.12
      BOUNDARY CONDITIONS: 
        FLOW REGIME: 
          Option = Subsonic
        END # FLOW REGIME:
        MASS AND MOMENTUM: 
          Normal Speed = 1 [m s^-1]
          Option = Normal Speed
        END # MASS AND MOMENTUM:
        TURBULENCE: 
          Option = Medium Intensity and Eddy Viscosity Ratio
        END # TURBULENCE:
      END # BOUNDARY CONDITIONS:
    END # BOUNDARY:in1
  END # DOMAIN:Default Domain
END # FLOW:Flow Analysis 1""")

Create an outlet boundary (out)

setup1.SendCommand(Command="""FLOW: Flow Analysis 1
  DOMAIN: Default Domain
&replace     BOUNDARY: out
      Boundary Type = OUTLET
      Interface Boundary = Off
      Location = F17.12
      BOUNDARY CONDITIONS: 
        FLOW REGIME: 
          Option = Subsonic
        END # FLOW REGIME:
        MASS AND MOMENTUM: 
          Option = Average Static Pressure
          Pressure Profile Blend = 0.05
          Relative Pressure = 0 [Pa]
        END # MASS AND MOMENTUM:
        PRESSURE AVERAGING: 
          Option = Average Over Whole Outlet
        END # PRESSURE AVERAGING:
      END # BOUNDARY CONDITIONS:
    END # BOUNDARY:out
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  END # DOMAIN:Default Domain
END # FLOW:Flow Analysis 1""")

Quit CFX-Pre

setup1.Exit()

Save the Project file

Save(
    FilePath=r"C:\saveJou.wbpj",
    Overwrite=True)

In the above snippets, note how CCL and command actions for CFX-Pre are encapsulated as ar-
guments of SendCommand instructions.

5.5.5.1.2. Journal of an Operation That Uses CFX-Solver Manager

When you record a journal file that refreshes and updates a CFX Solution cell, the contents will
be similar to the following snippet.

RefreshComponent(Component="/Schematic/Cell:Solution")
UpdateComponent(
    Component="/Schematic/Cell:Solution",
    AllDependencies=True,
    Force=False)

5.5.5.1.3. Journal of an Operation That Creates a Plane in CFD-Post

In the following incomplete snippet, a user has created a Results system, edited the Results cell,
loaded a CFX-Solver Results file (StaticMixer_001.res) and then created a plane named
"Plane 1":

Create the Results system

template1 = GetTemplate(TemplateName="Results")
system1 = template1.CreateSystem(Position="Default")

Edit the Results cell and load the Results file (StaticMixer_001.res)

results1 = system1.GetContainer(ComponentName="Results")
results1.Edit()
results1.SendCommand(Command=r"""DATA READER:
  Clear All Objects = false
  Append Results = true
  Edit Case Names = false
  Open to Compare = false
  Multi Configuration File Load Option = Separate Cases
  Open in New View = true
  Keep Camera Position = true
  Load Particle Tracks = true
  Files to Compare = 
END
DATA READER:
Domains to Load=
END
> load filename=C:\StaticMixer_001.res, multifile=append""")
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Set the camera and define a plane colored with a constant color

results1.SendCommand(Command="""VIEW:View 1
  Camera Mode = User Specified
  CAMERA:
    Option = Pivot Point and Quaternion
    Pivot Point = 0, 0, 0
    Scale = 0.226146
    Pan = 0, 0
    Rotation Quaternion = 0.279848, -0.364705, -0.115917, 0.880476
    Send To Viewer = False
  END

END

> autolegend plot=/PLANE:Plane 1, view=VIEW:View 1""")
results1.SendCommand(Command="""PLANE:Plane 1
Apply Instancing Transform = On
Apply Texture = Off
Blend Texture = On
Bound Radius = 0.5 [m]
Colour = 0.75, 0.75, 0.75
Colour Map = Default Colour Map
Colour Mode = Constant
Colour Scale = Linear
Colour Variable = Pressure

# ...
# (Lines omitted for brevity) 
# ...

END""")

results1.SendCommand(Command="""# Sending visibility action from View...
>show /PLANE:Plane 1, view=/VIEW:View 1""")

Save the project

Save(
    FilePath=r"C:\SaveJou.wbpj",
    Overwrite=True)

The commands in the script above are the default values for a plane.

5.5.5.2. Editing a Journal File (Scripting)

Scripting refers to the processes of editing and running a journal file in Workbench. You can create
your own scripts and include the power of Python to implement high-level programming constructs
for input, output, variables, and logic. The two examples that follow illustrate this for CFX-Pre and
CFD-Post.

5.5.5.2.1. Example: Using a Script to Change the Turbulence Setting in a Setup Cell

If you have a Workbench project currently open, you can run a script to change the characteristics
of the simulation. For example, if you have edited a Setup cell from a Workbench system, loaded
a case with a Default Domain in Flow Analysis 1, and want to use an interactive script
to set CFX-Pre to use one of two turbulence settings, you can run a script similar to the one that
follows.

Before running this script, you would have to first open the Command Window dialog box (by
selecting File > Scripting > Open Command Window from the Workbench main menu). To run
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the script, you would select File > Scripting > Run Script File from the Workbench main menu
and then use the browser to open the file containing the script.

x = int(raw_input("Enter: 1=k epsilon, 2=Shear Stress Transport (SST): "))

if x == 1:
 print 'k epsilon'
 SetScriptVersion(Version="12.1")
 system1 = GetSystem(Name="CFX")
 setup1 = system1.GetContainer(ComponentName="Setup")
 setup1.Edit()
 setup1.SendCommand(Command="""FLOW: Flow Analysis 1
 DOMAIN: Default Domain
     FLUID MODELS: 
       TURBULENCE MODEL: 
         Option = k epsilon
       END # TURBULENCE MODEL:
       TURBULENT WALL FUNCTIONS: 
         Option = Scalable
       END # TURBULENT WALL FUNCTIONS:
     END # FLUID MODELS:
   END # DOMAIN:Default Domain
 END # FLOW:Flow Analysis 1""")

elif x == 2:
 print 'Shear Stress Transport (SST)'
 SetScriptVersion(Version="12.1")
 system1 = GetSystem(Name="CFX")
 setup1 = system1.GetContainer(ComponentName="Setup")
 setup1.Edit()
 setup1.SendCommand(Command="""FLOW: Flow Analysis 1
 DOMAIN: Default Domain
     FLUID MODELS: 
       TURBULENCE MODEL: 
         Option = SST
       END # TURBULENCE MODEL:
       TURBULENT WALL FUNCTIONS: 
         Option = Automatic
       END # TURBULENT WALL FUNCTIONS:
     END # FLUID MODELS:
   END # DOMAIN:Default Domain
 END # FLOW:Flow Analysis 1""")

print 'Done'

Depending on the value of x you input in the Command Window, the script includes the CCL
in the appropriate setup1.SendCommand argument to set the TURBULENCE MODEL and
TURBULENT WALL FUNCTIONS options in the FLOW: Flow Analysis 1 > DOMAIN:
Default Domain > FLUID MODELS object for either the k-Epsilon or the Shear Stress Transport
turbulence models.

5.5.5.2.2. Example: Using a Script to Change an Existing Locator in a Results Cell

If you have a Workbench project currently open, you can run a script to change how the results
of the simulation are post-processed. For example, if you have edited a Results cell from a
Workbench system and CFD-Post is displaying a plane named Plane 1, you can run the following
script to change the plane to be colored by the variable Velocity or Pressure:

x = int(raw_input("Enter an integer: 1=Velocity, 2=Pressure: "))

if x == 1:
  print 'Velocity'
  results1.SendCommand(Command="""PLANE:Plane 1
  Colour Mode = Variable
  Colour Variable = 'Velocity'
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  END""")

elif x == 2:
  print 'Pressure'
  results1.SendCommand(Command="""PLANE:Plane 1
  Colour Mode = Variable
  Colour Variable = Pressure
  END""")

Depending on the value of x you input, the script includes the CCL in the appropriate res
ults1.SendCommand argument to set the values for Colour Mode and Colour Variable
in the PLANE:Plane 1 object for either the Velocity or Pressure variable.

5.5.5.3. Limitations of Scripting Actions with CFX Applications

There are the following limitations to scripting CFX applications. When interfacing with the Solution
cell:

• On the Define Run dialog box, the Reload run settings from file icon is not scriptable.

• CFX-Solver Manager actions that you can perform from the user interface after you start the run
are not scriptable.

• CFX Command Editor actions are not scriptable.

• The journaling command SwitchToBackgroundMode is not normally useful in a script.
Journals may record the invocation of this command after an Update, as the result of user
activity while an Update is in progress. However, replay of these journals will always wait for the
Update to complete before invoking the next command, rendering this step ineffective.

5.5.6. Performing System Coupling Simulations Using CFX in Workbench

See Coupling CFX to an External Solver: System Coupling Simulations in the CFX-Solver Modeling Guide.

5.5.7. Archiving CFX Projects

Archiving is the process of making a project available to another machine; you use File > Archive to
create a project archive. After you set the filename for the project and click Save, the Archive Options
dialog box appears, enabling you to set which optional files to include in the archive.

Note:

You should not archive or restore a project while the CFX-Solver Manager is running.

Archiving CFX projects follows the steps above, but the resulting archive is created with the restrictions
listed below.

The following will be archived (provided that you choose the appropriate options when archiving):

• Flamelet libraries

• Profile boundary files
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• Initial values files provided by the Workbench Project Schematic and those manually selected by
you from within CFX-Pre

• PAR files specified in CFX-Pre

• Ansys Input File (provided by the Workbench Project Schematic or manually specified by you from
within CFX-Pre)

• RGP files

• If you choose to archive with the Result/Solution files option selected, CFX-Solver Results files are
included.

• If you choose to archive with the Imported files external to project directory option selected,
imported files are included. For example, an imported geometry file will be added to the im-
port_files directory in the archived version of the project.

• In the normal workflow, no files are written to the User_files directory. However, if you perform
operations such as the export of a file from CFD-Post, that file will be copied to User_files. If
you then choose to archive with the Items in the User_files folder option selected, such files are
included in the archive.

The following will not be archived:

• Directory structures

• Customization files

• User Fortran source code or libraries

• Custom solvers

• Files referenced from within another non-CFX file (for example, a file referenced by an Ansys Input
File).

5.5.8. Troubleshooting

The topics in this section include:

5.5.8.1. Resolving Execution Control Conflicts

5.5.8.1. Resolving Execution Control Conflicts

If you add or change Execution Control in CFX-Pre in a way that is perceived to conflict with the
Execution Control settings stored in the Solution cell, an error message appears when you attempt
to update the Solution cell.

To resolve the error, right-click the Solution cell and choose one of the following options:

• Using execution control from Setup cell

• Using execution control from Setup cell always

• Using execution control from Solution cell
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• Using execution control from Solution cell always

The Using execution control from <Setup|Solution> cell options enable you to decide how
to resolve the conflict on a case-by-case basis. Alternatively, you can choose one of the Using exe-
cution control from <Setup|Solution> cell always options. The latter options change your
Workbench preference. To change the preference manually, select (from Workbench) Tools > Options
> CFX and change the value of the Set the default execution control conflict option for the
solution cell field, which specifies the default value for the Solution cell property "Execution Control
Conflict Option". For details, see the description for "Execution Control Conflict Option" in Properties
Pane in the CFX Introduction (p. 37).

5.5.9. Running Ansys CFX Tutorials in Ansys Workbench

Tutorials are available that demonstrate the use of Ansys CFX to set up, run, and postprocess CFD
simulations.

The Ansys CFX tutorials are generally written for Ansys CFX in stand-alone mode, but some also include
information on running the tutorial in Ansys Workbench.

Note:

When compiling a Fortran file with the cfx5mkext command in CFX-Pre in Ansys Work-
bench, a corresponding subdirectory is created for the output under the directory specified
by the Default Folder for Permanent File field (which is defined in the Ansys Workbench
> Tools > Options > Project Management pane). When performing this operation in CFX-
Pre in stand-alone mode, the subdirectory is created under your working directory.

In CFX-Pre in Ansys Workbench, when creating the user routine that calls the compiled
Fortran subroutine, on the CFX-Pre Basic Settings tab set the Library Path to the directory
named in the Default Folder for Permanent Files field (not to the working directory, as
you would when running CFX-Pre in stand-alone mode).
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Chapter 6: Help On Help
The following topics are discussed:

6.1. Document Conventions

6.1. Document Conventions

This section describes the conventions used in this document to distinguish between text, filenames,
system messages, and input that you need to type.

6.1.1. Spelling Conventions

Ansys CFX documentation uses American spelling:

• atomize/atomization rather than atomise/atomisation

• color rather than colour

• customize/customization rather than customise/customisation

• discretize/discretization rather than discretise/discretisation

• initialize/initialization rather than initialise/initialisation

• linearize/linearization rather than linearise/linearisation

• meter rather than metre

• normalize/normalization rather than normalise/normalisation

• oxidize/oxidizer/oxidization rather than oxidise/oxidiser/oxidisation

• vapor/vaporize/vaporization rather than vapour/vaporise/vaporisation

When searching, use American spellings:

Search for:For:

Color Map (or try Color Map Command in the CFD-Post User's Guide)Colour Map

Color Mode (or try Color Mode in the CFD-Post User's Guide)Colour Mode

Color Scale (or try Color Scale in the CFD-Post User's Guide)Colour Scale

Color Tab (or try Color Tab in the CFD-Post User's Guide)Colour Tab

Customization (or try Customization in the CFX-Pre User's Guide)Customisation

Domain Initialization (or try Domain: Initialization Tab in the CFX-Pre User's Guide)Domain Initialisation
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Search for:For:

Global Initialization (or try Initialization in the CFX-Pre User's Guide)Global Initialisation

Initialization Tab (or try Initialization Tab in the CFX-Pre User's Guide)Initialisation Tab

LinearizationLinearisation

Turbo Initialization (or try Turbo Initialization in the CFD-Post User's Guide)Turbo Initialisation

Auto-initialize (or try Requirements for Initialization in the CFD-Post User's Guide)Auto-initialise

Uninitialize (or try Uninitializing Components in the CFD-Post User's Guide)Uninitialise

Initialize All Components (or try Initialize All Components in the CFD-Post User's
Guide)

Initialise All
Components

Oxidize/OxidizerOxidise/Oxidiser

Undefined Color (or try Undefined Color in the CFD-Post User's Guide)Undefined Colour

Synchronize Camera (or try Case Comparison in the CFD-Post User's Guide)Synchronise Camera

6.1.2. File and Directory Names

Note that on Linux, directory names are separated by forward slashes (/) but on Windows, usually
backslashes are used (\). For example, a directory name on Linux might be /CFX/bin whereas on a
Windows system, the same directory would be named \CFX\bin.

Important:

Files names with multiple consecutive spaces cannot be read by Ansys CFX.

6.1.3. Optional Arguments

Optional arguments are shown using square brackets:

cfx5export -cgns [-verbose] <file>

Here the argument -verbose is optional, but you must specify a suitable filename.

6.1.4. Long Commands

Commands that are too long to display on a printed page are shown with "\" characters at the ends
of intermediate lines:

cfx5export -cgns [-boundary] [-corrected] [-C] \ 
 [-domain <number>] [-geometry] [-help] [-name <file>] \
 [-summary] [-timestep <number>] [-user <level>] [-norotate] \
 [-boundaries-as-nodes|-boundaries-as-faces] [-verbose] <file>

On a Linux system, you may type the "\" characters, pressing Enter after each. However, on a Windows
machine you must enter the whole command without the "\" characters; continue typing if the
command is too long to fit in the command prompt window and press Enter only at the end of the
complete command.
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6.1.5. Operating System Names

When we refer to objects that depend on the type of system being used, we will use one of the fol-
lowing symbols in the text:

<os> refers to the short form of the name which CFX uses to identify the operating system in question.
<os> will generally be used for directory names where the contents of the directory depend on the
operating system but do not depend on the release of the operating system or on the processor type.
Wherever you see <os> in the text you should substitute with the operating system name. The correct
value can be determined by running:

<CFXROOT>/bin/cfx5info -os

<arch> refers to the long form of the name that CFX uses to identify the system architecture in
question. <arch> will generally be used for directory names where the contents of the directory depend
on the operating system and on the release of the operating system or the processor type. Wherever
you see <arch> in the text you should substitute the appropriate value for your system, which can
be determined by running the command:

<CFXROOT>/bin/cfx5info -arch

73
Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Document Conventions



Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.74


	1st page
	Ansys_CFX_Introduction
	Ansys CFX Introduction
	Table of Contents
	Chapter 1: Computational Fluid Dynamics
	1.1. The History of CFD
	1.2. The Mathematics of CFD
	1.3. Uses of CFD
	1.4. CFD Methodology
	1.4.1. Creating the Geometry/Mesh
	1.4.2. Defining the Physics of the Model
	1.4.3. Solving the CFD Problem
	1.4.4. Visualizing the Results in the Postprocessor

	1.5. Further Background Reading

	Chapter 2: Overview of Ansys CFX
	2.1. The Ansys Product Improvement Program
	2.2. The Structure of Ansys CFX
	2.2.1. CFX-Pre
	2.2.2. CFX-Solver
	2.2.3. CFX-Solver Manager
	2.2.4. CFD-Post

	2.3. Running Ansys CFX
	2.3.1. Valid Syntax in Ansys CFX

	2.4. The Directory Structure of Ansys CFX
	2.5. Ansys CFX File Types
	2.6. Starting Ansys CFX Components from the Command Line
	2.6.1. Obtaining System Information with the cfx5info Command

	2.7. 3Dconnexion Product Support
	2.8. Compatibility with File Hosting Services

	Chapter 3: Customizing Ansys CFX
	3.1. Ansys CFX Resource Configuration Files
	3.1.1. The Site-wide Configuration Files
	3.1.2. User’s Configuration Files
	3.1.3. Syntax of CFX Resource Configuration Files
	3.1.3.1. Resource Names

	3.1.4. Resources Set in cfx5rc Files
	3.1.4.1. Setting Environment Variables



	Chapter 4: Using the Ansys CFX Launcher
	4.1. Starting the Ansys CFX Launcher

	Chapter 5: Ansys CFX in Ansys Workbench
	5.1. The Ansys Workbench Interface
	5.1.1. Toolbox
	5.1.2. Project Schematic
	5.1.3. Workspace Tabs
	5.1.4. View Menu
	5.1.5. Properties Pane
	5.1.6. Files Pane
	5.1.6.1. Ansys CFX Files in Ansys Workbench

	5.1.7. Sidebar Help
	5.1.8. Context Menu Commands

	5.2. Data Flow Within and Between Systems
	5.3. An Example Fluid Flow Setup
	5.4. Default File Locations
	5.5. Working with CFX in Workbench
	5.5.1. Tips on Using Ansys Workbench
	5.5.1.1. Ansys Workbench Interface
	5.5.1.2. Setting Units
	5.5.1.3. Files Pane
	5.5.1.4. Ansys Workbench Preferences: Named Selections
	5.5.1.5. Mesh Modifications in CFX-Pre in Ansys Workbench
	5.5.1.6. Loading .cmdb Files
	5.5.1.7. Ansys Workbench Connections

	5.5.2. Working with CFX/Fluid Flow Systems
	5.5.2.1. Changes in Behavior
	5.5.2.2. Duplicating Systems
	5.5.2.3. Renaming Systems
	5.5.2.4. Updating Cells
	5.5.2.5. Setup Cell
	5.5.2.6. Solution Cell
	5.5.2.7. Results Cell
	5.5.2.8. Recovering After Deleting Files
	5.5.2.9. Backwards Compatibility When Ansys CFX Files Exist in the Original Project
	5.5.2.10. License Sharing

	5.5.3. Working with Parameters and Design Exploration
	5.5.3.1. Retaining and Exporting Design Points
	5.5.3.2. Number of Design Points
	5.5.3.3. Obtaining Solutions for Design Points
	5.5.3.4. The CFX-Solver Background Mode
	5.5.3.5. Limitations When Using Parameters and Design Points with Ansys CFX

	5.5.4. Using CFX with the Remote Solve Manager
	5.5.4.1. Configuring CFX over Remote Solve Manager
	5.5.4.2. Limitations When Using Remote Solve Manager with Ansys CFX

	5.5.5. Using Journaling and Scripting with CFX in Workbench
	5.5.5.1. Acquiring a Journal File with CFX in Workbench
	5.5.5.1.1. Journal of an Operation That Uses CFX-Pre
	5.5.5.1.2. Journal of an Operation That Uses CFX-Solver Manager
	5.5.5.1.3. Journal of an Operation That Creates a Plane in CFD-Post

	5.5.5.2. Editing a Journal File (Scripting)
	5.5.5.2.1. Example: Using a Script to Change the Turbulence Setting in a Setup Cell
	5.5.5.2.2. Example: Using a Script to Change an Existing Locator in a Results Cell

	5.5.5.3. Limitations of Scripting Actions with CFX Applications

	5.5.6. Performing System Coupling Simulations Using CFX in Workbench
	5.5.7. Archiving CFX Projects
	5.5.8. Troubleshooting
	5.5.8.1. Resolving Execution Control Conflicts

	5.5.9. Running Ansys CFX Tutorials in Ansys Workbench


	Chapter 6: Help On Help
	6.1. Document Conventions
	6.1.1. Spelling Conventions
	6.1.2. File and Directory Names
	6.1.3. Optional Arguments
	6.1.4. Long Commands
	6.1.5. Operating System Names




