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Beta Features
Beta features have not been fully tested and validated. Ansys, Inc. may, at its discretion, fully release,
change, or withdraw beta features in future revisions. It makes no commitment to doing so on any
particular schedule. Ansys, Inc. makes no commitment to resolve defects reported against beta features.
However, your feedback will help us improve the quality of the product.

Beta features are not subject to the Ansys Class 3 error reporting system. Ansys, Inc. does not guarantee
that input files used with beta features will run successfully from version to version of the software, nor
with the final released version of the features. You may need to modify the input files before running
them on other versions.

To enable beta features in Workbench, select Tools → Options → Appearance and then select the
Beta Options check box.

1
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DesignXplorer Beta Features
The following topics describe beta features that appear in various panes in DesignXplorer systems:

F-Test Filtering

Export a Response Surface as a VHDL-AMS Language File

Define as Starting Point

Cumulative Distribution Plot Type

Export ROM Snapshots to Twin Builder

Manual Production of ROM Files from Standalone Fluent

F-Test Filtering

When you are configuring a Response Surface cell, you must set the type of response surface to gen-
erate. If you set Response Surface Type to Standard Response Surface - Full 2nd-Order Polynomials,
F-Test Filter (Beta) displays in the properties for output parameters. This option, which appears under
Output Settings, determines whether to filter significant terms of the polynomial regression. When the
check box is selected (default), the Significance Level value specified in the response surface properties
is used as the threshold for this filtering. If you clear this check box, significant terms are not filtered.
All terms are kept.

3
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Note:

Setting Significance Level in the response surface properties to 1 is equivalent to clearing
the F-Test Filter (Beta) check box for all output parameters.

Export a Response Surface as a VHDL-AMS Language File

When a Response Surface cell is open, the response surface that you generate can be exported to a
VHDL-AMLS Language file if the following conditions are met:

• There are no discrete input parameters.

• The response surface type is either Full 2nd-Order Polynomials or Kriging.

When these conditions are met, when you click Export Response Surface in the toolbar, VHDL-AMS
Language file (*.vhd) (Beta) is listed as a file type to which you can save.

Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
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Define as Starting Point

When an Optimization cell is open and Optimization is selected in the Outline pane, the Table pane
displays candidate points. If you right-click a candidate point, Define as Starting Point (Beta) is available
in the context menu if the optimization method is NLPQL, MISQP, or an external optimization method
defined in an ACT extension that requires a starting point. When this option is selected, the values for
this candidate’s input parameters are used to set the starting point.

Cumulative Distribution Plot Type

The sample points generated by a Six Sigma Analysis allow the building of statistical results such as
the Probability Density Function and the Empirical Cumulative Distribution Function for each parameter.
This means that you can see the propagation of uncertainties on input parameter to output parameters.

If you know and define the distribution types of input parameters in the Design of Experiments cell,
the distribution types of output parameters are unknown. When you select an output parameter in the
Outline pane for the Six Sigma Analysis cell, the Properties pane displays chart properties. For Cumu-
lative Distribution Plot Type (Beta), you select a distribution type. All attributes of this distribution,
such as mean, standard deviation, and so on, are then automatically selected to fit as best as possible
the Empirical Cumulative Distribution Function.

You can see which distribution type is closest to the empirical distribution by comparing two Cumulative
Distribution Functions and by comparing the Probability Density Function with the Probability Density.

5
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By default, Cumulative Distribution Plot Type (Beta) is set to Normal. This means that in the chart
for the output parameter, the solid blue and green curves are the cumulative distribution function and
probability density function based on the normal distribution.

If you set Cumulative Distribution Plot Type (Beta) to a different distribution type, the labels for the
solid blue and green curves are updated according. If you set Cumulative Distribution Plot Type
(Beta) to None, no solid blue or green curves are shown.

Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
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Export ROM Snapshots to Twin Builder

Users of Twin Builder can export the ROM snapshot files (ROMSNP) that are generated by the DOE in
a DesignXplorer 3D ROM system to build a static ROM in Twin Builder.

To export ROM snapshot files to Twin Builder:

1. Right-click in an empty area of the Workbench Project Schematic and select Export ROM
Snapshots to Twin Builder (Beta).

2. In the Browse For Folder window that opens, select or create the folder in which to save the
snapshot files to the format supported by Twin Builder.

In the Progress view, you can see the snapshot files being exported.

Note:

• All snapshot files are exported, including those from any 3D ROM system and from
any of these tables: Design of Experiments, Refinement Points, and Verification Points.

• In the exported snapshot files, the simplified mesh files contain only 3D-point coordin-
ates. You can visualize these coordinates in the Twin Builder Static ROM Builder, where
each coordinate is represented with a sphere.

Once the export finishes, you can start Twin Builder and select Twin Builder → Launch Static ROM
Builder. In the Select a project directory window that opens, you select the folder to which the
snapshot files were exported.

For more information about ROM snapshot files, search the DesignXplorer help for the "ROM Snapshot
Files" topic.

For more information about the Twin Builder Static ROM Builder and viewer, search the Twin Builder
help for the “Using Static ROM Builder” topic, paying attention to these child topics:

• “Preparing the Data,” which describes the format to which ROM snapshot files were exported

• “Viewer (Evaluate Tab),” which explains how to evaluate the output for given values of input
parameters

Manual Production of ROM Files from Standalone Fluent

This section provides a ROM workflow example (beta) for advanced Fluent users only. If you are not an
advanced Fluent user, you should use the standard workflow for automated ROM production, which is
described in "Using ROMs" in the DesignXplorer User's Guide.

This advanced example describes how to manually define or generate in standalone Fluent all of the
appropriate files needed to finally build a ROM in Workbench:

Setting Up the Workbench Project

Setting Up ROM Building in Fluent
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Creating the ROM in the ROM Builder

Creating Mesh and Snapshot Files in Fluent Standalone

Importing the Mesh and Snapshot Files into the DOE and Generating the ROM

The case, which is for a steady fluids simulation of a heat exchanger, is run independently for each
design point (design of experiments). The ROM-specific files are created manually in standalone Fluent
for later import into a 3D ROM system in a Workbench project.

Note:

• DesignXplorer advanced options must be enabled. Select Tools → Options →
Design Exploration and then select the Show Advanced Options check box
and click OK. DesignXplorer now displays advanced options in italic type in
various panes. Advanced ROM options provide for opening the ROM Builder log
file and setting a user-generated ROM mesh file.

• The CAS file for this advanced example is included in the same ZIP file as the
sample files for the standard example. To download the ZIP file, in "Using ROMs"
in the DesignXplorer User's Guide, see the "Prerequisites" topic.

Setting Up the Workbench Project

This section explains how to insert and configure in a Workbench project the Fluent system from
which to build the ROM.

1. In the Toolbox under Component Systems, double-click Fluent to add a system of this type
to the Project Schematic.

2. Right-click the Setup cell, select Import Fluent Case → Browse, navigate to the directory
where you extracted the sample files, and open the CAS file (HeatExchanger.cas).

The Parameter Set bar is added to the Project Schematic, indicating that input and output
parameters are defined in the CAS file.

3. Double-click the Parameter Set bar to open it.

4. Verify that input and output parameters are defined appropriately, which they are.

5. Close the Parameter Set bar.

6. Save the project, specifying a location and file name.

Setting Up ROM Building in Fluent

This section explains how to enable and load the ROM feature in Fluent and then select flow variables
and cell zones.

1. In the Project Schematic, double-click the Solution cell to open the case in Fluent.

Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
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2. To make Reduced Order Model (Off) visible in the tree under Setup → Models, enable and
load the ROM addon module by executing this command from the Fluent console:

define models addon 11

3. On the ribbon's Solution tab, click the button in the Initialization group for initializing the
entire flow field.

4. In the tree under Setup → Models, double-click Reduced Order Model (Off).

5. In the Reduced Order Model window that opens, select the Enable Reduced Order Model
check box to expand the window so that you can set up the ROM.

6. For this example, select:

• Static Temperature: all zones

• Velocity: all zones except wall zones

7. Once you have finalized your selections, click OK.

9
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8. Select File → Export → Case, name the file HeatExchanger_RomSetup.cas, and click
OK.

9. Select File → Close Fluent to close Fluent and push your changes to the Workbench project.

Creating the ROM in the ROM Builder

This section explains how to add, configure, and update the 3D ROM system in Workbench.

1. In the Toolbox under Design Exploration, double-click 3D ROM to add a system of this type to
the Project Schematic.

A 3D ROM system is inserted under the Parameter Set bar.

2. Double-click the Design of Experiments (3D ROM) cell to open it.

For this example, you will keep only one input parameter for the ROM.

3. In the Outline pane, select P1.

4. In the Properties pane, set the lower and upper bounds for P1 to 0.001 and 0.01 m/s.

5. In the Outline pane, clear the check boxes for P2, P3, and P4 to disable them.

Their constant values, which are reported in the Properties pane by default, can be kept.

6. In the Outline pane, select Design of Experiments (3D ROM).

7. In the Properties pane, set Number of Samples to 4.

8. In the toolbar, click Preview to generate the four design points without updating them.

9. Take note of the generated inlet velocity value for P1: 0.004375.

Tip:

You can export the data in the table to a CSV file.

10. Save the project and close Workbench.

Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
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Creating Mesh and Snapshot Files in Fluent Standalone

This section describes how to use the previewed design points in the DOE to update the Fluent
solution for each design point, create a mesh in the ROM format, and create the snapshot files that
are then used to build the ROM.

Tip:

You can execute these steps on a cluster without using Workbench.

1. Start standalone Fluent.

2. Select File → Read → Case and select HeatExchanger_RomSetup.cas.

3. If an information dialog box opens, click OK.

4. On the ribbon's User-Defined tab, click Execute on Demand to open the Execute on Demand
window.

5. Select the command write_rombuilder_setup_file::rom and click Execute.

This generates the setup files that are used when creating the mesh and snapshot files. These
setup files are written in the Fluent working directory and can be safely removed at the end
of this procedure.

6. Close the Execute on Demand window.

7. In the Console, execute this command:

(%rom-write-mesh-file "mesh.rommsh")

This creates the file mesh.rommsh in the Fluent working directory. This mesh file is used to
display the ROM.

8. In the tree, under Parameters & Customization > Parameters > Input Parameters, enter
the value for each parameter for the first design point that you previewed in the DOE:

a. Set inlet_velocity_shell to 0.004375 m/s.

b. Leave the default values for the other parameters.

9. On the ribbon's Solution tab, do the following:

a. Click the button in the Initialization group for initializing the entire flow field.

b. When asked if you want to discard the data and proceed, click OK.

c. Click Calculate in the Run Calculation group.

d. When the calculate finishes, click OK to close the information window.

10. In the Console, execute this command:

(%rom-write-snapshot-file "snp_1.romsnp")

11
Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Manual Production of ROM Files from Standalone Fluent



This creates the file snp_1.romsnp in the Fluent working directory.

11. For each of the three additional design points generated in the Design of Experiments cell,
repeat steps 8 through 10, entering the corresponding value for inlet_velocity_shell and
the appropriate name for the snapshot file:

• 0.008875 m/s and snp_2.romsnp

• 0.002125 m/s and snp_3.romsnp

• 0.006625 m/s and snp_4.romsnp

12. Close Fluent and download the ROMSNP and the ROMMSH files to the computer with Work-
bench installed.

Tip:

You can automate this step using Fluent scripting.

Importing the Mesh and Snapshot Files into the DOE and Generating the
ROM

This section describes how to use the mesh file and four snapshot files to produce the ROM.

1. Locate the file Rom.MeshProcessing.exe in the Workbench installation folder under
Addins\ROM\bin\Win64 for Windows or Addins\ROM\bin\Linux64 for Linux.

Note:

The next step, which can be computationally expensive, can be performed on a separate
computer.

2. Create the file mesh_processed.rommsh from the command line:

• For Windows, run the following command, where Path is the location where you want to
create the file:

Rom.MeshProcessing.exe C:\Path\mesh.rommsh C:\Path\mesh_processed.rommsh

• For Linux, the path in the following command assumes that Ansys is installed using the
symbolic link /ansys_inc. If necessary, substitute your installation path for the path
given:

/ansys_inc/v212/Framework/bin/Linux64/runwb2 -cmd /ansys_inc/v212/Addins/ROM/bin/Linux64/Rom.MeshProcessing.exe /Path/mesh.rommsh /Path/mesh_processed.rommsh

3. After the file mesh_processed.rommsh is created, start Workbench and open the project
HeatExchanger_RomProduction.wbpj.

4. In the Project Schematic, double-click the Design of Experiments (3D ROM) cell to open it.

Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
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5. In the Outline pane, select Design of Experiments (3D ROM).

When DesignXplorer advanced options are shown, ROM Mesh File is visible in the Properties
pane.

6. For ROM Mesh File, click Browse and select the file mesh_processed.rommsh that you created
in step 2.

7. When prompted, select Copy and Proceed.

8. Set Design of Experiments Type to Custom.

9. Right-click in the Table pane and select Set All Output Values as Editable.

13
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10. Manually set the snapshot file for each design point:

a. In the first line, enter a dummy value such as 0 for P5 and P6. This value is not used for ROM
building.

b. In the first line, right-click the Fluent ROM Snapshot cell, select Set Snapshot File, browse
to snp_1.romsnp, and when prompted click Copy and Proceed.

c. Repeat step b for the next three design points, selecting the corresponding snapshot file
(snp_2.romsnp through snp_4.romsnp).

Warning:

When manually setting a snapshot file, if you mistakenly select a file that does not
match the point, the resulting ROM will have invalid values. To avoid errors, you should
automate this step by importing a ROM snapshot archive file (SNPZ). Like a 7z or ZIP
file, a SNPZ file is a compressed file. It contains all snapshot files and one CSV file.

11. Save the project and update the Design of Experiments (3D ROM) cell.

This operation is fast because all of the outputs are already calculated.

12. In the ROM Builder cell, set Number of Modes to 4, which is the number of DOE points, and
click Update.

13. When the update completes, in the toolbar, click Open in ROM Viewer.
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