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Using This Manual
This preface is divided into the following sections:

1.What’s In This Manual

2.Typographical Conventions Used In This Manual

1. What’s In This Manual

The Ansys Fluent Workbench Tutorial Guide contains a number of tutorials that teach you how to use
Ansys Fluent to solve different types of problems.

2. Typographical Conventions Used In This Manual

Several typographical conventions are used in this manual’s text to help you find commands in the
user interface.

• Different type styles are used to indicate graphical user interface items and text interface items. For
example:

Iso-Surface dialog box

surface/iso-surface text command

• The text interface type style is also used when illustrating exactly what appears on the screen to
distinguish it from the narrative text. In this context, user inputs are typically shown in boldface. For
example,

solve/initialize/set-fmg-initialization

 Customize your FMG initialization:
   set the number of multigrid levels [5]

   set FMG parameters on levels ..

    residual reduction on level 1 is:  [0.001]
    number of cycles on level 1 is:  [10]  100

    residual reduction on level 2 is:  [0.001]
    number of cycles on level 2 is:  [50]  100

• Mini flow charts are used to guide you through the ribbon or the tree, leading you to a specific option,
dialog box, or task page. The following tables list the meaning of each symbol in the mini flow charts.

Table 1: Mini Flow Chart Symbol Descriptions

Indicated ActionSymbol

Look at the ribbon

Look at the tree

Double-click to open task page

ix
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Select from task page

Right-click the preceding item

For example,

Setting Up Domain → Mesh → Transform → Translate...

indicates selecting the Setting Up Domain ribbon tab, clicking Transform (in the Mesh group box)
and selecting Translate..., as indicated in the figure below:

And

Setup → Models → Viscous Model → Realizable k-epsilon

indicates expanding the Setup and Models branches, right-clicking Viscous, and selecting Realizable
k-epsilon from the Model sub-menu, as shown in the following figure:

And

Setup → Boundary Conditions → velocity-inlet-5
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indicates opening the task page as shown below:

In this manual, mini flow charts usually accompany a description of a dialog box or command, or a
screen illustration showing how to use the dialog box or command. They show you how to quickly
access a command or dialog box without having to search the surrounding material.

• In-text references to File ribbon tab selections can be indicated using a “/”. For example
File/Write/Case... indicates clicking the File ribbon tab and selecting Case... from the Write submenu
(which opens the Select File dialog box).
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Chapter 1: Introduction to Using Ansys Fluent in
Ansys Workbench: Fluid Flow and Heat Transfer in a
Mixing Elbow
This tutorial is divided into the following sections:

1.1. Introduction

1.2. Prerequisites

1.3. Problem Description

1.4. Setup and Solution

1.5. Summary

1.1. Introduction

This tutorial illustrates using Ansys Fluent fluid flow systems in Ansys Workbench to set up and solve
a three-dimensional turbulent fluid-flow and heat-transfer problem in a mixing elbow. It is designed to
introduce you to the Ansys Workbench tool set using a simple geometry. Guided by the steps that follow,
you will create the elbow geometry and the corresponding computational mesh using the geometry
and meshing tools within Ansys Workbench. You will use Ansys Fluent to set up and solve the CFD
problem, then visualize the results in both Ansys Fluent and in the CFD-Post postprocessing tool. Some
capabilities of Ansys Workbench (for example, duplicating fluid flow systems, connecting systems, and
comparing multiple data sets) are also examined in this tutorial.

This tutorial demonstrates how to do the following:

• Launch Ansys Workbench.

• Create a Fluent  fluid flow analysis system in Ansys Workbench.

• Create the elbow geometry using Ansys DesignModeler.

• Create the computational mesh for the geometry using Ansys Meshing.

• Set up the CFD simulation in Ansys Fluent, which includes:

– Setting material properties and boundary conditions for a turbulent forced-convection problem.

– Initiating the calculation with residual plotting.

– Calculating a solution using the pressure-based solver.

– Examining the flow and temperature fields using Ansys Fluent and CFD-Post.

• Create a copy of the original Fluent fluid flow analysis system in Ansys Workbench.

1
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• Change the geometry in Ansys DesignModeler, using the duplicated system.

• Regenerate the computational mesh.

• Recalculate a solution in Ansys Fluent.

• Compare the results of the two calculations in CFD-Post.

1.2. Prerequisites

This tutorial assumes that you have little to no experience with Ansys Workbench, Ansys DesignModeler,
Ansys Meshing, Ansys Fluent, or CFD-Post, and so each step will be explicitly described.

1.3. Problem Description

The problem to be considered is shown schematically in Figure 1.1: Problem Specification (p. 3). A
cold fluid at 293.15 K flows into the pipe through a large inlet and mixes with a warmer fluid at 313.15 K
that enters through a smaller inlet located at the elbow. The mixing elbow configuration is encountered
in piping systems in power plants and process industries. It is often important to predict the flow field
and temperature field in the area of the mixing region in order to properly design the junction.

Note:

Because the geometry of the mixing elbow is symmetric, only half of the elbow must be
modeled.

Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
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Figure 1.1: Problem Specification

Note:

The functionality to create named selections exists in both Ansys DesignModeler and Ansys
Meshing. For the purposes of this tutorial, named selections are created in Ansys Meshing
since the meshing application provides more comprehensive and extensive named selection
functionality.

1.4. Setup and Solution

To help you quickly identify graphical user interface items at a glance and guide you through the steps
of setting up and running your simulation, the Ansys Fluent Tutorial Guide uses several type styles and
mini flow charts. See Typographical Conventions Used In This Manual (p. ix) for detailed information.

The following sections describe the setup and solution steps for this tutorial:

1.4.1. Preparation

1.4.2. Creating a Fluent Fluid Flow Analysis System in Ansys Workbench

1.4.3. Creating the Geometry in Ansys DesignModeler

1.4.4. Meshing the Geometry in the Ansys Meshing Application
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1.4.5. Setting Up the CFD Simulation in Ansys Fluent

1.4.6. Solving

1.4.7. Displaying Results in Ansys Fluent and CFD-Post

1.4.8. Duplicating the Fluent-Based Fluid Flow Analysis System

1.4.9. Changing the Geometry in Ansys DesignModeler

1.4.10. Updating the Mesh in the Ansys Meshing Application

1.4.11. Calculating a New Solution in Ansys Fluent

1.4.12. Comparing the Results of Both Systems in CFD-Post

1.4.1. Preparation

1. Download the workbench_elbow.zip file here.

2. Unzip workbench_elbow.zip to your working folder. This file contains a folder, work-
bench_elbow, that holds the following items:

• two geometry files, elbow_geometry.agdb and elbow_geometry.stp

Note:

Ansys Fluent tutorials are prepared using Ansys Fluent on a Windows system. The screen
shots and graphic images in the tutorials may be slightly different than the appearance
on your system, depending on the operating system or graphics card.

1.4.2. Creating a Fluent Fluid Flow Analysis System in Ansys Workbench

In this step, you will start Ansys Workbench, create a new Fluent fluid flow analysis system, then review
the list of files generated by Ansys Workbench.

1. From the Windows Start menu, select Start > ANSYS 2021 R2 > Workbench 2021 R2 to start a
new Ansys Workbench session.

This displays the Ansys Workbench application window, which has the Toolbox on the left and
the Project Schematic to its right. Various supported applications are listed in the Toolbox and
the components of the analysis system will be displayed in the Project Schematic.

Note:

Depending on which other products you have installed, the analysis systems that appear
may differ from those in the figures that follow in this tutorial.
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2. Create a new Fluent fluid flow analysis system by double-clicking the Fluid Flow (Fluent) option
under Analysis Systems in the Toolbox.

Tip:

You can also drag-and-drop the analysis system into the Project Schematic. A green
dotted outline indicating a potential location for the new system initially appears in
the Project Schematic. When you drag the system to one of the outlines, it turns into
a red box to indicate the chosen location of the new system.

Figure 1.2: Ansys Workbench with a New Fluent-Based Fluid Flow Analysis System

3. Name the analysis.

a. Double-click the Fluid Flow (Fluent) label underneath the analysis system (if it is not already
highlighted).

b. Enter elbow for the name of the analysis system.

4. Save the project.

a. In Ansys Workbench, under the File menu, select Save.

File → Save

5
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This displays the Save As dialog box, where you can browse to your working folder and enter
a specific name for the Ansys Workbench project.

b. In your working directory, enter elbow-workbench as the project File name and click the
Save button to save the project. Ansys Workbench saves the project with a .wbpj extension
and also saves supporting files for the project.

Note that the fluid flow analysis system is composed of various cells (Geometry, Mesh, etc.)
that represent the workflow for performing the analysis. Ansys Workbench is composed of
multiple data-integrated and native applications in a single, seamless project flow, where indi-
vidual cells can obtain data from other cells and provide data to other cells. As a result of this
constant flow of data, a cell’s state can quickly change. Ansys Workbench provides a visual
indication of a cell’s state at any given time via icons on the right side of each cell. Brief de-
scriptions of the various states are provided below:

• Unfulfilled ( ) indicates that required upstream data does not exist. For example, when
you first create a new Fluid Flow (Fluent) analysis system, all cells downstream of the
Geometry cell appear as Unfulfilled because you have not yet specified a geometry for the
system.

• Refresh Required ( ) indicates that upstream data has changed since the last refresh or
update. For example, after you assign a geometry to the geometry cell in your new Fluid
Flow (Fluent) analysis system, the Mesh cell appears as Refresh Required since the geometry
data has not yet been passed from the Geometry cell to the Mesh cell.

• Attention Required ( ) indicates that the current upstream data has been passed to the
cell, however, you must take some action to proceed. For example, after you launch Ansys
Fluent from the Setup cell in a Fluid Flow (Fluent) analysis system that has a valid mesh,
the Setup cell appears as Attention Required because additional data must be entered in
Ansys Fluent before you can calculate a solution.

• Update Required ( ) indicates that local data has changed and the output of the cell must
be regenerated. For example, after you launch Ansys Meshing from the Mesh cell in a Fluid
Flow (Fluent) analysis system that has a valid geometry, the Mesh cell appears as Update
Required because the Mesh cell has all the data it must generate an Ansys Fluent mesh
file, but the Ansys Fluent mesh file has not yet been generated.

• Up To Date ( ) indicates that an update has been performed on the cell and no failures
have occurred or that an interactive calculation has been completed successfully. For example,
after Ansys Fluent finishes performing the number of iterations that you request, the Solution
cell appears as Up-to-Date.

• Interrupted, Update Required ( ) indicates that you have interrupted an update (or
canceled an interactive calculation that is in progress). For example, if you select the Cancel
button in Ansys Fluent while it is iterating, Ansys Fluent completes the current iteration and
then the Solution cell appears as Interrupted, Update Required.

• Input Changes Pending ( ) indicates that the cell is locally up-to-date, but may change
when next updated as a result of changes made to upstream cells. For example, if you
change the Mesh in an Up-to-Date Fluid Flow (Fluent) analysis system, the Setup cell
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appears as Refresh Required, and the Solution and Results cells appear as Input Changes
Pending.

• Pending ( ) indicates that a batch or asynchronous solution is in progress. When a cell
enters the Pending state, you can interact with the project to exit Workbench or work with
other parts of the project. If you make changes to the project that are upstream of the up-
dating cell, then the cell will not be in an up-to-date state when the solution completes.

For more information about cell states, see the Workbench User's Guide.

5. View the list of files generated by Ansys Workbench.

Ansys Workbench allows you to easily view the files associated with your project using the Files
view. To open the Files view, select the Files option under the View menu at the top of the Ansys
Workbench window.

View → Files

Figure 1.3: Ansys Workbench Files View for the Project After Adding a Fluent-Based Fluid
Flow Analysis System

In the Files view, you will be able to see the name and type of file, the ID of the cell that the file
is associated with, the size of the file, the location of the file, and other information. For more in-
formation about the Files view, see the Workbench User's Guide.

Note:

The sizes of the files listed may differ slightly from those portrayed in Figure 1.3: Ansys
Workbench Files View for the Project After Adding a Fluent-Based Fluid Flow Analysis
System (p. 7).

From here, you will create the geometry described in Figure 1.1: Problem Specification (p. 3),
and later create a mesh and set up a fluid flow analysis for the geometry.

7
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1.4.3. Creating the Geometry in Ansys DesignModeler

For the geometry of your fluid flow analysis, you can create a geometry in Ansys DesignModeler,
Ansys SpaceClaim Direct Modeler, or import the appropriate geometry file. In this step, you will create
the geometry in Ansys DesignModeler, then review the list of files generated by Ansys Workbench.

Important:

Note the Attention Required icon ( ) within the Geometry cell for the system. This
indicates that the cell requires data (for example, a geometry). Once the geometry is
defined, the state of the cell will change accordingly. Likewise, the state of some of
the remaining cells in the system will change.

Note:

If you would rather not create the geometry in Ansys DesignModeler, you can import a
pre-existing geometry by right-clicking the Geometry cell and selecting the Import Geo-
metry option from the context menu. From there, you can browse your file system to
locate the elbow_geometry.agdb geometry file that is provided for this tutorial. If you
do not have access to Ansys DesignModeler, you can use the elbow_geometry.stp
file instead.

To learn how to create a mesh from the geometry you imported, go to Meshing the Geo-
metry in the Ansys Meshing Application (p. 15).

1. Start Ansys DesignModeler.

In the Ansys Workbench Project Schematic, right-click the Geometry cell in the elbow fluid flow
analysis system to display the context menu, then select New DesignModeler Geometry.... This
displays the Ansys DesignModeler application.

2. Set the units in Ansys DesignModeler.

When Ansys DesignModeler first appears, you should select desired system of length units to work
from. For the purposes of this tutorial (where you will create the geometry in millimeters and
perform the CFD analysis using SI units) set the units to Millimeter.

Units → Millimeter

3. Create the geometry.

The geometry for this tutorial (Figure 1.1: Problem Specification (p. 3)) consists of a large curved
pipe accompanied by a smaller side pipe. Ansys DesignModeler provides various geometry prim-
itives that can be combined to rapidly create geometries such as this one. You will perform the
following tasks to create the geometry:

• Create the bend in the main pipe by defining a segment of a torus.

• Extrude the faces of the torus segment to form the straight inlet and outlet lengths.

• Create the side pipe by adding a cylinder primitive.
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• Use the symmetry tool to reduce the model to half of the pipe assembly, thus reducing
computational cost.

a. Create the main pipe:

i. Create a new torus for the pipe bend by choosing the Create → Primitives → Torus menu
item from the menubar.

A preview of the torus geometry will appear in the graphics window. Note that this is a preview
and the geometry has not been created yet. First you must specify the parameters of the torus
primitive in the next step.

ii. In the Details View for the new torus (Torus1), set Base Y Component to -1 by clicking
the 1 to the right of FD10, Base Y Component, entering -1, and pressing Enter. This
specifies the direction vector from the origin to the center of the circular cross-section at
the start of the torus. In the same manner, specify Angle; Inner Radius; and Outer Radius
as shown below.

Note:

Enter only the value without the units of mm. They will be appended auto-
matically because you specified the units previously.

iii. To create the torus segment, click the Generate button  that is located in the
Ansys DesignModeler toolbar.

9
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The Torus1 item appears in the Tree Outline view. If you want to delete this item, you
can right-click it and select Delete from the context menu that opens.

iv. Ensure that the selection filter is set to Faces. This is indicated by the Faces button 

appearing depressed in the toolbar and the appearance of the Face selection cursor,
when you mouse over the geometry.

v. Select the top face (in the positive Y direction) of the elbow and click the Extrude button

 from the 3D Features toolbar.

vi. In the Details View for the new extrusion (Extrude1), click Apply to the right of Geometry.
This accepts the face you selected as the base geometry of the extrusion.

vii. Click None (Normal) to the right of Direction Vector. Again, ensure that the selection filter
is set to Faces, select the same face on the elbow to specify that the extrusion will be
normal to the face and click Apply.
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viii.Enter 200 for FD1, Depth (>0) and click Generate.

ix. In a similar manner, create an extrusion of the other face of the torus segment to create
the 200 mm inlet extension. You will probably find it helpful to rotate the view so that you
can easily select the other face of the bend.

You can use the mouse buttons to change your view of the 3D image. The following table
describes mouse actions that are available:

Table 1.1: DesignModeler View Manipulation Instructions

Using Graphics Toolbar Buttons and the MouseAction

After clicking the Rotate icon, , press and hold the left mouse button
and drag the mouse. Dragging side to side rotates the view about the vertical
axis, and dragging up and down rotates the view about the horizontal axis.

Rotate view
(vertical,
horizontal)
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Using Graphics Toolbar Buttons and the MouseAction

After clicking the Pan icon, , press and hold the left mouse button and
drag the object with the mouse until the view is satisfactory.

Translate or
pan view

After clicking the Zoom icon, , press and hold the left mouse button and
drag the mouse up and down to zoom in and out of the view.

Zoom in and
out of view

After clicking the Box Zoom icon, , press and hold the left mouse button
and drag the mouse diagonally across the screen. This action will cause a

Box zoom

rectangle to appear in the display. When you release the mouse button, a
new view will be displayed that consists entirely of the contents of the
rectangle.

Clicking the Zoom to Fit icon, , will cause the object to fit exactly and be centered in
the window.

After entering the extrusion parameters and clicking Generate, the geometry should appear
as in Figure 1.4: Elbow Main Pipe Geometry (p. 12).

Figure 1.4: Elbow Main Pipe Geometry

b. Next you will use a cylinder primitive to create the side pipe.

i. Choose Create → Primitives → Cylinder from the menubar.

ii. In the Details View, set the parameters for the cylinder as follows and click Generate:

ValueSetting

XYPlaneBasePlane

137.5FD3, Origin X Coordinate

-225FD4, Origin Y Coordinate
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ValueSetting

0FD5, Origin Z Coordinate

0FD6, Axis X Component

125FD7, Axis Y Component

0FD8, Axis Z Component

12.5FD10, Radius (>0)

The Origin Coordinates determine the starting point for the cylinder and the Axis Components
determine the length and orientation of the cylinder body.

c. The final step in creating the geometry is to split the body on its symmetry plane which will
halve the computational domain.

i. Choose Tools → Symmetry from the menu bar.

ii. Select the XYPlane in the Tree Outline.

iii. Click Apply next to Symmetry Plane 1 in the Details view.

iv. Click Generate.
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The new surface created with this operation will be assigned a symmetry boundary condition
in Fluent so that the model will accurately reflect the physics of the complete elbow geo-
metry even though only half of it is meshed.

d. Specify the geometry as a fluid body.

i. In the Tree Outline, open the 1 Part, 1 Body branch and select Solid.

ii. In the Details View of the body, change the name of the Body from Solid to Fluid.

iii. In the Fluid/Solid section, select Fluid from the drop-down list.

iv. Click Generate.

Tip:

In addition to the primitives you used in this tutorial, Ansys DesignModeler offers a full
suite of 2D sketching and 3D solid modeling tools for creating arbitrary geometry. Refer
to the DesignModeler User's Guide for more information.
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4. Close Ansys DesignModeler by selecting File → Close DesignModeler or by clicking the ‘X’ icon
in the upper right-hand corner. Ansys Workbench automatically saves the geometry and updates
the Project Schematic accordingly. The question mark in the Geometry cell is replaced by a
check mark, indicating that there is a geometry now associated with the fluid flow analysis system.

5. View the list of files generated by Ansys Workbench by selecting View → Files.

Figure 1.5: Ansys Workbench Files View for the Project After Creating the Geometry

Note the addition of the geometry file (FFF.agdb, where FFF indicates a Fluent-based fluid flow
system) to the list of files. If you had imported the geometry file provided for this tutorial rather
than creating the geometry yourself, the elbow_geometry.agdb (or the elbow_geo-
metry.stp) file would be listed instead.

1.4.4. Meshing the Geometry in the Ansys Meshing Application

Now that you have created the mixing elbow geometry, you must generate a computational mesh
throughout the flow volume. For this section of the tutorial, you will use the Ansys Meshing application
to create a mesh for your CFD analysis, then review the list of files generated by Ansys Workbench.

Important:

Note the Refresh Required icon ( ) within the Mesh cell for the system. This indicates
that the state of the cell requires a refresh and that upstream data has changed since
the last refresh or update (such as an update to the geometry). Once the mesh is
defined, the state of the Mesh cell will change accordingly, as will the state of the
next cell in the system, in this case the Setup cell.

1. Open the Ansys Meshing application.
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In the Ansys Workbench  Project Schematic, double-click the Mesh cell in the elbow fluid flow
analysis system (cell A3). This displays the Ansys Meshing application with the elbow geometry
already loaded. You can also right-click the Mesh cell to display the context menu where you can
select the Edit... option.

Figure 1.6: The Ansys Meshing Application with the Elbow Geometry Loaded

2. Create named selections for the geometry boundaries.

In order to simplify your work later on in Ansys Fluent, you should label each boundary in the
geometry by creating named selections for the pipe inlets, the outlet, and the symmetry surface
(the outer wall boundaries are automatically detected by Ansys Fluent).

a. Select the large inlet in the geometry that is displayed in the Ansys Meshing application.

Tip:

• Use the Graphics Toolbar buttons and the mouse to manipulate the image until
you can easily see the pipe openings and surfaces.

• To select the inlet, the Single select ( ) mode must be active.

b. Right-click and select the Create Named Selection option.
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Figure 1.7: Selecting a Face to Name

This displays the Selection Name dialog box.

Figure 1.8: Applying a Name to a Selected Face

c. In the Selection Name dialog box, enter velocity-inlet-large for the name and click
OK.

d. Perform the same operations for:
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• The small inlet (velocity-inlet-small)

• The large outlet (pressure-outlet)

• The symmetry plane (symmetry).

The named selections that you have created appear under the Named Selections item in the
Outline view.

Important:

It is important to note that by using the strings “velocity inlet” and “pressure outlet”
in the named selections (with or without hyphens or underscore characters), Ansys
Fluent automatically detects and assigns the corresponding boundary types accord-
ingly.

3. Create a named selection for the fluid body.

a. Change the selection filter to Body in the Graphics Toolbar ( ).

b. Click the elbow in the graphics display to select it.

c. Right-click, select the Create Named Selection option and name the body Fluid.

By creating a named selection called Fluid for the fluid body you will ensure that Ansys Fluent
automatically detects that the volume is a fluid zone and treats it accordingly.

4. Set basic meshing parameters for the Ansys Meshing application.

For this analysis, you will adjust several meshing parameters to obtain a finer mesh.

a. In the Outline view, select Mesh under Project/Model to display the Details of “Mesh” view
below the Outline view.

Important:

Note that because the Ansys Meshing application automatically detects that
you are going to perform a CFD fluid flow analysis using Ansys Fluent, the
Physics Preference is already set to CFD and the Solver Preference is already
set to Fluent.

b. Expand the Quality node to reveal additional quality parameters. Change Smoothing to High.

c. Add a Sizing control.

i. With Mesh still selected in the Outline tree, click the elbow in the graphics display to
select it.

ii. Right click in the graphics area and select Insert → Sizing from the context menu.
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A new Sizing entry appears under Mesh in the project Outline tree

iii. In the Outline tree, click the new  Sizing control.

iv. Enter 6e-3 for Element Size and press Enter.

d. Click again Mesh in the Outline view and in the Details of “Mesh” view, expand the Inflation
node to reveal additional inflation parameters. Change Use Automatic Inflation to Program
Controlled.

5. Generate the mesh.

Right-click Mesh in the project Outline tree, and select Update in the context menu.
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Figure 1.9: The Computational Mesh for the Elbow Geometry in the Ansys Meshing Application

Important:

Using the Generate Mesh option creates the mesh, but does not actually create
the relevant mesh files for the project and is optional if you already know that the
mesh is acceptable. Using the Update option automatically generates the mesh,
creates the relevant mesh files for your project, and updates the Ansys Workbench
cell that references this mesh.

Note:

Once the mesh is generated, you can view the mesh statistics by opening the Statistics
node in the Details of “Mesh” view. This will display information such as the number
of nodes and the number of elements.

6. Close the Ansys Meshing application.

You can close the Ansys Meshing application without saving it because Ansys Workbench auto-
matically saves the mesh and updates the Project Schematic accordingly. The Refresh Required
icon in the Mesh cell has been replaced by a check mark, indicating that there is a mesh now
associated with the fluid flow analysis system.

7. View the list of files generated by Ansys Workbench.

View → Files
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Figure 1.10: Ansys Workbench Files View for the Project After Mesh Creation

Note the addition of the mesh files (FFF.msh and FFF.mshdb) to the list of files. The FFF.msh
file is created when you update the mesh, and the FFF.mshdb file is generated when you close
the Ansys Meshing application.

1.4.5. Setting Up the CFD Simulation in Ansys Fluent

Now that you have created a computational mesh for the elbow geometry, you will set up a CFD
analysis using Ansys Fluent, then review the list of files generated by Ansys Workbench.

1.4.5.1. Starting Ansys Fluent

1. In the Ansys Workbench Project Schematic, double-click the Setup cell in the elbow fluid flow
analysis system. You can also right-click the Setup cell to display the context menu where you
can select the Edit... option.

When Ansys Fluent is first started, the Fluent Launcher is displayed, enabling you to view and/or
set certain Ansys Fluent start-up options.

Note:

The Fluent Launcher allows you to decide which version of Ansys Fluent you will use,
based on your geometry and on your processing capabilities.
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Figure 1.11: Fluent Launcher

2. Ensure that the proper options are enabled.

Important:

Note that the Dimension setting is already filled in and cannot be changed,
since Ansys Fluent automatically sets it based on the mesh or geometry for the
current system.

a. Ensure that the Display Mesh After Reading option is enabled.

b. Select Double Precision under Options.

c. Set Solver Processes to 4 under Parallel (Local Machine).

Note:

Fluent will retain your preferences for future sessions.
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3. Click Start to launch Ansys Fluent.

Note:

The Ansys Fluent settings file (FFF.set) is written as soon as Ansys Fluent opens.

Figure 1.12: The Ansys Fluent Application

1.4.5.2. Setting Up Domain

In this step, you will perform the mesh-related activities using the Domain ribbon tab (Mesh group).

Note:

These controls are also available in the General task page that can be accessed by
clicking the Setup/General tree item.

1. Change the units for length.
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Because you want to specify and view values based on a unit of length in millimeters from
within Ansys Fluent, change the units of length within Ansys Fluent from meters (the default)
to millimeters.

Important:

Note that the Ansys Meshing application automatically converts and exports
meshes for Ansys Fluent using meters (m) as the unit of length regardless of
what units were used to create them. This is so you do not have to scale the
mesh in Ansys Fluent under Ansys Workbench.

Domain → Mesh → Units...

This displays the Set Units dialog box.

a. Select length in the Quantities list.

b. Select mm in the Units list.

c. Close the dialog box.

Note:

Now, all subsequent inputs that require a value based on a unit of length can be
specified in millimeters rather than meters.

2. Check the mesh.
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Domain → Mesh → Check → Perform Mesh Check

Note:

Ansys Fluent will report the results of the mesh check in the console.

 Domain Extents:
   x-coordinate: min (m) = -2.000000e-01, max (m) = 2.000000e-01
   y-coordinate: min (m) = -2.250000e-01, max (m) = 2.000000e-01
   z-coordinate: min (m) = 0.000000e+00, max (m) = 5.000000e-02
 Volume statistics:
   minimum volume (m3): 2.836821e-09
   maximum volume (m3): 6.611039e-08
     total volume (m3): 2.510838e-03
 Face area statistics:
   minimum face area (m2): 1.854435e-06
   maximum face area (m2): 4.386630e-05
 Checking mesh.....................................
Done.

Note:

The minimum and maximum values may vary slightly when running on different
platforms. The mesh check will list the minimum and maximum x and y values from
the mesh in the default SI unit of meters. It will also report a number of other mesh
features that are checked. Any errors in the mesh will be reported at this time. Ensure
that the minimum volume is not negative as Ansys Fluent cannot begin a calculation
when this is the case.

3. Review the mesh quality.

Domain → Mesh → Quality → Evaluate Mesh Quality

Note:

Ansys Fluent will report the results of the mesh quality below the results of the mesh
check in the console.

Mesh Quality:

Minimum Orthogonal Quality =  2.03636e-01 cell 19646 on zone 4 (ID: 115652 on partition: 1) 
at location ( 1.68524e-01,  1.01318e-01,  5.41369e-04)

Maximum Aspect Ratio =  3.09204e+01 cell 1395 on zone 4 (ID: 508 on partition: 0) 
at location ( 1.25755e-01, -1.56954e-01,  3.15732e-03)

Note:

The quality of the mesh plays a significant role in the accuracy and stability of the
numerical computation.  Checking the quality of your mesh is, therefore, an important
step in performing a robust simulation.  Minimum cell orthogonality is an important
indicator of mesh quality. Values for orthogonality can vary between 0 and 1 with
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lower values indicating poorer quality cells.  In general, the minimum orthogonality
should not be below 0.01 with the average value significantly larger. The high aspect
ratio cells in this mesh are near the walls and are a result of the boundary layer infla-
tion applied in the meshing step. For more information about the importance of
mesh quality refer to the Fluent User's Guide.

1.4.5.3. Setting Up Physics

In the steps that follow, you will select a solver and specify physical models, material properties,
and zone conditions for your simulation using the Setting Up Physics ribbon tab.

1. In the Solver group of the Physics ribbon tab, retain the default selection of the steady pressure-
based solver.

Physics → Solver

2. Set up your models for the CFD simulation using the Models group of the Physics ribbon tab.

Note:

You can also use the Models task page that can be accessed by double-clicking the
Setup/Models tree item.

a. Enable heat transfer by activating the energy equation.

In the Physics ribbon tab, select Energy (Models group).

Physics → Models → Energy

b. Enable the k-ω SST turbulence model.

i. In the Physics ribbon tab, click Viscous... (Models group).

Physics → Models → Viscous...
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ii. In the Viscous Model dialog box, retain the default selection of k-omega from the
Model list.

iii. Use the default SST from the k-omega Model group.

iv. Click OK to accept the model and close the Viscous Model dialog box.

Note that the Viscous... label in the ribbon is displayed in blue to indicate that the Viscous
model is enabled.
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3. Set up the materials for your CFD simulation using the Materials group of the Physics ribbon
tab.

Create a new material called water-liquid using the Create/Edit Materials dialog box.

a. In the Setting Up Physics ribbon tab, click Create/Edit... (Materials group).

Physics → Materials → Create/Edit...

b. Copy the material water-liquid (h2o < l >) from the materials database (accessed by clicking
the Fluent Database... button).
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Figure 1.13: The Create/Edit Materials Dialog Box

c. Select water-liquid (h2o < l >) from the materials list and Click Copy, then close the Fluent
Database... panel.

d. Ensure that there are now two materials (water and air) defined locally by examining the
Fluent Fluid Materials drop-down list in the Create/Edit Materials dialog box .

Note:

Both the materials will also be listed under Fluid in the Materials task page and
under the Materials tree branch.

e. Close the Create/Edit Materials dialog box.

4. Set up the cell zone conditions for the CFD simulation using the Zones group of the Physics
ribbon tab.
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a. In the Physics tab, click Cell Zones.

Physics → Zones → Cell Zones

This opens the Cell Zone Conditions task page.
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b. Set the cell zone conditions for the fluid zone.
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i. In the Cell Zone Conditions task page, in the Zone list, select fluid and click Edit... to
open the Fluid dialog box.

Note:

You can also double-click fluid in the Cell Zones Conditions task page or
under the Setup/Cell Zone Conditions tree branch in order to open the
corresponding dialog box.

ii. Select water-liquid from the Material Name drop-down list.

iii. Click Apply and close the Fluid dialog box.

5. Set up the boundary conditions for the CFD analysis using the Zones group of the Physics
ribbon tab.

a. In the Physics tab, click Boundaries (Zones group).

Physics → Zones → Boundaries

This opens the Boundary Conditions task page.
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Note:

To display boundary zones grouped by zone type (as shown above), click the
Toggle Tree View button in the upper right corner of the Boundary Conditions
task page and under the Group By category select Zone Type from the drop-
down list.
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b. Set the boundary conditions at the cold inlet (velocity-inlet-large).

Tip:

If you are unsure of which inlet zone corresponds to the cold inlet, you can use
the mouse to probe for mesh information in the graphics window. If you click
the right mouse button with the pointer on any node in the mesh, information
about the associated zone will be displayed in the Ansys Fluent console, including
the name of the zone. The zone you probed will be automatically selected from
the Zone selection list in the Boundary Conditions task page.

Alternatively, you can click the probe button ( ) in the graphics toolbar and
click the left mouse button on any node. This feature is especially useful when
you have several zones of the same type and you want to distinguish between
them quickly. The information will be displayed in the console.

i. From the Zone selection list, select velocity-inlet-large and click Edit....

ii. In the Velocity Inlet dialog box, ensure that Magnitude, Normal to Boundary is selected
for Velocity Specification Method.

iii. Enter 0.4  for Velocity Magnitude.

iv. In the Turbulence group, from the Specification Method drop-down list, select Intensity
and Hydraulic Diameter.
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v. Retain the default of 5  for Turbulent Intensity.

vi. Enter 100 mm for Hydraulic Diameter.

Note:

The hydraulic diameter  is defined as:

where  is the cross-sectional area and  is the wetted perimeter.

vii. Click the Thermal tab.

viii.Enter 293.15  for Temperature.

ix. Click Apply and close the Velocity Inlet dialog box.

c. In a similar manner, set the boundary conditions at the hot inlet (velocity-inlet-small), using
the values in the following table:

ValueSetting

Magnitude, Normal to BoundaryVelocity Specification Method

1.2  [m/s]Velocity Magnitude
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ValueSetting

Intensity & Hydraulic DiameterSpecification Method

5%Turbulent Intensity

25 [mm]Hydraulic Diameter

313.15[K]Temperature

d. Double-click pressure-outlet and set the boundary conditions at the outlet, as shown in
the Pressure Outlet dialog box.

Note:

Ansys Fluent will use the backflow conditions only if the fluid is flowing into the
computational domain through the outlet. Since backflow might occur at some
point during the solution procedure, you should set reasonable backflow condi-
tions to prevent convergence from being adversely affected.
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1.4.6. Solving

In the steps that follow, you will set up and run the calculation using the Solution ribbon tab.

Note:

You can also use the task pages listed under the Solution branch in the tree to perform
solution-related activities.

1. Set up solution parameters for the CFD simulation.

a. In the Solution ribbon tab, click Methods... (Solution group).i.

Solution → Solution → Methods...

This will open the Solution Methods task page.
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ii. Retain the default selections.

b. Enable the plotting of residuals during the calculation.

i. In the Solution ribbon tab, click Residuals... (Reports group).
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Solution → Reports → Residuals...

In the Residual Monitors dialog box, ensure that Plot is enabled in the Options group.

ii. Keep the default values for the Absolute Criteria of the Residuals, as shown in the Residual
Monitors dialog box.

iii. Click OK to close the Residual Monitors dialog box.

Note:

By default, all variables will be monitored and checked by Ansys Fluent as a means
to determine the convergence of the solution.

c. Create a surface report definition at the outlet (pressure-outlet).

Solution → Reports → Definitions → New → Surface Report → Facet Maximum
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i. In the Surface Report Definition dialog box, enter temp-outlet-0 for the Name.

ii. Under the Create group, enable Report File and Report Plot.

During a solution run, Ansys Fluent will write solution convergence data in a report file
and plot the solution convergence history in a graphics window.

It is good practice to monitor physical solution quantities in addition to equation residuals
when assessing convergence.

iii. Set Frequency to 3 by clicking the up-arrow button.

This setting instructs Ansys Fluent to update the plot of the surface report and write data to a
file after every 3 iterations during the solution.

iv. Select Temperature... and Static Temperature from the Field Variable drop-down lists.

v. Select pressure-outlet from the Surfaces selection list.
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vi. Click OK to save the surface report definition and close the Surface Report Definition
dialog box.

The new surface report definition temp-outlet-0 appears under the Solution/Report
Definitions tree item. Ansys Fluent also automatically creates the following items:

• temp-outlet-0-rfile (under the Solution/Monitors/Report Files tree branch)

• temp-outlet-0-rplot (under the Solution/Monitors/Report Plots tree branch)

d. In the tree, double-click the temp-outlet-0-rfile (under the Solution/Monitors/Report Files)
and examine the report file settings in the Edit Report File dialog box.

The dialog box is automatically populated with data from the temp-outlet-0 report
definition. The report that will be written in a report file during a solution is listed under Se-
lected Report Definitions.

Retain the default output file name and click OK.

e. In the tree, double-click temp-outlet-0-rplot (under Solution/Monitors/Report Plots) and
examine the report plot settings in the Edit Report Plot dialog box.
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The dialog box is automatically populated with data from the temp-outlet-0 report
definition. As the solution progresses, the report that is listed under Selected Report Defini-
tions will be plotted in a graphics tab window with the title specified in Plot Title.

Retain the default names for Plot Title and Y-Axis Label and click OK.

Note:

You can create report definitions for different boundaries and plot them in the same
graphics window. However, report definitions in the same Report Plot must have
the same units.

f. Initialize the flow field using the Initialization group of the Solution ribbon tab.

Solution → Initialization

i. Keep the Method at the default of Hybrid.

ii. Click Initialize.
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2. Calculate a solution using the Run Calculation group of the Solution tab.

Solution → Run Calculation

a. Start the calculation by requesting 250 iterations.

i. Enter 250 for No. of Iterations.

ii. Click Calculate.

Note that while the program is calculating the solution, the states of the Setup and Solution
cells in the fluid flow Ansys Fluent analysis system in Ansys Workbench are changing. For ex-
ample:

• The state of the Setup cell becomes Up-to-Date and the state of the Solution cell becomes
Refresh Required after the Run Calculation task page is visited and the number of iterations
is specified.

• The state of the Solution cell is Update Required while iterations are taking place.

• The state of the Solution cell is Up-to-Date when the specified number of iterations are
complete (or if convergence is reached).

As the calculation progresses, the surface report plot will be plotted in the graphics window
(temp-outlet-0–rplot tab window) (Figure 1.14: Convergence History of the Maximum Temper-
ature at Pressure Outlet (p. 44)).
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Figure 1.14: Convergence History of the Maximum Temperature at Pressure Outlet

The residuals history will be plotted in the Scaled Residuals tab window (Figure 1.15: Residuals
for the Converged Solution (p. 45)).
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Figure 1.15: Residuals for the Converged Solution

Note:

The solution will be stopped by Ansys Fluent when the residuals reach their specified
values or after 250 iterations. The exact number of iterations will vary depending
on the platform being used. An Information dialog box will open to alert you that
the calculation is complete. Click OK in the Information dialog box to proceed.

Because the residual values vary slightly by platform, the plot that appears on your
screen may not be exactly the same as the one shown here.

Note that the Ansys Fluent settings file (FFF.set) is updated in the Files view of the Ansys
Workbench before the calculation begins.

b. Examine the plots for convergence (Figure 1.15: Residuals for the Converged Solution (p. 45)
and Figure 1.14: Convergence History of the Maximum Temperature at Pressure Outlet (p. 44)).

Note:

There are no universal metrics for judging convergence. Residual definitions that
are useful for one class of problem are sometimes misleading for other classes of
problems. Therefore it is a good idea to judge convergence not only by examining
residual levels, but also by monitoring relevant integrated quantities and checking
for mass and energy balances.

There are three indicators that convergence has been reached:

• The residuals have decreased to a sufficient degree.
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The solution has converged when the Convergence Criterion for each variable
has been reached. The default criterion is that each residual will be reduced to

a value of less than , except the energy residual, for which the default criterion

is .

• The solution no longer changes with more iterations.

Sometimes the residuals may not fall below the convergence criterion set in the
case setup. However, monitoring the representative flow variables through itera-
tions may show that the residuals have stagnated and do not change with further
iterations. This could also be considered as convergence.

• The overall mass, momentum, energy, and scalar balances are obtained.

You can examine the overall mass, momentum, energy and scalar balances in
the Flux Reports dialog box. The net imbalance should be less than 0.2  of the
net flux through the domain when the solution has converged. In the next step
you will check to see if the mass balance indicates convergence.

3. With Ansys Fluent still running, go back to Ansys Workbench and view the list of generated files.

View → Files

Note the addition of the surface report definition file temp-outlet-0.out to the list of files.

The status of the Solution cell is now up-to-date.

1.4.7. Displaying Results in Ansys Fluent and CFD-Post

In this step, you will display the results of the simulation in Ansys Fluent, display the results in CFD-
Post, and then review the list of files generated by Ansys Workbench.

1. Display results in Ansys Fluent using the Results ribbon tab.

In Ansys Fluent, you can perform a simple evaluation of the velocity and temperature contours
on the symmetry plane. Later, you will use CFD-Post (from within Ansys Workbench) to perform
the same evaluation.
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a. Display filled contours of velocity magnitude on the symmetry plane (Figure 1.16: Velocity
Distribution Along Symmetry Plane (p. 48)).

Results → Graphics → Contours → New...

Note:

You can also double-click the Results/Graphics/Contours tree item.

i. Enter contour-vv for Contour Name.

ii. In the Contours dialog box, in the Options group, enable Filled.

iii. Select Banded in the Coloring group box.

iv. Ensure that Node Values and Boundary Values is enabled in the Options group.

v. From the Contours of drop-down lists, select Velocity... and Velocity Magnitude.

vi. From the Surfaces selection list, deselect all items by clicking  and then select symmetry.
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vii. Click Display to display the contours in the active graphics window.

Figure 1.16: Velocity Distribution Along Symmetry Plane

Note:

You may want to clear Headlight and Lighting in the Viewing ribbon tab (Display
group).

b. Display filled contours of temperature on the symmetry plane (Figure 1.17: Temperature Distri-
bution Along Symmetry Plane (p. 50)).

Results → Graphics → Contours → New...
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i. Enter contour-temp for Contour Name.

ii. Select Banded in the Coloring group box.

iii. Select Temperature... and Static Temperature from the Contours of drop-down lists.

iv. Click Display and close the Contours dialog box.
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Figure 1.17: Temperature Distribution Along Symmetry Plane

c. Close the Ansys Fluent application.

File → Close Fluent

Important:

Note that the Ansys Fluent case and data files are automatically saved when you
exit Ansys Fluent and return to Ansys Workbench.

The following prompt is presented, whenever settings change in Ansys Fluent and
in the Project Schematic the Solution cell might need to be refreshed..

d. View the list of files generated by Ansys Workbench.
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View → Files

Note the addition of the compressed Ansys Fluent case and data files to the list of files. These
will have names like FFF-1.cas.gz and FFF-1-00167.dat.gz. Note that the digit(s)
following FFF may be different if you have had to restart the meshing or calculation steps for
any reason and that the name of the data file is based on the number of iterations. Thus your
file names may be slightly different than those shown here.

2. Display results in CFD-Post.

a. Start CFD-Post.

In the Ansys Workbench  Project Schematic, double-click the Results cell in the elbow fluid
flow analysis system (cell A6). This displays the CFD-Post application. You can also right-click
the Results cell to display the context menu where you can select the Edit... option.

Note:

The elbow geometry is already loaded and is displayed in outline mode. Ansys
Fluent case and data files are also automatically loaded into CFD-Post.

Figure 1.18: The Elbow Geometry Loaded into CFD-Post

b. Reorient the display.

Click the blue Z axis on the axis triad in the bottom right hand corner of the graphics display
to orient the display so that the view is of the front of the elbow geometry.

c. Ensure that Highlighting ( ) is disabled.
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d. Display contours of velocity magnitude on the symmetry plane (Figure 1.19: Velocity Distribution
Along Symmetry Plane (p. 53)).

i. Insert a contour object using the Insert menu item at the top of the CFD-Post window.

Insert → Contour

This displays the Insert Contour dialog box.

ii. Keep the default name of the contour (Contour 1) and click OK to close the dialog box.
This displays the Details of Contour 1 view below the Outline view in CFD-Post. This view
contains all of the settings for a contour object.

iii. In the Geometry tab, from the Domains drop-down list, select fluid.

iv. In the Locations list, select symmetry.

v. In the Variable list, select Velocity.

vi. Click Apply.
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Figure 1.19: Velocity Distribution Along Symmetry Plane

e. Display contours of temperature on the symmetry plane (Figure 1.20: Temperature Distribution
Along Symmetry Plane (p. 54)).

i. In the Outline tree view, under User Locations and Plots, clear the check box beside the
Contour 1 object to disable the Contour 1 object and hide the first contour display.

ii. Insert a contour object.

Insert → Contour

This displays the Insert Contour dialog box.

iii. Keep the default name of the contour (Contour 2) and click OK to close the dialog box.
This displays the Details of Contour 2 view below the Outline view.

iv. In the Geometry tab, from the Domains drop-down list, select fluid.

v. In the Locations list, select symmetry.

vi. In the Variable list, select Temperature.

vii. Click Apply.
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Figure 1.20: Temperature Distribution Along Symmetry Plane

3. Close the CFD-Post application by selecting File → Close CFD-Post or by clicking the ‘X’ in the
top right corner of the window.

Important:

Note that the CFD-Post state files are automatically saved when you exit CFD-Post
and return to Ansys Workbench.

4. Save the elbow-workbench project in Ansys Workbench.

5. View the list of files generated by Ansys Workbench.

View → Files

Note the addition of the CFD-Post state file (elbow.cst) to the list of files. For more information
about CFD-Post (and the files associated with it), see the CFD-Post documentation.

1.4.8. Duplicating the Fluent-Based Fluid Flow Analysis System

At this point, you have a completely defined fluid flow system that has a geometry, a computational
mesh, a CFD setup and solution, and corresponding results. In order to study the effects upon the
flow field that may occur if you were to alter the geometry, another fluid flow analysis is required.
One approach would be to use the current system and change the geometry, however you would
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overwrite the data from your previous simulation. A more suitable and effective approach would be
to create a copy, or duplicate, of the current system, and then make the appropriate changes to the
duplicate system.

In this step, you will create a duplicate of the original Fluent-based fluid flow system, then review the
list of files generated by Ansys Workbench.

1. In the Project Schematic, right-click the title cell of the Fluid Flow (Fluent) system and select
Duplicate from the context menu.

Figure 1.21: Duplicating the Fluid Flow System
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Figure 1.22: The Original Fluid Flow System and Its Duplicate

Note:

Notice that in the duplicated system, the state of the Solution cell indicates that the
cell requires a refresh while the state of the Results cell indicates that the cell requires
attention. This is because when a system is duplicated, the case and data files are not
copied to the new system, therefore, the new system does not yet have solution data
associated with it.

2. Rename the duplicated system to new-elbow.

3. Save the elbow-workbench project in Ansys Workbench.

1.4.9. Changing the Geometry in Ansys DesignModeler

Now that you have two separate, but equivalent, Fluent-based fluid flow systems to work from, you
can make changes to the second system without impacting the original system. In this step, you will
make a slight alteration to the elbow geometry in Ansys DesignModeler by changing the diameter
of the smaller inlet, then review the list of files generated by Ansys Workbench.

1. Open Ansys DesignModeler.
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Right-click the Geometry cell of the new-elbow system (cell B2) and select Edit Geometry in
DesignModeler... from the context menu to display the geometry in Ansys DesignModeler.

2. Change the diameter of the small inlet (velocity-inlet-small).

a. In the Tree Outline, select Cylinder1 to open the Details View of the small inlet pipe.

b. In the Details View, change the FD10, Radius (>0) value from 12.5 millimeters to 19 milli-
meters.

c. Click the Generate button to generate the geometry with your new values.

Figure 1.23: Changing the Diameter of the Small Inlet in Ansys DesignModeler

3. Close Ansys DesignModeler.

4. View the list of files generated by Ansys Workbench.

View → Files
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Note the addition of the geometry, mesh, and Ansys Fluent settings files now associated with the
new, duplicated system.

1.4.10. Updating the Mesh in the Ansys Meshing Application

The modified geometry now requires a new computational mesh. The mesh settings for the duplicated
system are retained in the duplicated system. In this step, you will update the mesh based on the
mesh settings from the original system, then review the list of files generated by Ansys Workbench.

In the Project Schematic, right-click the Mesh cell of the new-elbow system (cell B3) and select
Update from the context menu. This will update the mesh for the new geometry based on the mesh
settings you specified earlier in the Ansys Meshing application without having to open the Ansys
Meshing editor to regenerate the mesh.

It will take a few moments to update the mesh. Once the update is complete, the state of the Mesh
cell is changed to up-to-date, symbolized by a green check mark.

For illustrative purposes of the tutorial, the new geometry and the new mesh are displayed below.

Figure 1.24: The Updated Geometry and Mesh in the Ansys Meshing Application

Inspecting the files generated by Ansys Workbench reveals the updated mesh file for the duplicated
system.

View → Files

1.4.11. Calculating a New Solution in Ansys Fluent

Now that there is an updated computational mesh for the modified geometry in the duplicated system,
a new solution must be generated using Ansys Fluent. In this step, you will revisit the settings within
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Ansys Fluent, calculate another solution, view the new results, then review the list of files generated
by Ansys Workbench.

1. Open Ansys Fluent.

In the Project Schematic, right-click the Setup cell of the new-elbow system (cell B4) and select
Edit... from the context menu. Since the mesh has been changed, you are prompted as to
whether you want to load the new mesh into Ansys Fluent or not.

Click Yes to continue, and click Start when Fluent Launcher is displayed in order to open Ansys
Fluent.

2. Ensure that the unit of length is set to millimeters.

Domain → Mesh → Units...

3. Check the mesh (optional).

Setting Up Domain → Mesh → Check → Perform Mesh Check

4. Revisit the boundary conditions for the small inlet.

Setup → Boundary Conditions → velocity-inlet-small Edit...

In the Velocity Inlet dialog box for velocity-inlet-small, you must set the hydraulic diameter to
38 mm based on the new dimensions of the small inlet.

5. Re-initialize the solution.

Solution → Initialization

Keep the Method at the default of Hybrid and click Initialize.

6. Recalculate the solution.

Solution → Run Calculation → Calculate

Set the No. of Iterations to 250 and click Calculate.

7. Close Ansys Fluent.

8. Revisit the results of the calculations in CFD-Post.
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Double-click the Results cell of the new-elbow fluid flow system to re-open CFD-Post where
you can review the results of the new solution.

9. Close CFD-Post.

10. Save the elbow-workbench project in Ansys Workbench.

11. View the list of files generated by Ansys Workbench.

View → Files

Note the addition of the solution and state files now associated with new duplicated system.

1.4.12. Comparing the Results of Both Systems in CFD-Post

In this step, you will create a new Results system in Ansys Workbench, use that system to compare
the solutions from each of the two Fluent-based fluid flow analysis systems in CFD-Post at the same
time, then review the list of files generated by Ansys Workbench.

1. Create a Results system.

In Ansys Workbench, drag a Results system from the Component Systems section of the Toolbox
and drop it into the Project Schematic, next to the fluid flow systems.

Figure 1.25: The New Results System in the Project Schematic
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2. Add the solutions of each of the systems to the Results system.

a. Select the Solution cell in the first Fluid Flow analysis system (cell A5) and drag it over the
Results cell in the Results system (cell C2). This creates a transfer data connection between
the two systems.

Figure 1.26: Connecting the First Fluid Flow System to the New Results System

b. Select the Solution cell in the second Fluid Flow analysis system (cell B5) and drag it over the
Results cell in the Results system (cell C2). This creates a transfer data connection between
the two systems.
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Figure 1.27: Connecting the Second Fluid Flow System to the New Results System

3. Open CFD-Post to compare the results of the two fluid flow systems.

Now that the two fluid flow systems are connected to the Results system, double-click the Results
cell in the Results system (cell C2) to open CFD-Post. Within CFD-Post, both geometries are dis-
played side by side.
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Figure 1.28: CFD-Post with Both Fluid Flow Systems Displayed

a. Re-orient the display.

In each view, click the blue Z axis on the axis triad in the bottom right hand corner of the
graphics display to orient the display so that the view is of the front of the elbow geometry.

Important:

Alternatively, you can select the synchronization tool ( ) in the 3D Viewer
Toolbar to synchronize the views, so that when you re-orient one view, the
other view is automatically updated.

b. Display contours of velocity magnitude on the symmetry plane.

i. Insert a contour object.

Insert → Contour

This displays the Insert Contour dialog box.

ii. Keep the default name of the contour (Contour 1) and click OK to close the dialog box.
This displays the Details of Contour 1 view below the Outline view in CFD-Post. This view
contains all of the settings for a contour object.

iii. In the Geometry tab, from the Domains list, select fluid.

iv. In the Locations list, select symmetry.

v. In the Variable list, select Velocity.
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vi. Click Apply. The velocity contours are displayed in each view.

Note:

To better visualize the velocity display, you can clear the Wireframe view option
under User Locations and Plots in the Outline tree view.

Figure 1.29: CFD-Post Displaying Velocity Contours for Both Geometries

c. Display contours of temperature on the symmetry plane.

i. In the Outline tree view, under User Locations and Plots, deselect the Contour 1 object
to hide the first contour display in CFD-Post.

ii. Insert another contour object.

Insert → Contour

This displays the Insert Contour dialog box.

iii. Keep the default name of the contour (Contour 2) and click OK to close the dialog box.
This displays the Details of Contour 2 view below the Outline view in CFD-Post.

iv. In the Geometry tab, select fluid in the Domains list.

v. Select symmetry in the Locations list.
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vi. Select Temperature in the Variable list.

vii. Click Apply. The temperature contours are displayed in each view.

Figure 1.30: CFD-Post Displaying Temperature Contours for Both Geometries

4. Close the CFD-Post application.

5. Save the elbow-workbench project in Ansys Workbench.

6. View the list of files associated with your project using the Files view.

View → Files

Note the addition of the Results system and its corresponding files.

1.5. Summary

In this tutorial, portions of Ansys Workbench were used to compare the fluid flow through two slightly
different geometries. Ansys DesignModeler was used to create a mixing elbow geometry, Ansys Mesh-
ing was used to create a computational mesh, Ansys Fluent was used to calculate the fluid flow
throughout the geometry using the computational mesh, and CFD-Post was used to analyze the results.
In addition, the geometry was altered, a new mesh was generated, and a new solution was calculated.
Finally, Ansys Workbench was set up so that CFD-Post could directly compare the results of both calcu-
lations at the same time.
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Chapter 2: Parametric Analysis in Ansys Workbench
Using Ansys Fluent
This tutorial is divided into the following sections:

2.1. Introduction

2.2. Prerequisites

2.3. Problem Description

2.4. Setup and Solution

2.1. Introduction

This tutorial illustrates using an Ansys Fluent fluid flow system in Ansys Workbench to set up and solve
a three-dimensional turbulent fluid flow and heat transfer problem in an automotive heating, ventilation,
and air conditioning (HVAC) duct system. Ansys Workbench uses parameters and design points to allow
you to run optimization and what-if scenarios. You can define both input and output parameters in
Ansys Fluent that can be used in your Ansys Workbench project. You can also define parameters in
other applications including Ansys DesignModeler and Ansys CFD-Post. Once you have defined para-
meters for your system, a Parameters cell is added to the system and the Parameter Set bus bar is
added to your project. This tutorial is designed to introduce you to the parametric analysis utility
available in Ansys Workbench.

The tutorial starts with a Fluid Flow (Fluent) analysis system with pre-defined geometry and mesh
components. Within this tutorial, you will redefine the geometry parameters created in Ansys Design-
Modeler by adding constraints to the input parameters. You will use Ansys Fluent to set up and solve
the CFD problem. While defining the problem set-up, you will also learn to define input parameters in
Ansys Fluent. The tutorial will also provide information on how to create output parameters in Ansys
CFD-Post.

This tutorial demonstrates how to do the following:

• Add constraints to the Ansys DesignModeler input parameters.

• Create an Ansys Fluent fluid flow analysis system in Ansys Workbench.

• Set up the CFD simulation in Ansys Fluent, which includes:

– Setting material properties and boundary conditions for a turbulent forced convection problem.

– Defining input parameters in Fluent

• Define output parameters in CFD-Post

• Create additional design points in Ansys Workbench.
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• Run multiple CFD simulations by updating the design points.

• Analyze the results of each design point project in Ansys CFD-Post and Ansys Workbench.

Important:

The mesh and solution settings for this tutorial are designed to demonstrate a basic paramet-
erization simulation within a reasonable solution time-frame. Ordinarily, you would use addi-
tional mesh and solution settings to obtain a more accurate solution.

2.2. Prerequisites

This tutorial assumes that you are already familiar with the Ansys Workbench interface and its project
workflow (for example, Ansys DesignModeler, Ansys Meshing, Ansys Fluent, and Ansys CFD-Post). This
tutorial also assumes that you have completed the introductory Ansys Fluent tutorials, and that you
are familiar with the Ansys Fluent graphical user interface. Some steps in the setup and solution procedure
will not be shown explicitly.

2.3. Problem Description

In the past, evaluation of vehicle air conditioning systems was performed using prototypes and testing
their performance in test labs. However, the design process of modern vehicle air conditioning (AC)
systems improved with the introduction of Computer Aided Design (CAD), Computer Aided Engineering
(CAE) and Computer Aided Manufacturing (CAM). The AC system specification will include minimum
performance requirements, temperatures, control zones, flow rates, and so on. Performance testing
using CFD may include fluid velocity (air flow), pressure values, and temperature distribution. Using
CFD enables the analysis of fluid through very complex geometry and boundary conditions.

As part of the analysis, a designer can change the geometry of the system or the boundary conditions
such as the inlet velocity, flow rate, and so on, and view the effect on fluid flow patterns. This tutorial
illustrates the AC design process on a representative automotive HVAC system consisting of both an
evaporator for cooling and a heat exchanger for heating requirements. This HVAC system is symmetric,
so the geometry has been simplified using a plane of symmetry to reduce computation time.
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Figure 2.1: Automotive HVAC System
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Figure 2.2: HVAC System Valve Location Details

Figure 2.1: Automotive HVAC System (p. 69) shows a representative automotive HVAC system. The system
has three valves (as shown in Figure 2.2: HVAC System Valve Location Details (p. 70)), which control the
flow in the HVAC system. The three valves control:

• Flow over the heat exchanger coils

• Flow towards the duct controlling the flow through the floor vents

• Flow towards the front vents or towards the windshield

Air enters the HVAC system at 310 K with a velocity of 0.5 m/sec through the air inlet and passes to
the evaporator and then, depending on the position of the valve controlling flow to the heat exchanger,
flows over or bypasses the heat exchanger. Depending on the cooling and heating requirements, either
the evaporator or the heat exchanger would be operational, but not both at the same time. The position
of the other two valves controls the flow towards the front panel, the windshield, or towards the floor
ducts.

The motion of the valves is constrained. The valve controlling flow over the heat exchanger varies
between 25° and 90°. The valve controlling the floor flow varies between 20° and 60°. The valve con-
trolling flow towards front panel or windshield varies between 15° and 175°.

The evaporator load is about 200 W in the cooling cycle. The heat exchanger load is about 150 W.

This tutorial illustrates the easiest way to analyze the effects of the above parameters on the flow pat-
tern/distribution and the outlet temperature of air (entering the passenger cabin). Using the parametric
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analysis capability in Ansys Workbench, a designer can check the performance of the system at various
design points.

Figure 2.3: Flow Pattern for the Cooling Cycle

2.4. Setup and Solution

The following sections describe the setup and solution steps for this tutorial:

2.4.1. Preparation

2.4.2. Adding Constraints to Ansys DesignModeler Parameters in Ansys Workbench

2.4.3. Setting Up the CFD Simulation in Ansys Fluent

2.4.4. Defining Input Parameters in Ansys Fluent

2.4.5. Solving

2.4.6. Postprocessing and Setting the Output Parameters in Ansys CFD-Post
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2.4.7. Creating Additional Design Points in Ansys Workbench

2.4.8. Postprocessing the New Design Points in CFD-Post

2.4.9. Summary

2.4.1. Preparation

To prepare for running this tutorial:

1. Download the workbench_parameter.zip file here.

2. Unzip the workbench_parameter.zip file to your working folder.

The extracted workbench_parameter folder contains a single archive file fluent-workbench-
param.wbpz that includes all supporting input files of the starting Ansys Workbench project and
a folder called final_project_files that includes the archived final version of the project. The
final result files incorporate Ansys Fluent and Ansys CFD-Post settings and all already defined design
points (all that is required is to update the design points in the project to generate corresponding
solutions).

2.4.2. Adding Constraints to Ansys DesignModeler Parameters in Ansys
Workbench

In this step, you will start Ansys Workbench, open the project file, review existing parameters, create
new parameters, and add constraints to existing Ansys DesignModeler parameters.

1. From the Windows Start menu, select Start > ANSYS 2021 R2 > Workbench 2021 R2 to start
Ansys Workbench.

This displays the Ansys Workbench application window, which has the Toolbox on the left and
the Project Schematic to its right. Various supported applications are listed in the Toolbox, and
the components of the analysis system are displayed in the Project Schematic.

Note:

When you first start Ansys Workbench, the Getting Started message window is dis-
played, offering assistance through the online help for using the application. You can
keep the window open, or close it by clicking OK. If you need to access the online help
at any time, use the Help menu, or press the F1 key.

2. Restore the archive of the starting Ansys Workbench project to your working directory.

File → Open...

Browse to your working directory, select the project archive file fluent-workbench-
param.wbpz, and click Open.

Now that the project archive has been restored, the project will automatically open in Ansys
Workbench.
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Figure 2.4: The Project Loaded into Ansys Workbench

The project (fluent-workbench-param.wbpj) already has a Fluent-based fluid flow analysis
system that includes the geometry and mesh, as well as some predefined parameters. You will
first examine and edit parameters within Workbench, then later proceed to define the fluid flow
model in Ansys Fluent.

3. Review the input parameters that have already been defined in Ansys DesignModeler.

a. Double-click the Parameter Set bus bar in the Ansys Workbench Project Schematic to open
the Parameters Set tab.

Note:

To return to viewing the Project Schematic, click the Project tab.

b. In the Outline of All Parameters view (Figure 2.5: Parameters Defined in Ansys DesignModel-
er (p. 74)), review the following existing parameters:

• The parameter hcpos represents the valve position that controls the flow over the heat
exchanger. When the valve is at an angle of 25°, it allows the flow to pass over the heat
exchanger. When the angle is 90°, it completely blocks the flow towards the heat exchanger.
Any value in between allows some flow to pass over the heat exchanger giving a mixed
flow condition.

• The parameter ftpos represents the valve position that controls flow towards the floor
duct. When the valve is at an angle of 20°, it blocks the flow towards the floor duct and
when the valve angle is 60°, it unblocks the flow.
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• The parameter wsfpos represents the valve position that controls flow towards the wind-
shield and the front panel. When the valve is at an angle of 15°, it allows the entire flow to
go towards the windshield. When the angle is 90°, it completely blocks the flow towards
windshield as well as the front panel. When the angle is 175°, it allows the flow to go towards
the windshield and the front panel.

Figure 2.5: Parameters Defined in Ansys DesignModeler

4. In the Outline of All Parameters view, create three new named input parameters.

a. In the row that contains New input parameter, click the parameter table cell with New name
(under the Parameter Name column) and enter input_hcpos. Note the ID of the parameter
that appears in column A of the table. For the new input parameter, the parameter ID is P4.
In the Value column, enter 15.

b. In a similar manner, create two more parameters named input_ftpos and input_wsfpos.
In the Value column, enter 25, and 90 for each new parameter (P5 and P6), respectively.
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Figure 2.6: New Parameters Defined in Ansys Workbench

5. Select the row (or any cell in the row) that corresponds to the hcpos parameter. In the Properties
of Outline view, change the value of the hcpos parameter in the Expression field from 90 to
the expression min(max(25,P4),90). This puts a constraint on the value of hcpos, so that
the value always remains between 25° and 90°. The redefined parameter hcpos is automatically
passed to Ansys DesignModeler. Alternatively the same constraint can also be set using the ex-
pression max(25, min(P4,90)).

After defining this expression, the parameter becomes a derived parameter that is dependent on
the value of the parameter input_hcpos with ID P4. The derived parameters are unavailable
for editing in the Outline of All Parameters view and could be redefined only in the Properties
of Outline view.

Important:

When entering expressions, you must use the list and decimal delimiters associated
with your selected language in the Workbench regional and language settings, which
correspond to the regional settings on your machine. The instructions in this tutorial
assume that your systems uses “.” as a decimal separator and “,” as a list separator.
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Figure 2.7: Constrained Parameter hcpos

6. Select the row or any cell in the row that corresponds to the ftpos parameter and create a
similar expression for ftpos: min(max(20,P5),60).
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Figure 2.8: Constrained Parameter ftpos

7. Create a similar expression for wsfpos: min(max(15,P6),175).
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Figure 2.9: Constrained Parameter wsfpos

8. Click the X on the right side of the Parameters Set tab to close it and return to the Project
Schematic.

Note the new status of the cells in the Fluid Flow (Fluent) analysis system. Since we have changed
the values of hcpos, ftpos, and wsfpos to their new expressions, the Geometry and Mesh

cells now indicates Refresh Required ( ).

9. Update the Geometry and Mesh cells.

a. Right-click the Geometry cell and select the Update option from the context menu.
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b. Likewise, right-click the Mesh cell and select the Refresh option from the context menu. Once
the cell is refreshed, then right-click the Mesh cell again and select the Update option from
the context menu.

10. Save the project in Ansys Workbench.

In the main menu, select File → Save

2.4.3. Setting Up the CFD Simulation in Ansys Fluent

Now that you have edited the parameters for the project, you will set up a CFD analysis using Ansys
Fluent. In this step, you will start Ansys Fluent, and begin setting up the CFD simulation.

2.4.3.1. Starting Ansys Fluent

In the Ansys Workbench  Project Schematic, double-click the Setup cell in the Ansys Fluent fluid
flow analysis system. You can also right-click the Setup cell to display the context menu where you
can select the Edit... option.

When Ansys Fluent is first started, Fluent Launcher is displayed, allowing you to view and/or set
certain Ansys Fluent start-up options.

Fluent Launcher allows you to decide which version of Ansys Fluent you will use, based on your geometry
and on your processing capabilities.
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Figure 2.10: Ansys Fluent Launcher

1. Ensure that the proper options are enabled.

Important:

Note that the Dimension setting is already filled in and cannot be changed, since
Ansys Fluent automatically sets it based on the mesh or geometry for the current
system.

a. Ensure that the Double Precision option is enabled.

b. Set Solver Processes to 4 under Parallel (Local Machine).

Note:

Fluent will retain your preferences for future sessions.

2. Click Start to launch Ansys Fluent.
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Figure 2.11: The Ansys Fluent Application

2.4.3.2. Setting Up Physics

1. In the Solver group of the Physics ribbon tab, retain the default selection of the steady pressure-
based solver.

Physics → Solver

2. Set up your models for the CFD simulation using the Models group of the Physics ribbon tab.

a. Enable heat transfer by activating the energy equation.

In the Physics ribbon tab, enable Energy (Models group).

Physics → Models → Energy
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b. Enable the turbulence model.

Physics → Models → Viscous...

i. Select the k-epsilon (2 eqn) from the Model group box.
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ii. Select Enhanced Wall Treatment from the Near-Wall Treatment group box.

iii. Click OK to retain the other default settings and close the Viscous Model dialog box.

Note that the Viscous... label in the ribbon is displayed in blue to indicate that the Viscous
model is enabled.

3. Define a heat source cell zone condition for the evaporator volume.

Physics → Zones → Cell Zones

Note:

All cell zones defined in your simulation are listed in the Cell Zone Conditions task
page and under the Setup/Cell Zone Conditions tree branch.

a. In the Cell Zone Conditions task page, under the Zone list, select fluid-evaporator and
click Edit... to open the Fluid dialog box.

b. In the Fluid dialog box, enable Source Terms.

c. In the Source Terms tab, click the Edit... button next to Energy.
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d. In the Energy sources dialog box, change the Number of Energy sources to 1.

e. For the new energy source, select constant from the drop-down list, and enter -787401.6

W/m3 — based on the evaporator load (200 W) divided by the evaporator volume (0.000254

m3) that was computed earlier.

f. Click OK to close the Energy sources dialog box.

g. Click Apply and close the Fluid dialog box.

2.4.4. Defining Input Parameters in Ansys Fluent

You have now started setting up the CFD analysis using Ansys Fluent. In this step, you will define
boundary conditions and input parameters for the velocity inlet.

1. Define an input parameter called in_velocity for the velocity at the inlet boundary.

a. In the Physics tab, click Boundaries (Zones group).

Physics → Zones → Boundaries

This opens the Boundary Conditions task page.

Note:

All boundaries defined in the case are also displayed under the Setup/Boundary
Conditions tree branch.

b. In the Boundary Conditions task page, click the Toggle Tree View button (in the upper right
corner), and under the Group By category, select Zone Type. This displays boundary zones
grouped by zone type.

c. Under the Inlet zone type, double-click inlet-air.
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d. In the Velocity Inlet dialog box, from the Velocity Magnitude drop-down list, select New
Input Parameter....

This displays the Parameter Expression dialog box.

85
Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Setup and Solution



e. Enter in_velocity for the Name, and enter 0.5 [m s^-1] for Definition.

f. Click OK to close the Parameter Expression dialog box.

g. Under the Turbulence group box, from the Specification Method drop-down list, select In-
tensity and Hydraulic Diameter.

h. Retain the value of 5  for Turbulent Intensity.

i. Enter 0.061 for Hydraulic Diameter (m).
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2. Define an input parameter called in_temp for the temperature at the inlet boundary.

a. In the Thermal tab of the Velocity Inlet dialog box, select New Input Parameter... from
the Temperature drop-down list.

b. Enter in_temp for the Name and enter 310 [K] for the Definition in the Parameter
Expression dialog box.

c. Click OK to close the Parameter Expression dialog box.

d. Click Apply and Close the Velocity Inlet dialog box.

3. Review all of the input parameters that you have defined in Ansys Fluent under the Parameters
& Customization/Parameters tree branch.

Parameters & Customization → Parameters → Input Parameters
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Figure 2.12: The Input Parameters Sub-Branch in Ansys Fluent

These parameters are passed to Ansys Fluent component system in Ansys Workbench and are
available for editing in Ansys Workbench (see Figure 2.13: The Parameters View in Ansys Work-
bench (p. 88)).

Figure 2.13: The Parameters View in Ansys Workbench

4. Set the turbulence parameters for backflow at the front outlets and foot outlets.
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a. In the Boundary Conditions task page, type outlet in the Zone filter text entry field. Note
that as you type, the names of the boundary zones beginning with the characters you entered
appear in the boundary condition zone list.

Note:

• The search string can include wildcards. For example, entering *let* will display
all zone names containing let, such as inlet and outlet.

• To display all zones again, click the red X icon in the Zone filter.

b. Double-click outlet-front-mid.

c. In the Pressure Outlet dialog box, under the Turbulence group box, select Intensity and
Hydraulic Diameter from the Specification Method drop-down list.

d. Retain the value of 5 for Backflow Turbulent Intensity (%).

89
Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Setup and Solution



e. Enter 0.044 for Backflow Hydraulic Diameter (m).

These values will only be used if reversed flow occurs at the outlets. It is a good idea to set reasonable
values to prevent adverse convergence behavior if backflow occurs during the calculation.

f. Click Apply and Close the Pressure Outlet dialog box.

g. Copy the boundary conditions from outlet-front-mid to the other front outlet.

Setup → Boundary Conditions → outlet-front-mid Copy...

i. Confirm that outlet-front-mid is selected in the From Boundary Zone selection list.

ii. Select outlet-front-side-left in the To Boundary Zones selection list.

iii. Click Copy to copy the boundary conditions.

Fluent will display a dialog box asking you to confirm that you want to copy the boundary
conditions.

iv. Click OK to confirm.

v. Close the Copy Conditions dialog box.

h. In a similar manner, set the backflow turbulence conditions for outlet-foot-left using the values
in the following table:

ValueParameter

Intensity and Hydraulic DiameterSpecification Method

5Backflow Turbulent Intensity (%)

0.052Backflow Hydraulic Diameter (m)
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2.4.5. Solving

In the steps that follow, you will set up and run the calculation using the Solution ribbon tab.

Note:

You can also use the task pages listed under the Solution branch in the tree to perform
solution-related activities.

1. Set the Solution Methods.

Solution → Solution → Methods...

This will open the Solution Methods task page.
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a. From the Scheme drop-down list, ensure that Coupled is selected.

b. In the Spatial Discretization group box, configure the following settings:

ValueSetting

PRESTO!Pressure
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ValueSetting

First Order UpwindMomentum

First Order UpwindEnergy

This tutorial is primarily intended to demonstrate the use of parameterization and design
points when running Fluent from Workbench. Therefore, you will run a simplified analysis using
first order discretization, which will yield faster convergence. These settings were chosen to
speed up solution time for this tutorial. Usually, for cases like this, we would recommend
higher order discretization settings to be set for all flow equations to ensure improved results
accuracy. The second-order scheme will provide a more accurate solution.

c. Ensure that Warped-Faced Gradient Correction is selected.

d. Ensure that Pseudo Transient is not selected.

2. Initialize the flow field using the Initialization group of the Solution ribbon tab.

Solution → Initialization

a. Retain the default selection of Hybrid Initialization.

b. Click the Initialize button.

3. Run the simulation in Ansys Fluent from the Run Calculation group of the Solution tab.

Solution → Run Calculation

a. Enter 1000 for No. of Iterations

b. Click the Calculate button.

Throughout the calculation, Fluent displays a warning in the console regarding reversed flow at the
outlets. This behavior is expected in this case since air is redirected to the outlets, creating small regions
of recirculation.

4. Close Fluent.
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File → Close Fluent

5. Save the project in Ansys Workbench.

File → Save

2.4.6. Postprocessing and Setting the Output Parameters in Ansys CFD-Post

In this step, you will visualize the results of your CFD simulation using Ansys CFD-Post. You will plot
vectors that are colored by pressure, velocity, and temperature, on a plane within the geometry. In
addition, you will create output parameters within Ansys CFD-Post for later use in Ansys Workbench.

In the Ansys Workbench Project Schematic, double-click the Results cell in the Ansys Fluent fluid
flow analysis system to start CFD-Post. You can also right-click the Results cell to display the context
menu where you can select the Edit... option.

The CFD-Post application appears with the automotive HVAC geometry already loaded and displayed
in outline mode. Note that Ansys Fluent results (that is, the case and data files) are also automatically
loaded into CFD-Post.

Figure 2.14: The Automotive HVAC Geometry Loaded into CFD-Post

1. Plot vectors colored by pressure.

a. From the main menu, select Insert → Vector or click  in the Ansys CFD-Post toolbar.

This displays the Insert Vector dialog box.

b. Keep the default name of Vector 1 by clicking OK.

c. In the Details view for Vector 1, under the Geometry tab, configure the following settings.
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i. Ensure All Domains is selected from the Domains drop-down list.

ii. From the Locations drop-down list, select symmetry central unit.

iii. From the Sampling drop-down list, select Equally Spaced.

iv. Set the # of Points to 10000.

v. From the Projection drop-down list, select Tangential.

d. In the Color tab, configure the following settings.
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i. From the Mode drop-down list, select Variable.

ii. From the Variable drop-down list, select Pressure.

e. In the Symbol tab, configure the following settings.

i. Set the Symbol Size to 0.5.
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f. Click Apply.

Vector 1 appears under User Locations and Plots in the Outline tree view.

In the graphics display window, note that symmetry-central-unit shows the vectors colored by
pressure. Use the controls in CFD-Post to rotate the geometry (for example, clicking the dark blue
axis in the axis triad of the graphics window). Zoom in to the view as shown in Figure 2.15: Vectors
Colored by Pressure (p. 97).

Note:

To better visualize the vector display, you can deselect the Wireframe view option
under User Locations and Plots in the Outline tree view.

Figure 2.15: Vectors Colored by Pressure

2. Plot vectors colored by velocity.

a. In the Details view for Vector 1, under the Color tab, configure the following settings.

i. Select Velocity from the Variable drop-down list.

ii. Click Apply.

The velocity vector plot appears on the symmetry-central-unit symmetry plane.
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Figure 2.16: Vectors Colored by Velocity

3. Plot vectors colored by temperature.

a. In the Details view for Vector 1, under the Color tab, configure the following settings.

i. Select Temperature from the Variable drop-down list.

ii. Select User Specified from the Range drop-down list.

iii. Enter 273 K for the Min temperature value.

iv. Enter 310 K for the Max temperature value.

v. Click Apply.

The user-specified range is selected much narrower than the Global and Local ranges in
order to better show the variation.
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Figure 2.17: Vectors Colored by Temperature

Note the orientation of the various valves and how they impact the flow field. Later in this tutorial,
you will change these valve angles to see how the flow field changes.

4. Create two surface groups.

Surface groups are collections of surface locations in CFD-Post. In this tutorial, two surface groups
are created in CFD-Post that will represent all of the outlets and all of the front outlets. Once
created, specific commands (or expressions) will be applied to these groups in order to calculate
a particular numerical value at that surface.

a. Create a surface group consisting of all outlets.

i. With the Outline tree view open in the CFD-Post tree view, open the Insert Surface Group
dialog box.

Insert → Location → Surface Group
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ii. Enter alloutlets for the Name of the surface group, and click OK to close the Insert
Surface Group dialog box.

iii. In the Details view for the alloutlets surface group, in the Geometry tab, click the

ellipsis icon  next to Locations to display the Location Selector dialog box.

iv. Select all of the outlet surfaces (outlet foot left, outlet front mid, outlet
front side left, and outlet windshield) in the Location Selector dialog box
(hold Ctrl for multiple selection) and click OK.

v. Click Apply in the Details view for the new surface group.

alloutlets appears under User Locations and Plots in the Outline tree view.
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b. Create a surface group for the front outlets.

Perform the same steps as described above to create a surface group called frontoutlets
with locations for the front outlets (outlet front mid and outlet front side
left).

5. Create expressions in CFD-Post and mark them as Ansys Workbench output parameters.

In this tutorial, programmatic commands or expressions are written to obtain numerical values
for the mass flow rate from all outlets, as well as at the front outlets, windshield, and foot outlets.
The surface groups you defined earlier are used to write the expressions.

a. Create an expression for the mass flow from all outlets.

i. With the Expressions tab open in the CFD-Post tree view, open the Insert Expression
dialog box.

Insert → Expression

ii. Enter floutfront for the Name of the expression and click OK to close the Insert Ex-
pression dialog box.

iii. In the Details view for the new expression, enter the following in the Definition tab.

-(massFlow()@frontoutlets)*2
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The sign convention for massFlow() is such that a positive value represents flow into the domain
and a negative value represents flow out of the domain. Since you are defining an expression
for outflow from the ducts, you use the negative of the massFlow() result in the definition of
the expression.

iv. Click Apply to obtain a Value for the expression.

Note the new addition in the list of expressions in the Expressions tab in CFD-Post.

In this case, there is a small net backflow into the front ducts.

v. Right-click the new expression and select Use as Workbench Output Parameter from the
context menu. A small “P” with a right-pointing arrow appears on the expression’s icon.

b. Create an expression for the mass flow from the wind shield.

i. Perform the same steps as described above to create an expression called floutwind-
shield with the following definition:

-(massFlow()@outlet windshield)*2

ii. Right-click the new expression and select Use as Workbench Output Parameter from the
context menu.

c. Create an expression for the mass flow from the foot outlets.

i. Perform the same steps as described above to create an expression called floutfoot
with the following definition:

-(massFlow()@outlet foot left)*2

ii. Right-click the new expression and select Use as Workbench Output Parameter from the
context menu.

d. Create an expression for the mass weighted average outlet temperature.

i. Perform the same steps as described above to create an expression called outlettemp
with the following definition:

massFlowAveAbs(Temperature)@alloutlets

ii. Right-click the new expression and select Use as Workbench Output Parameter from the
context menu.

6. Close Ansys CFD-Post.

In the main menu, select File → Close CFD-POST to return to Ansys Workbench.

7. In the Outline of All Parameters view of the Parameter Set tab (double-click Parameter Set),
review the newly-added output parameters that you specified in Ansys CFD-Post and when finished,
click the Project tab to return to the Project Schematic.

8. If any of the cells in the analysis system require attention, update the project by clicking the Update
Project button in the Ansys Workbench toolbar.

9. Optionally, review the list of files generated by Ansys Workbench. If the Files view is not open,
select View → Files from the main menu.
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You will notice additional files associated with the latest solution as well as those generated by
CFD-Post.

Figure 2.18: The Updated Project Loaded into Ansys Workbench Displaying the Files View

10. Save the project in Ansys Workbench.
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In the main menu, select File → Save

Note:

You can also select the Save Project option from the CFD-Post File ribbon tab.

2.4.7. Creating Additional Design Points in Ansys Workbench

Parameters and design points are tools that allow you to analyze and explore a project by giving you
the ability to run optimization and what-if scenarios. Design points are based on sets of parameter
values. When you define input and output parameters in your Ansys Workbench project, you are es-
sentially working with a design point. To perform optimization and what-if scenarios, you create
multiple design points based on your original project. In this step, you will create additional design
points for your project where you will be able to perform a comparison of your results by manipulating
input parameters (such as the angles of the various valves within the automotive HVAC geometry).
Ansys Workbench provides a Table of Design Points to make creating and manipulating design points
more convenient.

1. Open the Table of Design Points.

a. In the Project Schematic, double-click the Parameter Set bus bar to open the Table of
Design Points view. If the table is not visible, select Table from the View menu in Ansys
Workbench.

View → Table

The table of design points initially contains the current project as a design point (DP0),
along with its corresponding input and output parameter values.

Figure 2.19: Table of Design Points (with DP0)

From this table, you can create new design points (or duplicate existing design points)
and edit them (by varying one or more input parameters) to create separate analyses for
future comparison of data.

2. Create a design point (DP1) by duplicating the current design point (DP0).

a. Right-click the Current design point and select Duplicate Design Point from the
context menu.

The cells autofill with the values from the Current row.

b. Scroll over to the far right to expose the Retain column in the table of design points,
and ensure the check box in the row for the duplicated design point DP 1 (cell N4)
is selected.
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This allows the data from this new design point to be saved before it is exported for future
analysis.

3. Create another design point (DP2) by duplicating the DP1 design point.

a. Right-click the DP1 design point and select Duplicate Design Point from the context
menu.

Since this is a duplicate of DP1, this design point will also have its data retained.

4. Edit values for the input parameters for DP1 and DP2.

For DP1 and DP2, edit the values for your input parameters within the Table of Design Points
as follows:

in_tempin_velocityinput_wsf-
pos

input_ftposinput_hcpos

3000.6454545DP1

2900.7156090DP2

Figure 2.20: Table of Design Points (with DP0, DP1, and DP2 Defined)

For demonstration purposes of this tutorial, in each design point, you are slightly changing
the angles of each of the valves, and increasing the inlet velocity and decreasing the inlet
temperature. Later, you will see how the results in each case vary.

5. Update all of your design points.

Click the Update all Design Points button in the Ansys Workbench toolbar. Alternatively,
you can also select one or more design points, right-click, and select Update Selected Design
Points from the context menu. Click OK to acknowledge the information message notifying
you that some open editors may close during the update process. By updating the design
points, Ansys Workbench takes the new values of the input parameters for each design point
and updates the components of the associated system (for example, the geometry, mesh,
settings, solution, and results), as well as any output parameters that have been defined.

Note:

It may take significant time and/or computing resources to re-run the simula-
tions for each design point.

6. Export the design points to separate projects.

This will allow you to work with calculated data for each design point.
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a. Select the three design points, DP0, DP1, and DP2 (hold Shift for multiple selection).

b. Right-click the selected design points and select Export Selected Design Points.

Note the addition of three more Ansys Workbench project files (and their corresponding
folders) in your current working directory (fluent-workbench-param_dp0.wbpj,
fluent-workbench-param_dp1.wbpj and fluent-workbench-
param_dp2.wbpj). You can open each of these projects up separately and examine
the results of each parameterized simulation.

Tip:

You can easily access files in your project directory directly from the Files view by
right-clicking any cell in the corresponding row and selecting Open Containing
Folder from the menu that opens.

7. Inspect the output parameter values in Ansys Workbench.

Once all design points have been updated, you can use the table of design points to inspect
the values of the output parameters you created in CFD-Post (for example, the mass flow
parameters at the various outlets: floutfront, floutfoot, floutwindshield, and
outlettemp). These, and the rest of the output parameters are listed to the far right in the
table of design points.

8. Click the Project tab, located just above the Ansys Workbench toolbar, to return to the Project
Schematic.

9. (Optional) View the list of files generated by Ansys Workbench.

View → Files

The additional files for the new design points are stored with their respective project files
since you exported them.

10. Save the project in its current state in Ansys Workbench.

In the main menu, select File → Save.

11. Quit Ansys Workbench.

In the main menu, select File → Exit.

2.4.8. Postprocessing the New Design Points in CFD-Post

In this section, you will open the Ansys Workbench project for each of the design points and inspect
the vector plots based on the new results of the simulations.

1. Study the results of the first design point (DP1).

a. Open the Ansys Workbench project for the first design point (DP1).
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In your current working folder, double-click the fluent-workbench-param_dp1.wbpj
file to open Ansys Workbench.

b. Open CFD-Post by double-clicking the Results cell in the Project Schematic for the Fluid
Flow (Fluent) analysis system.

c. View the vector plot colored by temperature. Ensure that Range in the Color tab is set
to User Specified and the Min and Max temperature values are set to 273 K and 310
K, respectively.

Figure 2.21: Vectors Colored by Temperature (DP1)

d. View the vector plot colored by pressure. Ensure that Range in the Color tab is set to
Global.
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Figure 2.22: Vectors Colored by Pressure (DP1)

e. View the vector plot colored by velocity. Ensure that Range in the Color tab is set to
Global.
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Figure 2.23: Vectors Colored by Velocity (DP1)

f. When you are finished viewing results of the design point DP1 in Ansys CFD-Post, select
File → Close CFD-Post to quit Ansys CFD-Post and return to the Ansys Workbench Project
Schematic, and then select File → Exit to exit from Ansys Workbench.

2. Study the results of the second design point (DP2).

a. Open the Ansys Workbench project for the second design point (DP2).

In your current working folder, double-click the fluent-workbench-param_dp2.wbpj
file to open Ansys Workbench.

b. Open CFD-Post by double-clicking the Results cell in the Project Schematic for the Fluid
Flow (Fluent) analysis system.

c. View the vector plot colored by temperature. Ensure that Range in the Color tab is set
to User Specified and the Min and Max temperature values are set and the Min and
Max temperature values are set to 273 K and 310 K, respectively.

109
Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Setup and Solution



Figure 2.24: Vectors Colored by Temperature (DP2)

d. View the vector plot colored by pressure. Ensure that Range in the Color tab is set to
Global.
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Figure 2.25: Vectors Colored by Pressure (DP2)

e. View the vector plot colored by velocity. Ensure that Range in the Color tab is set to
Global.
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Figure 2.26: Vectors Colored by Velocity (DP2)

3. When you are finished viewing results in Ansys CFD-Post, select File → Close CFD-Post to
quit Ansys CFD-Post and return to the Ansys Workbench Project Schematic, and then select
File → Exit to exit from Ansys Workbench.

2.4.9. Summary

In this tutorial, input and output parameters were created within Ansys Workbench, Ansys Fluent,
and Ansys CFD-Post in order to study the airflow in an automotive HVAC system. Ansys Fluent was
used to calculate the fluid flow throughout the geometry using the computational mesh, and Ansys
CFD-Post was used to analyze the results. Ansys Workbench was used to create additional design
points based on the original settings, and the corresponding simulations were run to create separate
projects where parameterized analysis could be performed to study the effects of variable angles of
the inlet valves, velocities, and temperatures. Also, note that simplified solution settings were used
in this tutorial to speed up the solution time. For more improved solution accuracy, you would typically
use denser mesh and higher order discretization for all flow equations.
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