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Hexa Mesh Generation for a 2D Pipe Junction
In this tutorial, you will generate a mesh for a two-dimensional pipe junction that comprises two inlets
and one outlet. After generating an initial mesh, you will check the quality of the mesh, and refine it
for a Navier-Stokes solution.

Figure 1: 2D Pipe Geometry

This tutorial demonstrates how to do the following:

• Block the geometry.

• Associate entities to the geometry.

• Move vertices onto the geometry.

• Apply mesh parameters.

• Generate the initial mesh.

• Adjust the edge distribution and refine the mesh.

• Match the edges to improve quality.

• Verify and save the mesh.

Starting the Project

1
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Step 1: Block the Geometry

Step 2: Associate Entities to the Geometry

Step 3: Move the Vertices

Step 4: Apply Mesh Parameters

Step 5: Generate the Initial Mesh

Step 6: Adjust the Edge Distribution and Refine the Mesh

Step 7: Match the Edges to Improve Quality

Step 8: Verify and Save the Mesh and Blocking

Starting the Project

1. Set up a working directory on your computer.

2. Download the 2dpipe_junct.zip file here.

3. Unzip the 2dpipe_junct.zip file you have downloaded to your working directory.

4. Start Ansys ICEM CFD and create a new project in your working directory. Use an appropriate name,
for example Hexa2D_Pipe.

File → New Project

5. Open the geometry file (geometry.tin).

File → Geometry → Open Geometry...

Note:

If you want Ansys ICEM CFD to behave exactly as this tutorial describes, you should go to
the Settings Menu, click Selection, and disable Auto Pick Mode in the DEZ. Most experienced
ICEM CFD users prefer to enable Auto Pick Mode as it improves efficiency. See Selection in
the ICEM CFD Help Manual → Main Menu Area → Settings Menu for more detail.

Blocking Strategy

The blocking strategy for the 2D pipe geometry involves creating a T-shaped blocking and fitting it to
the geometry. The 2D pipe geometry is equivalent to a T shape with the right side of the blocking
crossbar bent upward to resemble the geometry. You will fit the T-shaped blocking to the geometry
by creating associations between the edges of the blocks and the curves in the geometry, and then
moving the vertices of the blocks onto the corners of the geometry. This procedure will be described
in subsequent steps.
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Figure 2: The Mesh and its Topology

Step 1: Block the Geometry

The geometry and part information has already been defined for this tutorial. You will create the initial block
in this step.

1. Create the initial block.

Blocking → Create Block  → Initialize Blocks 

a. Enter FLUID in the Part field.

b. Select 2D Planar in the Type drop-down list.

c. Click Apply.
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Step 1: Block the Geometry



d. Enable Vertices under Blocking.

Blocking → Vertices

e. Select Numbers under Vertices.

Blocking → Vertices → Numbers

Figure 3: Initial Block (p. 4) shows the initial block enclosing the geometry. You will modify the
initial block to create the topology of the model.

Figure 3: Initial Block

The curves are now colored separately instead of by part. This allows you to distinguish the indi-
vidual curve entities from each other, which is necessary for some of the blocking operations. You
can enable or disable the color coding by selecting/deselecting Show Composite.

Geometry → Curves → Show Composite

2. Split the initial block into sub-blocks.

In this case, you will split the initial block using two vertical splits and one horizontal split.

Blocking → Split Block  → Split Block 
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a. Create the vertical splits.

i. Ensure that Curves is enabled under Geometry.

Geometry → Curves

ii. Retain the selection of Screen select in the Split Method drop-down list.

Note:

In this case, the split may be done by approximation because only the topology
of the T-shape is essential, the exact proportion is not.

iii. Click (Select edge(s)) and select the edge defined by vertices 11 and 19 or by vertices
13 and 21.

iv. Position the new edge as shown in Figure 4: Initial Vertical Split (p. 6) and click the
middle-mouse button to accept the position.

5
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Step 1: Block the Geometry



Figure 4: Initial Vertical Split

The edge (33–34) is cyan colored indicating that it is an internal edge.

v. Similarly, select the edge defined by vertices 33 and 19 or vertices 34 and 21. Position
the new edge (see Figure 5: Block After the Vertical Splits (p. 7)) and click the middle-
mouse button to accept the position.

Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.6

Hexa Mesh Generation for a 2D Pipe Junction



Figure 5: Block After the Vertical Splits

b. Create the horizontal split using the Relative split method.
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i. Select Relative in the Split Method drop-down list.

ii. Enter 0.5 (midpoint of selected edge) for Parameter.

iii. Select any one of the vertical edges and click Apply.

Figure 6: Block After Three Splits (p. 9) shows the fully split block.
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Figure 6: Block After Three Splits

3. Delete the unnecessary blocks.

The next step in this “top down” approach is to remove/delete the blocks that are not required.

Blocking → Delete Blocks 

a. Ensure that Delete permanently is disabled.

b. Click  (Select block(s)) and select the blocks shown in Figure 7: Blocks to be Deleted (p. 10).

9
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Step 1: Block the Geometry



Figure 7: Blocks to be Deleted

c. Click the middle-mouse button or Apply to accept. (See Figure 8: Blocking Topology After
Deleting Blocks (p. 11)).

d. Click Apply to remove the selected blocks.

Note:

With Delete Permanent disabled (default), the deleted blocks are put into the
VORFN part, a default dead zone that is usually deactivated.

The geometry and blocking of the model now resembles Figure 8: Blocking Topology After Deleting
Blocks (p. 11). You may need to enable Blocks, under Blocking in the Model Tree.
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Figure 8: Blocking Topology After Deleting Blocks

Step 2: Associate Entities to the Geometry

You will associate the edges of the blocking to the curves of the CAD geometry in this step. First select the
edges and then the curves to which you want to associate them.

Note:

If two or more curves are selected per operation, those curves will automatically be grouped
(concatenated).

For reference, enable Show Curve Names (see Figure 9: Display Showing Vertex Numbers and Curve
Names (p. 12)).

Geometry → Curves → Show Curve Names

This is not required for edge to curve association, but helps to illustrate the fact that each blocking edge is
associated to the named curve(s).
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Step 2: Associate Entities to the Geometry



Figure 9: Display Showing Vertex Numbers and Curve Names

Blocking → Associate  → Associate Edge to Curve 

1. Associate the inlet, the left-most end of the large pipe.
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a. Ensure that Project Vertices is disabled.

b. Click  (Select edge(s)) and select edge 13–41. Click the middle-mouse button to accept
the selection.

c. Click  (Select compcurve(s)) and select CURVES/1. Click the middle-mouse button to accept
the selection.

d. Click Apply.

The associated edge will be colored green.

Note:

If Auto Pick Mode is enabled, this operation will run in “continuation mode”, allow-
ing you to select the next set of edges and curves without re-invoking the function.
Clicking the middle mouse button when no entities are selected or clicking Dismiss
will cancel the function.

2. Similarly, associate the following edge/curve combinations to make the T fit the geometry:

CurvesEdgesEntity

CURVES/721-44Outlet (top horizontal end of large
pipe)

CURVES/1033-42Small pipe

CURVES/1133-37

CURVES/937-43

CURVES/2, CURVES/5,
CURVES/6

13-34, 34-38,
38-21

Sides of large pipe

CURVES/3, CURVES/4,
CURVES/8

41-42, 43-44

Note:

When entities are overlapped with other entities, disabling certain entity types in
the Model tree will help to identify the right entity. For example, disable Vertices
and Edges to verify the curve names. Enable the Edges to proceed with the selec-
tion.

Note:

For the edges defining the sides of the pipe, select all the edges first before clicking
the middle-mouse button to confirm the selection. Next, select the curves, and then
click the middle-mouse button again. The curves will automatically be grouped as
one logical composite entity.
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Step 2: Associate Entities to the Geometry



3. Verify that the correct associations have been set (see Figure 10: Association of Edges to
Curves (p. 14)).

Blocking → Edges → Show association

Figure 10: Association of Edges to Curves

The green arrows in Figure 10: Association of Edges to Curves (p. 14) point from an edge to its associated
curve. Nodes and vertices of these edges will project on to the associated geometry. The cyan edges
(42-43, 34-42, 38-43) do not have to be associated. They are internal and will interpolate instead of
project on to geometry when the mesh is computed.

Note:

If the associations do not appear correctly, the edges can be reassociated to their
proper curves. It is not necessary to disassociate and then reassociate. Associating the
edge to a new curve will overwrite the previous association. The steps of operation can
also be retraced using the Undo and Redo buttons.

4. Disable Show Association after verifying the associations.

Blocking → Edges → Show association

Step 3: Move the Vertices

1. Manually move the vertices of the inlets and outlet (ends of large pipe).
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Blocking → Move Vertex  → Move Vertex 

Note:

If Auto Pick mode is enabled, selecting Move Vertex from the function tabs will prompt
you to select from the screen. It is usually not necessary to select Move Vertex from
the DEZ unless another option was previously selected.

• Click  (Select vert(s)) and move the vertices of the inlets and the outlet as shown in Fig-
ure 11: Moving Vertices of the Inlets and Outlet (p. 16).

Select the vertex and keeping the left-mouse button pressed, drag the vertex along the curve.
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Step 3: Move the Vertices



Figure 11: Moving Vertices of the Inlets and Outlet

Note:

Due to the associations made between the edges and curves, many of these vertices
will “snap” to the correct position. Vertices may, however, be moved along the
curve by dragging the mouse.

To capture the ends of the curves:

a. Select the vertex and drag it with the left mouse button depressed until the
vertex can be moved no further.

b. Position the cursor beyond the end of the curve to ensure that the end is
captured.

You may also prefer to associate the vertex with the points at the ends of the curves
as described later.

Note:

The ends of the pipe are straight and it is possible to block this example without
using the curve associations. However, the curve associations also create line ele-
ments on the curves to which they are associated. If you skip performing the curve
associations, the boundary line elements will not be created. This will make it im-
possible to apply boundary conditions to that edge (such as inlet or wall). Hence,
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most CFD solvers give errors if any of the perimeter edges are not associated with
perimeter curves.

2. Move the remaining vertices to their appropriate positions on the geometry.

Try to make the blocks as orthogonal (good internal angles) as possible.

Figure 12: Vertices Moved to Positions

3. Associate the vertices to the points.

This is an optional step.

a. Select Show Point Names.

Geometry → Points → Show Point Names

b. Make sure Point is selected for Entity in the Associate Vertex DEZ.

Blocking → Associate  → Associate Vertex 

c. Associate the following vertices and points:

PointVertex

POINTS/213
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POINTS/521

POINTS/141

POINTS/1042

POINTS/933

POINTS/837

POINTS/1143

POINTS/644

Click the middle-mouse button to complete the operation.

d. Deselect Show Point Names.

Geometry → Points → Show Point Names

4. Save the blocking file (2dpipe-geometry.blk).

File → Blocking → Save Blocking As...

The saved blocking file can be reloaded at a later time, using the File → Blocking → Open
Blocking... menu item.

Step 4: Apply Mesh Parameters

In this step, you will set mesh parameters (sizes) on the geometry (curves in this 2D case). This is done at the
geometry level and can be done before or after the blocking.

Mesh → Curve Mesh Setup 
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1. Click  (Select curve(s)).

The Select geometry toolbar will appear.

2. Click  (Select all appropriate visible objects) or enter v (for visible) in the display window.
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3. Enter 1 for Maximum size.

Note:

• Maximum size determines the length of the edge segments on the curve (or surface
for 3D).

• Height determines the length of the edge of the first layer normal to the curve.

• Height ratio determines the normal heights of the subsequent layers.

In this case, height and ratio are determined by the perpendicular curves whose maximum
size will override any height or ratio settings.

4. Retain the default settings for all other parameters and click Apply.

Step 5: Generate the Initial Mesh

Blocking → Pre-Mesh Params  → Update Sizes 

1. Retain the selection of Update All in the Method list.

Note:

This will automatically determine the number of nodes on the edges from the mesh
sizes set on the curves.

2. Select Run Check/Fix Blocks to check for mesh problems automatically and repair them if possible.

3. Click Apply.
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4. Enable Pre-Mesh.

Blocking → Pre-Mesh

The Mesh dialog will appear, asking if you want to recompute the mesh.

5. Click Yes in the Mesh dialog to compute the initial mesh.

6. Disable Vertices and Edges.

Blocking → Vertices

Blocking → Edges

The initial mesh is shown in Figure 13: Initial Mesh (p. 21).

Figure 13: Initial Mesh

Note:

The number of elements in the initial mesh is sensitive to exact vertex placement (longest
edge length in an index divided by the maximum size found along that index). Hence,
your mesh may differ slightly from the mesh shown in Figure 13: Initial Mesh (p. 21).
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Step 6: Adjust the Edge Distribution and Refine the Mesh

In this step, you will employ advanced edge meshing features to redistribute grid points to resolve the salient
features of the flow.

1. Disable Pre-Mesh.

Blocking → Pre-Mesh

2. Redisplay Curves and Edges.

3. See the distribution of grid points along the edges (Figure 14: Initial Bunching (p. 22)).

Blocking → Edges → Bunching

Figure 14: Initial Bunching

4. Display the vertex numbers.

Blocking → Vertices → Numbers

5. Reduce the number of nodes along the length of the large pipe.

Blocking → Pre-Mesh Params  → Edge Params 
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a. Select edge 13–34.

b. Enter 27 for Nodes and click Apply.
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Step 6: Adjust the Edge Distribution and Refine the Mesh



c. Similarly,click  (Select edge(s), select edge 21–38, enter 27 for Nodes and click Apply.

Note:

This is a structured grid. When the number of nodes is changed on one edge, all
parallel edges will automatically have the same number of nodes. In this case, edges
41–42 and 43–44 will have the same number of nodes as 13–34 and 38–21 respect-
ively.

Figure 15: Bunching After Changing the Number of Nodes

d. Enable Pre-Mesh and recompute the mesh.

6. Bias the nodes close to the wall boundaries of the large pipe.

a. Select edge 13–41, and enter 0.5 for both Spacing 1 and Spacing 2.

Note:

Spacing 1 refers to the node spacing at the beginning of the edge, while Spacing
2 refers to the spacing at the end of the edge. The beginning of the edge is shown
by the arrow after the edge is selected.

b. Enter 1.2 for both Ratio 1 and Ratio 2.
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Requested values for spacing and ratio are typed in the first column. Actual values are displayed
in the second column. Note that due to the number of nodes, the mesh law and spacing, the re-
quested ratios may not be attained. You may increase the number of nodes using the arrows until
the ratios are close to the requested value.

Note:

The Mesh Law is by default set to BiGeometric. This allows the nodes to be biased
towards both ends of the edge. The expansion rate from the end is a linear progres-
sion. Several other mathematical progression functions (laws) are available.

c. Enable Copy Parameters and retain the selection of To All Parallel Edges in the Method
drop-down list.

This will ensure that the parallel edges 34–42, 38–43, and 21–44 have the same spacing.

d. Click Apply.

7. Bias the nodes along the length of the long pipe.

a. Select edge 21–38 and change Spacing 1 and Spacing 2 to 0.5.

This will concentrate grid points toward the outlet and toward the small pipe.

b. Ensure that Copy Parameters is enabled and To All Parallel Edges is selected in the Method
drop-down list.

These changes will be reflected in edge 43–44 as well.

c. Click Apply.

d. An available Copy option will be used to concentrate grid points toward the inlet and toward the
small pipe.

In the Copy group box, select To Selected Edges Reversed in the Method drop-down list.

e. Click  (Select edge(s)) and select edges 13–34 and 41–42. Click the middle mouse button
to accept.

f. Click Apply.

8. Refine the nodes along the small pipe.

a. Select edge 33–42 and enter 9 for Nodes.

b. Enter 1.0 for Spacing 1 and 0.5 for Spacing 2, respectively.

c. Ensure that Copy Parameters is enabled and select To All Parallel Edges in the Method
drop-down list.

d. Click Apply.
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e. Similarly, select edge 33–37, enter 9 for Nodes, and click Apply.

9. Disable and then enable Pre-Mesh to recompute the mesh (Figure 16: Refined Mesh (p. 26)).

Blocking → Pre-Mesh

Figure 16: Refined Mesh

Step 7: Match the Edges to Improve Quality

In this step, the node spacing on the end of your selected Target Edge(s) will be modified to match the node
spacing on the selected Reference Edge. A better quality mesh is achieved by smoothing the size change
between adjacent cells.

Blocking → Pre-Mesh Params  → Match Edges 

1. Match the edge spacing manually.
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a. Retain Selected in the Method drop-down list.

b. For Reference Edge, click  (Select edge(s)) and then select edge 42–43.

c. For Target Edge(s), click  (Select edge(s)) and then select edges 41–42 and 42–33. Click
the middle-mouse button to accept the selection.

d. Click Apply.

e. Enable Pre-Mesh.

Blocking → Pre-Mesh

The Mesh dialog box will appear, asking if you want to recompute the mesh. Click Yes.

2. Match the edge spacing automatically.
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Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Step 7: Match the Edges to Improve Quality



a. Select Automatic from the Method drop-down list.

b. Ensure that the Spacing is set to Minimum.

c. Click  (Select vert(s) ) and then  (Select all appropriate visible objects) from the Select
Blocking-vertex toolbar.

Alternatively, with the mouse in the display window, you can enter v for all visible vertices, or drag
a box to select all vertices.

d. For Ref. Edges, click  (Select edge(s)) and then select the edges 13-34 and 34-42. Click the
middle-mouse button to accept the selection.

This selection chooses the i and j index at each vertex for matching.

e. Click Apply.

f. Disable and then enable Pre-Mesh to recompute the mesh.

Blocking → Pre-Mesh

The Mesh dialog box will appear, asking if you want to recompute the mesh. Click Yes.

Figure 17: Mesh Before Matching Edges (p. 29) and Figure 18: Mesh After Matching Edges (p. 29)
show the mesh before and after matching the edges, respectively.
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Figure 17: Mesh Before Matching Edges

Figure 18: Mesh After Matching Edges

Step 8: Verify and Save the Mesh and Blocking

1. Check the quality of the mesh.

Blocking → Pre-Mesh Quality Histograms 
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a. Retain the default settings and click Apply.

b. Select the worst two bars from the histogram.

The selected bars will be highlighted in pink (Figure 19: Pre-Mesh Quality Histogram (p. 30)).

Figure 19: Pre-Mesh Quality Histogram

The worst quality elements in the mesh will be highlighted (Figure 20: Elements With Worst Qual-
ity (p. 31)).
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Figure 20: Elements With Worst Quality

2. Convert the mesh to unstructured format.

Blocking → Pre-Mesh → Convert to Unstruct Mesh

3. Save the blocking file (2D-pipe-geometry-final.blk).

File → Blocking → Save Blocking As...

This block file can be loaded in a future session (File → Blocking → Open Blocking...) for additional
modification or to mesh a similar geometry. Save each blocking to a separate file instead of overwriting
a previous one. In more complex models, you may have to back track and load a previous blocking.

4. Save the project file (2D-pipe-geometry-final.prj).

File → Save Project As...

This will save all the files – tetin, blocking, and unstructured mesh.

5. Exit the current session.

File → Exit
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Step 8: Verify and Save the Mesh and Blocking
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Hexa Mesh Generation for a 2D Car
In this tutorial, you will generate a Mesh for external flow over a simple 2D Car profile residing in a
wind tunnel. The 2D Car geometry is shown.

Replay Control will be employed for recording all the blocking steps. Later, the replay (script) file will
be run to block and mesh a modified geometry.

Figure 21: 2D Car Geometry

This tutorial demonstrates how to do the following:

• Create Blocking to Resemble the Geometry

• Fit the Blocking to the Geometry

• Align the Vertices

• Set Mesh Parameters and Initialize the Mesh

• Create an Ogrid

• Refine the Mesh

• Use the Replay file for Design Iteration

• Create Output Data for a Solver

Starting the Project

Step 1: Create and Split the Blocking to Resemble the Geometry

Step 2: Associate and Fit the Blocking to the Geometry

Step 3: Align the Vertices

Step 4: Set Mesh Parameters and Generate the Initial Mesh

Step 5: Create an Ogrid

Step 6: Refine the Mesh using Edge Parameters
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Step 7: Save the Replay File and Use it for Design Iteration

Step 8: Create Output Data for a Solver

Starting the Project

1. Set up a working directory on your computer.

2. Download the 2dcar.zip file here.

3. Unzip the 2dcar.zip file you have downloaded to your working directory.

4. Initialize your project.

a. Ansys ICEM CFD stand-alone users:

i. Start Ansys ICEM CFD.

ii. Create a new project in your working directory. Use an appropriate name, for example
2D_Car_base.

File → New Project

b. Ansys Workbench users:

i. Create an ICEM CFD Component in your Project Schematic.

ii. Double click the Model cell to open ICEM CFD.

5. Open the original, unmodified geometry file. (car_base.tin).

File → Geometry → Open Geometry

The following Parts have been defined in the geometry. Ensure that all the names of the listed
Parts are available in the Display Tree.

• CAR: Vehicle geometry.

• GROUND: Lower limit of the wind tunnel.

• INLET: Where flow enters the wind tunnel. In this example, it is the left-side limit of the geometry.

• OUTLET: Where flow exits the wind tunnel.

• PNTS: Prescribed points associated with the Car.
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• TOP: Upper limit of the wind tunnel.

Note:

This geometry contains only curves and points. Surfaces are helpful, but not necessary
for 2D meshing.

6. Activate the Replay Control function.

A Replay file will be created and then used on the modified geometry (car_mod.tin). The same part
and entity names are used in both the base and modified geometries, which allows the Replay file to
be run without editing, on the modified geometry.

File → Replay Scripts → Replay Control

Note:

• The replay function allows you to record the steps necessary to complete the mesh.
The Replay Control window may be moved aside or minimized while recording, but
the window should be kept active until recording is complete.

• Record (after current) is enabled by default – all commands will be recorded until
you select Done.
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• The step of loading the geometry is not typically recorded in the replay script.

Note:

• If you want Ansys ICEM CFD to behave exactly as this tutorial describes, you should go to
the Settings Menu, click Selection, and disable Auto Pick Mode in the DEZ. Most experi-
enced ICEM CFD users prefer to enable Auto Pick Mode as it improves efficiency. See
Selection in the ICEM CFD Help Manual → Main Menu Area → Settings Menu for more
detail.

• Throughout this and other tutorials, Point Names, Curve Names, Vertex Numbers, and
other identifying labels are made visible or turned off as necessary to assist in describing
the steps of the tutorial. Most experienced users prefer to leave these labels disabled to
reduce screen clutter.

Step 1: Create and Split the Blocking to Resemble the Geometry

For an external flow model in a wind tunnel, the following steps are usually taken when blocking the
model to obtain the desired results.

• Initialize the blocking, and then carve a Cartesian set of blocks around the object using the Split
Blocks function.

• Move the vertices onto the geometry in order to fit all its features – bumpers, hood, trunk, and so
on in this tutorial.

• Create an Ogrid block around the geometry for boundary layer flow modeling.

These basic steps will be detailed through the next several sections of this tutorial.

1. Create the initial block.

Blocking → Create Block  → Initialize Blocks 
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a. In the Part field, enter FLUID.

b. From the Type drop-down list, choose 2D Planar.

c. Click Apply.

Figure 22: Initial Blocking

The curves are now colored separately instead of by part. This allows you to distinguish the individual
curve entities from each other, which is necessary for some of the blocking operations. You can enable
or disable the color coding by selecting/deselecting Show Composite in the Display tree, under Geometry
→ Curves.

Geometry → Curves → Show Composite

2. Associate the four edges of the initial block to the four sides of the wind tunnel.
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Blocking → Associate  → Associate Edge to Curve 

Note:

• When using Hexa for 2D, boundary line elements are created only if the edges are
associated with the boundary curves, and they are required before boundary conditions
may be applied.

• It is good practice to associate all perimeter edges with perimeter curves before the
edges are split. Then, when the edges are split, all segments will retain the necessary
association.

a. For reference, enable the display of Vertices by Numbers and Show Curve Names.

i. Blocking → Vertices

ii. Blocking → Vertices → Numbers

iii. Geometry → Curves → Show Curve Names

b. Click (Select edge(s)), and then select the edge 11-13 (endpoints are vertices 11 and 13).
Click the middle mouse button to accept the selection.

Note:

At any point in time while in selection mode, you can toggle to dynamic mode by
pressing F9. This may be necessary in order to zoom in or out, or otherwise manip-
ulate the display. Pressing F9 again will toggle back to selection mode.

c. Click  (Select compcurve(s)), and then select the curve INLET/1 that lay on top of the edge.
Click the middle mouse button to accept.
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d. Click Apply to complete the association.

e. Similarly associate the remaining edges (13-21, 21-19, and 19-11) to the curves (TOP/1,
OUTLET/1, and GROUND/1).

f. Disable the display of Curves in the Display Tree. Ensure that all edges have turned green in-
dicating a valid association.

g. In the Display Tree, re-enable Curves, disable Show Curve Names, and disable Vertices.

3. Split the Initial Block using Prescribed Point method.

Blocking → Split Block  → Split Block 

a. Set display parameters.

i. Ensure Curves and Edges are enabled (default) in the display tree, showing the initial
block.

ii. Enable the display of Points and Show Point Names.

Geometry → Points

Geometry → Points → Show Point Names

The name of the Points will appear on the screen.

iii. Zoom in to the rear bumper.
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b. Change Split Method to Prescribed point in the Split Block DEZ.

This method is based on the location of a specific point and is more parametric than the default
(Screen select), which is based on a percentage of the edge length.

c. Split the block vertically.

Splits are propagated perpendicular to a selected edge. That is, select a horizontal edge to make
a vertical split, and vice versa.

i. Click  (Select edge(s)), and then select any horizontal edge (top or bottom edge).

ii. Click  (Select point(s)), and then select PNTS/10 at the rear of the car.

Note:

At any point in time while in selection mode, you can toggle to dynamic mode

by pressing F9 or clicking  (Toggle dynamics). This may be necessary in
order to zoom in to get a closer view of the points. Pressing F9 again will
toggle back to selection mode.

iii. Click Apply.

The new edge will be created as shown in Figure 23: First Split (p. 40).

Figure 23: First Split

iv. Similarly, make one more vertical split at the front of the car through point PNTS/1.

d. Also, make two horizontal splits at the bottom and top of the vehicle (PNTS/12 and PNTS/5)
as in shown in Figure 24: First Block Splits at Car Extents (p. 41).
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Figure 24: First Block Splits at Car Extents

4. Split selected blocks using Index control.

By default, splits propagate only through the displayed blocks. By blanking blocks using Index control
values, the propagation of visible splits can be managed.

a. Select Index Control.

Blocking → Index Control

Note:

• This Index Control panel has two columns, Min and Max. All block edges and
vertices are assigned index values, I, J, and K. For example, the first edge perpen-
dicular to the x-axis of the global coordinate system has an index of I = 1, while
the first edge perpendicular to the y-axis has an index of J=1. For 2D cases, such
as this, the K index is undefined.

• To change the range, toggle the arrows or enter an integer value in the appro-
priate field. Only the blocks within this range are displayed.

• Click Reset to select all of the block indices.
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b. Change the Index range to I: 2-3 and J: 1-3 to display only the blocks containing the vehicle
and those underneath the vehicle.

Note:

As stated, this manages the visible propagation of splits. Implied splits are still
propagated behind the scenes in order to maintain structured block continuity.
You can expose these implied splits using Extend Splits.

c. Select any horizontal edge and create a vertical split through PNTS/7.

d. Similarly, create a vertical split through PNTS/4.

e. Select any vertical edge and create a horizontal split through PNTS/1.

f. Similarly, create a horizontal split through PNTS/4.

g. Change the Index range to I: 2-5 and J: 3-4.

Figure 25: Additional Vertical and Horizontal Splits

h. Create two more vertical splits through points PNTS/8 and PNTS/2.

i. Click Reset in the Index Control panel.

j. Disable the display of Points. See Figure 26: Fully Split (p. 43)
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Figure 26: Fully Split

5. Delete unnecessary blocks.

Blocking → Delete Block 

Currently, all of the blocks are in the FLUID volume part. For flow analysis, only the blocks outside of
the car should be retained. Therefore, blocks representing the interior of the car are reassigned to a
different volume part.

a. Enable the display of Blocks.

Blocking → Blocks.

This will show the blocks by their numbers.

b. Click  (Select block(s)) and then select the block to be deleted as shown in Figure 27: Blocks
to Delete (p. 43). The blocks selected for deletion are 17, 28, 26, 36, 30, 31, and 33. Your block
numbers may differ.

Figure 27: Blocks to Delete
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c. Click the middle-mouse button or Apply in the Delete Block DEZ to accept your selection.

d. Ensure that Delete permanently is disabled (default), and then click Apply.

The parts are not deleted permanently, but are put into the VORFN part – a holding place for
dormant parts. This helps maintain connectivity and allows easy retrieval if necessary.

Note:

In a different situation where a solid mesh is needed, for example Conjugate Heat
Transfer (CHT), a new part (SOLID) would be created and then these blocks would
be assigned to the new part.

e. Save the blocking.

File → Blocking → Save Blocking As

Provide a filename, for example, 2DCar_base_geometry.blk so that the file can be reloaded
at a later time, using File → Blocking → Open Blocking.

6. Manage the Replay control recording.

Bring the Replay control window to the foreground to see the recording of commands.

• You can manually insert or delete commands directly from the Replay control window, (or click
Edit to open the complete list in your default text editor, such as Notepad).

Remove the command used to save your blocking file. (Highlight the command, and then
click Delete One.) This is the one that starts with ic_hex_save_blocking.

• The Undo groupings are added by Ansys ICEM CFD to assist in replay control. While they may
be removed by clicking the Clean button, this is suggested ONLY if you have stepped through
your work flow without any need to Undo any command. You should also click Renumber if
you use Clean.

• The blocking lines are those start with ic_hex_. For example, if you scroll through the window,
you should see ic_hex_set_edge_projection 11 13 0 1 INLET/1, the command
that created the association of edge 11–13 to curve INLET/1.

Before proceeding with this tutorial, be sure the last line in the Replay Control window is
highlighted and Record (after current) is enabled.

Step 2: Associate and Fit the Blocking to the Geometry

To ensure proper projection of the blocking edges onto the geometry, project block vertices to the prescribed
points and block edges to the curves.

1. Enable the display of Points and Vertices.
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Geometry → Points

Blocking → Vertices

Ensure vertex numbers and point names are enabled (displayed).

2. Associate the Vertices to the Points.

Blocking → Associate  → Associate Vertex 

a. Ensure that the selected Entity is Point in the Blocking Associations DEZ.

b. Click  (Select Vert(s)), and then select vertex 55 (at the rear of the roof line).

You may have different vertex numbers depending on the order in which the splits were applied.
The important goal is to make the blocking more closely follow the shape of the geometry.

Note:

In the Display Tree, you may temporarily disable the display of Points while select-
ing a Vertex. Be sure to re-enable before selecting a Point. Similarly, disable and
re-enable Vertices while selecting Points.

c. Click  (Select Point(s)), and then select the nearest corner point (PNTS/6) to that vertex.

d. Click Apply.

The vertex will immediately move to the selected point.

e. Similarly, associate the following Vertices to the Points. See Figure 28: Vertex Associations (p. 45).

Figure 28: Vertex Associations

PointVertex Associated

PNTS/776

PNTS/884

PNTS/983

PNTS/1143
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PNTS/1254

PNTS/1442

PNTS/291

PNTS/392

PNTS/561

Make sure you associate the vertices that appear right on top of their respective points (69 >
PNTS/10, 60 > PNTS/13, 66 > PNTS/1, and 75 > PNTS/4). The vertices will turn red indicating
they are fixed to the prescribed point.

The blocks should now better represent the geometry of the car.

Figure 29: Blocks Fit to Car (p. 46) shows the blocking.

Figure 29: Blocks Fit to Car

3. Disable the display of Points and Internal Edges.

Geometry → Points

Blocking → Edges → Internal Edges

4. Associate the edges to the curves.

Blocking → Associate  → Associate Edge to Curve 

a. Click  (Select Edge(s)), and then select all the edges that lie on the car body by dragging
a selection box with the left-mouse button.

b. Click middle-mouse button to accept the selection of edges.

c. Click  (Select compcurve(s)), and then select all curves making up the car body individually
or by dragging a selection box.

d. Click middle-mouse button to accept the selection of curves.

e. Click Apply.
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5. Enable the display of the Internal Edges.

Blocking → Edges → Internal Edges

6. Disable the display of Curves to confirm that all the edges around the car body are associated and
colored green.

Geometry → Curves

7. Verify that the correct associations have been set.

Blocking → Edges → Show Association

This display option adds arrows to the middle of each edge (or each vertex) pointing to the geometry
entity (if any) that the edge (vertex) is associated with. If the edge (vertex) is already directly on top of
the geometry, then the arrow is not visible.

8. Enable the display of Curves.

The association of edges to curves on the front bumper will resemble Figure 30: Edge to Curve Association
at Front Bumper (p. 47).

Figure 30: Edge to Curve Association at Front Bumper
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Step 3: Align the Vertices

In this step, you will line up vertices on the Cartesian coordinate system to help improve mesh quality.

Note:

Similar to the Split Blocks command, Align Vertices acts only upon the displayed blocks.
Therefore, it is important to use the Index Control to isolate those blocks.

1. Isolate the blocks using index control.

The index control panel is at the bottom right hand corner.

a. Click Select corners.

b. Select the two diagonally opposite vertices (corners) below the car, as shown in Figure 31: Select
Vertices for Index Control (p. 48).

Note:

This changes the index control values.

Figure 31: Select Vertices for Index Control

2. Display the corner Indices for the Vertices.

Blocking → Vertices → Indices

3. Select Align Vertices.

Blocking → Move Vertex  → Align Vertices 
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a. Click  (Select edge(s)), and then select one vertical (J) edge to define the index align direc-
tion. See Figure 32: Edge and Vertex Selection (p. 49)

The program assumes the alignment to be in the Y-direction (vertical) of the active coordinate
system, so only the X and Z (in this case Z is undefined) coordinates will be adjusted.

b. Click  (Select vert(s)), and then select any of the top four vertices (for example, 5 2 1) as
shown.

All vertices with J=2 will be fixed and all other visible vertices will be moved into alignment. Observe
that XZ under Move in plane is automatically toggled on.

Figure 32: Edge and Vertex Selection

c. Click Apply.

The bottom vertices are adjusted to line up with those at the top. See Figure 33: Aligned Bottom Ver-
tices (p. 49).

Figure 33: Aligned Bottom Vertices

4. Click Reset in the Index control panel to display all blocks.

5. In the Display Tree, enable the display of Numbers for the Vertices.

Blocking → Vertices → Numbers

6. Set the location for a moved vertex.

Blocking → Move Vertex  → Set Location 

Vertex positions can also be adjusted by setting coordinates. In this case, the new coordinates will be
extracted from a reference vertex..

a. For Ref. Vertex, click  (Select vert(s)), and then select Vertex 92, near the front bumper.

Your vertex number may be different depending on the order in which the splits were applied.
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b. Enable Modify Y only.

c. For Vertices to Set, click  (Select vert(s)), and then select Vertex 74. Click the middle mouse
button to accept.

d. Click Apply.

The second vertex will be moved vertically to line up with the reference vertex as shown in Fig-
ure 34: Aligned Left Vertices (p. 50).

Figure 34: Aligned Left Vertices

Step 4: Set Mesh Parameters and Generate the Initial Mesh

1. Apply Mesh Parameters

Mesh → Curve Mesh Setup  → Select curve(s) 

a. Click  (Select items in a part) in the Select Geometry toolbar that appears. You can also
type Shift P.

The Select part dialog box will open.

Figure 35: Select Part Dialog box

b. Set the curve mesh size for CAR.
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i. Enable CAR and click Accept.

ii. Set Maximum size to 25 in the Curve Mesh Setup DEZ.

iii. Click Apply.

c. Set the curve mesh size for the wind tunnel parts.

i. In the Select part dialog box, Enable GROUND, INLET, OUTLET, and TOP. Disable CAR and
click Accept.

ii. Set Maximum size to 500 in the Curve Mesh Setup DEZ

iii. Click Apply.

2. Update the Mesh Parameters

Blocking → Pre Mesh Params  → Update Sizes 

a. Check that Method is Update All.

b. Click Apply.

This will automatically determine the number of nodes on the edges from the mesh sizes set on
the curves.

3. Enable Pre-mesh. Allow recompute when prompted.

Blocking → Pre-Mesh

Figure 36: Cartesian Grid before Edge Parameters

This creates a body-fitted blocking that is aligned with indices I and J. This is known as a Cartesian or
H-Grid type of blocking.
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4. Set Edge Parameters

Blocking → Pre Mesh Params  → Edge Params 

a. In the Display Tree, Disable Pre-Mesh and Enable Vertices by Number.

b. Click  (Select edge(s)), and then select edge 11-37 (along the GROUND part, in front of the
CAR).

c. Set the number of Nodes to 50.

d. Click Apply.

e. Click  (Select edge(s)), and then select edge 48-38 (vertical edge above the front of the
car).

f. Set the number of Nodes to 50.

g. Enter 1.2 for Ratio1 and Ratio2.

h. Click Apply.

i. Click  (Select edge(s)), and then select edge 49-50 (horizontal edge behind the car, at roof
level).

j. Set the number of Nodes to 75, and enter 1.2 for Ratio1 and Ratio2.

k. Click Apply.

l. Enable Pre-Mesh in the Display Tree and recompute. See Figure 37: Cartesian grid after Edge
Parameters (p. 52).

Figure 37: Cartesian grid after Edge Parameters

Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.52

Hexa Mesh Generation for a 2D Car



Step 5: Create an Ogrid

In this step, you will create an Ogrid, where the mesh radially propagates from the surface of the car towards
the outer domain. This will result in an orthogonal mesh to better capture near-wall or boundary layer flow.

1. Disable Pre-Mesh.

2. Enable the VORFN part to enable you to select the interior blocks.

Parts → VORFN

3. Create an Ogrid around the car.

Blocking → Split Block  → Ogrid Block 

a. Click (Select block(s)).

b. Select the blocks inside the car and below the car as shown in Figure 38: Blocks for Ogrid (p. 53).

Figure 38: Blocks for Ogrid

c. Press the middle-mouse button to accept the blocks.

d. Click  (Select edge(s)).

e. Select the edges along the ground under the car.

f. Press the middle-mouse button. See Figure 39: Blocks and Edges for Ogrid (p. 54).
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Figure 39: Blocks and Edges for Ogrid

g. Enable Around block(s).

h. Ensure that Offset is set to 1 and click Apply.

i. Disable VORFN in the Display Tree.

Figure 40: External Ogrid around the Car (p. 54) shows the Ogrid passing through the floor.

Figure 40: External Ogrid around the Car
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Step 6: Refine the Mesh using Edge Parameters

In this step, you will manually improve the mesh quality by adjusting the node distribution along critical
edges.

1. Set the edge meshing parameters.

Blocking → Pre Mesh Params  → Edge Params 

a. Select one of the radial edges of the Ogrid as shown in Figure 41: Edges for setting Edge
Parameters (p. 55).

Figure 41: Edges for setting Edge Parameters

b. Increase Nodes to 7 in the Pre-Mesh Params DEZ.

c. Select Geometric2 from the Mesh law drop-down list.

d. Enter 1 for Spacing 2.

e. Enter 1.5 for Ratio 2.

This will bunch the elements close to the car.

f. Enable Copy Parameters and ensure Method is set to To All Parallel Edges (default).
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g. Click Apply.

This node distribution will be applied throughout the Ogrid.

h. Click  (Select edge(s)) and select one of the vertical edges between the car and the ground.

i. Increase Nodes to 15.

j. Retain the other default settings.

k. Click Apply.

2. Enable Pre-Mesh and recompute. See Figure 42: Refined Ogrid Mesh (p. 56).

Figure 42: Refined Ogrid Mesh

Next, to avoid large area differences between adjacent cells, you will match node distributions along
adjoining edges.

3. Disable Pre-Mesh.
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4. Set the Index Control values to I: 0-9 and J: 0-5.

5. Match the edge spacing of a Reference Edge to a connecting Target Edge.

Blocking → Pre Mesh Params  → Match Edges 

a. Enable Link spacing.

b. Select the Reference Edge as shown in Figure 43: Edges for Matching Parameters (p. 57).

Figure 43: Edges for Matching Parameters

c. Select the Target Edge as shown, and then click the middle-mouse button to accept.

d. Click Apply to set the edge parameters for the target edge.

Spacing 2 on the Target Edge is now linked to the end spacing of the reference edge (linked 98
42). Changes to the reference edge distribution will automatically affect the edge distribution for
this target edge.

6. Copy the Edge Spacing to Parallel edges.

Blocking → Pre Mesh Params  → Edge Params 

a. Select the earlier Target edge.

b. Ensure that Copy Parameters is enabled.

c. Select To Visible Parallel Edges from the Method drop-down list.

57
Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Step 6: Refine the Mesh using Edge Parameters



Copy distribution To All Parallel Edges could include adjusting the distribution at the ceiling of the
tunnel. As the index control is set to specific value, you can limit the copy To Visible Parallel Edges
so that only the edges near the car are affected and not the ceiling of the tunnel which is not visible.

d. Click Apply.

7. Repeat the Match Edges and Copy Parameters steps for the edge behind the car.

8. Enable Pre-Mesh and recompute the mesh.

See Figure 44: Full Mesh prior to Smoothing (p. 58).

Figure 44: Full Mesh prior to Smoothing

9. Smooth the Mesh

Blocking → Pre Mesh Smooth 

a. From the Method drop-down list, choose Orthogonality.

b. Accept all other defaults.

c. Click Apply.
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Figure 45: Final Mesh on Base Geometry

Note:

For simplicity, not all possible edge parameter refinement was done in this tutorial. For
completeness, you may wish to set and match edge parameters above the car geometry
before smoothing.

Step 7: Save the Replay File and Use it for Design Iteration

The replay file can contain all steps for outputting the mesh and can be used in batch mode from the com-
mand line using icemcfd-batch-script replay-file.rpl. In this tutorial, you will use the Replay file interactively.

1. Bring the Replay control window to the foreground.

2. Right-click the Replay control window (near the text) and select Edit filter.

This shows the list of those commands that can be cleaned.

Note:

The replay file can contain all steps taken during the entire session, some of which may
be redundant or needed only during recording. For example, commands beginning with
ic_undo are added by ICEM CFD while recording, but do not contribute directly to
the mesh creation process. However, they may be important in using the replay file if
you had to backtrack during your session.

You may use the Clean → Renumber sequence to remove extraneous commands and
then number the commands properly, but this is recommended only if you are certain
that it will not cause replay problems. Typically, it is safer to save the longer replay file.

3. Right-click again to go back to the replay script.

4. Disable Record (after current).
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Step 7: Save the Replay File and Use it for Design Iteration



5. Click Save and enter an appropriate filename. For example, 2DCar_Hexa_Ogrid_replay.rpl

Note:

• The replay file may be used to build the block topology on a similar geometry, or
design iteration. Instead of manually repeating the sequence of commands, run the
replay file.

• Ansys Workbench users: All files associated with your project are saved together in
a folder with the same name as your Workbench project file.

6. Open the modified geometry, car_mod.tin.

a. Ansys ICEM CFD users:

i. Initiate a new Ansys ICEM CFD session.

ii. File → Geometry → Open Geometry.

b. Ansys Workbench users:

i. Close the Mesh, Blocking, and Geometry.

File → Mesh → Close Mesh

File → Blocking → Close Blocking

File → Geometry → Close Geometry

ii. Open the modified geometry.

File → Geometry → Open Geometry

Note:

Ansys Workbench users:

• All files associated with your project are saved together in a folder with the same
name as your Workbench project. By closing the Mesh, Blocking and Geometry
without exiting the ICEM CFD environment, you will more easily locate and use
the replay file. However, by opening a new Geometry, the Blocking and Mesh
files will be recreated, overwriting the previous ones.

• Alternatively, to preserve the base Geometry, Blocking and Mesh within your
project, you may create a second ICEM CFD component in your Workbench Project
schematic and then open the modified geometry there. Since the replay script
is associated with the first ICEM CFD component, you will need to navigate your
OS folder hierarchy to find it.
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In car_mod.tin, the trunk or deck-lid is extended rearward, the rear windshield (backlight) angle is
changed and the windshield is moved slightly rearward.

Figure 46: Modified Geometry

7. Load the replay file that was saved earlier.

File → Replay Scripts → Load script file

Note:

Ansys Workbench users: All files associated with your project are saved together in a
folder with the same name as your Workbench project file. If you initiated a second
ICEM CFD component in your Workbench project, you will have to manually search for
your replay file.

8. In the Replay control window, click to highlight the command on line number. 1.

9. Click Do all.

If the Always update option is enabled, you can see each step. Disabling that option will be faster
(without display delays). This is the real power of replay.

Note:

The blocking file is parametric and you can load the saved blocking file from the other
configuration and update it to get a similar result.

10. Enable Pre-Mesh and recompute.

This mesh will be generated using exactly the same parameters as earlier, so the differences in solutions
may be attributed to the changes in the geometry, rather than to any dissimilarity in the grids.
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Step 7: Save the Replay File and Use it for Design Iteration



Figure 47: Final Mesh on Modified Geometry

11. Save the project file. Use a suitable name, for example 2D_Car-Mod.

File → Save Project As

Step 8: Create Output Data for a Solver

1. Save the unstructured mesh.

Blocking → Pre-Mesh → Convert to Unstruct Mesh

2. Export the mesh to the solver.

Output Mesh → Select solver 

3. Select Ansys Fluent from the Output Solver drop-down list.

4. Click Apply.

5. Set the boundary conditions.

Output Mesh → Boundary conditions 

a. Expand Edges.

b. Expand INLET.

c. Select Create New, and then select velocity-inlet from the dialog box.

d. Click Okay.

e. Similarly select pressure-outlet, exhaust-fan, outlet-vent as a boundary condition for OUTLET.

f. Also, select wall as the boundary condition for TOP and GROUND.

g. Click Accept to set the boundary conditions.
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6. Write the input file for Ansys Fluent.

Output Mesh → Write input 

The Open dialog box appears.

a. Choose the UNS file created earlier, for example 2D_Car_mod.

b. Click Open to open your UNS file.

The Ansys Fluent window will appear.

c. Select 2D for Grid dimension.

d. Enter an appropriate name for the Output file, for example 2D_Car_mod.

e. Click Done.

You can use this MESH file in Ansys Fluent to set up and solve.
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Step 8: Create Output Data for a Solver
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Hexa Mesh Generation for a 3D Pipe Junction
In this tutorial, you will generate a mesh for a three-dimensional pipe junction. After checking the
quality of the initial mesh, you will create an Ogrid in the blocking to improve mesh quality.

Figure 48: 3D Pipe Geometry

This tutorial demonstrates how to do the following:

• Create parts and a material point for the geometry.

• Block the geometry.

• Fit the Blocking to the Geometry.

• Generate the initial mesh.

• Check the mesh quality.

• Create an Ogrid in the blocking.

• Verify and save the mesh.

Starting the Project

Step 1: Preparing the Geometry

Step 2: Creating the Initial Blocking
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Step 3: Fitting the Blocking to the Geometry

Step 4: Generating the Initial Mesh

Step 5: Checking the Mesh Quality

Step 6: Creating an Ogrid in the Blocking

Step 7: Verifying and Saving the Mesh

Starting the Project

1. Set up a working directory on your computer.

2. Download the 3dpipe_junct.zip file here.

3. Unzip the 3dpipe_junct.zip file you have downloaded to your working directory.

4. Start Ansys ICEM CFD and create a new project in your working directory. Use an appropriate name,
for example Hexa3D_Pipe.

File → New Project

5. Open the geometry file (geometry.tin).

File → Geometry → Open Geometry...

Note:

If you want Ansys ICEM CFD to behave exactly as this tutorial describes, you should go to
the Settings Menu, click Selection, and disable Auto Pick Mode in the DEZ. Most experienced
ICEM CFD users prefer to enable Auto Pick Mode as it improves efficiency. See Selection in
the ICEM CFD Help Manual → Main Menu Area → Settings Menu for more detail.

Step 1: Preparing the Geometry

The geometry used in this tutorial is contained in a single part. You will separate the geometry into different
parts to define different boundary regions, and then create an interior material point.

1. Enable Surfaces under Geometry in the display control tree.

2. Create a new part for the largest semi-cylinder.

Parts → Create Part
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a. Enter CYL1 for Part in the Create Part DEZ.

b. Retain the selection of  (Create Part by Selection) and click  (Select entities).

The Select geometry toolbar will appear.

c. Disable Toggle selection of points ( ), Toggle selection of curves ( ), and Toggle se-

lection of bodies (  ) to avoid the selection of entities other than surfaces.

d. Ensure that Toggle selection of surfaces is enabled ( ).

Note:

Entity types can also be deactivated by disabling them in the display control tree.

e. Select the largest semi-cylinder and click the middle-mouse button to accept the selection.

f. Click Apply in the Create Part DEZ.

The new part CYL1 will be added to the display control tree.

3. Similarly, create new parts for the smaller semi-cylinder (CYL2), cylinder ends (INL and OUT), and
symmetry planes (SYM) as shown in Figure 49: 3D Pipe Geometry—Surface Parts (p. 68).
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Step 1: Preparing the Geometry



Figure 49: 3D Pipe Geometry—Surface Parts

Note:

When in continuation mode (with Auto Pick Mode enabled) after pressing the middle-
mouse button or Apply, you can type in a new Part name and continue to select the
surface(s) without re-invoking the function.

4. Create a new part comprising all the curves in the geometry.

a. Enter CURVES for Part in the Create Part DEZ.

b. Retain the selection of  (Create Part by Selection) and click  (Select entities).

c. Enable Toggle selection of curves ( ) in the Select geometry toolbar.

d. Disable Toggle selection of surfaces ( ) in the Select geometry toolbar.

e. Click (Select all appropriate objects) or type a to select all the curves.

You need not click the middle-mouse button when using the Select all appropriate objects or
the Select all appropriate visible objects option.

Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.68

Hexa Mesh Generation for a 3D Pipe Junction



f. Click Apply in the Create Part DEZ.

5. Create a new part comprising all the points in the geometry.

a. Enter POINTS for Part in the Create Part DEZ.

b. Retain the selection of  (Create Part by Selection) and click  (Select entities).

c. Enable Toggle selection of points ( ) in the Select geometry toolbar.

d. Disable Toggle selection of curves ( ) in the Select geometry toolbar.

e. Click  (Select all appropriate objects) or type a to select all the points.

f. Click Apply in the Create Part DEZ.

Note:

The selection logic is flexible and there are many ways to select entities. This step illus-
trated an example of selection logic.

6. Create a Material Point.

Geometry → Create Body  → Material Point 

a. Enter FLUID for Part.

b. Ensure that Points is enabled in the display control tree.

c. Click  (Select location(s)) and select two locations such that the midpoint lies within the
volume (Figure 50: Selection of Points for Creating Material Point (p. 70)). Click the middle-
mouse button to accept the selection of the points.
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Step 1: Preparing the Geometry



Figure 50: Selection of Points for Creating Material Point

d. Click Apply so that FLUID appears under Parts in the display control tree.

Rotate the model to confirm that the new material point is within the volume and does not just
appear so from one perspective.

Note:

Parts (such as GEOM) will be deleted when they no longer contain any entities.

7. Save the geometry file with a new filename, for example 3d-pipe-geometry.tin.

File → Geometry → Save Geometry As...

Step 2: Creating the Initial Blocking

The blocking strategy for the 3D pipe geometry involves creating two blocks from the initial block—one each
for each half cylinder, forming an L-shaped configuration. Later, you will create an Ogrid to improve the
mesh quality.

The blocking functionality in Ansys ICEM CFD provides a projection based mesh generation environment. All
block faces between different materials are projected to the closest CAD surfaces. Block faces within the same
material may also be associated to specific CAD surfaces to allow for the definition of internal walls. In
general, there is no need to perform any individual face associations to underlying CAD geometry which re-
duces the time for mesh generation.

1. Create an initial block.
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Blocking → Create Block  → nitialize Blocks 

a. Ensure that Part is set to the correct material (FLUID).

b. Retain the selection of 3D Bounding Box in the Type drop-down list.

You need not select entities when creating a bounding box around the entire geometry.

c. Click Apply.

2. Split the initial block into sub-blocks.

Blocking → Split Block  → Split Block 

a. Enable Curves and Surfaces.

Geometry → Curves

Geometry → Surfaces

b. Display the left view for better visualization

The L-shaped topology is best seen in a side view.

View → Left

You can also select the X-axis in the display triad in the lower right hand corner to reorient the
model as it appears in Figure 51: Geometry Showing Split Locations (p. 72).

c. Create a vertical split.
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Step 2: Creating the Initial Blocking



i. Click  (Select edge(s)) and select one of the horizontal edges.

ii. Position the new edge near the front end of the small cylinder (Figure 51: Geometry
Showing Split Locations (p. 72)) and click the middle-mouse button to accept the new
position.

d. Create a horizontal split.

i. Click  (Select edge(s)) and select one of the vertical edges.

ii. Position the new edge near the top of the large cylinder (Figure 51: Geometry Showing
Split Locations (p. 72)) and click the middle-mouse button to accept the new position.

Figure 51: Geometry Showing Split Locations (p. 72) shows the split block.

Figure 51: Geometry Showing Split Locations

3. Delete the unnecessary upper block.

Blocking → Delete Block 

a. Click  (Select block(s)) and select the block to be deleted as shown in Figure 52: Block to
be Deleted (p. 73).

b. Ensure that Delete permanently is disabled.

c. Click the middle-mouse button and then Apply in the Delete Block DEZ.
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Figure 52: Block to be Deleted

Step 3: Fitting the Blocking to the Geometry

Blocking → Associate  → Associate Edge to Curve 
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Step 3: Fitting the Blocking to the Geometry



1. Disable Surfaces.

Geometry → Surfaces

When associating edges to curves, you need to display only curves and edges. Hence, you can disable
unwanted entities to avoid confusion.

2. Associate the three edges at the top (A) with the three curves forming the small semicircle (A' ).
See Figure 53: Edges Associated to Curves (p. 75).
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Figure 53: Edges Associated to Curves

a. Click  (Select edge(s)) and select the edges denoted by A. Click the middle-mouse button
to accept the selection.

b. Click  (Select compcurve(s)) and select the curves denoted by A'. Click the middle-mouse
button to accept the selection.

When selecting multiple curves, the first curve selected determines the curve color of the final
grouped curve. To avoid confusion with green edges, experts try to avoid selecting the green curve
segments first.

c. Click Apply in the Associate Edge -> Curve DEZ.

3. Similarly, associate the three edges in the front of the large cylinder (B) with the three curves
forming the large semicircle (B').

4. Associate the three edges on the Y-plane near the cylinder intersections (C) with the semicircle
curve forming the intersection (C').

5. Associate the side rear edges of the large cylinder (D, E) to the curves forming the rear ends (D',
E’), respectively.

6. Verify that the correct associations have been set (Figure 54: Projection of Edges to the Associated
Curves (p. 76))

Blocking → Edges → Show association
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Step 3: Fitting the Blocking to the Geometry



The display of Surfaces has been enabled in Figure 54: Projection of Edges to the Associated
Curves (p. 76).

Figure 54: Projection of Edges to the Associated Curves

Disable Show association when you are satisfied.

7. Move all the vertices onto the geometry.

Blocking → Associate  → Snap Project Vertices 

Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.76

Hexa Mesh Generation for a 3D Pipe Junction



a. Retain the selection of All Visible for Vertex Select.

b. Click Apply.

8. Manually adjust the vertices at the INL and OUT parts.

Blocking → Move Vertex  → Move Vertex 

a. Click  (Select vert(s)) and select one of the vertices on the curved edge of the part OUT
(top of vertical, small cylinder).

b. Move the vertex along the associated curve such that the edges along the smaller cylinder
are nearly equidistant.

Drag the vertex along the curve, keeping the left-mouse button pressed.

c. Similarly, move the vertices at the junction of CYL1 and CYL2 to appropriate locations.

Also, move vertices on the curved INL geometry. See (Figure 55: Moved Vertices (p. 77)).

Figure 55: Moved Vertices

Note:

To optimize mesh quality, the vertices should be spaced to minimize the average
deviation of the edges from the curve. To achieve the most even distribution with
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Step 3: Fitting the Blocking to the Geometry



this half cylinder case, place the vertices approximately 60 degrees apart (180° half
circle/3 edges = 60° per edge).

9. Save the blocking (3D-pipe-geometry.blk).

File → Blocking → Save Blocking As...

The blocking file can be reloaded at a later time, using the File → Blocking → Open Blocking...
menu item.

Step 4: Generating the Initial Mesh

For this model, you will set the sizes on the parts, rather than on individual surfaces or curves.

1. Set the sizes on the parts to generate the mesh.

Mesh → Part Mesh Setup 

a. Click the max size header.

The MAX SIZE dialog box will open.

b. Enter 10 for max size and click Accept.

c. Decrease max size for CYL2 to 5.

d. Enter 1 for height for CYL1 and CYL2.

e. Enter 1.2 for height ratio for CYL1 and CYL2.

f. Click Apply and then Dismiss in the Part Mesh Setup dialog box.

2. View the sizes set.

Geometry → Surfaces → Hexa Sizes
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In Figure 56: Hexa Mesh Sizes (p. 79) the “quad” along the surface represents the max size, the
thickness represents the height, while the number is the height ratio.

Figure 56: Hexa Mesh Sizes

3. Update the mesh.

The hexa blocking file (.blk) is different from the Ansys ICEM CFD geometry file (.tin). You can set the
entity mesh parameters at any point before or after blocking. The Update Sizes command is a quick
and easy way to translate the entity parameters from the geometry to the blocking. Mesh counts are
propagated through a mapped mesh. Hence, the smallest size across any index is used.

Blocking → Pre-Mesh Params  → Update Sizes 
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Step 4: Generating the Initial Mesh



a. Retain the selection of Update All and select Run Check/Fix Blocks.

b. Click Apply.

c. Enable Pre-Mesh.

Blocking → Pre-Mesh

The Mesh dialog box will appear, asking if you want to recompute the mesh. Click Yes.

d. Disable Surfaces and Edges.

Geometry → Surfaces

Blocking → Edges

e. Select Solid & Wire.

Blocking → Pre-Mesh → Solid & Wire

The initial mesh is shown in Figure 57: Initial Mesh (p. 81).

Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.80

Hexa Mesh Generation for a 3D Pipe Junction



Figure 57: Initial Mesh

Step 5: Checking the Mesh Quality

The major quality criteria for a hexa mesh are angle, determinant, and warpage. Refer to the Help Manual
for details on the available quality measures.

Blocking → Pre-Mesh Quality Histograms 

1. Select Angle in the Criterion drop-down list.

2. Retain the default settings for Histogram Options and click Apply.
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Step 5: Checking the Mesh Quality



3. Select the worst two bars from the histogram.

The selected bars will be highlighted in pink (Figure 58: Histogram of Angle (p. 82)).

Figure 58: Histogram of Angle

4. Right-click in the histogram window and ensure that Show is enabled.

5. Disable Pre-Mesh.

Blocking → Pre-Mesh

The highlighted elements are shown (Figure 59: Elements with Worst Quality (p. 82)). Most of the bad
elements (with the worst angles) are on the block corners. This is due to the H-grid nature of the mesh
within a curved geometry.

Figure 59: Elements with Worst Quality

6. Right-click in the histogram window and select Done.
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Step 6: Creating an Ogrid in the Blocking

In this step, you will create an internal Ogrid to improve the angles in the block corners. This is the best
method for fixing bad angles in block corners within cylindrical geometry. Ansys ICEM CFD has a specific
Ogrid tool to make it easy to accomplish even on complicated geometry. Before proceeding to this step,
make sure that your surface vertices are aligned as you want them and internal edges are straight. The Ogrid
tool offsets the boundary faces orthogonally and you may end up with twice as many vertices. It is more
convenient to adjust your surface blocking to ideal locations before Ogrid rather than after.

1. Enable Surfaces.

Geometry → Surfaces

2. Create the Ogrid.

Blocking → Split Block  → Ogrid Block 

a. Click  (Select block(s)) and then  (Select all appropriate visible objects) from the se-
lection tool bar.

Alternatively, enter v for all visible blocks or drag a box to select all blocks.

Note:

The option a indicating all is not available for blocking to avoid selection of VORFN
blocks, which are not visible, but are still in the model.
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Step 6: Creating an Ogrid in the Blocking



b. Click  (Select face(s)) and select the faces representing the planar geometry (INL, SYM,
OUT). See Figure 60: Blocks and Faces Selected for Ogrid Creation (p. 84). Click the middle-
mouse button to accept the selection.

Figure 60: Blocks and Faces Selected for Ogrid Creation

You can also select the faces using any of the following:

• Select  (Toggle select diagonal corner vertices) in the Select blocking face toolbar
that appears or type Shift-D on the keyboard. This will allow you to select two diagonally
opposite corners that make up the face.

• Select  (Select items in a part) in the Select blocking face toolbar that appears or
type Shift-P on the keyboard. This will open the Select Blocking parts dialog box and
will allow you to select the faces.

c. Retain the default settings and click Apply in the Ogrid Block DEZ.

In Figure 61: Blocking with the Ogrid Structure (p. 85), the Ogrid passes through the selected
faces. The radial blocks are adjacent to the cylinder surfaces.
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Figure 61: Blocking with the Ogrid Structure

3. Modify the Ogrid.

Blocking → Edit Block  → Modify Ogrid 

a. Retain the selection of Rescale Ogrid in the Method drop-down list.
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Step 6: Creating an Ogrid in the Blocking



b. Retain the selection of All Visible for Block Select.

c. Click  (Select edge(s)) and select the radial edge shown in Figure 62: Edge Selected for
Modifying the Ogrid (p. 86).

Figure 62: Edge Selected for Modifying the Ogrid

d. Ensure that Absolute distance is disabled.

e. Enter 0.5 for Offset.

f. Click Apply in the Modify Ogrid DEZ.

4. Update the surface mesh sizes on the blocking.

Blocking → Pre-Mesh Params  → Update Sizes

a. Retain the selections of Update All and Run Check/Fix Blocks.

b. Click Apply in the Recalculate Sizes DEZ.

c. Enable Pre-Mesh.

Blocking → Pre-Mesh

d. Click Yes in the Mesh dialog box.

5. Refine the mesh using edge parameters.
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Blocking → Pre-Mesh Params  → Edge Params 

a. Disable Pre-Mesh.

Blocking → Pre-Mesh

b. Click  (Select edge(s)) and select one of the radial edges.

c. Increase Nodes to 7.
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Step 6: Creating an Ogrid in the Blocking



d. Enter 0.2 for Spacing 1.

e. Enable Copy Parameters and select To All Parallel Edges in the Method drop-down list.

f. Enable Copy absolute and click Apply in the Meshing Parameters DEZ.

g. Enable Pre-Mesh.

Blocking → Pre-Mesh

h. Click Yes in the Mesh dialog box.

i. Disable Curves and Surfaces under Geometry and Edges under Blocking in the display
control tree.

The final mesh is shown in Figure 63: The Final Mesh (p. 88).

Figure 63: The Final Mesh

Step 7: Verifying and Saving the Mesh

1. Check the mesh quality.

Blocking → Pre-Mesh Quality Histograms 

a. Select Angle in the Criterion drop-down list and click Apply.

You can see the improved mesh quality in the histogram (Figure 64: Histogram of Angle (p. 89)).
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Figure 64: Histogram of Angle

b. Select Determinant 2×2×2 in the Criterion drop-down list and click Apply.

2. Save the mesh in unstructured format.

Blocking → Pre-Mesh → Convert to Unstruct Mesh

This saves the .uns file as the mesh in the working directory and automatically loads it.

3. Save the project file (3D-pipe-geometry-final.prj).

File → Save Project As...

4. Exit the current session.

File → Exit
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Step 7: Verifying and Saving the Mesh
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Hexa Mesh Generation for a Sphere Cube Geometry
In this tutorial, you will employ an Ogrid to fit the topology of the region between a cube and a sphere.
The Ogrid forms a topological bridge between the dissimilar topologies and provides excellent element
quality.

Figure 65: Sphere Cube Geometry

This tutorial demonstrates how to do the following:

• Prepare the geometry.

• Create Initial Blocking.

• Associate the Blocking to the Geometry.

• Create the Ogrid.

• Fit the Ogrid using prescribed points.

• Generate the mesh.

• View scan planes.

• Verify and save the mesh.
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Starting the Project

Step 1: Preparing the Geometry

Step 2: Blocking the Geometry

Step 3: Fitting the Blocking to the Geometry

Step 4: Creating the Ogrid

Step 5: Generating the Mesh

Step 6: Viewing the Scan Planes

Step 7: Verifying and Saving the Mesh

Starting the Project

1. Set up a working directory on your computer.

2. Download the spherecube.zip file here.

3. Unzip the spherecube.zip file you have downloaded to your working directory.

4. Start Ansys ICEM CFD and create a new project in your working directory. Use an appropriate name,
for example Sphere_Cube.

File → New Project

5. Open the geometry file (geometry.tin).

File → Geometry → Open Geometry

Note:

If you want Ansys ICEM CFD to behave exactly as this tutorial describes, you should go to
the Settings Menu, click Selection, and disable Auto Pick Mode in the DEZ. Most experienced
ICEM CFD users prefer to enable Auto Pick Mode as it improves efficiency. See Selection in
the ICEM CFD Help Manual → Main Menu Area → Settings Menu for more detail.

Step 1: Preparing the Geometry

The geometry used in this tutorial will be separated into different parts to define different boundary regions,
and then checked to establish full connectivity. Finally a material point will be created.

1. In the display control tree under Geometry, enable Surfaces.

2. Create a new part for the symmetry surface.

Parts → Create Part

a. Enter SYMM for Part in the Create Part DEZ.

b. Retain the selection of  (Create Part by Selection) and click  (Select entities).
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The Select geometry toolbar will appear.

c. Disable Toggle selection of points ( ), Toggle selection of curves ( ), and Toggle se-

lection of bodies (  ) (material region definition) to avoid the selection of entities other
than surfaces.

d. Ensure that Toggle selection of surfaces is enabled ( ).

e. Select the four symmetry surfaces at the bottom of the geometry and click the middle-mouse
button to accept the selection.

f. Click Apply in the Create Part DEZ.

The new part SYMM will be added to the display control tree.

3. Similarly, create new parts for the sphere (SPHERE) and the cube (CUBE) as shown in Fig-
ure 66: Sphere Cube—Parts (p. 93).

Figure 66: Sphere Cube—Parts

4. Delete the curves.

Geometry → Delete Curves 

a. Click  (Select curve(s)) and then  (Select all appropriate objects) in the Select geometry
toolbar to select all the curves.
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b. Ensure that Delete Permanently is disabled.

Note:

When Delete Permanently is disabled, the deleted curves become dormant. In a
later step, when you use Build Topology, these original curves will be used as
opposed to surface-extracted curves.

c. Click Apply.

5. Delete the points.

Geometry → Delete Points 

a. Click  (Select point(s)) and then  (Select all appropriate objects) in the Select geometry
toolbar to select all the points.

b. Ensure that Delete Permanently is disabled.

c. Click Apply.

6. Use the Build Diagnostic Topology option to establish connectivity.

Note:

This will create the connectivity you will need later for grouping the tangential curves
(Figure 69: Grouped Tangential Curves (p. 100)).

Geometry → Repair Geometry  → Build DiagnosticTopology 
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a. Ensure that Inherit Part is enabled.

b. Enable Filter points and Filter curves.
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c. Retain the other settings and click Apply.

Note:

The build topology establishes connectivity and places the curves in an inherited
part name. This is not as critical here where only a few curves would need to be
placed into a part, but could be very useful in a really large model where interactively
selecting curves for parts could become tedious.

7. Create a Material Point

Geometry → Create Body  → Material Point 

a. Enter FLUID for Part.

b. Ensure that Points is enabled in the display control tree.

c. Click  (Select location(s)) and select two locations such that the midpoint lies within the
volume (Figure 67: Selection of Locations for Creating Material Point (p. 96)). Click the middle-
mouse button to accept the selection of the locations.

Figure 67: Selection of Locations for Creating Material Point

d. Click Apply so that FLUID appears under Parts in the display control tree.
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Rotate the model to confirm that the new material point is within the volume and does not just
appear so from one perspective.

Note:

The use of a material point is not required. However, creating one will fix the volume
part name within the tetin file. This will avoid any problems caused by the volume
name in the block file not being recognized by the tetin (geometry) file in future
sessions.

8. Save the geometry file (sphere-cube-new.tin).

File → Geometry → Save Geometry As...

Step 2: Blocking the Geometry

The blocking strategy for the sphere cube geometry involves creating an Ogrid around the cube and then
fitting the inside of the Ogrid to the cube using the prescribed points of the model.

In this step, you will create the initial block.

Blocking → Create Block  → Initialize Blocks 

1. Ensure that Part is set to the correct material (FLUID).

2. Retain the selection of 3D Bounding Box in the Type drop-down list.

You need not select entities when creating a bounding box around the entire geometry.

3. Click Apply (Figure 68: Initial Blocking (p. 98)).
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Figure 68: Initial Blocking

Step 3: Fitting the Blocking to the Geometry

The block vertices and edges need to be fit to geometry points and curves.

1. Create a Composite Curve

Even though curves can be automatically grouped while associating edges to curves, sometimes it be-
neficial to group them first. One such benefit is the ability to group all curves that tangentially meet
(smooth transition at the ends of two adjacent curves).

In this step, you will group the tangential curves around the base of the hemisphere.

Blocking → Associate  → Group Curve 

Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.98

Hexa Mesh Generation for a Sphere Cube Geometry



a. Retain the selection of Group Curves.

b. Select All tangential for Group.

c. Click Apply in the Group/Ungroup curves DEZ.

Note:

This feature needs geometry connectivity. If you had not run build topology, the
software will prompt you to do so now.

All four base curves forming the circular perimeter of the hemisphere will be grouped as shown
in Figure 69: Grouped Tangential Curves (p. 100).
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Figure 69: Grouped Tangential Curves

2. Project Edges to Curves

Blocking → Associate  → Associate Edge to Curve 

a. Click  (Select edge(s)) and select the four bottom edges using the left-mouse button. Click
the middle-mouse button to accept the selection.

b. Click  (Select compcurve(s)) and select the grouped circular curve using the left-mouse
button. Click the middle-mouse button to accept the selection.

c. Click Apply in the Associate Edge -> Curve DEZ.

The selected edges will turn green.

3. Verify that the correct associations have been set as shown in Figure 70: Projection of Edges to the
Associated Curves (p. 101).

a. Enable Vertices and display by Numbers, in the display control tree.

Blocking → Vertices

Blocking → Vertices → Numbers

b. Enable the display of Surfaces and select the Solid display.
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Geometry → Surfaces

Geometry → Surfaces → Solid

c. Select Show association.

Blocking → Edges → Show association

Figure 70: Projection of Edges to the Associated Curves

d. Disable Show association before proceeding.

e. Disable Surfaces before proceeding.

 Geometry → Surfaces

4. Move the vertices to the curves and surfaces.

Blocking → Associate  → Snap Project Vertices 

a. Retain the selection of All Visible for Vertex Select.

b. Click Apply (Figure 71: Vertices Moved to Geometry (p. 102)).
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Figure 71: Vertices Moved to Geometry

Step 4: Creating the Ogrid

In this step, you will create an Ogrid to capture the cube as well as radially propagate the mesh onto the
sphere.

1. Create the half Ogrid.

Blocking → Split Block  → Ogrid Block 

a. Click  (Select face(s)) and select the bottom face of the block. Click the middle-mouse
button to accept the selection.
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Figure 72: Blocks and Faces Selected for Ogrid Creation

The block will also be selected. When you select the face, both blocks on either side get selected.
The VORFN block beneath the face is not active, so a flat icon is shown instead of the block under-
neath.

b. Click Apply in the Ogrid Block DEZ (Figure 73: Ogrid Created (p. 103)).

Figure 73: Ogrid Created

2. Fit the Ogrid using prescribed points.

You will use the central block of the Ogrid to represent the cube.

a. Enable Points and Vertices.

Geometry → Points
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Blocking → Vertices

b. Associate the vertices to the points.

Blocking → Associate  → Associate Vertex 

i. Ensure that Point is selected for Entity in the Blocking Associations DEZ.

ii. Click  (Select vert(s)) and select a corner vertex of the central block.

iii. Click  (Select point(s)) and select the corner point closest to the selected vertex on
the cube geometry.

iv. Click Apply.

The vertex will immediately snap to the selected point and the point will turn red. Red means
a fixed vertex which can not be moved unless the association is changed.

v. Similarly, capture the seven remaining corner vertices making the block fit the cube (see
Figure 74: Inner Block Fit to the Cube (p. 105)).

3. Associate the edges of the central block to the underlying curves of the cube geometry.

Note:

Without this step, the sharp feature nodes will be simply surface projected. This will
cause problems for the smoother and may also cause boundary condition issues with
some solvers.

Blocking → Associate  → Associate Edge to Curve 

a. Click  (Select edge(s)) and select an edge of the central block. Click the middle-mouse
button to accept the selection.

b. Click  (Select compcurve(s)) and select the underlying curve on the cube geometry. Click
the middle-mouse button to accept the selection.

c. Click Apply.

d. Similarly, associate the remaining edges to the curves of the cube (Figure 74: Inner Block Fit
to the Cube (p. 105)).

Figure 74: Inner Block Fit to the Cube (p. 105) shows the inner Ogrid block fit to the cube geometry.
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Figure 74: Inner Block Fit to the Cube

4. Delete the unnecessary central block.

You can remove the central block because the mesh will only be generated in the volume between the
SPHERE and CUBE. Very often, when multiple blocks are displayed, it is difficult to select the icon repres-
enting the block(s). An alternative method is to select the block by selecting a pair of diagonally opposing
corners.

Blocking → Delete Block 

The Select Blocking-block toolbar will appear.

a. Select  (Toggle select diagonal corner vertices) In the Select Blocking-block toolbar.

Alternatively, you can type Shift-D on the keyboard.

b. Select the two corner vertices as shown in Figure 75: Deleting the Block (p. 106) and click the
middle-mouse button to accept the selection.
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Figure 75: Deleting the Block

Note:

You can also simply select the central block from the screen. This option is used
here mainly for demonstration purposes as it may be useful in situations where
many blocks exist and individual selection could be difficult.

c. Ensure that Delete permanently is disabled.

d. Click Apply to delete the block.

Step 5: Generating the Mesh

1. Disable the display of blocking edges and vertices.

Blocking → Edges

Blocking → Vertices

2. Enable the display of surfaces and select Wire Frame display.

Geometry → Surfaces

Geometry → Surfaces → Wire Frame

3. Set the part parameters.

Mesh → Part Mesh Setup 

Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.106

Hexa Mesh Generation for a Sphere Cube Geometry



a. Under Maximum size:

i. Enter 0.5 for CUBE

ii. Enter 1 for both SPHERE and SYMM.

b. Under Height:

i. Enter 0.01 for CUBE.

ii. Enter 0.02 for SPHERE.

c. Under Height ratio, enter 1.2 for both CUBE and SPHERE.

d. Click Apply and then Dismiss in the Part Mesh Setup dialog box.

4. View the sizes set (Figure 76: Hexa Mesh Sizes (p. 108)).

Geometry → Surfaces → Hexa Sizes
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Figure 76: Hexa Mesh Sizes

5. Update the mesh.

Blocking → Pre-Mesh Params  → Update Sizes 

a. Retain the selection of Update All in the Method list.

b. Click Apply.

c. Enable Pre-Mesh.

Blocking → Pre-Mesh

The Mesh dialog box will appear, asking if you want to recompute the mesh. Click Yes.

d. Disable Edges under Blocking, Surfaces and other entity types under Geometry in the display
control tree.

Blocking → Edges

Geometry → Surfaces

e. Select Solid & Wire for the Pre-Mesh display.

Blocking → Pre-Mesh → Solid & Wire

The initial mesh is shown in Figure 77: Initial Mesh (p. 109).
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Figure 77: Initial Mesh

Step 6: Viewing the Scan Planes

Viewing the volume mesh can provide another good visual diagnostic. Within blocking, this is done by means
of a scan plane, where an I, J, K or radial Ogrid index plane is scrolled through the volume.

1. Display the Edges and Curves

Blocking → Edges

Geometry → Curves

2. Disable Pre-Mesh.

Blocking → Pre-Mesh

3. Select Scan Planes.

Blocking → Pre-Mesh → Scan planes

The scan plane control window appears in the lower right hand corner of the screen. The scan plane is
not planar. For instance, enabling # 0 displays all the nodes of constant I index, not constant X-coordin-
ates. You need to click the up/down arrows for either Block Index or Grid Index to move the scan plane.
Block Index increments one block at a time whereas Grid Index increments one node at a time.
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a. Enable On for the index plane, # 0.

# 0, # 1, # 2 represent I, J, K respectively. # 3 represents the radial (Ogrid) direction. In this
model, I, J, K is more or less lined up with the global X, Y, Z coordinates respectively.

b. Increase the Grid Index for the # 0 index plane until the scan plane appears about half way
through the model.

Note:

When you increase the Grid Index, two planes will be visible at the same time.
Along the radial (Ogrid) block, I is equal to 1 throughout the entire block.

c. Click Select in the scan plane control window.

d. Select one of the edges parallel to the current scan plane (an edge lined up along Y). See
Figure 78: Scan Planes for the Mesh (p. 111).
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Figure 78: Scan Planes for the Mesh

Note:

The Select option enables the index plane perpendicular to any selected edge. In
this case, the edge selected is a J edge and the resulting scan plane will be perpen-
dicular to that edge and will display constant J nodes. The index plane # 1 is
automatically enabled in the scan plane control window.

e. Continue to select and switch back and forth through the other planes as well.

f. Click Done to exit the scan plane control window.

Step 7: Verifying and Saving the Mesh

1. Check the mesh quality.

Blocking → Pre-Mesh Quality Histograms 

If you are satisfied with the mesh quality, convert the existing mesh to an unstructured mesh.

2. Save the mesh in unstructured format.

Blocking → Pre-Mesh → Convert to Unstruct Mesh

This saves the .uns file as the mesh in the working directory and automatically loads it.

3. Save the blocking file (sphere-cube-final.blk).
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File → Blocking → Save Blocking As...

4. Save the project file (sphere—cube-final.prj).

File → Save Project As...

5. Exit the current session.

File → Exit
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Hexa Mesh Generation for a Pipe with Embedded
Blade
In this tutorial, you will use the Collapse function to create a degenerate topology in a Conjugate Heat
transfer problem around a blade located in the center of a cylindrical pipe. The Pipe-Blade geometry
is shown.

Figure 79: Pipe-Blade Geometry

This tutorial demonstrates how to do the following:

• Starting the Project

• Creating Parts in the Mesh Editor

• Starting Blocking and Fitting it to the Geometry

• Splitting and Collapsing Blocks around the Blade Material

• Fitting the blocking to the Blade geometry

• Generating the Ogrid

• Defining and Refining the Mesh using Surface Parameters and Edge Parameters

• Checking mesh quality for determinants and angle

• Saving before Quitting
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Starting the Project

Step 1: Creating Parts in the Mesh Editor

Step 2: Initial Blocking and Associations

Step 3: Splitting and Collapsing Blocks around the Blade

Step 4: Fit the Blocking to the Blade geometry

Step 5: Generating the Ogrid

Step 6: Defining the Mesh using Surface Parameters

Step 7: Refining the Mesh using Edge Parameters

Step 8: Checking and Improving Mesh Quality

Step 9: Saving your Work

Starting the Project

1. Set up a working directory on your computer.

2. Download the pipeblade.zip file here.

3. Unzip the pipeblade.zip file you have downloaded to your working directory.

4. Start Ansys ICEM CFD and create a new project in your working directory. Use an appropriate name,
for example Pipe_Blade.

File → New Project

5. Open the geometry file (geometry.tin).

File → Geometry → Open Geometry

Note:

• If you want Ansys ICEM CFD to behave exactly as this tutorial describes, you should go to
the Settings Menu, click Selection, and disable Auto Pick Mode in the DEZ. Most experi-
enced ICEM CFD users prefer to enable Auto Pick Mode as it improves efficiency. See
Selection in the ICEM CFD Help Manual → Main Menu Area → Settings Menu for more
detail.

• Throughout this and other tutorials, Point Names, Curve Names, Vertex Numbers, and
other identifying labels are made visible or turned off as necessary to assist in describing
the steps of the tutorial. Most experienced users prefer to leave these labels disabled to
reduce screen clutter.

Step 1: Creating Parts in the Mesh Editor

Initially, all surfaces, curves, and points of the geometry are in the generic part GEOM. The different geometries
must be assigned to appropriate parts for further processing.
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1. In the Display tree, enable the display of Points and Surfaces, and enable Show Point Names.

Points

Points → Show Point Names

2. Create curves for the leading and trailing edge of the blade.

Geometry → Create/Modify Curve  → From Points 

a. Check that the Part name is GEOM.

b. Click  (Select location(s)), and then select the two points at the leading edge of the blade,
GEOM/9 and GEOM/11.

c. Click Apply or the middle mouse button to accept the new geometry.

d. Similarly, create a new curve at the trailing edge of the blade using points GEOM/8 and
GEOM/10.

Figure 80: Curves for Leading and Trailing edges.

3. Enable the display of Surfaces.

Surfaces

4. Create surface part assignments.

Parts → Create Part
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a. Follow this sequence to assign the region enclosed by GEOM/4 - GEOM/7 to the part OUTLET.

i. Type the name OUTLET in the Part field.

ii. Ensure  (Create Part by Selection) is selected.

iii. Click  (Select entities).

The Select Geometry toolbar appears.

iv. Ensure Toggle selection of points  is off.

Similarly toggle off  (Toggle selection of curves) and  (Toggle selection of bodies).

Leave only Toggle selection of surfaces  enabled.

v. Select the surface defined by the points GEOM/4 - GEOM/7. Click the middle mouse
button to accept.

vi. Click Apply.

The surface geometry changes color and your new part name appears in the Display tree.

b. Similarly, reassign the region that is enclosed by points GEOM/0 - GEOM/3 to the part INLET.

c. Also, assign the surface defining the cylindrical pipe to a part named CYL.

d. Finally, the two surfaces belonging to the solid blade in the middle of the cylinder should be
assigned to a part named BLADE.

Refer to Figure 81: Part Assignments (p. 117) for the Surface part assignments.
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Figure 81: Part Assignments

For this tutorial, leave the curves and points assigned to the initial part GEOM.

5. Create fluid and solid Material Points for the interiors of the cylinder and blade, respectively.

The material point that will be created will help us to keep the FLUID region separate from the SOLID
region. This is not strictly necessary since blocks can simply be created in the FLUID part rather than
creating a material point.

Geometry → Create Body 

a. Enter FLUID in the Part field in the Create Body DEZ.

b. Ensure Material Point  is enabled.

c. With the left mouse button, select two locations on the opposite sides of the cylinder. Click
the middle mouse button to accept.

d. Click Apply.

Note:

The FLUID material point should not be within the BLADE. locations. Rotate the
model to confirm that FLUID is in an appropriate location.

e. Similarly, create a part named SOLID using two locations on the blade surfaces so that the
midpoint will be inside the blade.
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6. Delete any Empty Parts.

Parts → Delete Empty Parts

7. Save the updated model before continuing on in this tutorial.

File → Save Project

Step 2: Initial Blocking and Associations

The blocking strategy for this model involves an internal Ogrid longitudinally in the pipe, surrounding separate
blocking for the blade. Within the Ansys ICEM CFD, projection-based, mesh generation environment, the
block faces between different materials (at the Fluid-Solid interface) are projected to the closest geometry
surface. Block faces within the same material may be associated to specific CAD surfaces only if necessary
for the definition of internal walls.

Here, you create the initial blocking, and then fit the blocking more closely to the geometry by associ-
ating the vertices and edges to the geometry.

1. Initialize the blocking.

Blocking → Create Block  → Initialize Blocks 

a. Ensure that Part is set to the correct material (FLUID).

b. Retain the selection of 3D Bounding Box in the Type drop-down list.

You need not select entities when creating a bounding box around the entire geometry.

c. Click Apply.
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2. Ensure Points are displayed, including Show Point Names.

In the Display tree, enable the display of Vertices, and enable vertex Numbers.

Blocking → Vertices

Blocking → Vertices → Numbers

3. Associate the vertices to points on the geometry.

Blocking → Associate  → Associate Vertex 

a. Ensure that Point is selected under Entity.

b. Click  (Select vert(s)), and then select Vertex 42 (upper right corner at the OUTLET end).

c. Click  (Select point(s)), and then select Point GEOM/7 (nearest to Vertex 42).

d. Click Apply to create the association as shown in Figure 82: First Vertex to Point Associ-
ation (p. 119).

Figure 82: First Vertex to Point Association

e. Similarly, associate the other vertices and points around both INLET and OUTLET. When finished,
your blocking should look like Figure 83: Vertex to Point Associations for the Pipe (p. 120).
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Figure 83: Vertex to Point Associations for the Pipe

Note:

When possible and to achieve the best quality mesh, Block vertices on any circular
geometry should be placed so that edges are equal in length and the internal angles
between edges are 90 degrees.

4. Associate the block edges to curves on the geometry.

Blocking → Associate  → Associate Edge to Curve 

a. In the Display tree, disable the display of Points and Surfaces; and enable the display of
Curves.

b. Click  (Select edge(s)), and then select the four edges of the blocking at the OUTLET end
of the pipe.

c. Click the middle mouse button to accept.

d. Click  (Select compcurve(s)), and then select the four curves around the OUTLET end of
the pipe.
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Figure 84: Select Edges and Curves

e. Click Apply to complete the association.

The edges turn green confirming their association. Also notice the four curves become one
color indicating that they have been grouped into a single curve.

f. Similarly, associate the four edges at the INLET end of the pipe to the corresponding four
curves.

g. To see a confirmation of the associations, enable Show Association under Edges in the Display
tree. See Figure 85: Edge to Curve Associations for the Pipe (p. 122).

Blocking → Edges → Show Association.
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Figure 85: Edge to Curve Associations for the Pipe

Note:

• If the edges lie on the geometry, as is the case with longitudinal edges, the projection
arrows are not shown. By default, all external edges are surface-associated to the
nearest active surface and appear as white (black if a light background).

• Should any Edge-to-Curve association mistakes occur, the association can be set to

using Blocking → Associate  → Associate Edge to Surface .

5. Group curves (optional).

Note:

Curves are automatically group when multiple curves are selected for making an associ-
ation. This step may be used to manually group curves.

Blocking → Associate  → Group/Ungroup curves 

a. Click  (Select curve(s) or compcurve(s)), and then select the curves to be grouped. For
example the four curves that define the OUTLET.

b. Click Apply to group them. All curves will be the same color.
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Step 3: Splitting and Collapsing Blocks around the Blade

In this tutorial, the Blade is regarded as a Solid region, while the region surrounding the Blade is regarded
as a Fluid. You will generate a Hexahedral Mesh for both regions, but first the Blocking must be Split and
then Collapsed around the Blade, creating a degenerate Hexahedral mesh in the Blade region.

Note:

Before employing the Collapse function for your own applications, confirm that the solver
accepts degenerated hexas (for a structured solver) or penta_6 elements (prism) for an un-
structured solver.

The steps instruct you to split the block in the k-direction (z-direction) and i-direction (x-direction) around
the blade, creating further blocking topology for the blade. For better precision, the Prescribed point
method is chosen for splitting the blocks in the k-direction, while the i-direction splits will be made by visual
judgment.

1. In the Display, tree, disable display of Vertices (under Blocking) and Surfaces (under Geometry).
Enable the display of Points.

2. Select View → Top, and then click  (Fit Window).

3. Create z-direction splits using Prescribed points.

Blocking → Split Block  → Split Block 

a. Change the Split method to Prescribed point using the drop-down list.

b. Click  (Select edge(s)), and then select one of the vertical (z-direction) edges.

c. Click  (Select point(s)), and then select Point GEOM/9 (bottom of blade geometry).

d. Click Apply to create the split.

e. Similarly create two more splits using points GEOM/8 (top of blade geometry) and GEOM/12
(middle of blade geometry).

Note:

Make sure that the span of the Edge that is selected includes the Prescribed Point
that will be selected.

See Figure 86: Z-direction Splits (p. 124).
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Step 3: Splitting and Collapsing Blocks around the Blade



Figure 86: Z-direction Splits

4. Create x-direction splits using Screen select.

a. Change the Split method to Screen select using the drop-down list.

b. Click  (Select edge(s)), and then select one of the horizontal (x-direction) edges.

c. Click-and-drag the split along your selected edge until it is aligned over one of the points on
the side (widest part) of the blade geometry.

Note:

A single click-and-drag may be used to position the split. Alternatively, multiple
click-and-drag operations may be performed as necessary prior to clicking the
middle mouse button.

d. Click the middle mouse button to accept.

e. Similarly, create another split aligned over the opposite side of the blade geometry. See Fig-
ure 87: X-direction Splits (p. 125).
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Figure 87: X-direction Splits

5. Collapse Blocks to display the Blade.

In this sequence, the Collapse feature is introduced to create degenerate blocks for the blade.

a. Before collapsing the blocks, the two center blocks, representing the Blade, should be assigned
to the part SOLID.

Parts → SOLID → Add to Part

i. Select (Blocking Material, Add Blocks to Part).

ii. Click  (Select block(s)), and then select the two blocks of the Blade.

iii. Click the middle mouse button to accept.

iv. Click Apply. The blocks will change color to match SOLID as seen in the Display tree.

b. Use Index Control to isolate the visible blocks.

Blocking → Index Control

Change the Index control for the I-dimension to 2-3.

Note:

Every time a block Split is performed, the Index control is updated. After the splits
are complete, the full range of the I-dimension will be from 0-5. Reducing this to
2–3 displays only the center blocks longitudinally in the pipe, including the blade.
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Step 3: Splitting and Collapsing Blocks around the Blade



c. Now open the Merge Vertices DEZ.

Blocking → Merge Vertices  → Collapse Blocks 

d. Click  (Select edge(s)), and then choose the edge that should be collapsed. In this case it
is the shortest edge of the selected blocks.

e. Click  (Select Block(s)) and then select the blocks in front of and behind the blade as shown
in Figure 88: Blocks for Collapse (p. 126).

Figure 88: Blocks for Collapse

f. Click Apply.

After collapsing, the model should be as shown in Figure 89: Collapsed Blocks (p. 127).
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Figure 89: Collapsed Blocks

Step 4: Fit the Blocking to the Blade geometry

Associating edges and vertices ensures the mesh will respect the geometry entities, which allows for
simpler mesh refinement and more rapid design iterations.

1. Associate Edges to Curves on the Blade.

Blocking → Associate  → Associate Edge to Curve 

Make sure Project Vertices is disabled in the Blocking Associations DEZ.

a. Click  (Select edge(s)), and then click two adjacent edges on the side of the blade. See
Figure 90: Select Edges and Curves for Association (p. 128).
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Step 4: Fit the Blocking to the Blade geometry



Figure 90: Select Edges and Curves for Association

b. Click the middle mouse button to accept.

c. Click  (Select compcurve(s)), and then select the single curve closest to your selected
edges.

d. Click the middle mouse button to accept.

e. Click Apply. The edges turn green to indicate a successful association.

2. Similarly, create Edge to Curve associations for the top and bottom of the blade, on both sides.

3. Also associate the leading and trailing edges of the blade to the two curves added at the beginning
of this tutorial.

4. In the Display tree, enable Show Associations. See Figure 91: Edges Associated to Curves on
Blade (p. 129).

Blocking → Edges → Show Association
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Figure 91: Edges Associated to Curves on Blade

5. Move all associated vertices to the geometry.

Blocking → Snap Project Vertices 

a. Ensure that All Visible is selected for Vertex Select.

b. Click Apply. All vertices move to the geometry.

In the Display tree, disable the display of Vertices and Points, enable the display of Curves. Your blocking
should appear as in Figure 92: Fully Split and Associated Blocking (p. 130).
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Step 4: Fit the Blocking to the Blade geometry



Figure 92: Fully Split and Associated Blocking

Note:

Vertex Color Distinction

Notice that when vertices or edges are associated with geometry entities, then the movement
of the vertices is restricted to the associated geometry. The colors of the vertices indicate
their associations and degrees of freedom.

• Vertices associated with Points are red and are fixed at a single place in the coordinate
system.

• Vertices associated to a Curve are green and can be moved on the associated curve.

• By default, all the vertices not associated with a point or curve but lying on a Surface
boundary are white (black if a light background) and are free to move on that surface.

• Additionally, internal surfaces are blue and vertices can be moved along the blue block
edges to which they are connected.

Step 5: Generating the Ogrid

If the pre-mesh is generated with the existing blocking, the result would show badly skewed cells on the four
corners of the pipe. Converting the existing H-Grid blocking topology to an Ogrid topology inside the pipe
will produce a mesh that is low in skewness, with orthogonal grid on the pipe walls. The following steps will
improve the overall mesh quality.
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1. Open the Ogrid DEZ.

Blocking → Split Block  → Ogrid Block 

2. Click  (Select block(s)), and then select all the Blocks of both the FLUID and SOLID regions. You

may use  (Select all appropriate visible objects) since the Ogrid will be added in the entire
pipe as shown in Figure 93: Blocks and Faces selected for Ogrid (p. 131).

Figure 93: Blocks and Faces selected for Ogrid

3. Similarly, click  (Select face(s)), and then select only the two INLET faces and two OUTLET faces
as shown.

4. Press the middle mouse button to accept.

5. Click Apply to create the Ogrid.

6. Save the updated blocking before continuing on in this tutorial.

File → Save Project
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Step 5: Generating the Ogrid



Figure 94: Completed Blocking

Note:

The procedures described here make a parametric blocking file in which the vertices and
edges are associated with geometric entities. This means that you can modify the geometry,
keeping the same entity names, and then reload the saved blocking file to quickly generate
a similar result.

Step 6: Defining the Mesh using Surface Parameters

In this step, you will define node distributions for the blocking using surface parameters.

Surfaces should be turned ON in the Display Tree so they can be selected from the screen.

Mesh → Surface Mesh Setup 

1. Click  (Select surface(s)), and then select all surfaces by box-selecting the entire model. Altern-
atively press a with the mouse in the graphic window.

2. Enter 0.3 for Maximum Size, 0.03 for Height, and 1.25 for Height Ratio.
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3. Click Apply to assign the surface parameters.

Note:

Display the surface parameters by Geometry → Surfaces → Hexa Sizes

In Figure 95: Hexa Mesh size on Surface (p. 134), the “quad” in the center of the surface
represents the max size, its thickness represents the height, while the number is the
height ratio.
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Step 6: Defining the Mesh using Surface Parameters



Figure 95: Hexa Mesh size on Surface

Disable the display of Hexa Sizes in the Display tree.

4. Select Blocking → Pre-Mesh Params  → Update Sizes 

Make sure Update All is toggled on (default).

5. Click Apply.

This will compute the node distributions on the blocking edges from the surface parameters.

6. Enable the Pre-Mesh display from the Display Tree. Allow recompute when prompted.

Blocking → Pre-Mesh

7. Enable Solid & Wire in the Display tree for better visualization. See Figure 96: Initial Mesh on Outlet
surface (p. 135).

Blocking → Pre-Mesh → Solid & Wire
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Figure 96: Initial Mesh on Outlet surface

The mesh is denser at the walls. The near wall elements will have the same initial height that was set
on the surface parameters, which was 0.03.

Step 7: Refining the Mesh using Edge Parameters

Although it may be enough to define the meshing with surface parameters, the mesh quality of more complex
models can be improved by defining additional edge parameters. Perform these next steps to redistribute
points along the diagonal (radial) edge of the Ogrid.

Blocking → Pre-Mesh Params  → Edge Params 

1. Disable Pre-Mesh in the Display tree.

This will allow changes without requiring Mesh recompute at every step, and allow edges to be easily
seen and selected.

2. In the Display tree, enable the display of Vertices, and then enable display of vertex Numbers.

3. Click  (Select edge(s)), and then select one of the Radial Edges of the Ogrid. See Figure 97: Select
Radial Edge of the Ogrid (p. 136).
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Step 7: Refining the Mesh using Edge Parameters



Figure 97: Select Radial Edge of the Ogrid

4. Set Spacing 1 to 0.015, which is half of the previous value. Also set Spacing 2 to 0, which will
allow it to go as large as is needed, and Nodes to 13, which will allow Ratio 1 (1.25) to be met.

5. Enable Copy Parameters, and then select To All Parallel Edges from the Copy drop-down list.

6. Click Apply.

Note:

In the Display tree, enable the display of Bunching.

Blocking → Edges → Bunching
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Figure 98: Edge Parameter Bunching

Spacing 1 is the first element size at start of the edge (vertex 134) and Spacing 2 is
the last element size at the finish end (vertex 200). Start and Finish are identified by the
direction arrow that displays on the edge. The small ‘quads’ give a visual indication of
the mesh size at that point.

Disable the Bunching display.
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Step 7: Refining the Mesh using Edge Parameters



7. In the Display tree, enable Pre-Mesh. Allow Recompute when prompted.

Note:

If you right-click Pre-Mesh, in the Display tree, you should see Project faces is checked
On (default).

8. In the Display tree, disable the display of the SOLID part. The final mesh should appear similar to
Figure 99: Final Mesh (p. 138). Your colors may vary, and may be changed by right-clicking on a Part
name in the Display tree.

Figure 99: Final Mesh

Step 8: Checking and Improving Mesh Quality

1. Check mesh quality.
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Blocking → Pre-mesh Quality Histogram 

2. In the Criterion drop-down list, select Determinant (2x2x2).

Enter the Min-X value = 0, Max-X value = 1, Max-Y height = 12, and Num of bars = 20.

Check the Active Parts only is selected.

3. Click Apply.

Figure 100: Determinant 2x2x2 Quality Histogram

Note:

A value of determinant greater than 0.2 is acceptable for most commercial solvers.

4. In the Criterion drop-down list, change the selection to Angle.

Enter the Min-X value = 0, Max-X value = 90, Max-Y height = 12, and Num of bars = 18.

5. Click Apply.

Figure 101: Angle Quality Histogram – before Smoothing

Note:

An angle greater than 18 degrees is acceptable for most commercial solvers.

To display cells of a particular determinant or angle value, click a histogram bar. Cells
within that range will be highlighted allowing closer inspection. (You will have to change
the Pre-Mesh display to Wire Frame from Solid & Wire).
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Step 8: Checking and Improving Mesh Quality



6. Run the Pre-mesh Smoother.

Blocking → Pre-mesh Smooth 

7. In the Method drop-down list, select Quality.

Enter Smoothing iterations = 3, Up to quality = 0.5, and Criterion = Angle.

Under Advanced Options, enable Active Parts only.

8. Click Apply to smooth mesh.

Changes in the minimum angle of the mesh can be seen in the histogram as shown.

Figure 102: Angle Quality Histogram – after Smoothing

9. You can examine the mesh in cross section using the Cut Plane.

Blocking → Pre-Mesh → Cut Plane

a. In the Display tree, disable the display of Pre-Mesh.

b. Using the Method drop-down list, select Middle Z plane. See Figure 103: Mid-Z Cut
Plane (p. 141).
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Figure 103: Mid-Z Cut Plane

c. Use the scroll wheel to move the Cut Plane back and forth in the z-direction to examine the
mesh behavior around the Blade.

d. Change the Method to Middle Y plane. See Figure 104: Mid-Y Cut Plane (p. 141).

Figure 104: Mid-Y Cut Plane

e. Scroll the Cut Plane up and down through the pipe.
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Step 8: Checking and Improving Mesh Quality



f. Click Dismiss when finished examining Cut Planes.

Re-enable Pre-Mesh in the Display tree.

Step 9: Saving your Work

1. Select File → Blocking → Save Blocking As and enter a suitable name such as pipe_blade.blk.

Saving the blocking will allow you to change any meshing parameters, yet quickly restore a known
state by reloading the blocking onto the geometry.

2. The mesh may be saved in an unstructured or structured format, depending on the input needs of
your solver.

Blocking → Pre-Mesh → Convert to Unstruct Mesh

Blocking → Pre-Mesh → Convert to MultiBlock Mesh

This will write the mesh to an output file using the default file name in the working directory, and im-
mediately load the mesh. Ansys ICEM CFD allows you to save your mesh in a format needed for your
solver.

3. Select File → Save Project.
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Hexa Mesh Generation for an Elbow Part
In this tutorial, you will generate a hexa mesh for a three-dimensional elbow intersected internally by
a cylinder.

Figure 105: Elbow Geometry

This tutorial demonstrates how to do the following:

• Prepare the geometry.

• Block the geometry.

• Split the blocks.

• Fit the computational domain to the geometry.

• Create the first Ogrid.

• Create the second Ogrid.

• Generate the mesh.

• Verify and save the mesh.
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Starting the Project

Step 1: Preparing the Geometry

Step 2: Blocking the Geometry

Step 3: Fitting the Blocking to the Geometry

Step 4: Creating the First Ogrid

Step 5: Adjust the Ogrid Edge Length to Improve Quality

Step 6: Generate the Pre-Mesh

Step 7: Creating the Second Ogrid

Step 8: Generating the Mesh

Step 9: Saving the Project

Starting the Project

1. Set up a working directory on your computer.

2. Download the elbow_part.zip file here.

3. Unzip the elbow_part.zip file you have downloaded to your working directory.

Note:

These two files are of the same geometry. The *.agdb file is in the native Workbench
format while the *.tin file is in the native Ansys ICEM CFD geometry format. Assuming
you have the Workbench Readers, proceed to the next steps in this tutorial. If not, see
the notes at the end of this section.

4. Start Ansys ICEM CFD and create a new project in your working directory. Use an appropriate name,
for example Hexa_Elbow.

File → New Project

5. Import the geometry (Elbow.agdb).

File → Import Model
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1. Select Elbow.agdb in the Select Import Model File dialog box and click Open.

2. Ensure that Import Geometry is enabled.

Retain the other default settings and click Apply.

The DesignModeler file is now read into Ansys ICEM CFD.

3. Enable Surfaces in the display control tree.

 Geometry → Surfaces

Note:

If Workbench Readers are not installed, use File → Geometry → Open Geometry to open
the native Ansys ICEM CFD file Elbow.tin. You will also need to create the parts, as well

145
Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Starting the Project



as Delete unattached curves. Refer to Figure 106: Elbow Part With Material Points (p. 147) for
part names and the Sphere Cube tutorial for instructions.

Note:

If you want Ansys ICEM CFD to behave exactly as this tutorial describes, you should go to
the Settings Menu, click Selection, and disable Auto Pick Mode in the DEZ. Most experienced
ICEM CFD users prefer to enable Auto Pick Mode as it improves efficiency. See Selection in
the ICEM CFD Help Manual → Main Menu Area → Settings Menu for more detail.

Step 1: Preparing the Geometry

Geometry → Create Body  → Material Point 

1. Create the FLUID material point within the volume.

a. Enter FLUID for Part.

b. Click  (Select location(s)) and select two locations on opposite sides of the elbow such
that the midpoint lies within the ELBOW_1_1 part but outside the CYL part (Figure 106: Elbow
Part With Material Points (p. 147)). Click the middle-mouse button to accept the selection of
the points.

c. Click Apply so that FLUID appears under Parts in the display control tree.

Rotate the model to confirm that the new material point is appropriate.

2. Similarly, create the SOLID material point inside the cylinder.

You can do this by selecting 2 locations on the edge of the cylinder.
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Figure 106: Elbow Part With Material Points

3. Click Dismiss to close the Create Body DEZ.

4. Set up mesh sizes.

Mesh → Part Mesh Setup 

a. Click the Maximum size header.

The MAXIMUM SIZE dialog will appear.

i. Enter 5 for Maximum size.

ii. Click Accept.

b. Similarly set Height to 1 and Height ratio to 1.2.
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Step 1: Preparing the Geometry



c. Click Apply and then Dismiss to close the Part Mesh Setup dialog box.

Note:

If you enable hexa sizes ( Geometry → Surfaces → Hexa Sizes) you can see the
hexa size icon on each surface. The base size indicates the nominal size on each
surface, the thickness shows the initial height at the wall (if set) and the number
shows the growth ratio at the wall. Setting sizes is a quick way to seed the mesh
and these hexa size icons are a quick reference to make sure the sizes are set
reasonably. However precise mesh size/distribution settings should be done at the
blocking level using edge parameters.

5. Save the geometry file (elbow-new.tin) before proceeding with the rest of the tutorial.

File → Geometry → Save Geometry As...

Step 2: Blocking the Geometry

The blocking strategy for this model involves making two internal Ogrids inside of an L shaped blocking.

• The first Ogrid will capture topology, specifically to create the internal cylinder hole.

• The second Ogrid will improve the mesh quality within the main elbow-pipe and provide a
boundary layer.

1. Create the initial block.

Blocking → Create Block  → Initialize Blocks 
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a. Ensure that Part is set to the correct material (FLUID).

b. Retain the selection of 3D Bounding Box in the Type drop-down list.

You need not select entities when creating a bounding box around the entire geometry.

c. Ensure that Orient with geometry is disabled.

d. Click Apply to initialize the block around the entire geometry.

2. Split the initial block.

Blocking → Split Block  → Split Block 

a. Enable Curves in the display control tree.

b. Ensure that Screen select is chosen from the Split Method drop-down list.

c. Create splits as shown in Figure 107: Split Block (p. 149) by selecting any edge in the Y or X
direction through which you want to run the perpendicular split.

Select the edge and hold down the left-mouse button while moving the mouse. Adjust the position
such that the split is near the extent of the circular curve of the geometry. Click the middle mouse
button to accept the split position.

Figure 107: Split Block

3. Delete the corner block.

Blocking → Delete Block 

a. Select the block highlighted in Figure 108: Deleting the Block (p. 150).
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Step 2: Blocking the Geometry



Figure 108: Deleting the Block

b. Ensure that Delete permanently is disabled and click Apply.

Note:

Deleting a block without Delete permanently enabled, will just change the mater-
ial to VORFN, which is sufficient in most cases. Use Delete permanently only in
rare situations where you specifically want to break up blocking topology.

Step 3: Fitting the Blocking to the Geometry

In this step, you will associate the blocking edges to geometry curves, and move vertices onto the geometry.

1. Disable Surfaces so that the rest of the entities are clearly visible.

2. Associate the four edges surrounding the INLET surface to the appropriate curve(s).

Blocking → Associate  → Associate Edge to Curve 

a. Enable Project vertices.

b. Select the four edges surrounding the INLET part (A in Figure 109: Selection of Edges and
Curves for Association (p. 151)) and click the middle-mouse button to complete the selection.

Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.150

Hexa Mesh Generation for an Elbow Part



c. Select the curve (A' in Figure 109: Selection of Edges and Curves for Association (p. 151)) and
click the middle-mouse button to complete the selection.

Figure 109: Selection of Edges and Curves for Association

d. Click Apply to associate the edges to the curves.

3. Similarly, associate the four edges surrounding the OUTLET surface (B in Figure 109: Selection of
Edges and Curves for Association (p. 151)) to the appropriate curve (B' in Figure 109: Selection of
Edges and Curves for Association (p. 151)).

4. Move the remaining vertices to the nearest active surface.

Blocking → Associate  → Snap Project Vertices 

Note:

With the edges associated to the appropriate curves, the other (surface associated)
vertices can be automatically moved onto the geometry to the nearest active surface.
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Step 3: Fitting the Blocking to the Geometry



a. Ensure that All Visible is selected for Vertex Select.

b. Click Apply.

c. Display the right view.

View → Right

The blocking will be oriented as seen in Figure 110: Vertices Moved Onto the Geometry—Right
View (p. 152).

Figure 110: Vertices Moved Onto the Geometry—Right View

d. Display the isometric view.

View → Isometric

You can also display the isometric view by pressing Shift+I or clicking the cyan ball on the triad.
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The blocking will be oriented as seen in Figure 111: Vertices Moved Onto the Geometry—Isometric
View (p. 153).

Figure 111: Vertices Moved Onto the Geometry—Isometric View

5. Manually move two of the vertices slightly from their present position.

Making these changes before creating the Ogrids is much easier than doing it after because there are
fewer nodes to move, and internal node movement, orthogonality, etc. do not yet need to be considered.
It is always good to ensure the surface mesh is setup as well as possible before increasing complexity
with further splits or Ogrids.

Blocking → Move Vertex  → Move Vertex 

a. Orient the model as shown in Figure 112: Moving the Vertices (p. 154), so that the cylinder
edges overlap.

b. Move the vertices to their new positions as indicated in Figure 112: Moving the Vertices (p. 154).

Click the vertex using the left-mouse button and hold the button while you slide the vertex along
the surface. The vertices are moved to position the edge away from the cylinder curve.

153
Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Step 3: Fitting the Blocking to the Geometry



Figure 112: Moving the Vertices

Figure 113: Moved Vertices—Isometric View (p. 154) shows the blocking (isometric view) after the
vertices have been moved.

Figure 113: Moved Vertices—Isometric View

Step 4: Creating the First Ogrid

This tutorial focuses on the flow outside of the internal pipe. Thus, in generating the first Ogrid, you will es-
sentially partition the volume around the small internal pipe so that part of the blocking may be removed.

1. Create the first Ogrid.

Blocking → Split Block  → Ogrid Block 
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a. Click Select block(s) and select the 2 blocks shown in Figure 114: Blocks and Faces Selected
for the First Ogrid (p. 155). Click the middle mouse button to finish the selection.

b. Click Select face(s) and select the faces shown in Figure 114: Blocks and Faces Selected for
the First Ogrid (p. 155). Click the middle mouse button to finish the selection.

The cylinder will now pass through the top and bottom of the geometry.

Figure 114: Blocks and Faces Selected for the First Ogrid

c. Click Apply to create the first Ogrid.

After creating the first Ogrid, the blocking will appear as shown in Figure 115: First Ogrid (p. 155).

Figure 115: First Ogrid
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2. Assign the material inside the cylinder to the SOLID part.

This will remove this region from the mesh if it is computed with the SOLID part disabled.

Blocking → Index Control

The index control window will appear in the lower right corner.

a. Change the Min for O3 from 0 to 1.

You can click the up arrow or type the number and click the enter key on the keyboard. You should
then see only the blocking shown in Figure 116: Visible Blocks After Using Index Control (p. 156)

Figure 116: Visible Blocks After Using Index Control

b. Select the blocking material.

Parts → SOLID → Add to Part

i. Click  (Blocking Material, Add Blocks to Part ).

ii. Click (Select block(s)), box select the entire model, and click the middle mouse button
to accept. Alternatively, press v on the keyboard to select all visible.

iii. Click Apply.

The selected blocks will then be assigned to the SOLID part.
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Figure 117: Blocks Assigned to SOLID Part

Note:

When you delete a block material or move it to another part, Ansys ICEM CFD
Hexa assumes that there is a surface boundary between the blocks and auto-
matically applies an association to the nearest active surface for the faces at
the block material boundaries. You will see that the previously blue edges turn
white/black to indicate this.

c. Associate the Ogrid edges to the cylinder curves (Figure 118: Edges Projected to the Cylinder
Curves (p. 158)).

Blocking → Associate  → Associate Edge to Curve 

i. Ensure that Project vertices is enabled.

ii. Associate the edges denoted C to CURVE C' using Figure 118: Edges Projected to the
Cylinder Curves (p. 158) as a guide.

iii. Associate the edges denoted D to CURVE D' using Figure 118: Edges Projected to the
Cylinder Curves (p. 158) as a guide.

iv. View the association between edges and curves.

Blocking → Edges → Show association

v. Enable the display of Surfaces in the display tree.
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Figure 118: Edges Projected to the Cylinder Curves

Step 5: Adjust the Ogrid Edge Length to Improve Quality

1. Disable the elbow part surface ELBOW_1_1 in the display tree.

Parts → ELBOW_1_1

The association arrows point to the outside surfaces of the elbow part (Figure 118: Edges Projected to
the Cylinder Curves (p. 158)). If you try to snap project vertices now, these vertices will move outward to
the elbow part surfaces. Hence, you must disable the ELBOW_1_1 part in the display tree, so that the
vertices will not move to that part.

2. Snap project the vertices to the cylinder

Blocking → Associate  → Snap Project Vertices 

a. Ensure that All Visible is enabled.

b. Click Apply.

The blocking should look like Figure 119: Vertices Projected to the Cylinder (p. 159).
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Figure 119: Vertices Projected to the Cylinder

3. Improve the placement of the vertices on the cylinder.

Blocking → Move Vertex  → Set Location 
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a. Ensure that Set Position is selected in the Method drop-down list.

b. Ensure that Vertex is selected in the Reference From group box.

c. Click (Select vert(s)) next to Ref. Vertex and select one of the higher vertices as shown in
Figure 120: Moving the Vertices on the Cylinder (p. 161) as a reference to which the other vertices
will be moved.

d. Ensure that the Coordinate system is set to Cartesian.

e. Enable Modify Y.

Selecting Modify Y will allow you to move the vertices in the Y direction.

f. Click  (Select vert(s)) next to Vertices to Set and select the other 3 vertices.

You can select the vertices by block selecting all of them.

g. Click Apply.

All the vertices will be aligned such that they have the same Y value (Figure 120: Moving the Vertices
on the Cylinder (p. 161)).
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Figure 120: Moving the Vertices on the Cylinder

4. Align the vertices to the base plane.

Blocking → Move Vertex  → Align Vertices 
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a. Click  (Select edge(s)) and select an edge along the Y direction for Along edge direction
(see Figure 121: Aligning Vertices (p. 162)).

b. Click (Select vert(s)) and select the vertex at the base of the edge on the base plane for
Reference vertex (see Figure 121: Aligning Vertices (p. 162))

c. Ensure that XZ is selected in the Move in plane group box.

d. Click Apply.

Figure 121: Aligning Vertices
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5. Realign the vertices on the geometry.

After aligning the edges you may notice that some vertices have moved off the geometry a little bit
(Figure 122: Vertices Moved Off the Geometry (p. 163)). You will now use Snap Project Vertices to realign
them.

Figure 122: Vertices Moved Off the Geometry

Blocking → Associate  → Snap Project Vertices 

Repeat the steps for aligning to the base plane and snap vertices until you get the geometry right
(Figure 123: Vertex Positions After the Final Alignment (p. 163)).

Figure 123: Vertex Positions After the Final Alignment

6. Enable ELBOW_1_1 in the display tree.
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7. Click Reset in the Index Control window.

Step 6: Generate the Pre-Mesh

1. Update the mesh sizes.

Blocking → Pre-Mesh Params  → Update Sizes 

a. Ensure that Update All is selected for Method.

b. Select Run Check/Fix Blocks.

c. Click Apply.

2. Enable Pre-Mesh.

Blocking → Pre-Mesh

The Mesh dialog box will appear, asking if you want to recompute the mesh. Click Yes.

3. Examine the quality.

Blocking → Pre-Mesh Quality Histogram 

a. Disable SOLID in the display tree.

Parts → SOLID

b. Ensure that Determinant 2×2×2 is selected in the Criterion drop-down list.

c. Retain the values of 0 for Min-X value and 1 for Max-X value.

d. Retain the values of 0 for Max-Y height and 20 for Number of bars.

e. Ensure that Only visible index range is disabled.

f. Enable Active parts only.

g. Click Apply (Figure 124: Pre-Mesh Quality Histogram (p. 164)).

Figure 124: Pre-Mesh Quality Histogram

Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.164

Hexa Mesh Generation for an Elbow Part



h. Select the lower value bars (<0.6) to see the skewed cells (Figure 125: Skewed Cells (Below 0.6)
in the Pre-Mesh (p. 165)).

Figure 125: Skewed Cells (Below 0.6) in the Pre-Mesh

These cells can be corrected using the Ogrid tool.

i. Right-click in the histogram window and select Done.

4. Disable Pre-Mesh.

Blocking → Pre-Mesh

5. Enable SOLID.

Parts → SOLID

Note:

These elements are skewed because a mapped block is being fit to a curved shape. At
the mesh corners, projection to the curved shape opens up the element’s internal angle
to approach 180 degrees. The finer the mesh, the closer the angle to 180 degrees and
the worse the quality of the element. The Ogrid tool re-configures the blocking topology
by inserting blocks aligned with the wall and moving this H-Grid corner inward to avoid

165
Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Step 6: Generate the Pre-Mesh



the projection issue. The Ogrid tool is very robust and can be used to improve the
quality on simple models like this or form quality boundary layers for much more complex
models. It is also ideal for better capturing the physics of the boundary layer profile
(viscous wall). At other times it is advantageous to layer elements normal to the curved
wall.

Step 7: Creating the Second Ogrid

In this step, you will create a second Ogrid to improve the mesh quality within the main elbow pipe, and
also provide a boundary layer.

Blocking → Split Block  → Ogrid Block 

1. Ensure that both SOLID and FLUID are enabled in the display tree.

You enabled SOLID at the end of the previous step. Unless both SOLID and FLUID are enabled, the Ogrid
will also wrap the valve stem (small cylinder), which is also valid, but may require additional mesh
editing to get good quality.

2. Create the Ogrid.

a. Click  (Select Block(s)) and select all the blocks by box selecting over the entire model.

b. Add the faces on the inlet and outlet.

i. Click  (Select Faces) and select all the faces on the INLET and OUTLET as shown in
Figure 126: Blocks and Faces Selected for the Ogrid (p. 166).

Figure 126: Blocks and Faces Selected for the Ogrid
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There are five faces on the OUTLET part and one face on the INLET part. If you select the
wrong face, deselect it by clicking again using the right–mouse button. You can also select

the faces by clicking the  icon in the Select Blockingface toolbar. This toolbar appears

when you click the  (Select Faces) icon. Select INLET and OUTLET in the Select Blocking
parts dialog box. In addition select the center face on the OUTLET part.

ii. Click the middle-mouse button after selecting the faces.

c. Click Apply to create the Ogrid (Figure 127: The Second Ogrid (p. 167)).

Figure 127: The Second Ogrid

3. Set the edge length to improve quality.

Blocking → Move Vertex  → Set Edge Length 

a. Click  (Select edge(s)) and select one of the edges shown in Figure 128: Resizing Edges—First
Pair (p. 168). Click the middle mouse button.

You can see that the length is approximately 15. You will reduce this to improve the quality.

b. Select the two edges shown in Figure 128: Resizing Edges—First Pair (p. 168).

c. Enter 5 for Length and click Apply (Figure 128: Resizing Edges—First Pair (p. 168)).
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Figure 128: Resizing Edges—First Pair

d. Similarly rescale the edges shown in Figure 129: Resizing Edges—Second Pair (p. 168) to a value
of 8.

Figure 129: Resizing Edges—Second Pair

4. Recompute the pre-mesh.

a. Disable SOLID.

Parts → SOLID

b. Enable Pre-Mesh and click Yes to recompute.

Blocking → Pre-Mesh

c. Update the pre-mesh parameters.

Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.168

Hexa Mesh Generation for an Elbow Part



Since the edges were computed before, they did not have the sizes set.

Blocking → Pre-Mesh Params  → Update Sizes 

• Ensure Update All is selected and click Apply (Figure 130: Pre-Mesh for the Elbow (p. 169)).

Figure 130: Pre-Mesh for the Elbow

Step 8: Generating the Mesh

1. Adjust the boundary layers by setting the edge parameters.

Blocking → Pre-Mesh Params  → Edge Params 
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a. Select one of the radial edges as shown in Figure 131: Radial Edge Selected (p. 171).
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Figure 131: Radial Edge Selected

b. Enter 16 for Nodes.

c. Enter 0.05 for Spacing1.

d. Enable Copy Parameters and ensure that To All Parallel Edges is selected in the Method
drop-down list.

e. Click Apply.

You have adjusted the boundary layers for all edges.

f. Recompute the pre-mesh.

Blocking → Pre-Mesh

Figure 132: Pre-Mesh After Adjusting the Boundary Layer
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In Figure 132: Pre-Mesh After Adjusting the Boundary Layer (p. 171), initially there is uniformity and
then the mesh size suddenly increases after a certain point. You will manually adjust edge para-
meters and use match edges to rectify this. This will also result in better quality.

2. Adjust the uniformity over the edges.

Blocking → Pre-Mesh Params  → Edge Params 

a. Select any radial edge as shown in Figure 133: Selected Edge (p. 172).

Figure 133: Selected Edge

The arrow points inwards.

b. Set Spacing2 to 0.25 In the Meshing Parameters DEZ.

c. Enable Copy Parameters and select To All Parallel Edges in the Method drop-down list.

This setting is copied to all the edges.

d. Click Apply.

e. Recompute the mesh.
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Figure 134: Pre-Mesh After Modifying Edge Parameters

In Figure 134: Pre-Mesh After Modifying Edge Parameters (p. 173), the distribution on the edges is
much smoother now. However, there still is a slight jump around the center where the mesh size
is considerably larger. You will use match edges to improve the mesh distribution.

3. Match the inward edges and outward edges to correct the jump in the midsection.

Blocking → Pre-Mesh Params  → Match Edges 

a. Select the Reference Edge and Target Edge as shown in Figure 135: Edges Selected for Match
Edges (p. 173).

Figure 135: Edges Selected for Match Edges
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This will match the end spacing of the outer reference edge to the end spacing of the inner target
edge. But only the selected radial edge is matched. You have to copy this to all the other edges.

b. Recompute the mesh.

c. Copy the spacing to all the other edges.

Blocking → Pre-Mesh Params  → Edge Params 

i. Click  (Select edge(s)) and select the matched edge.

ii. Ensure Copy Parameters is enabled and To All Parallel Edges is selected in the Method
list.

iii. Click Apply.

iv. Recompute the mesh.

4. Check the quality of the mesh.

Blocking → Pre-Mesh Quality Histogram 

a. Ensure that Determinant 2x2x2 is selected in the Criterion drop-down list.

b. Retain 0 for Min-X value and 1 for Max-X value.

c. Retain 0 for Max-Y height and 20 for Number of bars.

d. Ensure that Only visible index range is disabled.

e. Enable Active parts only.

f. Click Apply.

g. Select the lower value bars to see the skewed cells (Figure 136: Worst Cells in the Pre-
Mesh (p. 175)).
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Figure 136: Worst Cells in the Pre-Mesh

You can see the improvement in mesh quality. The skewed cells are those which have a greater
aspect ratio. You can reduce this by adjusting the nodes on the corresponding edge.

5. Improve the quality by adding elements in the direction of the skewed cells.

Blocking → Pre-Mesh Params  → Edge Params 

a. Select the edge near the skewed cells (see Figure 137: Edge Selected to Improve Quality (p. 176)).
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Figure 137: Edge Selected to Improve Quality

b. Increase the number of nodes to 20.

c. Ensure Copy Parameters is enabled and To All Parallel Edges is selected in the Method list.

d. Recompute the mesh.

e. Check the quality of the mesh.

Blocking → Pre-Mesh Quality Histogram 

i. Ensure that Determinant 2x2x2 is selected in the Criterion drop-down list.

ii. Retain 0 for Min-X value value and 1 for Max-X value value.

iii. Retain 0 for Max-Y height and 20 for Number of bars.

iv. Ensure that Only visible index range is disabled.

v. Enable Active parts only.

vi. Click Apply.

vii. Select the lower value bars to see the skewed cells (Figure 138: Worst Cells After Adding
Cells (p. 177)).
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Figure 138: Worst Cells After Adding Cells

The element quality has improved and there are fewer elements in the lower bars of the his-
togram. The cells which now remain appear to have poor internal angles, and could be im-
proved by adjusting the blocking to improve these angles. Adjusting the blocking too far could
result in other cells (on the other side of the moved vertex) worsening. You could tweak to
further improve this mesh, but it is more than high enough to give good results in any com-
mercial solver. You will always have "worst elements", but if they are above the solver require-
ments, you can proceed. Typically, exceeding 0.1 for a determinant and 9 to 18 degrees for
angle is sufficient.

Step 9: Saving the Project

1. Save the blocking file.

File → Blocking → Save Blocking As...

2. Save the mesh in unstructured format with the default name hex.uns to the working directory.

Blocking → Pre-Mesh → Convert to Unstruct Mesh

The mesh will automatically be loaded.

3. Write the input file for Ansys Fluent.
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Output Mesh → Select solver 

a. Select Ansys Fluent from the Output Solver drop-down list.

b. Click Apply.

4. Set the appropriate boundary conditions.

Output Mesh → Boundary conditions 

a. Set the boundary condition for ELBOW_1_1 to wall.

i. Click Create new under ELBOW_1_1.

ii. Select wall from the list of Boundary Conditions in the Selection dialog box.

iii. Click Okay.

iv. Enter the zone ID, if required.

b. Similarly, set the boundary conditions for INLET to  velocity-inlet  and OUTLET to pressure-
outlet, exhaust-fan, outlet-vent.

c. Set the boundary conditions for FLUID to fluid and SOLID to solid.

Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.178

Hexa Mesh Generation for an Elbow Part



d. Click Accept after setting the boundary conditions.

Note:

Mixed/unknown refers to the dimension of the elements in a part. If a part contains
all volume elements, it clearly belongs in the Volumes branch. Similarly, parts in
the Surfaces branch should contain only shell elements, and the Edges branch
should contain only curve elements, and so on. However, if a part has a mixture of
surfaces, curves and points, then the mesh will contain a mixture of element types
and the part will be located in the Mixed/unknown branch of the tree. If you apply
wall properties, these are applied to the shells in that part only.

5. Write the input file for Ansys Fluent.

Output Mesh → Write input 

a. Select the appropriate .uns file.

The Ansys Fluent dialog will appear.

179
Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Step 9: Saving the Project



b. Enter elbow for Output file.

c. Click Done.

You can read this mesh file and proceed to setup and solve in Ansys Fluent.
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Bottom Up Hexa Mesh Strategy for a Grid Fin
In this tutorial, you will generate a hexa mesh for a Grid Fin. This could be done with top down methods,
as is done in other tutorials. For example, the triangles between the fins could be handled with the
option to create Y-blocks, or by creating an Ogrid and then collapsing the corners. However, the point
of this tutorial is to introduce bottom up blocking concepts that will be helpful on very difficult examples.
Further, since the geometry does not change significantly in the Z-direction, the 3D blocking is created
by extruding an initial 2D blocking. This is simpler than building a bottom up 3D blocking (you do not
need to select as many vertex locations), but the concept is the same.

Also, the Grid Fin is part of a rotating machine. You will minimize the model size by modelling only a
section of the rotating machinery, and then implementing symmetry with Periodic nodes.

The geometry is as shown in Figure 139: Grid Fin Geometry (p. 182)
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Figure 139: Grid Fin Geometry

This tutorial demonstrates how to do the following:

• Create an initial 2D block associated with a minor geometry.

• Create an Ogrid to extend the 2D blocking.

• Complete the 2D blocking using vertex placement.

• Extrude the blocking to 3D, and then create further splits and associations.

• Resolve zero thickness walls.

• Define periodicity.

• Generate and refine the mesh.

Starting the Project

Step 1: Creating an Initial 2D Blocking Associated with a Minor Geometry
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Step 2: Creating an Ogrid and Placing Vertices

Step 3: Completing the 2D Grid by Vertex Placement

Step 4: Extruding the 2D Grid to Create 3D Blocking

Step 5: Resolving Zero Thickness Walls

Step 6: Defining Periodicity

Step 7: Generating and Refining the Mesh

Step 8: Cleaning up

Starting the Project

1. Set up a working directory on your computer.

2. Download the gridfin.zip file here.

3. Unzip the gridfin.zip file you have downloaded to your working directory.

4. Start Ansys ICEM CFD and create a new project in your working directory. Use an appropriate name,
for example Grid_Fin.

File → New Project

5. Open the geometry file (geometry.tin).

File → Geometry → Open Geometry

Note:

• If you want Ansys ICEM CFD to behave exactly as this tutorial describes, you should go to
the Settings Menu, click Selection, and disable Auto Pick Mode in the DEZ. Most experi-
enced ICEM CFD users prefer to enable Auto Pick Mode as it improves efficiency. See
Selection in the ICEM CFD Help Manual → Main Menu Area → Settings Menu for more
detail.

• Throughout this and other tutorials, Point Names, Curve Names, Vertex Numbers, and
other identifying labels are made visible or turned off as necessary to assist in describing
the steps of the tutorial. Most experienced users prefer to leave these labels disabled to
reduce screen clutter.

Step 1: Creating an Initial 2D Blocking Associated with a Minor Geometry

Blocking Strategy: In this tutorial, we will start by creating a 2D blocking with a "bottom up" approach. Since
the Grid Fin geometry is primarily an extruded model in the Z-direction, we can then extrude the 2D blocking
in the Z-direction to create the 3D blocking. More typically, a top-down approach, in which you first capture
the outer geometry and then split the blocks to capture the minor geometry, is used. However, the flexibility
of ICEM CFD Hexa to use either approach (or a combination of both) is very powerful and this tutorial will
give you some insight.
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https://storage.ansys.com/doclinks/f_tutorials.html?code=gridfin-FLU-N2a


The bottom-up approach to blocking starts with a simple 2D Planar block. In subsequent procedures it will
be copied, split, and extruded to capture the full geometry.

1. In the Display tree, under Geometry, ensure the display of Curves is enabled and Surfaces is dis-
abled.

2. Initialize the 2D Planar block.

Blocking → Create Block  → Initialize Blocks 

a. Enter LIVE in the Part field.

b. Change the Type to 2D Planar.

c. Click Apply.
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Figure 140: Initial 2D Blocking

Note:

By design, 2D blocking is created only in the XY plane. If the 2D part of your geometry
is not parallel to the XY plane, it is recommended that the geometry be reoriented to
make it so. Later in the process, vertex movement and z-direction extrusion may be
difficult without this orientation.

The initial blocking surrounds the extents of the geometry. Here, in keeping with the bottom-up approach,
it is collapsed to fit a small portion of the geometry that resides in the x-y plane.

3. In the Display tree, Enable display of Vertices, by Number, and Enable display of Points, by Name.

Blocking → Vertices

Blocking → Vertices → Numbers

Geometry → Points

Geometry → Points → Show Point Names

4. Associate Vertex 21 to point POINTS.3.

Blocking → Associate  → Associate Vertex 
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a. Ensure that Point is enabled in the Entity box (default).

b. Click  (Select vert(s)), and then select vertex 21 (top right corner of the block).

c. Click  (Select point(s)), and then select the point POINTS.3. See Figure 141: POINTS.3,
POINTS.17 and POINTS.1 Location (p. 187).

Note:

At any point in time while in selection mode, you can toggle to dynamic mode by
pressing F9. This may be necessary in order to zoom in to get a closer view of the
curves. Pressing F9 again will toggle back to selection mode.

You may also enable and disable the display of geometry or blocking entities while
selecting a different type of entity. For example, you may want to disable curves
while selecting points.

d. Click Apply to complete the association.

The vertex moves immediately to the associated point.
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Figure 141: POINTS.3, POINTS.17 and POINTS.1 Location

5. Similarly, associate vertex 19 to point POINTS.17 and vertex 11 to point POINTS.1.

Note:

When selecting a vertex, you may choose  (Select by numbers) from the Select
Blocking - Vertex toolbar. A window pops up, Enter the vertex number, Click Done,
and then click the middle mouse button to accept.

Similarly, when selecting a point, you may follow a similar procedure starting with 
(Select by name) from the Select geometry toolbar.

6. Associate vertex 13 to curve CURVE.1.

Associating the vertex to the curve constrains its movement to the curve. The precise position will be
set in the next steps.

a. In the Blocking Associations DEZ, select Curve in the Entity box.

b. Click  (Select vert(s)), and then select vertex 13.

c. Click the middle mouse button to accept.
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Step 1: Creating an Initial 2D Blocking Associated with a Minor Geometry



d. Click  (Select compcurve(s)), and then select the curve CURVES.1 (between points POINTS.1
and POINTS.3).

e. Click the middle mouse button to accept.

f. Click Apply to complete the association.

The vertex does not move to the curve immediately.

7. Position vertex 13 in the middle of the curve.

a. Blocking → Move Vertex  → Move Vertex 

i. Click  (Select vert(s)).

ii. Click and drag vertex 13 to a point near the middle of the curve.

iii. Click the middle mouse button to accept.

b. Blocking → Move Vertex  → Set Location 
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i. Ensure Method is Set Position and Reference From is Vertex.

ii. For Ref. Vertex, click  (Select vert(s)), and then select Vertex 19.

You may find it useful to disable the display of points while performing this sequence.

iii. Ensure only Modify X is selected in the Set area.

iv. For Vertices to Set, click  (Select vert(s)), and then select Vertex 13.

v. Click the middle mouse button to accept your selection.

vi. Click Apply.

Vertex 13 moves into x-direction alignment with vertex 19, which is the center of the
curve.
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Step 1: Creating an Initial 2D Blocking Associated with a Minor Geometry



Figure 142: Initial Block associated to minor Geometry

Step 2: Creating an Ogrid and Placing Vertices

In this sequence, you will split the block into an orthogonal grid, and then move the vertices into position
for better quality mesh generation. Finally, the Ogrid will be copied to resolve other portions of the Shell
geometry.

1. Create the Ogrid.

Blocking → Split Block  → Ogrid Block 

a. Click  (Select Block(s)), and then select the only block.

b. Click the middle-mouse button to accept the selection.

c. Click  (Select Edge(s)), and then select the edges 11-19 and 19-21.

d. Click the middle-mouse button to accept the selection.

See Figure 143: Selection of Block and Edges for Ogrid creation (p. 191)
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Figure 143: Selection of Block and Edges for Ogrid creation

e. Click Apply.

The blocking after Ogrid creation is shown in Figure 144: Blocking after Ogrid creation (p. 191)

Figure 144: Blocking after Ogrid creation
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Step 2: Creating an Ogrid and Placing Vertices



2. Associate mid-edge vertices.

Blocking → Associate  → Associate Vertex 

a. In the Entity selection box, enable Point.

b. Click  (Select vert(s)), and then select vertex 33.

c. Click  (Select point(s)), and then select the point POINTS.18.

d. Click Apply to complete the association.

The vertex moves immediately to the associated point.

e. Similarly, associate vertex 35 to point POINTS.14.

3. Move middle Ogrid vertex.

a. Display the front view.

View → Front

b. Fix the direction of the vertex.

Blocking → Move Vertex  → Move Vertex 

i. Under Movement Constraints, enable Fix direction.

ii. For Vector, click  (Select edge(s)), and then select edge 13-34 (vertical edge).

c. Move the middle vertex.

i. In the Move Vertex DEZ, click  (Select vert(s)).

ii. Click and drag vertex 34 towards vertex 13.

iii. Click the middle mouse button to accept.

The blocking after vertex placement is shown in Figure 145: Blocking after Vertices are
Moved (p. 193)
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Figure 145: Blocking after Vertices are Moved

Copy/Rotate will be used to resolve other triangular portions of this geometry. However, since it also
copies existing associations, all blocking must first be disassociated from the geometry. In effect, asso-
ciations were created only as a means to position the vertices precisely.

4. Disassociate from the geometry.

Blocking → Associate  → Disassociate From Geometry 

a. Click  (Select vert(s)), and then select all vertices.

Use a selection box, or click  (Select all appropriate visible objects), or press v.

b. Click  (Select edge(s)), and then select all edges.

c. Click Apply.

In the Display tree, temporarily disable the display of Curves and Points to confirm that the
color of edges and vertices has changed to blue, indicating they are no longer associated with
any geometry entities.

5. Rotate/Copy the blocking.

Blocking → Transform Block  → Rotate Block 

193
Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Step 2: Creating an Ogrid and Placing Vertices



a. Enable Copy.

b. Set the Number of copies to 3.

c. For Rotation, select Z from the Axis drop-down list.

d. Ensure that the Angle is 90.

e. For Center of Rotation, select User's Point from the Center Point drop-down list.

f. Click  (Select location(s)), and then select POINTS 17 (the center point of the grid).

g. Click the middle mouse button to accept your location selection.

h. Click  (Select block(s)), and then select all blocks.

i. Click Apply.

The blocking after the Rotate/Copy transformation is shown in Figure 146: Blocking after Rotate
and Copy. (p. 194)

Figure 146: Blocking after Rotate and Copy.

Step 3: Completing the 2D Grid by Vertex Placement

In this sequence, you will manually create blocks to extend the blocking from the central Shell part to the
limits of the geometry. The extents of a new block are defined by selecting four corner points, starting with
existing vertices and ending with points on the boundary of the geometry.

Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.194

Bottom Up Hexa Mesh Strategy for a Grid Fin



To identify the location of the Shell part, enable Surfaces in the Display tree, and then disable/enable Shell
(under Part).

In the Display tree, enable Edges and Vertices (under Blocking) and Curves (under Geometry). Disable
Points.

1. Create the first block.

Blocking → Create Block  → From Vertices/Faces 

Retain the default settings. Ensure that Part name is set to LIVE (default).

a. Click  (Select vert(s)), and then select the vertices 11 and 13 (in that order).

b. Click middle-mouse button to accept the selection.

As two more positions need to be selected, it remains in geometry selection mode.

c. Select two locations (in the same order) shown by 0 and 1 in Figure 147: Vertices and Points
selected for First Block (p. 196).
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Step 3: Completing the 2D Grid by Vertex Placement



Figure 147: Vertices and Points selected for First Block

d. Click middle-mouse button to accept the selection.

Note:

The order of selecting vertices/locations is important for the block creation. You
need to select vertex 11 before 13 and location 0 before 1. This is referred to as a
"Z-pattern". Also, when selecting a combination of vertices and locations, it is im-
portant to start your Z-pattern so that the vertices are selected before the locations.
See From Vertices/Faces, under Blocking → Create Block in the Help document-
ation for more information.

e. Click Apply. See Figure 147: Vertices and Points selected for First Block (p. 196)
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The block is drawn and the new vertices are numbered 99 and 100.

2. Similarly, create the second block.

a. Click  (Select vert(s)), and then select the vertices, 13, 21, and 100 (in that order).

b. Click middle-mouse button to accept the selection.

c. Select the location as shown in Figure 148: Vertices and Points selected for Second Block (p. 197).

Figure 148: Vertices and Points selected for Second Block

d. Click middle-mouse button to accept the selection.

e. Click Apply. The blocking after creating second block is shown in Figure 149: First Two Blocks
added. (p. 198)
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Step 3: Completing the 2D Grid by Vertex Placement



Figure 149: First Two Blocks added.

3. Continue creating blocks all the way around the central Shell part. Use the following table and
Figure 150: Complete 2D blocking (p. 199) as a guide.

Note:

• You may temporarily disable entities in the Display tree to help with locating vertices
and points.

• Select Vertices and Points in the order listed. Select existing Vertices before clicking
the middle mouse button. Then select the remaining points to outline the block before
the second middle mouse button. New vertex numbers are assigned when Apply is
clicked and the block is created.

Select location, in
order.

Select existing Vertices, in
order.

122, 12345, 67

13667, 65, 123

149, 15099, 11

16511, 47, 150
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18047, 45, 165

19545, 122, 180

210, 21121, 111

22821, 89, 210

24589, 65, 228

26265, 136, 245

Figure 150: Complete 2D blocking

Step 4: Extruding the 2D Grid to Create 3D Blocking

The Complete 2D grid will be positioned in a single plane at the boundary of the geometry, and then extruded
in the Z-direction through the extent of the geometry.

Then, you will further split the 3D blocking, delete unused portions and associate the final blocking to the
geometry.

In the Display tree, disable the display of Points for this sequence.
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1. Move all vertices to one plane at the bottom of the geometry.

Blocking → Move Vertex  → Set Location 

a. Under Set, ensure that only Modify Z is checked.

b. Enter 5 for Z.

c. For Vertices to Set, click  (Select vert(s)).

d. Select all vertices.

i. Use a box selection.

ii. Click the middle mouse button to apply.

Alternatively, click  (Select all appropriate visible objects.

e. Click Apply.

The complete topology is moved to Z = 5 plane.

2. Extrude to create 3D blocking.

Blocking → Create Block  → 2D to 3D 

a. From the Method drop-down list, select Translate.

b. For Z Distance, enter 5.

c. Click Apply.

The 3D blocking after extrusion is shown in Figure 151: Initial 3D Blocking after Extrusion (p. 201)
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Figure 151: Initial 3D Blocking after Extrusion

In the Display tree, under Geometry, enable Points and Curves, and disable Surfaces. Under
Blocking, enable Edges and disable Vertices.

3. Split the blocks to define the length of the Shell and Hub parts.

Blocking → Split Block  → Split Block

a. From the Split Method drop-down list, select Prescribed point.

b. Click  (Select edge(s)), and then select any edge in the z-direction.

c. Click  (Select point(s)), and then select the point POINTS.16.

d. Click Apply.

e. Similarly, split the block again by selecting any edge in the z-direction and point POINTS.8.
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Step 4: Extruding the 2D Grid to Create 3D Blocking



See Figure 152: Blocks after first z-direction splits (p. 202) with display of Points disabled.

Figure 152: Blocks after first z-direction splits

4. Further splits to define the Hub part.

a. Set the Index control values as shown in the following table:

Blocking → Index Control

MaxMinDim

10I

11J

32K

00O3

00O4

10O5
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10O6

10O8

10O9

b. In the Split Block by Prescribed point DEZ, click  (Select edge(s)), and then the edge inter-
secting point POINTS.15 as shown in Figure 153: POINTS.15 and Edge for First Hub Split (p. 203).

Figure 153: POINTS.15 and Edge for First Hub Split

c. Click  (Select point(s)), and then select the point POINTS.15.

d. Click Apply.

e. Similarly, create a split passing through point POINTS.16 perpendicular to the edge as shown
in Figure 154: POINTS.16 and Edge for Second Hub Split (p. 204).
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Step 4: Extruding the 2D Grid to Create 3D Blocking



Figure 154: POINTS.16 and Edge for Second Hub Split

f. In the Display tree, enable Blocks, and then enable Solid block display and disable Whole
blocks display.

Blocking → Blocks

Blocking → Blocks → Solid

Blocking → Blocks → Whole blocks

g. Set the Index control values as shown in the following table:

MaxMinDim

20I

11J

32K

00O3

00O4

20O5
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Figure 155: Blocks after Split around the Hub Part.

5. Delete the two blocks for the Hub part.

Blocking → Delete Block .

a. Ensure that Delete permanently is disabled.

b. Click  (Select block(s)), and then select the two middle blocks.

c. Click the middle mouse button to accept.

d. Click Apply.

Deleting blocks with Delete permanently disabled simply moves blocks to the reserved part,
VORFN. These blocks can later be retrieved by enabling VORFN part, and moving to a different
part name. The nodes count on edges will remain linked across the deleted block. Deleting blocks
with Delete permanently enabled will disconnect blocks in the VORFN region, allowing different
nodes count to be set on edges across this deleted block. But it will also cause VORFN to be rebuilt
and a recalculation of the indices on all vertices. This can create a complicated index scheme,
which may cause problems further along in the blocking process. It is also used to fix index problems
that already exist since it forces a recalculation of indices.

205
Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Step 4: Extruding the 2D Grid to Create 3D Blocking



Figure 156: Hub Blocks Deleted

6. In the Index Control panel, click Reset, and then click Done.

7. In the Display tree, disable Blocks and Points; and enable Show Curve Names.

8. Associate edges around the Hub

To resolve the HUB accurately, you need to associate the edges lying on the top of the curves.

Blocking → Associate  → Associate Edge to Curve 

a. Click  (Select compcurve(s)), and then select the curve CURVES.31. See Figure 157: Four
curves for Association around the Hub (p. 207).
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Figure 157: Four curves for Association around the Hub

b. Click the middle mouse button to accept.

You may find it useful to disable Curves while selecting Edges, and vice versa.

c. Click  (Select edge(s)), and then select the edge that lies on top of CURVES.31.

d. Click the middle mouse button to accept.

e. Click Apply to complete the association.

When an edge becomes associated with a curve, it is colored green. You should confirm the asso-
ciation has occurred by temporarily disabling the display of Curves.

f. Similarly, associate the remaining curves defining the hub, CURVES.36, CURVES.28, and
CURVES.34 with the edges that lie on top of them.
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9. Associate all internal edges to their respective curves as much as possible. Internal edges are colored
blue.

Disabling and enabling the display of Curves will allow you to identify where a curve is underlying an
edge, and to confirm that your associations are completed.

You may find it useful to change the Index Control for dimension K to 2-3 when associating the edges
around the Shell part.

10. Also, associate all external edges to their respective curves.

11. Associate all vertices to their nearest geometry points wherever possible.

As with Curves and Edges, it is useful to disable one type of entity while selecting another.

12. Move all the vertices onto the geometry.

Blocking → Associate  → Snap Project Vertices 

a. Under Vertex Select, retain the selection of All Visible.

b. Click Apply.
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Figure 158: Blocking after Internal and External Edge Association

In Figure 158: Blocking after Internal and External Edge Association (p. 209), Internal Edges and Curves
have been disabled to reduce screen clutter to better see where edges have been associated to curves.

Step 5: Resolving Zero Thickness Walls

In this sequence, blocking faces are associated with geometry surfaces representing the parts Shell, Plate1
and Plate2. By making these associations, the mesh will respect these internal surfaces boundaries.

1. To reduce screen clutter, set the values of index control as shown in the following table:

MaxMinDim

30I

11J

32K
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10O3

00O4

30O5

00O6

10O8

00O9

2. Display the front view.

View → Front

3. Associate the faces to part PLATE1.

Blocking → Associate  → Associate Face to Surface .

a. In the Method list, ensure Part is selected.

b. Click  (Select face(s)).

The Select Blocking-face toolbar will appear.

Figure 159: Select Block-face toolbar with Toggle All enabled

Ensure that Toggle between all and partial enclosure is selected as shown in Figure 159: Select
Block-face toolbar with Toggle All enabled (p. 210)

c. Click , and then select the area as shown in Figure 160: Selection polygon for Association
to PLATE1 (p. 211)
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Figure 160: Selection polygon for Association to PLATE1

When using the polygon selection method, draw the polygon by clicking corner points around
the perimeter of the selection area. Click the middle mouse button to finish the polygon.

d. Click middle-mouse button to accept the polygon selection.

e. Click  (Select part(s)).

The Select parts window opens.

f. Select PLATE1 and click Accept.

g. Click Apply.

4. Similarly, associate the face identified in Figure 161: Selection polygon for Association to
PLATE2 (p. 211) with the part PLATE2

Figure 161: Selection polygon for Association to PLATE2

5. Similarly, associate the four faces with the part SHELL.
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Ensure to select the regions one by one. The Part must be SHELL for each of them.

Figure 162: Four selection rectangles for Association to SHELL

6. Check the Face to Surface associations.

a. In the Display tree, enable the display of Faces.

b. Under Faces, enable Face Projection.

Blocking → Faces → Face Projection
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Figure 163: Faces associated to Surfaces on parts PLATE1, PLATE2, and SHELL

Note:

The faces have same color as the part to which they are associated.

c. Disable the display of Faces.

7. In the Index Control window, click Reset.

Note:

The two faces corresponding to the HUB part remain disassociated.

Step 6: Defining Periodicity

Periodic functionality plays a key role in properly analyzing rotating machinery applications, for example.
Typically, only a section of the rotating machinery is modeled along with symmetry parameters, in order to
minimize the model size. By specifying a periodic relationship between the inflow and outflow boundaries
– flow characteristics at the inflow boundary must be identical to the flow characteristics at the outflow –
the section specification may be extended to the full model.

Defining periodicity in Ansys ICEM CFD requires periodic parameters such as axis location, axis orientation,
and angle to be specified. Often these parameters are applied to entities that are already defined in the
geometry (.tin) file.

Then, the periodic relationship is applied to block faces and ensures that a node on the first boundary has
identical R- and Z- coordinates to the corresponding node on the second boundary. Corresponding vertices
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Step 6: Defining Periodicity



on the two faces are selected in sequence until all vertices on both flow boundaries have been selected. At
this point, a full periodic relationship between the boundaries has been generated.

1. Check/define the periodic parameters.

Mesh → Global Mesh setup  → Set up Periodicity 

Figure 164: Periodicity Set Up DEZ

Base is a point through which the axis of rotation passes, in this case it is the origin.

Axis is a vector that defines the axis of rotation, in this case parallel to the z-axis.

Angle defines the extent of the computational domain around the axis of rotation. 360° represents
on full rotation. In this example, Angle should be 20 degrees.

2. In the Display tree, enable the display of Vertices, and then under Vertices, enable Numbers.

3. Create the periodic relationship between two vertices.

Blocking → Edit Block  → Periodic Vertices 

a. Enable Create in the Edit Block DEZ.

b. Click  (Select vert(s)) and select the vertex 411 on the periodic plane PERIODIC1.

c. Select the vertex 383 on the periodic plane PERIODIC2.
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d. Click Apply.

This will define the periodicity between two vertices.

4. Similarly, define the periodicity between all twenty vertex pairs lying on the periodic planes,
PERIODIC1 and PERIODIC2.

5. Check that the periodic relationship has been correctly setup between vertex pairs.

Blocking → Vertices → Periodic

Figure 165: Vertex Pairs defined for Periodicity

Step 7: Generating and Refining the Mesh

Before generating the mesh, meshing parameters must be defined. In this example, a multigrid mesh will be
generated. A multigrid mesh restricts the number of elements on an edge to be divisible by a power of two.
That is, for a given multigrid level, M, the number of elements must be an integer multiple of 2^M, therefore
the number of nodes will be N*(2^M) +1. For example, for multigrid level 2, the number of nodes on an edge
will be 5, 9, 13, 17 or similar. The actual number will be a function of the geometry and allowable maximum
mesh size.
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1. Define the meshing multigrid parameters.

Settings → Meshing Options → Hexa Meshing

a. Enter 2 for Multigrid level.

b. Retain the other default settings.

c. Click Apply.

2. Set the surface mesh size.

Mesh → Surface Mesh Setup 

a. Click  (Select surface(s))

b. Click  (Select all). Alternatively, press a to select all.

c. Set the Maximum size to 0.4, the Height to 0.4, and the Height ratio to 1.2.

d. Click Apply.

3. Update Sizes

Blocking → Pre-Mesh Params  → Update Sizes 

a. Ensure Update All is selected.

This will automatically determine the number of nodes on the edges from the surface mesh
sizes and multigrid level.

b. Click Apply.

4. Compute and display the Mesh.

Blocking → Pre-mesh

Allow re-compute when prompted.
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Figure 166: The Complete Initial Mesh

5. Check the mesh quality.

Blocking → Pre-Mesh Quality Histograms 

a. In the Criterion drop-down list, select Determinant 3x3x3.

b. Retain the default settings for Histogram Options.

c. Click Apply.

6. There may be negative determinants as a result of the order of vertex selection when creating
blocks to finish the 2D grid. Change the direction of inverted blocks.

Blocking → Block Checks 
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a. From the Method drop-down list, select Fix Inverted Blocks.

b. Click Apply.

Allow re-compute when prompted.

Figure 167: Determinant Histogram after Fix Inverted Blocks

Step 8: Cleaning up

Typically, many splits are required to block a complicated geometry, thereby producing many unnecessary
blocks. A large number of blocks increases the analysis computation time for multiblock solvers. When writing
a multiblock mesh output for some solvers, it is better to have the fewest number of blocks possible. You
can reduce the number of blocks by following these steps:
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Figure 168: Complete Blocking prior to Reducing the Number of Blocks

1. In the Display tree, select Init output blocks.

Blocking → Init output blocks

This will initialize the mesh to the full blocking for a multiblock mesh.

2. Enable the display of Output Blocks.

Blocking → Pre-Mesh → Output Blocks

3. Disable Pre-Mesh.

Blocking → Pre-Mesh

4. Disable the display of Vertices.
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Blocking → Vertices

5. Merge the unnecessary blocks.

Blocking → Edit Block  → Merge Blocks 

a. Select Automatic for Merge Blocks.

b. Click Apply.

Tip:

Merging blocks will normally affect the mesh, but if done after Initializing output blocks,
and displaying Output Blocks, it will not affect the mesh. It will only reduce the number
of blocks.
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Figure 169: Complete Blocking after Reducing the Number of Blocks

6. Save the blocking.

File → Blocking → Save Blocking As

Choose an appropriate filename.

7. Save the multiblock mesh.

File → Blocking → Save Multiblock Mesh

When the Multiblock dialog box appears, select the domain type Volume.

8. File → Exit

221
Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Step 8: Cleaning up



Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.222



Tetra Mesh in a Piston/Valve Assembly
In this tutorial example, you will generate and smooth a tetrahedral mesh for a piston/valve configuration.
The complete geometry is shown in Figure 170: Piston Valve Geometry (p. 224).

In the process, you will use features of Ansys ICEM CFD designed to improve your efficacy when working
with certain types of geometries. The first tool is Build Diagnostic Topology. This tool creates curves
and points from surface edges and corners depending on their proximity. It will also remove curves or
points when surfaces or curves meet below a specified shallow angle. Refer to Build Topology, under
Geometry → Repair Geometry, in the Help documentation for more detail.

Also, you will be required to define a thin cut in the Geometry to mark a region where Ansys ICEM CFD
Tetra will respect two surfaces that meet at a shallow angle. Refer to Specifying Meshing Behavior
Inside Small Angles or in Small Gaps, under Tetra Meshing → Tetra Mesh Generation Steps, in the
Ansys ICEM CFD User's Manual for more information. Similarly, Curvature/Proximity Based Refinement is
used to resolve geometries with small radius of curvature or in close proximity to one another. Refer
to Global Mesh Size, under Mesh → Global Mesh Setup, in the Help documentation for more inform-
ation on Curvature/Proximity Based Refinement.
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Figure 170: Piston Valve Geometry

This tutorial demonstrates how to do the following:

• Prepare the geometry using Build Topology and defining parts.

• Set the mesh parameters.

• Generate a tetra mesh, and compute prism layers.

• Check the mesh for errors.

Starting the Project

Step 1: Preparing the Geometry

Step 2: Setting Mesh Parameters

Step 3: Generating the Mesh

Step 4: Checking the mesh and Cleaning up

Starting the Project

1. Set up a working directory on your computer.

2. Download the pistonvalve.zip file here.
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3. Unzip the pistonvalve.zip file you have downloaded to your working directory.

4. Start Ansys ICEM CFD and create a new project in your working directory. Use an appropriate name,
for example PistonValve.

File → New Project

5. Open the geometry file (geometry.tin).

File → Geometry → Open Geometry

Note:

• If you want Ansys ICEM CFD to behave exactly as this tutorial describes, you should go to
the Settings Menu, click Selection, and disable Auto Pick Mode in the DEZ. Most experi-
enced ICEM CFD users prefer to enable Auto Pick Mode as it improves efficiency. See
Selection in the ICEM CFD Help Manual → Main Menu Area → Settings Menu for more
detail.

• Throughout this and other tutorials, Parts, Points, Curves and Surfaces may be made visible
or turned off as necessary to assist in describing the steps of the tutorial. Typically, the
default settings for visibility are sufficient for most work, and such steps are used only to
isolate specific parts for specific tasks.

Step 1: Preparing the Geometry

Initially, the geometry file described only surfaces. Build Topology is used to create curves and points from
the surface intersections. Then, parts will be defined to contain the geometry entities.

1. Build Topology.

Geometry → Repair Geometry  → Build Diagnostic Topology 

a. Set the Tolerance to a value of 0.3.

Note:

Note: The default build topology tolerance is calculated as ~1/1000th of the distance
between the min and max coordinates in the model (0.2 in this case). However, the
geometry is poor and there are many gaps greater than 0.2. If you use the default,
these gaps would be indicated by pairs of yellow (single edge, unattached) curves.
By increasing this tolerance to 0.3, build diagnostic topology will walk over these
gaps. A single red curve is placed between the edges of the surfaces indicating
topological connectivity between the surfaces, but not modifying or repairing the
surfaces. Typically, the topology tolerance is set smaller than your smallest mesh
size.

b. Leave all other defaults and click Apply.
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c. Enable Filter Curves and Filter Points, and leave the default angle at 30 degrees.

Note:

Filtered curves (or points) are made dormant if the surfaces (or curves) on either
side meet at less than the specified angle. If the surfaces (curves) meet at greater
than the specified angle, the feature curve (point) remains. Since Octree Tetra forces
the mesh to respect curves and points, removing unnecessary ones increases the
patch independence and mesh quality.

d. Click Apply.

Figure 171: Build Diagnostic Topology applied to Piston Valve Geometry

2. In the Display tree, disable Curves.

3. Create parts for the surfaces.

Parts → Create Part

a. For the Part name, enter SHROUD.

b. Click  (Select entities), and then click the curved surface at the top of the geometry.

See Figure 172: SHROUD, PORT, and CYL Identified (p. 227).

c. Click Apply.
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d. Similarly, create separate parts for PORT and CYL.

Note:

• Some parts include multiple surface entities.

• Your colors may differ from what is shown here.

Figure 172: SHROUD, PORT, and CYL Identified

e. Create separate parts for SEAT, STEM, and VALVE. See Figure 173: SEAT, STEM and VALVE
Identified (p. 228).

Tip:

In the Display tree, you can disable the display of parts already created, making it
easier to zoom in to name the remaining parts.
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Figure 173: SEAT, STEM and VALVE Identified

Note:

If a surface is missed, it may be easily added to the part using:

(partname) → Add to part

4. Optional: Create parts for curves (CUR) and points (PTS).

The curve (point) selection is simplified by enabling only curves (points) in the Display tree, and

then using  (Select all appropriate visible objects).

5. Define a Material Point.

Geometry → Create Body  → Material Point 

a. For the Part name, enter LIVE.

b. Click  (Select location(s)), and then select two locations on the PORT such that their mid-
point is inside the PORT.
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c. Click the middle mouse button.

d. Click Apply.

Dynamically rotate the model to confirm that LIVE is located within the geometry, and not outside
the geometry.

Figure 174: Piston Valve Geometry with all Parts Named

Step 2: Setting Mesh Parameters

In this sequence, you will establish mesh parameters based on geometry types, paying special attention to
regions where small radius of curvature or thin cuts may cause problems when generating the mesh.

1. Create Global Mesh parameters.

Mesh → Global Mesh Setup  → Global Mesh Size 

a. For the Scale factor, enter a value of 0.6.

b. For the Max element, enter a value of 128.

c. Enable Curvature/Proximity Based Refinement.
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Ensure the Min Size is set to 1.

Note:

Curvature/Proximity Based Refinement allows Ansys ICEM CFD to determine local
tetrahedral or triangle sizes based on the size of the features in the model. Paramet-
ers set here are used to set a local minimum size limit, the number of elements
between two geometries, or the number of segments used to define a curved edge.

d. Click Apply.

2. Specify Volume Mesh parameters.

Mesh → Global Mesh Setup  → Volume Meshing Parameters 

a. For Mesh Type, select Tetra/Mixed from the drop-down list.

b. For Mesh Method, select Robust (Octree) from the drop-down list.

c. Click Define thin cuts. The Thin cuts dialog box opens.

Note:

• A thin cut region is any region between two parts that may be thinner than the
tetrahedral mesh element defined on the parts. Defining thin cuts ensures the
surface mesh respects the two surfaces rather than have surface mesh elements
span the nodes between the surfaces.

• For successful implementation, the two parts can never touch, and in this case,
they are separated by a curve in a 3rd part.

i. Click Select. The Select part dialog box opens.

ii. Click PORT to select the first part.

iii. Click STEM to select the second part.

The Select part dialog box closes, returning you to the Thin cuts dialog box.

iv. Click Add.

The two part names will appear in the Thin cuts window.

v. Click Done to return to the Global Mesh Setup DEZ.

d. Click Apply.
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Figure 175: Region between PORT and STEM for Thin cut

Figure 175: Region between PORT and STEM for Thin cut (p. 231) shows a close-up view of the region
between the PORT and STEM parts where the Thin cut will be applied, respecting the two surfaces.

3. Specify Surface Mesh parameters.

Mesh → Surface Mesh Setup 

a. Click  (Select surface(s)).

b. With the mouse in the display area, press a to select all surfaces.

c. For Maximum Size, enter a value of 16.

Note:

Setting the maximum size on the surfaces will not affect “Curvature/Proximity Based
Refinement” set in an earlier step.

d. Click Apply.

4. Save the project.

File → Save Project

Mesh parameters will be saved along with the geometry in the tetin file.
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Step 3: Generating the Mesh

1. Create the Tetrahedral Mesh.

Mesh → Compute Mesh 

a. Ensure Mesh Type is Tetra/Mixed and Mesh Method is Robust (Octree).

b. Click Compute.

Allow the mesh generation process to complete. Look for Finished Compute Mesh in the
Message Window.

2. In the Display Tree, under Mesh, expand Shells and ensure Triangles is enabled.

Right-click Shells, and then enable Solid & Wire display for the (surface) mesh.

Zoom in on the region between PORT and STEM where the thin cut was defined, the mesh should
resemble Figure 176: Initial Mesh at PORT-STEM Intersection (p. 232). The surfaces of the PORT and
STEM are respected and the mesh elements are made smaller to resolve the short radius of curvature
of the STEM.

Figure 176: Initial Mesh at PORT-STEM Intersection

3. Display the tetrahedral volume mesh.

a. In the Display tree, enable Volumes and disable Shells.

b. Right-click Volumes, and then select Solid & Wire.

c. Right-click Mesh, mouse over Cut Plane, and then select Manage Cut Plane.
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d. In the Fraction Value box, enter a value of 0.415 (This will place the cut plane at approxim-
ately the middle of the valve stem.)

Figure 177: Tetra Volume Mesh around Valve

4. Create the Prism Mesh.

Prism layers on the surfaces allows for efficient capture of shear or boundary layer physics.

a. In the Part Mesh Setup dialog box, enable Prism for all surface parts except the SHROUD.

Mesh → Part Mesh Setup 
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Click Apply, and then Dismiss.

b. Re-compute the mesh, this time with prisms.

Mesh → Compute Mesh 

c. Enable the check box beside Compute Prism Layers.

d. Click Compute.

When reminded that the Mesh Already Exists, click Replace.

5. Display the Tetra/Prism volume mesh using the same sequence as above.
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Figure 178: Tetra/Prism Volume Mesh around Valve

Step 4: Checking the mesh and Cleaning up

In this sequence, the mesh will be checked for errors and then improved by a Linear-to-quadratic transform-
ation.

1. Check the mesh.

Edit Mesh → Check Mesh 

a. Accept all defaults.

b. Click Apply.
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c. If asked to delete unconnected vertices, click Yes.

Figure 179: Finished Mesh on the Piston-Valve

2. Save the mesh and all other associated project files.

File → Save Project

3. Close the project.

File → Close Project

4. Exit the program.
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File → Exit
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Step 4: Checking the mesh and Cleaning up



Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.238



Tetra/Prism Mesh in a Fin Configuration
In this tutorial example, you will generate and smooth a combined tet/prism mesh for the volume region
surrounding a general fin configuration, as well as for the surface of the fin. Using a mesh density region
allows finer mesh control around the leading and trailing edges of the fin. After initial mesh generation,
Laplace smoothing will be used to provide a more uniformly spaced mesh. Finally, the Hexa-Core utility
will be used to reduce the element count in the main volume.

This tutorial demonstrates how to do the following:

• Prepare the geometry.

• Set up mesh parameters.

• Generate the tetra/prism mesh.

• Check and smooth the tetra/prism mesh.

• Build the hexa-core mesh.

• Save and exit.

Starting the Project

Step 1: Creating Surface Parts and a Material Point

Step 2: Setting up Mesh Parameters

Step 3: Generating the Tetra/Prism Mesh

Step 4: Checking and Smoothing the Tetra/Prism Mesh

Step 5: Building the Hexa-Core mesh

Step 6: Saving the Project

Starting the Project

1. Set up a working directory on your computer.

2. Download the fin_config.zip file here.

3. Unzip the fin_config.zip file you have downloaded to your working directory.

4. Start Ansys ICEM CFD and create a new project in your working directory. Use an appropriate name,
for example Tetra_Fin.

File → New Project

5. Open the geometry file (geometry.tin).
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File → Geometry → Open Geometry

6. Repair the geometry.

Geometry → Repair Geometry  → Build Diagnostic Topology 

a. Accept all default parameters.

b. Click Apply.

Figure 180: Fin Configuration Geometry with Build Topology

Note:

Display of Surfaces has been enabled in the Display tree.
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Curve colors: Red indicates a curve at the intersection of two surfaces, Blue indicates a
curve at the intersection of more than two surfaces.

Note:

• If you want Ansys ICEM CFD to behave exactly as this tutorial describes, you should go to
the Settings Menu, click Selection, and disable Auto Pick Mode in the DEZ. Most experi-
enced ICEM CFD users prefer to enable Auto Pick Mode as it improves efficiency. See
Selection in the ICEM CFD Help Manual → Main Menu Area → Settings Menu for more
detail.

• Throughout this and other tutorials, Parts, Points, Curves and Surfaces may be made visible
or turned off as necessary to assist in describing the steps of the tutorial. Typically, the
default settings for visibility are sufficient for most work, and such steps are used only to
isolate specific parts for specific tasks.

Step 1: Creating Surface Parts and a Material Point

In this sequence, you will prepare the geometry for mesh creation. This includes create parts and a material
point, assigning geometry surfaces and a volume region to them.

1. In the Display tree, under Geometry, under Curves, disable the display of Show Wide.

2. Create Surface parts for the extents of the geometry.

Parts → Create Part

a. For the Part name, enter INLET.

b. Ensure  (Create Part by Selection) is selected.

c. Click  (Select entities).

d. In the Select geometry toolbar, toggle OFF Selection of Points , Curves  and Bodies

.

e. Click to select the surface for the INLET part, and then click the middle mouse button to accept
the selection.

See Figure 181: Part names for External Surfaces (p. 242).

f. Click Apply to complete the part creation.
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Step 1: Creating Surface Parts and a Material Point



Figure 181: Part names for External Surfaces

Note:

Surface colors are assigned when the part name is applied.

g. Similarly create parts for OUTLET, SYMM and BOX.

3. Create Surface parts for the Fin geometry.

Create parts for LEAD, PRESS (the lower surface of the fin), SUCT (the upper surface), TIP, and
TRAIL as shown in Figure 182: Part names for Fin Surfaces (p. 243).

Tip:

You may find it useful to disable the display of curves and previously created surface
parts when creating these surface parts on the fin geometry.
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Figure 182: Part names for Fin Surfaces

Note:

Curves and Points will remain in the GEOM part, which is simplest for this tutorial. In
practice, you may want to add the curves and points into parts along with the surfaces.

4. Create a Material point for the volume region that lies within the BOX, surrounding the fin.

Geometry → Create Body  → Material Point 

a. For the Part name, enter FLUID.

b. Click  (Select location(s)).

c. Select two locations such that their midpoint is within the region inside the box. For example,
choose one on the fin tip and one at a box corner.

d. Click the middle mouse button to accept.

e. Click Apply.

Step 2: Setting up Mesh Parameters

Maximum mesh sizes on various surfaces and volumes are defined. First the Global Mesh parameters are
defined, then further refinement is applied individually to surfaces and a Density region.

1. Set Global Mesh Size.

Mesh → Global Mesh Setup  → Global Mesh Size 

a. For Max element, enter a value of 32.
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b. For Scale factor, enter a value of 1.

This parameter is referred to by other mesh parameters. The Scale factor allows you to globally
control the mesh size instead of changing the mesh size on each and every entity. For more inform-
ation, refer to Global Mesh Size, under Mesh → Global Mesh Setup, in the Help documentation
for more information.

c. Click Apply.

2. Set Surface Mesh parameters on the external surfaces.

Mesh → Surface Mesh Setup 

a. Click  (Select surface(s)), and then click the six surfaces that form the external box structure.

Click the middle mouse button to accept.

b. For the Maximum size, enter 4. Leave all other default values.

c. Click Apply.

3. Set Surface Mesh parameters on the fin surfaces.

a. Still in the Surface Mesh Setup DEZ, click  (Select surface(s)).

b. In the Select geometry popup toolbar, click  (Select items in a part).

c. In the Select part dialog box, select LEAD, TRAIL, PRESS, SUCT, and TIP. Click Accept.

d. For the Maximum size, enter 1. Leave all other default values.

e. Click Apply.

4. Set Curve Mesh parameters.

Mesh → Curve Mesh Setup 

Note:

All curves are in the GEOM part.

a. Click  (Select curve(s)).

b. In the Select geometry popup toolbar, click  (Select items in a part).

c. In the Select part dialog box, select GEOM, and then click Accept.
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d. For the Maximum size, enter 0. Leave all other default values.

If the Maximum size is set to 0, this effectively unsets the curve maximum size, allowing adjacent
surface sizes alone to control the mesh.

Click Apply.

5. Create Mesh Density regions at the leading and trailing surfaces of the fin.

A density region allows you to set a local maximum size within a portion of the volume. This is useful
for locally increasing refinement to better capture flow details without needing to refine the entire mesh.

Mesh → Create Mesh Density 

a. Size = 0.0625

b. Ratio = 0, and

c. Width = 4.

d. For the Density Location From, choose Points.

e. Click  (Select location(s)), and then select two points from the screen that define the surface
LEAD.

Select one point at the base of the fin, centered on the leading edge; and one point at the
tip of the fin, also centered on the leading edge. See Figure 183: Two Points on LEAD sur-
face (p. 245).

Figure 183: Two Points on LEAD surface

f. Click middle mouse button to complete the selection.

g. Click Apply.
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h. Similarly, create a Mesh Density region at the trailing surface of the fin.

Figure 184: Fin with Density Regions added to Leading and Trailing Edges

Note:

The density region is created as a cylindrical volume of radius Width x Size. To control the
growth ratio away from the density region, set a value for Ratio. Setting Ratio to 0 uses a
default of 1.2.

6. Set meshing parameters by Parts.

Mesh → Part Mesh Setup 

In the Part Mesh Setup dialog box:

a. Enable Prism for the fin parts (LEAD, PRESS, SUCT, TIP and TRAIL).

b. Enable Hexa-core for the material part (FLUID).

c. Set Maximum size to 4 for the part FLUID.

d. Select Apply, and then Dismiss.
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Figure 185: Dialog Box for Part Mesh Setup

Note:

All sizes on all parts could have been set in this dialog box. Most experienced users
prefer this for efficiency. When set using the Part Mesh Setup dialog box, sizes apply
to all entity types (curves and surfaces) within each part.

7. Save your project before generating the mesh. This will also save changes to geometry (tetin) file,
including the mesh parameters setup in this sequence.

File → Save Project

Step 3: Generating the Tetra/Prism Mesh

The initial tetra/prism mesh is generated and examined using a cut plane.

1. Create the mesh.

Mesh → Compute Mesh  → Volume Mesh 

a. For Mesh Type, select Tetra/Mixed from the drop-down list.

b. For Mesh Method, select Robust (Octree) from the drop-down list.

c. Enable Create Prism Layers.

d. Leave all other default values.
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Step 3: Generating the Tetra/Prism Mesh



e. Click Compute.

Note:

The default prism parameters (Mesh ; Global Mesh Setup ; Prism Meshing Params)
indicate 3 prism layers using the local prism thickness based on the surface triangle
size (as no initial height is specified).

2. View a cut plane at the leading surface of the fin.

Mesh → Cut Plane → Manage Cut Plane

Mesh → Volumes → Solid & Wire

Also, in the Display tree, enable Surfaces, and then disable INLET, OUTLET, BOX, and SYMM.

a. For Method, select Middle X plane from the drop-down list.

b. Use the scroll wheel to move the cut plane.

Zoom, pan, and rotate using left, middle, and right mouse buttons.
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Figure 186: Cut Plane View for Initial Tetra/Prism Mesh

Note:

In this cutplane view, the sides of the prism layers appear as smooth, regular, four-sided
figures.

The Density regions at the leading and trailing edges of the fin increases resolution with a
smaller local maximum size on surface and volume elements within the region.

Step 4: Checking and Smoothing the Tetra/Prism Mesh

In this sequence, automated error checking and smoothing are used to improve the mesh before converting
to Hexa-core.

1. Error checking the mesh.

Edit Mesh → Check Mesh 

a. Accept the default settings.

If asked to delete disconnected vertices, click Yes.

b. Click Apply.
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2. Smooth the mesh

Edit Mesh → Smooth Mesh Globally 

Figure 187: Initial Quality Histogram for Tetra/Prism Mesh

Several elements have a lower quality than the "acceptable" value of 0.3.

a. For Smoothing Iterations, enter a value of 5.

b. For Up to Value, enter a value of 0.4.

c. For Criterion, select Quality from the drop-down list.

d. In the Smooth Mesh Type selection box,

i. Select Smooth for TETRA_4, TRI_3, and QUAD_4.

ii. Select Freeze for PENTA_6.

Note:

By initially freezing the Penta_6 layer, you can smooth the rest of the tetra/tri
mesh without damaging the prism layer, which is important to capture the
boundary layer physics.

e. Click Apply.

A new histogram appears, showing some changes have occurred.

3. Re-run the smoothing, this time including the PENTA_6 elements.

a. Change the Up to Value to 0.2 to prevent dramatic distortion of the prism layers.

b. Select Smooth for the PENTA_6 type.

c. Click Apply.
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Figure 188: Quality Histogram for Tetra/Prism Mesh after Smoothing

4. Find data for Mesh comparison.

Info → Mesh Info

Scroll through the message window to find the number of elements in the FLUID part (the tetra
and prism volume elements belong to this part). You should see a number greater than 700,000.

5. Save the Project.

File → Save Project

Step 5: Building the Hexa-Core mesh

In this sequence, tetra mesh elements that are not close to any geometry features are replaced with hexa
elements, reducing the total number of elements.

1. Enable Hexa-Core meshing.

Mesh → Compute Mesh  → Volume Mesh 

a. For Mesh Type, select Tetra/Mixed from the drop-down list.

b. For Mesh Method, select Quick (Delauney) from the drop-down list.

c. Enable Create Hexa Core.

Disable Create Prism Layer.

d. Under Input, select Existing Mesh from the drop-down list.

e. Enable Load mesh after completion.

f. Click Compute.

This will replace the core volume elements with Hexa elements of a size = 4.0 as set earlier.

See Figure 189: Cut Plane View of Hexa Core Mesh (p. 252).
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Step 5: Building the Hexa-Core mesh



Figure 189: Cut Plane View of Hexa Core Mesh

2. Save the project using a new name, for example, Hexa_Fin. This preserves the original tetra/prism
mesh in one project, the hexa-core mesh in another.

File → Save Project As

3. Repeat the Checking and Smoothing steps completed earlier.

Edit Mesh → Check Mesh 

Edit Mesh → Smooth Mesh Globally 
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Figure 190: Quality histogram for Hexa-Core mesh

4. Find data for mesh comparison.

Info → Mesh Info

Scroll through the message window to find the number of elements in the FLUID part (this part
now includes the hexa elements as well as tetra and prism). This time you should see a number
less than 200,000.

Step 6: Saving the Project

1. Save the mesh.

File → Save Project

2. Close the project.

File → Close Project

3. Exit the program.

File → Exit
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Tetra/Prism Mesh Generation for an Aorta
This tutorial demonstrates the generation of a tetra/prism mesh for an aorta, starting from STL data.

The aorta geometry used in this tutorial is courtesy of Marc Horner, an Ansys, Inc. engineer, and Mater-
ialise Inc., who extracted the geometry from the MRI scan images.

Figure 191: Aorta Geometry

This tutorial demonstrates how to do the following:

• Import STL data into Ansys ICEM CFD.

• Prepare the geometry by creating parts and a material point.

• Set up global and part parameters for meshing.

• Generate the mesh using the Octree approach.

• Generate the mesh using the Delaunay approach.

• Examine the mesh using cut-planes.

• Smooth the mesh to improve the mesh quality.

Starting the Project

Step 1: Preparing the Geometry

Step 2: Setting the Mesh Parameters

Step 3: Generating the Octree Mesh

Step 4: Generating the Delaunay Mesh
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Step 5: Saving the Project

Further Setup

Starting the Project

1. Set up a working directory on your computer.

2. Download the aorta.zip file here.

3. Unzip the aorta.zip file you have downloaded to your working directory.

4. Start Ansys ICEM CFD and create a new project in your working directory. Use an appropriate name,
for example Tetra_Aorta.

File → New Project

5. Import the geometry (Aorta.stl).

File → Import Geometry → Faceted → STL

a. Select the STL file (Aorta.stl) in the Open dialog box and click Open.

The STL import options dialog will appear.

b. Retain the selection of Generate for Part names and click Done.

The imported geometry will be displayed in the graphics window.

c. Select  (Solid Full Display) from the Solidframe Display Options menu.
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Figure 192: The Aorta Geometry

Note:

If you want Ansys ICEM CFD to behave exactly as this tutorial describes, you should go to
the Settings Menu, click Selection, and disable Auto Pick Mode in the DEZ. Most experienced
ICEM CFD users prefer to enable Auto Pick Mode as it improves efficiency. See Selection in
the ICEM CFD Help Manual → Main Menu Area → Settings Menu for more detail.

Step 1: Preparing the Geometry

The imported geometry comprises a single part. You will split the geometry and define the parts and a ma-
terial point in this step.

1. Split the geometry.

Geometry → Create/Modify Surface  → Segment/Trim Surface 
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Step 1: Preparing the Geometry



a. Select By Angle from the Method drop-down list.

b. Click  (Select surface(s)) and select the aorta surface. Click the middle-mouse button to
accept the selection.

c. Enter 35 for Angle and click Apply.

2. Create the INLET part.

Parts → Create Part

a. Enter INLET for Part in the Create Part DEZ.

b. Retain the selection of  (Create Part by Selection) and click  (Select entities).

The Select geometry toolbar will appear.

c. Select the inlet surface (Figure 193: Aorta—Parts (p. 259)) and click the middle-mouse button
to accept the selection.

d. Click Apply.

3. Create the OUTLETS part.

a. Enter OUTLET for Part in the Create Part DEZ.
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b. Click  (Select entities) and select the outlet surfaces (Figure 193: Aorta—Parts (p. 259)). Click
the middle-mouse button to accept the selection.

Tip:

Use the Toggle dynamics (hotkey F9) option to toggle between selection mode
and dynamic mode to better orient the geometry for easier selection of entities.
You can also hold down the Ctrl key to toggle between selection mode and dynamic
mode.

c. Click Apply.

Note:

You could also create a unique part for each output surface for easier display/selec-
tion in the solver.

Figure 193: Aorta—Parts

4. Rename the part comprising the arterial wall to AORTA_WALL.

Parts → AORTA.MESH.PART.1 → Rename

• Enter AORTA_WALL in the New name dialog and click Done.

5. Extract the feature curve from the inlet and outlet surfaces.

Geometry → Create/Modify Curve  → Extract Curves from Surfaces 
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a. Expand the Parts section of the tree and deselect AORTA_WALL.

Parts → AORTA_WALL

The graphics display shows only the inlet and outlet surfaces.

b. Click  (Select surface(s)) and then  (Select all appropriate visible objects) in the Select
geometry toolbar.

All the inlet and outlet surfaces will be selected.

c. Select Create New in the Extract Edges list.

d. Click Apply.

6. Enable AORTA_WALL in the Parts section of the tree.

Parts → AORTA_WALL

7. Select  (WireFrame Simple Display) to restore the wireframe display.

8. Create the Material Point

Geometry → Create Body 
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a. Enter FLUID for Part.

b. Retain the selection of Centroid of 2 points for Location.

c. Click  (Select location(s)) and select two locations such that the midpoint lies within the
volume (see Figure 194: Selection of Points for Creating Material Point (p. 261)). Click the middle-
mouse button to accept the selection of the points.

Figure 194: Selection of Points for Creating Material Point

d. Click Apply.
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The FLUID part appears under Parts in the display control tree. Select  (WireFrame Full Display)
and rotate the geometry to confirm that the new material point is within the volume and does not
just appear so from one perspective.

9. Click  (Solid Full Display) to restore the shaded surface visualization.

Step 2: Setting the Mesh Parameters

1. Measure the smallest diameter on the aorta geometry.

You will use this value to set the minimum size for the mesh.

a. Zoom in to the smallest diameter in the graphics display.

b. Click  (Measure Distance) and select a pair of locations to measure the diameter (Fig-
ure 195: Measuring the Smallest Diameter (p. 262)).

Figure 195: Measuring the Smallest Diameter

The distance is reported to be around 1.5.

2. Assign the mesh sizes.

Mesh → Global Mesh Setup  → Global Mesh Size 
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a. Enter 2 for Max element.

b. Select Enabled for Curvature/Proximity Based Refinement and enter 0.5 for Min size
limit.

c. Set Refinement to 18.

d. Click Apply.

3. Specify the parts for prism creation.

Mesh → Part Mesh Setup 

a. Enable Prism for AORTA_WALL.

b. Retain the default settings for other parameters.
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Step 2: Setting the Mesh Parameters



c. Click Apply and then Dismiss.

The prism height is set to zero which allows it to “float”. The prisms will have a variable thickness
calculated to reduce the volume change between the last prism and the adjacent tetra.

4. Modify the global prism settings.

Mesh → Global Mesh Setup  → Prism Meshing Parameters 
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a. Set the Number of volume smoothing steps to 0.

b. Retain the default settings for the other parameters and click Apply.
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Step 2: Setting the Mesh Parameters



Step 3: Generating the Octree Mesh

1. Compute the mesh.

Mesh → Compute Mesh  → Volume Mesh 

a. Ensure that the Mesh Method is set to Robust (Octree).

b. Enable Create Prism Layers.

c. Click Compute.

The progress will be reported in the message window.

2. Examine the mesh (Figure 196: Octree Mesh for the Aorta (p. 267)).

a. Disable the display of surfaces.

Geometry → Surfaces

b. Select Solid & Wire.

Mesh → Shells → Solid & Wire
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Figure 196: Octree Mesh for the Aorta

Note:

Some solvers may not like the volume transitions in the Octree mesh. Step 4 explains
how you can replace the Octree volume mesh with a Delaunay volume mesh for
smoother volume transition.

3. Use cut planes to examine the mesh.

a. Select Wire Frame.

Mesh → Shells → Wire Frame

b. Select Manage Cut Plane.

Mesh → Cut Plane... → Manage Cut Plane

c. Set the following parameters:

i. Retain the selection of by Coefficients in the Method drop-down list.

ii. Set Fraction Value to 0.95.

iii. Click Apply.

d. Enable the display of volumes in the display control tree.

Mesh → Volumes
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Step 3: Generating the Octree Mesh



e. Select Solid & Wire.

Mesh → Volumes → Solid & Wire

Zoom in to view the cut plane (Figure 197: Cut Plane in Z Direction for the Octree Mesh (p. 268)).

Figure 197: Cut Plane in Z Direction for the Octree Mesh

f. Examine the mesh using a cut plane in the X direction.

i. Select Middle X Plane in the Method drop-down list.

ii. Set Fraction Value to 0.62.

iii. Click Apply.

Manipulate the display to obtain the view shown in Figure 198: Cut Plane in X Direction for
the Octree Mesh (p. 269).
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Figure 198: Cut Plane in X Direction for the Octree Mesh

g. Disable Show Cut Plane in the Manage Cut Plane DEZ.

4. Smooth the mesh.

The smoothing approach involves initial smoothing of the interior elements without adjusting the prisms.
After initial smoothing, you will smooth the prisms as well.

Edit Mesh → Smooth Mesh Globally 

The quality histogram appears in the right hand corner.
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Step 3: Generating the Octree Mesh



a. Enter 20 for Smoothing iterations and 0.2 for Up to value.

b. Retain the selection of Quality in the Criterion drop-down list.

c. Select Freeze for PENTA_6.

d. Retain the other settings and click Apply.

The quality histogram will be updated.

e. Enter 5 for Smoothing iterations and 0.01 for Up to value.

f. Select Smooth for PENTA_6.

g. Click Apply.

The quality histogram will be updated accordingly (Figure 199: Histogram—Quality After Smooth-
ing (p. 270)).

Figure 199: Histogram—Quality After Smoothing
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5. Check the mesh for any errors that may cause problems during the analysis.

Edit Mesh → Check Mesh

a. Retain the default set of checks.

b. Click Apply to check for errors and possible problems in the mesh.

Make sure no errors/problems are reported during the check.

Step 4: Generating the Delaunay Mesh

In this step, you will replace the Octree mesh with the Delaunay mesh because it has a smoother volume
transition.

1. Set the volume mesh parameters.

Mesh → Global Mesh Setup  → Volume Meshing Parameters 
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Step 4: Generating the Delaunay Mesh



a. Select Quick (Delaunay) from the Mesh Method drop-down list.

b. Retain the other settings and click Apply.

2. Compute the mesh.

Mesh → Compute Mesh  → Volume Mesh 
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a. Ensure that Quick (Delaunay) is selected in the Mesh Method drop-down list.

b. Disable Create Prism Layers.

The Create Prism Layers option can be disabled as the prisms were already generated during the
Octree mesh generation.

c. Ensure that Existing Mesh is selected in the Select drop-down list.

d. Ensure that Load mesh after completion is enabled.

e. Click Compute.

The progress will be reported in the message window.

3. Examine the mesh using cut planes.

a. Examine the mesh using a cut plane in the Z direction.

Manipulate the display to obtain the view shown in Figure 200: Cut Plane Z Direction for the
Delaunay Mesh (p. 274).
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Step 4: Generating the Delaunay Mesh



Figure 200: Cut Plane Z Direction for the Delaunay Mesh

b. Examine the mesh using a cut plane in the X direction.

Manipulate the display to obtain the view shown in Figure 201: Cut Plane in X Direction for the
Delaunay Mesh (p. 274).

Figure 201: Cut Plane in X Direction for the Delaunay Mesh

From Figure 200: Cut Plane Z Direction for the Delaunay Mesh (p. 274) and Figure 201: Cut Plane
in X Direction for the Delaunay Mesh (p. 274), you can see that the mesh transition is now
much smoother.
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4. Smooth the mesh.

As the prisms were smoothed in the previous step, you will smooth the other elements without adjusting
the prisms.

Edit Mesh → Smooth Mesh Globally 

a. Enter 20 for Smoothing iterations and 0.2 for Up to value.

b. Retain the selection of Quality in the Criterion drop-down list.

c. Select Freeze for PENTA_6.

d. Retain the other settings and click Apply.

The quality histogram will be updated.

5. Check the mesh for any errors that may cause problems during the analysis.

Edit Mesh → Check Mesh

Step 5: Saving the Project

1. Save the geometry and mesh.

File → Save Project As...

2. Select the solver.

Output Mesh → Select solver 

a. Select Ansys Fluent from the Output Solver drop-down list.

b. Click Apply.

3. Set the appropriate boundary conditions.
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Step 5: Saving the Project



Output Mesh → Boundary conditions 

a. Set the boundary condition for AORTA_WALL to wall.

i. Click Create new under AORTA_WALL.

ii. Select wall from the list of Boundary Conditions in the Selection dialog box.

iii. Click Okay.

iv. Enter the required zone ID.

b. Similarly, set the boundary conditions for INLET to velocity-inlet  and OUTLETS to pressure-
outlet, exhaust-fan, outlet-vent.

c. Set the boundary conditions for FLUID to fluid.
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d. Click Accept after setting the boundary conditions.

Note:

Mixed/unknown refers to the dimension of the elements in a part. If a part contains
all volume elements, it clearly belongs in the Volumes branch. Similarly, parts in
the Surfaces branch should contain only shell elements, and the Edges branch
should contain only curve elements, and so on. However, if a part has a mixture of
surfaces, curves and points, then the mesh will contain a mixture of element types
and the part will be located in the Mixed/unknown branch of the tree. If you apply
wall properties, these are applied to the shells in that part only.

4. Write the input file for Ansys Fluent.

Output Mesh → Write input 

a. Select the appropriate .uns file.
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Step 5: Saving the Project



The Ansys Fluent dialog will appear.

b. Select Yes for Scaling and enter 0.001 for x scaling factor, y scaling factor, and z scaling
factor, respectively.

The mesh was created in units of millimeters (mm), and hence needs to be scaled to meters.

c. Retain the default settings for other parameters.

d. Enter aorta for Output file.

e. Click Done.

Note:

You can read the saved mesh file in Ansys Fluent and proceed to setup and solve for
transient, laminar flow.

Further Setup

You can solve this example for transient, laminar flow using Ansys Fluent. A basic setup could include
the following:

• Material properties

– Density: 1060 kg/m3

– Viscosity: 0.0035 kg/m-s

• Solver setup: transient, laminar flow
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• Boundary conditions

– The transient velocity profile (one cycle) is available with the tutorial example file (AorticIn-
flowWaveform.prof). The profile assumes a cardiac output of 6.8 l/min and 75 beats per minute.

Note:

Run at least 1.5 cycles to remove the effects of the initial condition.

– Assume zero pressure at the outlets.

• Post-processing

– The periodic solution can be visualized by plotting the inlet pressure for 3 cycles.

– Other results of interest include wall shear, static pressure on the wall, and velocities along the
length.

A more advanced setup could include two-way FSI, which can be done using Ansys.
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Prism Options in a Hybrid Mesh for a Helicopter
This tutorial demonstrates some prism options in a hybrid tetra/prism mesh for a helicopter.

Note:

The far-field used in the tutorial is smaller than normal to reduce the runtime.

Figure 202: Helicopter Geometry

This tutorial demonstrates how to do the following:

• Prepare the geometry for meshing.

• Set up mesh parameters.

• Generate the starting tetrahedral mesh.

• Generate prisms using the ICEM CFD post-inflation process.

• Generate prisms using the Fluent pre-inflation process.

• Modify mesh parameters on a part-by-part basis.

Starting the Project
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Step 1: Preparing the Geometry

Step 2: Setting the Mesh Parameters

Step 3: Generating the Tetrahedral mesh

Step 4: Generating Post Inflation Prism Layers

Step 5: Generating Pre Inflation Prism Layers

Step 6: Part-by-part Prism Meshing Parameters

Starting the Project

1. Set up a working directory on your computer.

2. Download the helicopter.zip file here.

3. Unzip the helicopter.zip file you have downloaded to your working directory.

4. Start Ansys ICEM CFD and create a new project in your working directory. Use an appropriate name,
for example Helicopter.

File → New Project

5. Open the geometry file (helicopter.tin).

File → Geometry → Open Geometry

Note:

If you want Ansys ICEM CFD to behave exactly as this tutorial describes, you should go to
the Settings Menu, click Selection, and disable Auto Pick Mode in the DEZ. Most experienced
ICEM CFD users prefer to enable Auto Pick Mode as it improves efficiency. See Selection in
the ICEM CFD Help Manual → Main Menu Area → Settings Menu for more detail.

Step 1: Preparing the Geometry

In most cases, you would put the parts comprising the helicopter fuselage into a single part. In this
tutorial, separate parts will be retained to support localized mesh density settings.

Build Topology is used to check surface connectivity, and a Material Point will be added to identify
the volume mesh region.

1. Check surface conectivity using Build Topology.

Geometry → Repair Geometry  → Build Topology 

a. Enable Filter points and Filter curves in the Filter by angle group box.

b. Leave the default values in all other settings.

c. Click Apply.
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Most curves turn red indicating a boundary between two surface parts.

2. Examine the helicopter body parts.

a. Enable Surfaces under Geometry in the display control tree.

Geometry → Surfaces

b. Zoom in to the helicopter fuselage and examine the geometry.

Two curves within the tail part are yellow indicating attachment to a single surface. The
problem is due to an overlapping sliver surface as shown in Figure 203: Overlapped Sliver
Surface (p. 283).

Figure 203: Overlapped Sliver Surface

3. Delete the small overlapped surface.

Geometry → Delete Surface 

a. Click  (Select surface(s)) and click the small triangular surface within the yellow curves.

b. Click the middle mouse button to accept.

c. Click Apply.

4. Recheck surface connectivity using Build Topology. Use the same settings as before.

Now all curves are red including where the overlapped surface was removed.
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Step 1: Preparing the Geometry



5. Create a Material Point

Geometry → Create Body 

a. Enter FLUID for Part.

b. Retain the selection of Centroid of 2 points for Location.

c. Click  (Select location(s)) and select two locations such that the midpoint lies within the
volume (one on the symmetry surface and other on the far-field surface, see Figure 204: Selec-
tion of Points for Creating Material Point (p. 285)). Click the middle-mouse button to accept
the selection of the points.
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Figure 204: Selection of Points for Creating Material Point

d. Click Apply so that FLUID appears under Parts in the display control tree.

Step 2: Setting the Mesh Parameters

A relatively large Global mesh size will be defined to allow for coarser mesh away from the fuselage.
The surface of the helicopter body requires finer mesh. Finally, prisms will be enabled to better capture
boundary layer effects.

1. Assign the global mesh sizes.

Mesh → Global Mesh Setup  → Global Mesh Size 

a. Retain the value of 1 for Scale factor.

b. Enter 1024 for Max element.

The value for Max element is chosen to be 1024 because it is a power of two which is important
for Octree mesh generation.

c. Click Apply.

2. Specify the global prism meshing parameters.
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Step 2: Setting the Mesh Parameters



Mesh → Global Mesh Setup  → Prism Meshing Parameters 

a. Set Height ratio to 1.2 and Number of layers to 4.

b. Set Prism height limit factor to 1.

c. Scroll to the bottom and click Advanced Prism Meshing Parameters.

Enable Auto Reduction in the dialog box.

d. Click Apply and then Dismiss.

3. Set surface mesh parameters on the helicopter body parts.

Mesh → Surface Mesh Setup 

a. Click  (Select surface(s)) and then select the entire helicopter body.

You may find the box select tool useful for this. It may also help to turn off the FARFIELD and
FLUID parts in the Display tree.

b. Set the Maximum size to 64.

c. Click Apply.

Step 3: Generating the Tetrahedral mesh

A tetrahedral mesh is calculated using the fast and robust Octree method. This allows for a consistent
starting mesh for prism option comparison.

1. Compute the tetrahedral mesh.

Mesh → Compute Mesh  → Volume Mesh 

a. Ensure that the Mesh Type is set to Tetra/Mixed.

b. Ensure that the Mesh Method is set to Robust (Octree).

c. Initially, ensure Create Prism Layers is not checked.

d. Click Compute.

The progress of meshing will be reported in the message window.

2. Examine the mesh (Figure 205: Initial Tri Surface Mesh on Helicopter (p. 287)). To reduce graphics
clutter, disable the display of surfaces, and disable the FARFIELD and FLUID parts.

Geometry → Surfaces
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Parts → FARFIELD

Parts → FLUID

Figure 205: Initial Tri Surface Mesh on Helicopter

Figure 205: Initial Tri Surface Mesh on Helicopter (p. 287) shows the surface triangles on the helicopter
body and symmetry plane. The various colors are matched to the part names in the display tree.

Step 4: Generating Post Inflation Prism Layers

In this step, you will add boundary layers using the ICEM CFD post inflation method. This method first
generates the tetrahedral volume mesh, then replaces volume elements adjacent to the surfaces of se-
lected parts with prism layers. The advantage of the post inflation method is its robustness, particularly
if the Octree method is used for the initial volume fill.

1. Enable prisms and verify mesh size parameters on the helicopter surface parts. The Part Mesh
Setup dialog box is used for efficiency.

Mesh → Part Mesh Setup 

a. Enable Prisms for all parts associated with the helicopter body. FARFIELD, FLUID, and SYMPLANE
remain disabled.
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Step 4: Generating Post Inflation Prism Layers



b. Ensure FARFIELD and SYMPLANE have Maximum size set to 1024. Ensure helicopter parts
have Maximum size set to 64.

Note:

FLUID has Maximum size set to 0 indicating the size will be set by other parts. You
could also use 0 for FARFIELD and SYMPLANE to allow the global maximum to set
the size.

c. Click Apply and then Dismiss.

2. Recompute the volume mesh, this time with Create Prism Layers enabled.

Mesh → Compute Mesh  → Volume Mesh 
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The progress will be reported in the message window. The existing mesh first disappears. Partway
through the process, the tet mesh reappears. At the end, the triangles near the helicopter are replaced
as the prism layers are computed.

3. Examine the mesh.
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Step 4: Generating Post Inflation Prism Layers



a. In addition to the visual inspection, you can check mesh quality statistics using the Quality
Metrics.

Edit Mesh → Display Mesh Quality 

b. You can choose which elements to check using Mesh types to check. Select Yes for the
volume elements (TETRA_4 and PENTA_6).

c. You can choose the Criterion. Select Quality.

d. Click Apply.

The quality statistics are displayed along with the quality histogram.

Tip:

If you click the histogram bars, the cells with the selected quality range will be
highlighted. For example, if you display the quality for only the PENTA_6 elements
and click the lowest bar(s), you will see the lowest quality prisms occur in the region
of high curvature around the TAIL part.

Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.290

Prism Options in a Hybrid Mesh for a Helicopter



On the histogram, right-click and select Done to close it.

Step 5: Generating Pre Inflation Prism Layers

In this step, you will add boundary layers using the Fluent meshing, pre inflation method. This method
first generates a triangular surface mesh (if one is not available), then creates the prism layers into the
volume, and finally fills the remaining volume with tetrahedral cells. The advantages of the pre inflation
method are that it is typically faster and yields smoother prisms than the post inflation method. It also
supports hex core volume fill.

Mesh → Compute Mesh  → Volume Mesh 
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1. In the Compute Mesh DEZ:

a. For Mesh Method, select Fluent Meshing.

b. Enable Create Prism Inflation Layers and select the Pre Inflation (Fluent Meshing) inflation
method.

c. Click Compute.

2. Examine the mesh.
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The existing surface triangles are the starting point for the pre inflation process, so there is no visual
difference in surface mesh. However, statistically, there are significantly fewer cells in the final volume
mesh and the initial quality distribution shows wider range of values.

Step 6: Part-by-part Prism Meshing Parameters

In this section, you will modify the prism meshing parameters on a part-by-part basis. Settings made
in the Part Mesh Setup dialog box will override the global parameters set initially. Using the Part Mesh
Setup dialog box is more efficient than using equivalent surface mesh setup and curve mesh setup
DEZ.

Mesh → Part Mesh Setup 

1. The lowest quality prisms were found in regions of high curvature. If the surface mesh size is reduced
in these regions, more cells will be generated, but with overall better quality.

Reduce the Maximum size on the NOSE, TAIL and WINDSHIELD to 32.

2. To reduce the variation in the overall height of the prism layers, the layer thickness is reduced over
large surface mesh and increased over small surface mesh.

Set the Prism height limit factor to 0.5 on the ...BODY parts and 2.0 on the NOSE, TAIL and WIND-
SHIELD.
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3. The pre inflation process requires a starting surface mesh. Recompute the volume mesh using the
Robust (Octree) method with Create Prism Layers disabled.

Notice the finer surface mesh on the NOSE, WINDSHIELD and TAIL parts.

4. Now recompute the inflation layers using the Fluent meshing, pre inflation method. The prisms
look smoother and the overall quality is improved.
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5. Save any work and exit the current session.

File → Exit
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Merged Tetra-Hexa Mesh in a Hybrid Tube
In this tutorial, you will generate a mesh for a “Hybrid Tube”. This tube consists of three regions (CYL1,
CYL2, and CYL3), separated by two interfaces (INTERFACE1 and INTERFACE2). The geometry is shown
in Figure 206: Hybrid Tube Geometry showing Three Sections and Part Names (p. 297).

The process will generate tetrahedral domains in CYL1 and CYL2 and a hexahedral domain in CYL3. The
three domains will then be made conformal at the two interfaces. The following are requirements for
a successful merge:

• You may select multiple surface mesh parts to merge. The interfaces on both sides of the merge
do not need to be in the same part, although often that is easier to organize.

• The merge function can handle many interfaces between two or more meshes, including curved
interfaces. However, all the elements in the selected parts must be involved in the merge.

• The perimeters of all the interface parts must be associated to curves that are aligned (or even
on the same curve) on both sides of the interface.

• When two meshes are merged, at least one must be tetra/tri mesh.

See Merge Meshes, under Edit Mesh → Merge Nodes, in the Help documentation for more information.

Figure 206: Hybrid Tube Geometry showing Three Sections and Part Names

The steps to complete this tutorial are listed:

• Set up appropriate mesh parameters.

• Generate independent tetrahedral meshes in Cyl1 and Cyl2 regions.

• Make the two meshes conformal at the Interface1 boundary.

• Generate a structured hexa mesh in Cyl3 region.

• Merge the hexa mesh and tetra mesh at the Interface2 boundary.
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Starting the Project

Step 1: Setting the Mesh Parameters

Step 2: Generating the Tetra Mesh in CYL1

Step 3: Generating the Tetra Mesh in CYL2

Step 4: Merging the Tetra Mesh between CYL1 and CYL2

Step 5: Generating the Hexa Mesh in CYL3

Step 6: Merging the Tetra Mesh with Hexa Mesh at Interface2

Step 7: Cleaning up and Saving the Project

Starting the Project

1. Set up a working directory on your computer.

2. Download the hybridtube.zip file here.

3. Unzip the hybridtube.zip file you have downloaded to your working directory.

4. Start Ansys ICEM CFD and create a new project in your working directory. Use an appropriate name,
for example HybridTube.

File → New Project

5. Open the geometry file (geometry.tin).

File → Geometry → Open Geometry

Note:

• If you want Ansys ICEM CFD to behave exactly as this tutorial describes, you should go to
the Settings Menu, click Selection, and disable Auto Pick Mode in the DEZ. Most experi-
enced ICEM CFD users prefer to enable Auto Pick Mode as it improves efficiency. See
Selection in the ICEM CFD Help Manual → Main Menu Area → Settings Menu for more
detail.

• Throughout this and other tutorials, Parts, Points, Curves, Surfaces, and their identifying
labels may be made visible or turned off as necessary to assist in describing the steps of
the tutorial. Typically, to avoid screen clutter, the default settings for visibility are sufficient
for most work; and such steps are used only to isolate specific parts for specific tasks.

Step 1: Setting the Mesh Parameters

Mesh parameters for the entire model will be set. Parameters for individual parts may be set locally at the
time the mesh is generated.

1. Set maximum element size globally.
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Mesh → Global Mesh Setup  → Global Mesh Size 

a. For the Scale factor, enter a value of 1.

b. For the Max element, enter a value of 16.

c. Click Apply.

2. Set mesh sizes on surfaces and curves.

Mesh → Part Mesh Setup 

The Part Mesh Setup dialog box appears.

a. For parts CURVES, CYL1, CYL2, and CYL3, set the Maximum size value to 4.

b. For parts INLET, INTERFACE1, INTERFACE2 and OUTLET, set the Maximum size value to 2.

c. Click Apply, and then Dismiss.

Note:

Mesh sizes on curves and surfaces may also be setup using Surface Mesh Setup

and Curve Mesh Setup , but the Part Mesh Setup dialog box is typically more effi-
cient when setting multiple parts.

3. Save your work.

File → Save project

Meshing parameters are saved with the geometry file.
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Step 1: Setting the Mesh Parameters



Step 2: Generating the Tetra Mesh in CYL1

A tetrahedral mesh is generated in the CYL1 region and then saved. Later, this mesh data file will be opened
to complete the merge to another mesh.

1. Create a Material point.

Geometry → Create Body  → Material Point 

a. Change the Part name to LIVE1.

b. Click  (Select location(s)), and then click two opposite corners of CYL1.

Note:

You may find it useful to disable CYL2 and CYL3 in the display tree while making
this selection.

c. Click the middle mouse button to accept the selection.

d. Click Apply to create the Material point.

Rotate the model to ensure that LIVE1 lies inside the CYL1 section.

Figure 207: Material Point LIVE1 Created
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2. Create mesh in the LIVE1 part.

Mesh → Compute Mesh  → Volume Mesh 

a. For Mesh Type, select Tetra/Mixed from the drop-down list.

b. For Mesh Method, select Robust (Octree) from the drop-down list.

c. For Select Geometry, select All from the drop-down list.

d. Click Compute to generate the mesh.

Figure 208: Tetra Mesh in CYL1 Region Created

3. Save the mesh data.

File → Mesh → Save Mesh As

a. Choose an appropriate name, for example Cyl1_Tetra_Mesh.uns.

b. Close the mesh data file.

File → Mesh → Close Mesh

Step 3: Generating the Tetra Mesh in CYL2

The Material point will be moved to the CYL2 region where a Tetra mesh will be generated.
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1. Move the Material point.

Geometry → Transform Geometry  → Translate Geometry 

a. Click  (Select geometry), and then click the LIVE1 body point.

b. Click the middle mouse button to accept.

c. For Method, choose Explicit from the drop-down list.

d. For X Offset, enter a value of 25.

e. Click Apply.

The Material point should now be located within the CYL2 region. Rotate the model to confirm.

2. Rename the Material point to LIVE2.

Part → LIVE1 → Rename

Change the name, and then click Done.

3. Create the mesh in the LIVE2 part.

Mesh → Compute Mesh  → Volume Mesh 

a. For Mesh Type, select Tetra/Mixed from the drop-down list.

b. For Mesh Method, select Robust (Octree) from the drop-down list.

c. For Select Geometry, select All from the drop-down list.

d. Click Compute to generate the mesh.
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Figure 209: Tetra Mesh in CYL2 Region Created

4. Save the mesh data.

File → Mesh → Save Mesh As

Choose an appropriate name, for example Cyl2_Tetra_Mesh.uns.

Do not close the mesh data file.

Step 4: Merging the Tetra Mesh between CYL1 and CYL2

The first two volume meshes are made conformal at their common surface, INTERFACE1.

1. Reopen the first mesh.

File → Mesh → Open mesh

a. In the Open dialog box, choose the mesh file previously created.

Click Open.

b. The Mesh Exists dialog box opens. Choose Merge.
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Step 4: Merging the Tetra Mesh between CYL1 and CYL2



Figure 210: CYL1 and CYL2 Meshes Open

Note:

At this point the two mesh files are simply concatenated. Merging the meshes to form
a conformal mesh is a later step.

2. In the Display tree, turn OFF all parts except INTERFACE1, and then reorient the model for an end
view.

3. Make the two meshes conformal.

Edit Mesh → Merge Nodes  → Merge Meshes 

a. For Method, choose Merge volume meshes.

b. For Merge surface mesh parts, click  (Select part(s)).

c. In the Select part dialog box, choose INTERFACE1 and then click Accept.

d. Click Apply.
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Figure 211: Meshes merged at INTERFACE1 Surface

4. Reestablish a normal view of all parts and geometries.

5. Save the project.

File → Save Project

Step 5: Generating the Hexa Mesh in CYL3

Blocking is required in the CYL3 region before creating the Hexa mesh. The cylindrical shape lends itself very
well to the creation of an Ogrid block scheme.

1. In the Display Tree, disable Mesh to reduce screen clutter.

2. Generate initial blocking.

Blocking → Create Block  → Initialize Blocks 

Accept all defaults, and then click Apply.
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Figure 212: Initial 3D Bounding Block

All geometry will be contained in the created block.

3. In the Display tree, under Blocking, enable Vertices, and then enable vertex Numbers.

Under Geometry, enable Show Curve Names and disable Surfaces.

4. Constrain the blocking to only CYL3 using Edge to Curve associations.

Blocking → Associate  → Associate Edge to Curve 

a. Ensure that Project vertices is enabled.

b. Click  (Select edge(s)), and then select the four edges surrounding CURVES.4, identified by
vertices 37, 38, 41, and 42.

c. Click the middle mouse button to accept your selection.

d. Click  (Select compcurve(s)), and then click CURVES.4 (at the OUTLET end).

e. Click the middle mouse button to accept your selection.

f. Click Apply.

The blocking snaps to the interior of the curve and the four edges turn green indicating a
valid association.

g. Similarly, associate the four edges at the other end of the block (between vertices 21, 22, 25,
26) to CURVES.3.
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Figure 213: Blocking Constrained to CYL3

Note:

This is necessary to meet the Merge Meshes condition that the nodes on both sides of
the merge interface be projected to the perimeter curves.

5. Create longitudinal Ogrid.

Blocking → Split Block  → Ogrid Block 

a. Click  (Select block(s)), and then click the only block.

b. Click the middle mouse button to accept.

c. Click  (Select face(s)), and then select the faces at the two ends of the block (corresponding
to surfaces INTERFACE2 and OUTLET).

d. Click the middle mouse button to accept.
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Figure 214: Block and Faces selected for Ogrid Split

e. Click Apply.

6. Set edge parameters for blocking.

Blocking → Pre-Mesh Params  → Update Sizes 

Note:

In Settings → Meshing Options → Hexa Meshing menu, ensure Multigrid level is set
to 0.

a. Ensure Update All is enabled.

b. Click Apply.

This will have the effect of setting mesh size based on surface mesh parameters specified earlier.

7. Refine edge parameters longitudinally.

Blocking → Pre-Mesh Params  → Edge Params 

a. Click  (Select edge(s)), and then select edge 25-41.

b. For the number of Nodes, enter 17.
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Figure 215: Set Parameters for Longitudinal Edge

c. Leave all other values unchanged and click Apply.

8. Display the Hexa mesh.

a. In the Display tree, under Blocking, enable Pre-Mesh.

b. When prompted, click Yes to recompute the mesh.

Figure 216: Hexa Mesh in CYL3 region
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Step 5: Generating the Hexa Mesh in CYL3



In the Display tree, Edges, Vertices, Curves, and Surfaces are disabled. Pre-Mesh is displayed as
Solid & Wire.

9. Save the blocking information file.

File → Save Blocking As

10. In the Display tree, disable Blocking and enable Mesh, Surfaces and Curves.

Step 6: Merging the Tetra Mesh with Hexa Mesh at Interface2

The hexa mesh will now be merged with the existing tetra mesh at INTERFACE2. The two meshes are made
conformal by the addition of a pyramid layer at the surface.

1. Open the hexa mesh.

File → Mesh → Load from Blocking

The Mesh Exists dialog box opens.

Choose Merge.

2. In the Display tree, turn OFF all parts except INTERFACE2, and then reorient the model for an end
view.

3. Make the two meshes conformal.

Edit Mesh → Merge Nodes  → Merge Meshes 

a. For Method, choose Merge volume meshes.

b. For Merge surface mesh parts, click  (Select part(s)).

c. In the Select part dialog box, choose INTERFACE2 and then click Accept.

d. Click Apply.

Figure 217: Meshes merged at INTERFACE2 Surface

Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.310

Merged Tetra-Hexa Mesh in a Hybrid Tube



4. View the pyramids at INTERFACE2.

a. Enable the display of all Parts.

b. Disable the display of Shells.

c. Enable the display of Volumes, and then selectively enable and disable the Hexahedra, Tet-
rahedra and Pyramid elements.

Figure 218: Pyramids at INTERFACE2

5. Reestablish a normal view of all parts and geometries.

6. Save the project.

File → Save Project

Step 7: Cleaning up and Saving the Project

1. Smooth the Hybrid Mesh.

Edit mesh → Smooth Mesh Globally 
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Step 7: Cleaning up and Saving the Project



Figure 219: Quality Histogram prior to Smoothing

a. For Smoothing iterations, enter a value of 12.

b. For Up to quality, enter a value of 0.4.

c. For Criterion, select Quality from the drop-down list.

d. Click Apply.

Figure 220: Quality Histogram after Smoothing

2. Save the complete mesh in a new file.

File → Mesh → Save Mesh As

a. Select a suitable file name, for example merged_mesh_domain.uns.

b. Click Apply.

3. Exit, saving the project on the way out.

File → Exit
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Multizone Mesh in HVAC Square-to-circle Transition
Duct
In this tutorial example, you will use the Ansys ICEM CFD MultiZone meshing method to automatically
hybrid mesh a section of HVAC duct.

This mesher is ideal for situations where a high quality boundary layer mesh is needed, but it would
be difficult to lay out a structured grid to fill the volume. It is particularly designed for external aerody-
namics where the boundary layer is critical and the volume around it can be very complicated.

The MultiZone process starts with surface blocking extracted from the geometry topology and then
extrudes/sweeps these blocks into the volume to create the high quality boundary element zones (Ogrid).
The remainder of the complex volume is filled by a variety of methods including mapped hexa blocks,
swept blocks or unstructured mesh zones (which can be filled with a variety of unstructured methods
available). Where possible, the MultiZone tool automatically subdivides the volume and can handle
multi-source & target and multi-direction sweeping based on the robust ICEM CFD Hexa blocking
framework. In addition, ICEM CFD Hexa blocking tools (Adjust Mesh distribution, Move vertices, Align
verts, Check quality, Smooth, etc.) are available to interactively improve the mesh as necessary.

This tutorial demonstrates how to do the following:

• Set up mesh parameters.

• Create automatic surface blocking.

• Convert 2D surface blocking to 3D volume blocking.

• Improve the mesh quality.

• Convert irregular tetra mesh to hexa-core mesh.

Starting the Project

Step 1: Setting up Global and Part Mesh Parameters

Step 2: Creating Automatic Surface Blocking

Step 3: Converting the Surface Blocking to 3D Blocking

Step 4: Checking and Improving the Mesh

Step 5: Converting to Hexa-core and Saving the Project

Starting the Project

1. Set up a working directory on your computer.

2. Download the duct_transition.zip file here.

313
Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

https://storage.ansys.com/doclinks/f_tutorials.html?code=duct_transition-FLU-N2a


3. Unzip the duct_transition.zip file you have downloaded to your working directory.

4. Start Ansys ICEM CFD and create a new project in your working directory. Use an appropriate name,
for example Multizone_Hvac.

File → New Project

5. Open the geometry file (DuctTransition_Long.tin).

File → Geometry → Open Geometry

Figure 221: Geometry for HVAC Transition Duct

Surfaces have been enabled in the Display tree.

Note:

• If you want Ansys ICEM CFD to behave exactly as this tutorial describes, you should go to
the Settings Menu, click Selection, and disable Auto Pick Mode in the DEZ. Most experi-
enced ICEM CFD users prefer to enable Auto Pick Mode as it improves efficiency. See
Selection in the ICEM CFD Help Manual → Main Menu Area → Settings Menu for more
detail.

• Throughout this and other tutorials, Parts, Points, Curves and Surfaces may be made visible
or turned off as necessary to assist in describing the steps of the tutorial. Typically, the
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default settings for visibility are sufficient for most work, and such steps are used only to
isolate specific parts for specific tasks.

Step 1: Setting up Global and Part Mesh Parameters

There are a few options for meshing this duct using ICEM CFD. Each has its advantages and disadvantages:

• Tetra/Prism: This is automated and has good feature capture ability, but is slower and less efficient
in most solvers.

• Body-Fitted Cartesian: Also automated, but has low feature capture and boundary resolution.

• Hexa: Can be made to capture all the details, but the blocking may require an experienced user.

• Multizone Meshing is able to capture the details, and by starting with a Patch-based Surface Topology
many of the processes can be automated. This is the preferred method for this geometry and will be
described here.

1. Establish surface patches and connectivity.

Geometry → Repair Geometry  → Build Diagnostic Topology 

a. Use the default tolerance (0.003).

b. Click Apply.
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Step 1: Setting up Global and Part Mesh Parameters



Figure 222: Build Diagnostic Topology on HVAC Transition Duct

Note:

Wide Red curves indicate connectivity between surface patches. Connectivity between
adjacent surface patches is important when creating the surface blocking. Check the
model carefully for holes and unconnected surfaces (indicated by yellow curves), and
repair if necessary.

2. Set Global Mesh Parameters.

Mesh → Global Mesh Setup  → Global Mesh Size 

a. Set Max element value to 0.8.

b. Click Apply.

3. Set Mesh Parameters by Part.

Mesh → Part Mesh Setup 

a. Set parameters as shown in the graphic.
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Figure 223: Part Mesh Setup for HVAC Transition Duct

b. Click Apply, and then Dismiss.

Step 2: Creating Automatic Surface Blocking

A 2D Surface Blocking will be created. The Blocking will be forced to respect the curves identified in the Build
Diagnostic Topology step.

1. Initiate the 2D blocking.

Blocking → Create Block  → Initialize Blocks 

2. In the Type drop-down list, select 2D Surface Blocking.

3. Under Surface Blocking, in the Method drop-down list, select Mostly mapped.

4. In the Free Face Mesh Type drop-down list, select Quad Dominant.

5. Under Merge blocks across curves, in the Method drop-down list, select None.

6. Leave all other default settings.

Note:

By not selecting any surfaces explicitly, all surfaces will be meshed.
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Step 2: Creating Automatic Surface Blocking



7. Click Apply.

The curves turn multicolored because this is more useful in the blocking phase of meshing. (In the Display
tree, Curve display settings switch from “Color by Count” to “Show Composite”.)

8. To view the surface mesh, enable Pre-Mesh, under Blocking in the Display tree. Allow recalculate
when prompted.
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Figure 224: Initial Surface Mesh on HVAC Transition Duct

Disable Pre-Mesh before proceeding.

Step 3: Converting the Surface Blocking to 3D Blocking

The surface blocking is inflated to create the 3D blocking in the volume.

1. Extrude 2D Blocking into the volume.

Blocking → Create Block  → 2D to 3D 

a. In the Method drop-down list, select MultiZone Fill.

b. Enable the Create Ogrid around faces check box.

c. Click Select Part(s) .

In the Select Parts dialog box, Duct is checked. The default selected parts are set by the Prism
settings in the Part Mesh Setup dialog earlier.

Click Accept.

The Offset distance is calculated from the Prism settings. The display shows the average, but
the actual offset will be calculated part by part.
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Step 3: Converting the Surface Blocking to 3D Blocking



d. For Fill Type Method, choose Advanced from the drop-down list.

Advanced will create mapped blocks wherever possible (front and back sections in this model),
then attempt a swept mesh in the unstructured regions (fails in the model), and finally fills the re-
maining volume with the default unstructured fill (Tetra in the this example).

2. Click Apply.

3. Examine the completed 3D Mesh.
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Figure 225: Completed 3D Blocking for HVAC Transition Duct

In the Display tree, under Geometry, disable Curves and Surfaces; under Blocking, disable Edges;
and right-click Pre-Mesh and choose Solid & Wire.

Zoom in to the curved end of the duct to observe the inflation layers on the duct surface and the
Ogrid structure of the blocking.
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Step 3: Converting the Surface Blocking to 3D Blocking



Figure 226: Ogrid structure and Boundary Layer Detail

4. Display the internal mesh structure.

Blocking → Pre-Mesh → Cut plane

Disable Pre-Mesh in the Display tree.

a. In the Method drop-down list, select Middle Z Plane.
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Figure 227: Longitudinal Cut plane view in HVAC Transition Duct

From the menu bar, choose View → Front.

Note:

• Both end zones contain Hexa elements automatically mapped during the 2D to
3D fill process.

• The middle zone is Tetra Mesh, indicating it is unstructured.

b. In the Method drop-down list, select Middle Y Plane.
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Step 3: Converting the Surface Blocking to 3D Blocking



Figure 228: Cross-Sectional Cut plane view in HVAC Transition Duct

View → Top

Note:

The structured boundary layer (hexa mesh) near the surface is created because of
Ogrid blocking.

c. Use the scroll wheel to move the cut plane along the duct geometry.

Observe the hexa mesh at the extents of the duct (orthogonal blocking structure), and the ir-
regular tetra mesh in the center of the duct (transition region).

Step 4: Checking and Improving the Mesh

The 3D volume mesh is examined. The poorest quality cells are improved by manually positioning vertices.

1. Change the Display to do manual quality improvement.

a. Dismiss the Cut Plane Pre-Mesh DEZ.

b. In the Display tree, enable Edges and Vertices, then right-click Vertices and choose Numbers.

c. Zoom in to one of the triangular transition regions in the center of the duct.
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Figure 229: Transition Region Blocking

2. Check Mesh Quality and find lowest quality blocks.

Blocking → Pre-Mesh Quality Histograms 

a. Accept all defaults and click Apply.

Notice the quality is all above 0.4. The model would be acceptable as it is, but you will improve it
further with interactive adjustments to the blocking. This flexibility is one of the advantages of the
Multizone method.

b. On the Quality histogram, click to select the three lowest bars (below 0.6).

The bars change color and the corresponding elements are highlighted.
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Step 4: Checking and Improving the Mesh



Figure 230: Location of Lower Q elements

3. The inner edges (blue) will be adjusted to improve the quality.

Blocking → Move Vertex  → Align Vertices in-line 

a. For Reference Direction, click  (Select vert(s)).

b. Select the two vertices as shown in Figure 231: Vertices for Alignment Inline (p. 326) (numbers
184 and 185 as shown).

Figure 231: Vertices for Alignment Inline

c. For Vertices, click  (Select vert(s)).

d. Select the vertex in between (number 190) the two reference vertices as shown in Fig-
ure 231: Vertices for Alignment Inline (p. 326).

e. Click the middle mouse button to accept.

f. Click Apply.
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The middle vertex snaps into alignment with the endpoints.

Figure 232: Vertices after Alignment

g. Repeat for the three other sides shown in Figure 231: Vertices for Alignment Inline (p. 326).

Reference Direction: 184 and 186; Move Vertex: 192.

Reference Direction: 186 and 187; Move Vertex: 194.

Reference Direction: 187 and 185; Move Vertex: 195.

h. Repeat for three other transition regions around the duct.

4. Recheck the Pre-Mesh Quality. Use the default settings.

Figure 233: After Aligning Vertices

Now there are no elements with Quality Metric less than 0.55, and the lowest quality elements are in
the circular part of the duct.
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Step 4: Checking and Improving the Mesh



Step 5: Converting to Hexa-core and Saving the Project

1. Convert the irregular tetra mesh in the center of the duct to hexa-core.

Blocking → Edit Block  → Convert Block Type 

a. In the Type drop-down list, select 3D Free Block Mesh Type.

b. In the Mesh Type drop-down list, select Hexa-Core.

c. Click  (Select block(s)).

d. Select block 42 in the middle of the duct where the transition from square to circle occurs.

Tip:

If you find it difficult to select the internal block, you could adjust the index control

(set O3 to 0:0 in this case); or click  (Select by numbers), enter the block number
(42 in this case) in the dialog box, and then click Done.

e. Click middle mouse button to accept.

f. Click Apply.

2. In the Display tree, right-click Pre-Mesh, and then select Recompute.

3. Re-examine the internal mesh structure as was done earlier.
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Figure 234: Final Mesh after Conversion to Hexa-Core

4. Generate an unstructured mesh output file for a Solver.

Blocking →  Pre-Mesh → Convert to Unstruct Mesh

This will create and load the hex.uns file, which can be exported in a wide variety of solver formats.

5. Close the project.

File → Close Project

6. Exit the program.

File → Exit
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Step 5: Converting to Hexa-core and Saving the Project
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