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Introduction to Ansys ICEM CFD

Ansys ICEM CFD provides advanced geometry acquisition, mesh generation, and mesh diagnostic and
repair tools to provide integrated mesh generation for today’s sophisticated analyses.

Maintaining a close relationship with the geometry during mesh generation, Ansys ICEM CFD is designed
for use in engineering applications such as computational fluid dynamics and structural analysis.

Ansys ICEM CFD’s mesh generation tools offer the capability to parametrically compute meshes from
geometry in numerous formats:

+ Multi-block structured

+ Unstructured hexahedral

*+ Unstructured tetrahedral

+ Cartesian with H-grid refinement

+ Hybrid meshes comprising hexahedral, tetrahedral, pyramidal and/or prismatic elements
* Quadrilateral and triangular surface meshes.

Ansys ICEM CFD provides a direct link between geometry and analysis. In Ansys ICEM CFD, you can input
geometry in almost any format, whether a commercial CAD design package, third-party universal
database, scan data, or point data. Beginning with a robust geometry module that supports the creation
and modification of surfaces, curves and points, Ansys ICEM CFD’s open geometry database offers the
flexibility to combine geometric information in various formats for mesh generation. The resulting
structured or unstructured meshes, topology, inter-domain connectivity, and boundary conditions are
then stored in a database where they can easily be translated to input files formatted for a particular
solver.

General Meshing Workflow
The Ansys ICEM CFD User Interface

General Meshing Workflow

The general meshing workflow is:

1. Create a working directory.

2. Create a new project (or open an existing project).
3. Create or import the geometry.

4. If necessary, repair the geometry before meshing.
5. If necessary, block the geometry.

6. Compute the mesh.

Release 2021 R2 - © ANSYS, Inc.Allrights reserved.- Contains proprietary and confidential information
of ANSYS, Inc.and its subsidiaries and affiliates.



Introduction to Ansys ICEM CFD

7. Check the mesh for errors and edit as required.
8. Describe the physics.
9. Generate the input for the solver.

Figure 1: Overall ICEM CFD Process
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The workflow is demonstrated in a video on the customer site. See Ansys ICEM CFD Process Overview.

Creating a Project

All the files required for a particular analysis are contained within a project. You can either create a
new project or open an existing project.

Note:

If you already have a project open, creating a new project will close the current project.

To create a project:

1. Create a working directory where you will keep all of the files associated with your project.

Release 2021 R2 - © ANSYS, Inc.Allrights reserved.- Contains proprietary and confidential information
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General Meshing Workflow

2. Select File > New Project.
3. Browse to the working directory that you created.

4. Specify a File name for the project and click Save.

Note:

The special characters A, 3, C, 0, 6, U, and U are not supported in file names on Linux.

The Project directory typically contains one or more of the following file types:
Project Settings (*.prj)

An ICEM CFD project file contains the information necessary to manage the data files associ-
ated with your project.

Tetin (*.tin)

Contains geometry entities, material points, parts associations, and global and entity mesh
sizes.

Mesh (*.uns)

Includes details of the line, shell, and volume mesh elements of the project. Shell meshes
are composed of triangular and/or quadrilateral elements; volume meshes may include tetra-
hedra, hexahedra, pyramids, and/or prisms.

Blocking (*.blk)

Includes details of the underlying framework used to create a structured hexahedral mesh
in your project. Blocking files can also be loaded from, or saved to, an unstructured mesh.

Attributes (*.atr) or (*.fbc)

Maintain the association of user-specified data for parts, element properties, loads, and con-
straints with the nodes/elements of the mesh for a project.

Parameters (*.par)

Contains mesh-independent data such as material properties, local coordinate systems,
solver analysis setup, and run parameters. The data in the parameters file is cross-referred in
the attributes file when a set of parameters is associated with the nodes/elements of the
mesh.

Cartesian (*crt)
Contains information regarding the Cartesian grid, if one has been created for your project.
Journal (*.jrf)

Contains a record of the operations performed (see General in the Ansys ICEM CFD Help
Manual).
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Replay (*.rpl)

Contains a replay script (see Replay Scripts in the Ansys ICEM CFD Help Manual).

Creating or Importing the Geometry

Ansys ICEM CFD includes a wide range of tools for creating a new geometry or manipulating an ex-
isting geometry. You can create a simple geometry or alter a complex geometry without having to
go back to the original CAD. This can be done for CAD (NURBS surfaces) and triangulated surface
data.

ICEM CFD also supports several geometry interfaces that enable you to import geometry from other
formats (CAD, 3rd party geometry, Faceted Data, and Mesh formats). These interfaces provide the
bridge between parametric geometry creation tools available in CAD systems and the computational
mesh generation and mesh optimization tools available in Ansys ICEM CFD. Currently supported in-
terfaces include the most popular CAD systems and many legacy formats. For a complete list of sup-
ported geometry interfaces, see Import Model and Import Geometry in the Help manual.

Geometry Preparation

Although most of the meshing modules within Ansys ICEM CFD allow minor gaps and holes in the
geometry, you should confirm that the geometry is free of any flaws that would inhibit optimal mesh
creation. For example, the tetra mesher requires that the model contains a closed volume; if there

are any holes in the geometry that are larger than the local tetras, the mesh will not be created. Ansys
ICEM CFD provides tools for such operations on either CAD or triangulated surfaces.

The Repair Geometry page in the Help manual provides links to the tools that are used to find and
repair such flaws. The typical procedure is to identify possible geometry problems using the Build
Topology operation and then use the other tools to effect any needed repair.

In cases where feature capture is necessary, geometry curves and points will act as constraints for
the edges and nodes, respectively, of the mesh elements. If necessary, Build Topology is able to
create such curves and points automatically from surface data, thereby capturing certain key features
in the geometry.

See Repairing the Geometry before Meshing (p. 11) in the Tetra Meshing chapter for more information
on geometry preparation.

Parts

The Ansys ICEM CFD environment can combine CAD surface geometry and triangulated surface data
into a single geometry database (tetin file) using the geometry interfaces. All geometry entities—in-
cluding surfaces, curves and points—are tagged or associated into a grouping called a part. With this
part association, you can enable or disable all entities within the part, visualize them with a different
color, assign mesh sizes on all entities within the part, and apply different boundary conditions by
part. More information on the display and management of parts can be found in Parts, in the Help
manual.

Release 2021 R2 - © ANSYS, Inc.Allrights reserved.- Contains proprietary and confidential information
4 of ANSYS, Inc.and its subsidiaries and affiliates.



General Meshing Workflow

Blocking the Geometry

The blocking feature in Ansys ICEM CFD provides a projection-based mesh-generation environment.
All block faces between different materials are projected to the closest CAD surfaces. Block faces
within the same material can also be associated to specific CAD surfaces to enable the definition of
internal walls. Generally you do not need to perform any individual face associations to underlying
CAD geometry, which reduces the time for the mesh generation.

The blocking step is used when a structured, hexa-mesh is desired in one or more parts (quad mesh
if 2D parts). A premesh is generated in the blocked regions which can be refined and improved on

a block-by-block basis. The premesh data is converted to structured or unstructured mesh data before
it is merged with mesh data from other parts or passed to a solver.

There can be multiple Blocking strategies, depending on the topology you are working with:

+ Typically you take a top-down approach, in which you first capture the outer geometry and then
split, delete, and merge blocks to capture the minor geometry. The volume can be filled by a variety
of methods including mapped hexa blocks, swept blocks, or unstructured mesh zones (which can
be filled with a variety of unstructured methods available).

+ You may be able to use a bottom-up approach, in which you start by creating a 2D blocking, add
blocks to capture more detail, and then extrude the 2D blocking to create the 3D blocking. Again,
the volume can be filled by a variety of methods.

For further information on blocking, see Blocking Strategy (p. 30) in the Hexa Meshing chapter.

Computing the Mesh
To proceed from geometry and parts to a completed mesh requires two steps:
1. Set up Mesh Parameters

You should specify mesh size, type, and method along with several type- and method-specific
controls. The parameters can be applied globally and individually to parts, surfaces, curves, or re-
gions. Rotational and translational periodicity is also supported.

2. Compute the Mesh
Meshing methods available include the following:
Tetra

The Ansys ICEM CFD Tetra mesher takes full advantage of object-oriented, unstructured meshing
technology. With no tedious up-front triangular surface meshing required to provide well-balanced
initial meshes, Ansys ICEM CFD Tetra works directly from the CAD surfaces and fills the volume
with tetrahedral elements using the Octree approach. A powerful smoothing algorithm provides
good element quality. Options are available to automatically refine and coarsen the mesh both

on the geometry and within the volume.

Also included are a Delaunay algorithm and an Advancing Front algorithm to create tetras from
an existing surface mesh and also to give a smoother transition in the volume element size. The
Delaunay method is robust and fast; while the advantage of the Advancing Front method is its
ability to generate a smoothly transitioning Tetra mesh with a controlled volume-growth ratio.
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Prism

Ansys ICEM CFD Prism generates hybrid meshes consisting of layers of prism elements near the
boundary surfaces and tetrahedral elements in the interior for better modeling of near-wall
physics of the flow field. When compared to pure tetrahedral meshes, this results in smaller ana-
lysis models, better convergence of the solution, and better analysis results.

Hexa

The Ansys ICEM CFD Hexa mesher is a semi-automated meshing module that allows rapid gener-
ation of multi-block structured or unstructured hexahedral volume meshes. ICEM CFD Hexa rep-
resents a new approach to mesh generation where the operations most often performed by experts
are automated and made available at the touch of a button. Blocks can be built and interactively
adjusted to the underlying CAD geometry. This blocking can be used as a template for other

similar geometries for full parametric capabilities. Complex topologies, such as internal or external
Ogrids, can also be generated automatically.

Hybrid Meshes
The following types of hybrid meshes can also be created:

+ Tetra and Hexa meshes can be united (merged) at a common interface in which a layer of
pyramids is automatically created to make the two mesh types conformal. These meshes
are suitable for models where it is preferred to have a "structured" hexa mesh in one part
and is easier to create an "unstructured" tetra mesh in another more complex part.

+ Hexa-Core meshes can be generated where the majority of the volume is filled with a
Cartesian array of hexahedral elements essentially replacing the tetras. This is connected
to the remainder of a prism/tetra hybrid by automatic creation of pyramids. Hexa-Core al-
lows for reduction in number of elements for quicker solver run time and better conver-
gence.

Shell Meshing

Ansys ICEM CFD provides a method for rapid generation of surface meshes (quad and tri) for both
3D and 2D geometries. Mesh types can be All Tri, Quad w/one Tri, Quad Dominant, or All Quad.
The following methods are available:

+ Mapped based shell meshing (Autoblock): Internally uses a series of 2D blocks, resulting
in @ mesh that aligns better with the geometry curvature.

+ Patch based shell meshing (Patch Dependent): Uses a series of "loops" that are automat-
ically defined by the boundaries of surfaces and/or a series of curves. This method gives
the best quad-dominant quality and capturing of surface details.

+ Patch independent shell meshing (Patch Independent): Uses the Octree method. This
is the best and most robust method for use on an unclean geometry.

+ Shrinkwrap: Used for a quick generation of a mesh. As it is used as the preview of the
mesh, hard features are not captured.

Complete descriptions of the meshing processes are included in subsequent chapters.
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Checking/Editing the Mesh

The mesh editing tools in Ansys ICEM CFD enable you to diagnose and fix problems in the mesh. You
can also improve the mesh quality. A number of manual and automatic tools are available for opera-
tions such as conversion of element types, refining or coarsening the mesh, smoothing the mesh,
and so on.

The process of improving the mesh quality typically involves:

1. Check the mesh for problems such as holes, gaps, and overlapping elements using the dia-
gnostic checks available. Fix the problems using the appropriate automatic or manual repair
methods.

2. Check the elements for bad quality and use smoothing to improve the mesh quality.

If the mesh quality is poor, it may be more appropriate to either fix the geometry or to recreate
the mesh using more appropriate size parameters or a different meshing method.

Describing the Physics

Ansys ICEM CFD includes tools to describe the physical properties of your model and the type of
analysis being performed.

Describing the physics for your project involves:
1. Defining or editing the material properties.

Several common materials are included in the Material Library; or you can define your own
material, including certain non-linear behavior. The data may be saved for later recall to a
* mat file.

2. Assigning the material properties to the Parts of your model.
3. Applying Constraints to the model.

Constraints include movement restrictions and initial velocity, and may be applied to points,
curves, surfaces or parts.

4. Applying Loads to the model.

Loads may be force, pressure or temperature, and may be applied to points, curves, surfaces,
or parts.

Note:

Not all solvers support all available Constraints or Loads.

Generating the Input for the Solver

Ansys ICEM CFD includes output interfaces to various flow and structural solvers, producing appropri-
ately formatted files that contain complete mesh and boundary-condition information. After selecting
the solver, you can modify the solver parameters and write the necessary input files.
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Introduction to Ansys ICEM CFD

More information about the Ansys ICEM CFD Output Interfaces is available from the Help menu. The
Output Interfaces feature opens the Ansys ICEM CFD Output Interfaces information in a browser.

For information about a specific interface, refer to the Table of Supported Solvers and click the name
of the interface.

The Ansys ICEM CFD User Interface

The Ansys ICEM CFD user interface offers a complete environment to create and manage your compu-
tational grids. As shown in Figure 2: Ansys ICEM CFD User Interface Components (p. 8), the user interface
contains several functional areas. The general meshing workflow is from left to right across the Function

Tabs.

Figure 2: Ansys ICEM CFD User Interface Components
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Note:

The user interface style shown is the default, Workbench style. For more information about
the user interface (GUI Style) features, refer to the Settings menu.

The user interface is completely described in the Ansys ICEM CFD Help Manual.
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Tetra Meshing

The Tetra mesher generates tetrahedral volume meshes directly from the CAD geometry or stereo-
lithography (STL) data, without requiring an initial triangular surface mesh—you have only to select the
geometry to be meshed.

The Tetra mesher can use different meshing algorithms to fill the volume with tetrahedral elements

and to generate a surface mesh on the object surfaces. You can define prescribed curves and points to
determine the positions of edges and vertices in the mesh. For improved element quality, the Tetra
mesher incorporates a powerful smoothing algorithm, as well as tools for local adaptive mesh refinement
and coarsening.

Features of Tetra Meshing

The Tetra mesher is suitable for complex geometries and offers:

+ Rapid model setup

+ Mesh independent of underlying surface topology

* No surface mesh necessary

+ Generation of mesh directly from CAD or STL surfaces

+ Definition of element size on CAD or STL surfaces

+ Control over element size inside a volume

+ Nodes and edges of tetrahedra are matched to prescribed points and curves

+ Curvature/Proximity Based Refinement automatically determines tetrahedra size for individual
geometry features

+ Volume and surface mesh smoothing, merging nodes and swapping edges

+ Tetrahedral mesh can be merged into another tetra, hexa, or hybrid mesh and then can be
smoothed

+ Coarsening of individual material domains

+ Enforcement of mesh periodicity, both rotational and translational
+ Surface mesh editing and diagnostic tools

* Local adaptive mesh refinement and coarsening

+ One consistent mesh for multiple materials
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Tetra Meshing

+ Fast algorithm

+ Automatic detection of holes and easy ways to repair the mesh.

Note:

+ Tetra meshing is not efficient for capturing shear or boundary layer physics. To mesh for
such situations, choose a method that supports inflation layers and prisms. See Prism
Meshing (p. 23).

+ Tetra meshing creates an unstructured mesh of tetrahedral cells. For a structured, multi-
block approach or an unstructured mesh of hexahedral cells, see Hexa Meshing (p. 27).

The tetra meshing chapter includes the following sections.
Inputs to the Tetra Mesher
Tetra Mesh Generation Steps
Choosing the Tetrahedral Mesh Method
Computing the Tetra Mesh

Inputs to the Tetra Mesher

The Tetra mesher accepts the following inputs:
+ B-Spline Curves and Surfaces (p. 10)
+ Triangular Surface Meshes as Geometry Definition (p. 10)

+ Full/Partial Surface Mesh (p. 11).

B-Spline Curves and Surfaces

When the input is a set of B-Spline curves and surfaces with prescribed points, the mesher approximates
the surface and curves with triangles and edges respectively; and then projects the vertices onto the
prescribed points.

The B-Spline curves enable the Tetra mesher to follow discontinuities in surfaces. If no curves are specified
at a surface boundary, the Tetra mesher will mesh triangles freely over the surface edge. Similarly, pre-
scribed points enable the mesher to recognize sharp corners in the geometry. Ansys ICEM CFD provides
tools (Build Topology) to extract points and curves to define sharp features in the surface model.

Triangular Surface Meshes as Geometry Definition

Prescribed curves and points can also be extracted from triangulated surface geometry. This could be
stereo-lithography (STL) data or a surface mesh converted to faceted geometry. Though the nodes of
the Tetra-generated mesh will not exactly match the nodes of the given triangulated geometry, they
will follow the overall shape. A geometry for meshing can contain both faceted and B-Spline geometry.
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Tetra Mesh Generation Steps

Full/Partial Surface Mesh

Existing surface mesh for all or part of the geometry can be specified as input to the Tetra mesher. The
final mesh will then be consistent with—and connected to—the existing mesh nodes.

Tetra Mesh Generation Steps

The steps involved in generating a Tetra mesh are:

1.

2.

5.

6.

Repair the geometry before meshing.

Specify the geometry details.

Specify sizes on surfaces/curves.

Specify the behavior in small angles or in small gaps between objects.
Determine the desired mesh method.

Compute the mesh.

The computed mesh should be checked for errors and smoothed for quality as necessary. See Checking
and Improving the Mesh (p. 41) in this manual. When satisfactory, it is ready for applying loads,
boundary conditions, and so on, and for writing to the desired solver.

Repairing the Geometry before Meshing

Before generating the mesh, you should confirm that the geometry is free of any flaws that would
inhibit optimal mesh creation. The Tetra mesher requires that the model contains a closed volume;

if there are any holes in the geometry that are larger than the local tetras, the mesh may not be
computed. The Build Topology operation is used to check your geometry and represent connectivity
between adjacent surfaces with different colored curves. You can correct any identified problem on
the mesh or you can repair the geometry in that vicinity and repeat the meshing process. For further
information on the process of interactively closing holes, see the following sections.

Repairing Holes in the Geometry
Filling, Timming, and Blending a Gap
Matching Curves

Note:

If you want to save the changes in the native CAD files, perform any geometry repairs in
a direct CAD interface.

Repairing Holes in the Geometry

During the process of finding the bounding surfaces to close the volume mesh, the mesher will
determine if there are holes in the model. If holes are found, the Message window will display a
message like "Material point ORFN can reach material point LIVE." You will be prompted with a
dialog box saying, "Your geometry has a hole, do you want to repair it?" A jagged line will display
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the leakage path from the ORFN part to the LIVE part. The elements surrounding the hole will also
be displayed. To repair the hole, select the single edges bounding it and the mesher will loft a
surface mesh to close the hole. Further holes would be flagged and repaired in the same manner.
If there are many problem areas, it may be better to repair the geometry or adjust the meshing
parameters.

Closing Holes Bounded by Multiple Surfaces
If the hole is bounded by more than one surface, you can use the Close Holes feature. For example,

in Figure 3: Hole Bounded by Multiple Surfaces (p. 12), the yellow curves represent the boundary
of the hole. It is clear that this hole is bounded by more than one surface.

Figure 3: Hole Bounded by Multiple Surfaces

Figure 4: Closed Hole (p. 12) shows the geometry after the Close Holes operation is completed.
A new surface is created to close the hole.

Figure 4: Closed Hole

Closing Holes on Single Surfaces

If the hole lies entirely within a single surface, such as a trimmed surface, you can use the Remove
Holes feature. For example, in Figure 5: Holes Within a Single Surface (p. 13), the two yellow
curve loops represent the boundaries of holes on a surface.
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Tetra Mesh Generation Steps

Figure 5: Holes Within a Single Surface

Figure 6: After Removing One Hole (p. 13) shows the geometry after the Remove Holes operation
is completed for one of the holes. The existing surface is modified by removing the trim definition.

Figure 6: After Removing One Hole

Filling, Trimming, and Blending a Gap
Consider the case of a geometry with a gap shown in Figure 7: Geometry With a Gap (p. 13).

Figure 7: Geometry With a Gap

Figure 8: Using the Fill Feature (p. 14) shows the use of the Fill feature.
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Figure 8: Using the Fill Feature

Figure 9: Using the Trim Feature (p. 14) shows the use of the Trim feature.

Figure 9: Using the Trim Feature

Figure 10: Using the Blend Feature (p. 14) shows the use of the Blend feature.

Figure 10: Using the Blend Feature

Matching Curves

The Match feature is used in cases where curves lie very close to each other and have ends that
meet (see Figure 11: Geometry With Mismatched Edges (p. 15) and Figure 12: Geometry After Using
the Match Edges Option (p. 15)). The gap between the two curves must be within a reasonable
tolerance in order for this feature to work.
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Tetra Mesh Generation Steps

Figure 11: Geometry With Mismatched Edges

Specifying the Geometry Details

In addition to a closed set of surfaces, the Tetra mesher requires curves and points where hard features
(hard angles, corners) are to be captured in the mesh. Figure 13: Curves and Points Representing

Sharp Edges and Corners (p. 16) shows a set of curves and points representing hard features of the
geometry.
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Figure 13: Curves and Points Representing Sharp Edges and Corners

Figure 14: Mesh with Curves and Points (p. 16) shows the resultant surface mesh if the curves and
points are preserved in the geometry. Mesh nodes are forced to lie along the curves and points to
capture the hard features of the geometry.

Figure 14: Mesh with Curves and Points

Figure 15: Mesh Without Curves and Points (p. 16) shows the resultant surface mesh if the curves and
points are deleted from the geometry. The hard features of the geometry are not preserved, but
rather are neglected or chamfered. The boundary mesh nodes lie on the surfaces, but they will lie on
the edges of the surfaces only if curves and points are present. Removal of curves and points can be
used as a geometry-defeaturing tool.

Figure 15: Mesh Without Curves and Points

Use the Build Topology option to identify points, curves, surfaces and their connectivity in the geo-
metry. Build Topology also includes options to automatically repair some minor geometry faults.
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Tetra Mesh Generation Steps

Specifying Sizes on Surfaces and Curves

To produce the optimal mesh, it is essential that all surfaces and curves have the proper tetra sizes
assigned to them. For a visual representation of the mesh size, select Geometry > Surfaces > Tetra
Sizes from the Display Tree. The same can be done with Curves. Tetra icons will appear, representing
the element size of the mesh to be created on these entities. Using the mouse, you can rotate the
model and visually confirm that the tetra sizes are appropriate. If a curve or surface does not have

an icon plotted on it, the icon may be too large or too small to see. In this case, modify the mesh
parameters so that the icons are visible in a normal display.

Mesh size can be set for individual curves and surfaces, or by parts, using the Curve Mesh Setup and
Surface Mesh Setup tools on the Mesh tab. Modify the mesh size for all entities by adjusting the
Scale Factor, which is found with other Global Mesh Setup tools on the Mesh tab.

Important:

If the Scale Factor is assigned a value of O, the Tetra mesher will not run.

Curvature/Proximity Based Refinement

If the maximum tetrahedral size defined on a surface is larger than needed to resolve the feature,
you can employ Curvature/Proximity Based Refinement, accessed in the Global Mesh Setup tools,
to automatically subdivide the mesh to capture the feature. The value specified is proportional to the
global scale factor, and is the smallest size to be achieved through automatic element subdivision.
Even with large sizes specified on the surfaces, the features can be captured automatically.

The Curvature/Proximity Based Refinement value is the minimum element size to be achieved via
automatic subdivision. If the maximum size on a geometry entity is smaller than the
Curvature/Proximity Based Refinement value, the Tetra mesher will still subdivide to meet that
requested size. The effect is a geometry-based adaptation of the mesh.

Specifying Meshing Behavior Inside Small Angles or in Small Gaps

The Tetra mesher automatically attempts to close all holes in a model so special consideration should
be given to regions between two surfaces, or curves, that are very close together or that meet at a
small angle. (This would also apply if the region outside the geometry has small angles.) If the tetra
sizes are larger than, or approximately the same size as, the distance between the surfaces or curves,
the surface mesh could have a tendency to jump the gap, thereby creating non-manifold vertices
during the meshing process. That is, the small thickness or gap may be interpreted as a hole by the
mesher. You should either define a thin cut in order to establish that the gap is not a hole; or make
the mesh size small enough so that it will not close the gap when the meshing is performed.

If the local tetra sizes are not small enough to allow at least 2 or 3 elements across the material

thickness (or gap), you should select Define thin cuts, in the Volume Meshing Parameters section
of the Global Mesh Setup tools. To define a thin cut, the two surfaces have to be in different Parts.
If the surfaces meet, the curve at the intersection of the surfaces will need to be in a different part.
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Choosing the Tetrahedral Mesh Method

Ansys ICEM CFD supports four different methods for generating the tetrahedral volume mesh. They are
listed as Tetra/Mixed as each method includes the option of adding boundary layer prism elements.
See Tetra/Mixed Mesh Type in the Ansys ICEM CFD Help Manual for more information on these methods.

The Robust (Octree) method generates a volume mesh using a top-down approach, then the mesh is
made conformal to the geometry and a patch-independent surface mesh is created at all of the
boundaries and internal walls. This method supports several options as describe in Robust (Octree). The
process is described in detail on the next page.

The Quick (Delaunay) and Smooth (Advancing Front) methods are bottom up, requiring an existing
closed surface mesh to start. If one has not yet been created, ICEM CFD will create the surface mesh
from the geometry. Both methods support several options as described in Quick (Delaunay) and Smooth
(Advancing Front). Choose a method based on your speed and quality priorities.

Tip:

Expert users often use the Robust approach to generate a surface mesh and then regen-
erate the volume mesh using one of the bottom-up approaches.

The Fluent Meshing method uses Ansys Fluent, in batch, to generate the tetrahedral volume mesh

from an input surface mesh, volume mesh or geometry. If no surface mesh input is specified, it will be
computed before the Fluent batch process is started. This method is similar to the Quick (Delaunay)
method with additional options for prism layers and/or hexahedral elements in the core. The pre inflation
prism option first creates the boundary layers from the surface mesh and then fills the remaining volume
with tetrahedrons, or optionally, hexa elements. The post inflation prism option replaces tetra elements
at the surface with prisms and is more familiar to ICEM CFD users. Each prism option has advantages,
and you should not expect the same results from both algorithms. Fluent Meshing inflation also allows
part-by-part inflation parameter control.

Global volume fill parameters for this method are described and set using the Fluent Meshing DEZ.

Both pre inflation and post inflation prism options use most of the same parameters, which are set using
the Prism Meshing Parameters DEZ. Options presented when the mesh is computed include pre inflation
or post inflation selection and the hexa-core option.

Important:

If enabled, the prisms are grown from a shell mesh (input or created) with the direction
of growth determined by the geometry. If no geometry is available, pure tetra meshing

will be done without inflation. If the input mesh is a surface mesh, the volume(s) should
be marked by material point(s).

The Octree Method

The Octree mesh method is based on the following spatial subdivision algorithm: This algorithm ensures
refinement of the mesh where necessary, but maintains larger elements where possible, enabling

faster computation. Once the "root" tetrahedron, which encloses the entire geometry, has been ini-
tialized, Tetra subdivides the root tetrahedron until all element size requirements are met.

Release 2021 R2 - © ANSYS, Inc.Allrights reserved.- Contains proprietary and confidential information
18 of ANSYS, Inc.and its subsidiaries and affiliates.



Choosing the Tetrahedral Mesh Method

Figure 16: Initial Geometry Input to Tetra

At this point, the Tetra mesher balances the mesh so that elements sharing an edge or face do not
differ in size by more than a factor of 2.

Figure 17: Tetra Enclosing the Full Geometry
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Figure 18: Tetra Enclosing the Full Geometry in Wire Frame Mode

Figure 19: Cross-Section of the Initial Meshing

After this is done, Tetra makes the mesh conformal (that is, it guarantees that each pair of adjacent
elements will share an entire face). The mesh does not yet match the given geometry, so the mesher
next rounds the nodes of the mesh to the prescribed points, prescribed curves, or model surfaces.

Tetra then "cuts away" all of the mesh that cannot be reached by a user-defined material point without
intersection of a surface.
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Figure 20: Mesh after Tetra Captures Surfaces and Separates the Useful Volume

e

Figure 21: Final Mesh before Smoothing

Finally, the mesh is smoothed by moving nodes, merging nodes, swapping edges and in some cases,
deleting bad elements.
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Figure 22: Final Mesh after Smoothing

Computing the Tetra Mesh

Additional options such as disabling the surface mesh display, generating prisms or hexa elements, and
selecting specific parts may be set before computing the tetrahedral volume mesh using the parameters
specified. See Compute Volume Mesh
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Tetra meshing is not efficient for capturing shear or boundary layer physics. Using inflation elements
(prism, penta-6 or hexa) along surfaces efficiently increases boundary layer resolution perpendicular to
the wall, allowing you to capture these effects. With Ansys ICEM CFD, mixed prism and tetra generation
is automatic and intelligent, creating prism layers near the surface while maintaining the ease and
automation of Tetra mesh. Prism has always been necessary for CFD customers, but now that the feature
is more widely available, many other branches of CAE have started using prisms to better resolve the
physics perpendicular to the surfaces of their models.

To capture the Y+ for a Navier-Stokes mesh, the spacing of the prism layers is the primary concern,
with the rate of volume change between cells also important. Calculations are done between nodes or
elements, and a Prism mesh gives you more elements perpendicular to the surface. This is an efficient
way to achieve better resolution (more calculations per unit distance) of the solution normal to the
surface, without increasing the number of elements along the surface. This gives you a quicker and
more accurate solution than can be achieved with a very fine tetra mesh.

Prism Mesh Process

The prism mesh process generates prism elements near boundary surfaces from tetrahedral volume or
triangular surface mesh. There are two main processes:

+ The post inflation process creates prisms between the boundary shells and the adjacent tetra-
hedral elements. The process can remove tetrahedral elements and smooth the mesh to yield
the necessary quality as the inflation layer grows into the existing volume mesh. The resulting
prisms are made conformal with the existing tetrahedral volume mesh.

+ The pre inflation process first creates the boundary layer elements from the surface mesh. The
remaining volume is then filled with unstructured mesh. If a volume mesh exists, it is first removed.
If no surface mesh exists, it must first be generated from the geometry.

Note:

- This process is available using the Fluent Meshing executable, run in batch from
ICEM CFD.

- Pre inflation prism meshing (Fluent Meshing method) requires either a volume
mesh or material point to define a direction for prism growth.

- To define a direction for pre-inflation prism growth into a volume containing more
than one region of the same material due to an internal wall, an initial volume
mesh (for example, tetrahedral by octree method) is needed.
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Prism Mesh Preparation

When generating prism mesh, preparation is essential. It is easier to edit a tetra mesh than a tetra/prism
mesh. A prism mesh can also be difficult to smooth, so it will save time to start with good quality
tetra or tri-surface mesh.

+ Start with a Tetra-volume mesh or Tri-surface mesh.
+ Check aspect ratios and quality.
Highly skewed or low quality elements are not suitable for prism growth.
+ Check and fix all diagnostics.
Single/multiple edges, non-manifold vertices, and duplicate elements will crash the prism mesher.
+ Visually scan the surface mesh.
Look for and repair any surface discrepancies or sharp tent-like structures in the mesh.
+ Make sure part associations are correct.

Look for a few elements of one part scattered among another part. Extruding from a few isolated
elements will likely crash the prism mesher. Modify part assignments of such elements.

+ Use the Smoothing Options for Tetra and Tri surface mesh under Mesh > Global Mesh Setup >
Prism Meshing Parameters when creating the prism mesh.

Laplace is typically the best option for Triangle Quality type for the eventual prism quality.

Choosing Prism Options

All necessary parameters are specified globally on the Mesh > Global Mesh Setup > Prism Meshing
Parameters DEZ. A full description is contained at Prism Meshing Parameters in the Help manual.

Certain parameters can then be adjusted on a part-by-part or entity-by-entity basis using Part Mesh
Setup, Surface Mesh Setup and Curve Mesh Setup. For instance, you can specify 3 prism layers

with a growth rate of 1.2 globally, but set 5 layers on a certain part. Part settings override global
settings and entity (surface or curve) settings override part settings. Between entities the smaller size
overrides the larger. Setting a specific parameter on a single entity within a part or between parts is
handled intelligently. For example, if you set a local parameter, such as height, on a single curve entity,
the prism mesher will interpolate that parameter smoothly across the surface between curves.

You may also select volume parts for prism growth. If no volume parts are selected, ICEM CFD assumes
that you want to grow prisms into all volumes bordering the prism surfaces. If you select specific
volume parts, then prism layers will be grown into only those volumes.

The height and direction of the prism layer extrusion are calculated on an element-by-element basis
and may vary due to global or local controls, or for improved quality. You may choose to set the initial
height, number of layers, and growth ratio, which are then used to determine the last layer height
and prisms total height (unless limited by prism height limit factor). Or you may prefer to set only
the number of layers and growth ratio, which then allows Prism to adjust the initial height and locally
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optimize the volume transition between the prisms and tetras. If you are concerned about Y+, you
can then adjust the first-cell height using Edit Mesh > Split Mesh > Split Prisms.

Before the first layer is created and after the last layer is created, surface and/or volume smoothing

is done according to the global settings and selected process. The layers are grown one at a time
with only directional smoothing applied before extruding each layer. This continues until all the re-
quested layers are grown. The smoothing is the most time-consuming operation, so for simple con-
figurations, it may be best to turn off all smoothing and grow all the layers one at a time. This enables
you to take advantage of the variable height feature.

Computing the Prism Mesh
There are two ways to initiate the prism mesh computation:
Compute Mesh > Volume Mesh > Create Prism Layers

You enable this option to create prisms next to wall geometries as part of the volume meshing
process. You can choose whether to create prism mesh from the geometry, or from the surface
or volume mesh depending on the Mesh Method chosen.

All volume meshing parameters are set globally using Mesh > Global Mesh Setup before clicking
Compute.

Compute Mesh > Prism Mesh

You can use this option to grow prism layers next to wall geometries, from an existing volume
mesh or surface mesh. If the existing volume mesh is tet/hexa mesh, on the hexa side the prisms
will be added within the first hexa layer.

Prism growth parameters are set globally using Mesh > Global Mesh Setup > Global Prism
Settings. Local parameters, which override the global parameters, can be set as described in the
previous section (p. 24) or using Select Parts for Prism Layer.

The inflation process (p. 23) is chosen before clicking Compute.

Note:

« You can add prisms to existing layers or you can subdivide and redistribute layers. If
many prism layers are needed, it can be faster and more robust to create initial thick
prism layers and then split them to create the total desired number of prism layers using
Edit Mesh > Split Mesh > Split Prisms.

+ You can compute a prism mesh without an input surface model loaded. Prism will gen-
erate a temporary faceted surface model from the input mesh.

Smoothing a Hybrid Tetra/Prism Mesh
Smoothing options are described in Smoothing the Mesh Globally (p. 43) in this manual.

It is easier to smooth a triangle or tetrahedral mesh than a hybrid tetra/prism mesh. First smooth only
the Tetra and Tri elements by selecting Freeze for other element types.
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Once the tetra and tri elements are as smooth as possible, then all elements are smoothed concurrently.
Decrease the quality Up to value if the prism elements are severely distorted by smoothing.
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Hexa is a 3D object-based, semi-automatic, multi-block structured and unstructured, surface and volume
mesher. Hexa represents a new approach to hexahedral mesh generation. The block topology model

is generated directly on the underlying CAD geometry. Within an easy-to-use interface, those operations
most often performed by experts are readily accessible through automated features.

There is access to two types of entities during the mesh generation process in Hexa: block topology
and geometry. After interactively creating a 3D block topology model equivalent to the geometry, the
block topology may be further refined through the splitting of edges, faces and blocks. In addition,
there are tools for moving the block vertices, either individually or in groups, onto associated curves
or CAD surfaces. You may also associate specific block edges with important CAD curves to capture
important geometric features in the mesh.

Moreover, for models where you can take advantage of symmetry conditions, topology transformations
such as translate, rotate, mirror and scaling are available. The simplified block topology concept allows
rapid generation and manipulation of the block structure and, ultimately, rapid generation of the
hexahedral meshes.

Hexa provides a projection-based mesh generation environment where, by default, all block faces

between different materials are projected to the closest CAD surfaces. Block faces within the same
material can also be associated to specific CAD surfaces to allow for definition of internal walls. In

general, there is no need to perform any individual face associations to underlying CAD geometry,
which further reduces the difficulty of mesh generation.

Features of Hexa
Some of the more advanced features of Hexa include:
Ogrids

For very complex geometry, Hexa automatically generates body-fitted internal and external Ogrids
to parametrically fit the block topology to curved geometry to ensure good quality meshes.

Edge-Meshing Parameters

Hexa's edge-meshing parameters offer unlimited flexibility in applying user-specified bunching re-
quirements.

Time-Saving Methods

Hexa provides time-saving surface-smoothing and volume-relaxation algorithms on the generated
mesh.
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Mesh Quality Checking

With a set of tools for mesh quality checking, elements with undesirable skewness or angles can
be displayed to highlight the block topology region where the individual blocks need to be adjusted.

Mesh Refinement/Coarsening

Refinement or coarsening of the mesh can be specified for any block region to allow a finer or
coarser mesh definition in areas of high or low gradients, respectively.

Replay Option

Replay file functionality enables parametric block topology generation linked to parametric changes
in geometry.

Periodicity

Applicable when analyzing rotating machinery applications, for example, Hexa allows you to define
the periodic behavior of a section of the system and mesh only that section, thereby minimizing
the model size. Translational periodicity is also supported.

Link Shape

This enables you to link the edge shape to existing deforming edge. This gives better control over
the grid specifically in the case of parametric studies.

Adjustability

Options to generate 3D surface meshes from the 3D volume mesh and 2D to 3D block topology
transformation.

The Hexa Database

The Hexa database contains both geometry and block topology data, each containing several sub-en-
tities.

The Geometric data entities are:

+ Points: x, y, z point definition

+ Curves: trimmed or untrimmed NURBS curves

+ Surfaces: NURBS surfaces, trimmed NURBS surfaces

The Block Topological data entities are:

+ Vertices: corner points of blocks, of which there are at least eight, that define a block
+ Edges: a face has four edges and a block twelve

+ Faces: six faces make up a block

+ Blocks: volume made up of vertices, edges and faces
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Color coding in Hexa
The topological entities are color-coded based on their properties:
White Edges and Vertices

These edges are between two material volumes. The edge and the associated vertices will be pro-
jected to the closest CAD surface between these material volumes. The vertices of these edges can
move only on the surfaces.

Note:

If you have chosen a light-colored background for the graphics display window, these
display in black.

Blue Edges and Vertices

These are internal edges within a material volume. The vertices of these edges, also blue, can be
moved by selecting the edge just before it and can be dragged on that edge.

Green Edges and Vertices

These edges and the associated vertices are being projected to curves. The edges will take the
shape of the curves when meshed, and the vertices can be moved only on the curve(s) to which
they are being projected.

Red Vertices

These vertices are projected to prescribed points.

Hexa Mesh Generation with Blocking

The process to generate a Hexa mesh is outlined below, and described in detail in the following sections.
1. Import a geometry file using any of the direct, indirect, or faceted data interfaces.

2. Interactively define the block model through split, merge, Ogrid definition, edge/face modific-
ations, and vertex movements.

3. Check the block quality to ensure that the block model meets specified quality thresholds.

4. Assign edge meshing parameters—such as maximum element size and initial element height
at the boundaries—and set the expansion ratios.

5. Generate the mesh with or without projection parameters specified.
6. Check the mesh quality to ensure that specified mesh quality criteria are met.

7. Write output files to the desired solvers.
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If necessary, you can always return to previous steps to manipulate the blocking if the mesh quality
does not meet the specified threshold or if the mesh does not capture certain geometry features. The
blocking can be saved at any time, allowing you to return to previous block topologies.

Additionally, at any point in this process, you can generate the mesh with various projection schemes
such as full face projection, edge projection, point projection or no projection at all.

Note:

In the case of no projection, the mesh will be generated on the faces of the block model
and may be used to quickly determine if the current blocking strategy is adequate or if it
must be modified.

Intelligent Geometry in Hexa

Using Ansys ICEM CFD's Direct CAD Interfaces, which maintain the parametric description of the geo-
metry throughout the CAD model and the grid generation process, hexahedral grids can be easily
remeshed on the modified geometry.

The geometry is selected in the CAD system and tagged with information ("made intelligent") for grid
generation such as boundary conditions and grid sizes, and this intelligent geometry information is
saved with the primary geometry.

In Hexa, by updating all entities with the update projection function, blocking vertices projected to
prescribed points in the geometry are automatically adapted to the parametric change and one can
recalculate the mesh immediately. Additionally, with the use of its Replay functionality, Hexa provides
complete access to previous operations.

Blocking Strategy

With Hexa, the basic steps necessary to generate a hexahedral mesh are the same, regardless of model
complexity.

1. Create an initial blocking (Initialize Blocks) using one of the various approaches to blocking.

2. Edit the blocking topology using splitting, merging and shaping techniques so that the blocking
topology represents the simulation model, composed with hex shapes wherever possible.

3. Fine tune mesh sizes and tweak topology get a good quality premesh.

When you are satisfied with the pre-mesh quality, convert the pre-mesh to the appropriate type of
mesh - unstructured or multiblock.

There are two general strategies for blocking a 3D model. These are commonly referred to as Top
Down (p. 30) or Bottom Up (p. 31).

Top Down

The top down blocking approach starts from one block generated from the 3D bounding box. The
blocking topology is shaped to the simulation model using split, delete, merge and move tools.
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Blocking Strategy

Figure 23: Top Down Blocking Strategy

This approach has the following advantages:

+ It is often easier to get an all hex mesh using this approach since the global topology is a hex
mesh. When splits are made, the blocking remains as all 3D mapped blocks and there is an index
control which maintains the connectivity for fast mesh calculations.

+ The global topology helps avoid getting stuck in a corner, but requires some upfront thought
on how the global topology should be constructed to match the CAD topology.

+ There are no direct associations to the CAD when the blocking is initialized. Such associations
are controlled manually. The mesh can be generated at any time and the blocking projected to
the surfaces, allowing you to check and add shape as the blocking progresses.

Bottom Up

The bottom up blocking approach, also called 3D MultiZone, starts from the surface structure of the
3D CAD. For each surface it constructs a 2D blocking face, and then it tries to fill those 2D faces with
3D blocks.

Figure 24: Bottom Up Blocking Strategy

This approach has the following advantages:

+ It should always produce a mesh, but it may not be a hexahedral mesh.
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Where it can it generates mapped blocks. If this is not possible it will try to generate swept
blocks. If this is not possible, a free block is generated. The free block can be filled with a tet,
hex-core, or hex-dominant mesh.

+ This automated decomposition provides a good starting point to meshing. A user can then do
manual decomposition to get more hex mesh. This flexibility is often helpful as a user doesn't
always know how long it will take to get a hex mesh, so it is reassuring to know that a mesh
can be generated at any time.

+ The blocking topology model is automatically associated (shaped) by the CAD. A user can
gradually release those constraints as the blocking progresses to get more hex mesh.

While the two general approaches are identified as top down and bottom up, a user may use a combin-
ation to successfully block any given geometry.

Figure 25: Mixed Blocking Strategy

Hexa Block Types

A description of Mapped, Swept and Free block types is shown in Figure 26: Hexa Block Types (p. 33).

+ Mapped blocks are required to have an equal number of nodes on parallel edges. In 3D
blocking, this will result in hexahedral cells; quadrilateral cells in 2D blocking.

+ Free blocks may have different numbers of nodes on opposite sides, resulting in non-hexa
(quad if 2D) cells.

+ Swept blocks are identified by having two free faces opposite each other; and mapped faces
on the perpendicular sides between.
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Figure 26: Hexa Block Types
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When blocking a model, it is important to note that the block type affects many operations within
Hexa and the entire approach to mesh generation. For example, if you split a model having mapped
blocks, the split will propagate through faces that have a mapped relationship to the opposite side.
For free blocks, a split will terminate at the free face. Similarly, if you set edge parameters on a mapped
face edge, opposite edges will necessarily have the same number of nodes. If however, that edge is
attached to a free face, the number of nodes on the opposite side will not be adjusted. Using this
free/mapped relationship, you can shape the blocking and resulting mesh.

Sweept

Some operations may result in a degenerate block - a 7-sided mapped block. Degenerate blocks
have special behavior for mapped blocking and are not allowed in swept or free blocking.

Figure 27: Degenerate Block

The ability to Convert Block Type from free to mapped or vice versa imposes constraints on the
blocking and resulting mesh. By imposing more constraints, you can enforce a greater number of
hexa elements, while reducing the constraints can sometimes improve mesh transitioning.
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Figure 28: Mesh Generation within Block Types
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Automatic Ogrid Generation

Generating Ogrids is a very powerful and quick technique used to achieve a quality mesh to model
geometry when you desire a circular or "O"-type mesh, either around a localized geometric feature or
globally around an object. This would not be possible without Ogrids.

Using the Automatic Ogrid

The Ogrid creation capability is simply the modification of a single block or blocks to a 5 sub-block
topology as shown below. There are several variations of the basic Ogrid generation technique; the
Ogrid shown below is created entirely inside the selected block.

Figure 29: Initial block, Block with Ogrid, Ogrid with Add Face
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Edge Meshing Parameters
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Using the Add face feature, an Ogrid can be created such that the Ogrid passes through the selected
block faces. In Figure 29: Initial block, Block with Ogrid, Ogrid with Add Face (p. 34), the Add face
feature was used on the last block to include one face on the block prior to generating the Ogrid.

Important Features of an Ogrid
Generation of Orthogonal Mesh Lines at an Object Boundary

The generation of the Ogrid is fully automatic and you simply select the blocks needed for Ogrid
generation. The Ogrid is then generated either inside or outside the selected blocks. The Ogrid
can be fully contained within its selected region, or it can pass through any of the selected block
faces.

Rescaling an Ogrid After Generation

When the Ogrid is generated, its size is scaled based upon a factor in the Blocking >Edit Block

> Modify Ogrid window. The Rescale Ogrid feature enables you to re-scale the previously gen-
erated Ogrid. If a value less than 1 is assigned, the resulting Ogrid will be smaller than the original.
Conversely, a value larger than 1, will result in a larger Ogrid.

The blocks can also be modified by moving the vertices of the blocks and by defining specific
relationships between the faces, edges and vertices to the geometry.

Edge Meshing Parameters

The edge meshing parameter task is automated to provide you with unlimited flexibility in specifying
bunching requirements. Assigning the edge meshing parameters occurs after the development of the
block topology model. This feature is accessible by selecting Blocking > Edge params.

You can use the following predefined Mesh laws. These are described in Bunching Laws:

+ Bi-Geometric (default)

Release 2021 R2 - © ANSYS, Inc.Allrights reserved.- Contains proprietary and confidential information
of ANSYS, Inc.and its subsidiaries and affiliates. 35



Hexa Meshing

+ Bi-Exponential
+ Curvature

+ Exponential 1
+ Exponential 2
* FullCosinus

+ Geometric 1
+ Geometric 2
+ HalfCosinus1
+ HalfCosinus2
*+ Hyperbolic

+ Linear

+ Poisson

+ Spline

+ Uniform

In addition to the predefined edge meshing functions, there are several interactive or user-defined
Mesh laws available in the drop-down list.

The interactive or user-defined mesh laws include:

+ FromGraphs

Note:

By selecting this option, a dialog box opens in which you select a source file or function
and then add, delete, or otherwise modify the control points describing the edge parameter
settings.

+ FromEdgePoints
* OnScreen

Additional tools such as Linked Bunching and multiple Copy options provide you with the ability to
apply the specified edge bunching parameters quickly to the entire model.

Tip:

You can use variables in a replay script as a means to parameterize edge parameters. See
Parameterizing Edge Parameters (p. 38) for details.
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Making Parametric Changes to the Geometry

Smoothing Techniques

In Hexa, both the block topology and the mesh can be smoothed to improve the overall block/mesh
quality either in a certain region or for the entire model. The block topology can be smoothed to improve
the block shape prior to mesh generation. This reduces the time required for development of the block
topology model.

The geometry and its associative surfaces, curves, and points are all constraints when smoothing the
block topology model. Once the block topology smoothing has been performed, you can smooth the
mesh after specifying the proper edge-bunching parameters.

The quality criteria for smoothing are described in Pre-Mesh Quality in the Ansys ICEM CFD Help Manual.

Refinement and Coarsening

Use Blocking > Pre-Mesh Params > Refinement to refine or coarsen the mesh. You can apply the re-
finement/coarsening in all three major directions simultaneously or in just one major direction.

Refinement

You can use refinement for solvers that accept non-conformal node matching at the block bound-
aries. The refinement capability minimizes the model size while achieving proper mesh definition
in critical areas of high gradients. To refine the mesh, enter a scale factor greater than 1.

Coarsening

In areas of the model where the flow characteristics are such that a coarser mesh definition is ad-
equate, coarsening of the mesh may be appropriate to contain model size. To coarsen the mesh,
enter a scale factor less than 1.

Making Parametric Changes to the Geometry

With ICEM CFD’s Replay feature, you can analyze geometry variations. Changes in length, width and
height of specific geometry features are known as parametric changes. Parametric changes do not affect
the block topology, so the Replay function can automatically generate a topologically similar block
model that can be used for the parametric changes in geometry. If any of the Direct CAD Interfaces are
used, all geometric parameter changes are performed in the native CAD system.

To generate a Replay file:

1. From File > Replay Scripts, activate the recording of the commands needed to generate a custom
meshing process. All of the steps in the mesh development process are recorded, including blocking,
mesh size, edge meshing, boundary condition definition, and final mesh generation.

2. Make a parametric change in the geometry and then replay the recorded file on the changed geo-
metry. All steps in the mesh generation process are automated from this point.
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Parameterizing Edge Parameters

You can use variables in the replay script as a means to parameterize edge parameters. Here is an
example:

#vari abl es

set n 10

set hl 0.01

set rl 1.2

ic_load_tetin myfile.tin

i c_hex_surface_bl ocking -inherited -swept -min_edge 0.0

ic_geo_new famly SOLI D

ic_hex_twod_to_threed SCOLID -swept

ic_hex_set_mesh 19 18 n $n hl $hl h2rel 0.0 r1 $rl1 r2 2 Imax O default unl ocked

i c_hex_create_mesh SURFS SOLID proj 2 dimto_nesh 3

ic_hex_wite_file hex.uns SURFS SOLID proj 2 dimto_mesh 3 -family_boco fanily_boco. fbc

ic_uns_load hex.uns 3 0 {} 2

The variables for the edge parameters are set at the top of the replay file. Within the script, the '$'
indicates a variable. To parameterize the edge parameters, you can update the variables at the top
of the script and then rerun the script.

Analyzing Rotating Machinery

Periodic definition can be applied to the blocking in ICEM CFD. Typically, you will model only a section
of the rotating machinery and implement symmetry in order to minimize the model size. By specifying
a periodic relationship between the inflow and outflow boundaries, the particular specification can be
applied to the model; flow characteristics entering a boundary must be identical to the flow character-
istics leaving a boundary.

The periodic relationship is applied to block faces; and ensures that a node on the first boundary has
two identical coordinates to the corresponding node on the second boundary. Using the Blocking >
Edit Block > Periodic Vertices option, the application prompts you to select corresponding vertices
on the two faces in sequence. When all vertices on both flow boundaries have been selected, a full
periodic relationship between the boundaries has been generated.

Determining the Pre-Mesh Quality

The pre-mesh quality functions are accessible through Blocking > Pre-Mesh Quality.

Applying any of the quality checks produces a histogram plot. The quality Criterion, typically in the
range of 0 to 1, is subdivided and assigned to Bars on the x-axis. The y-axis measures the number of
elements in a given range and is scaled from 0 to a value that is indicated by the Height.

Determining the Location of Elements

By clicking on any of the histogram bars you can determine where in the model these elements are
located. The selected histogram bars will be highlighted by a change in color. After selecting the bars,
the Show feature is selected to highlight the elements in this range. If the Solid feature is enabled, the
elements marked in the histogram bars will be displayed with solid shading.

Some of the quality metrics are:
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Unstructured and Multi-block Structured Meshes

Determinant

Computes the deformation of the elements in the mesh by first calculating of the Jacobian of each
hexahedron and then normalizing the determinant of the matrix. A value of 1 represents a perfect
hexahedral cube, while a value of 0 is a totally inverted cube with a negative volume. In general,
determinant values above 0.3 are acceptable for most solvers.

Angle

Checks the maximum internal angle deviation from 90° for each element. Various solvers have dif-
ferent tolerance limits for the internal angle check. If the elements are distorted and the internal
angles are small, the accuracy of the solution will decrease. It is always wise to check with the
solver provider to obtain limits for the internal angle threshold. The histogram x-axis will cover the
range of 0 to 90°.

Volume

Computes the internal volume of the elements in the model. The x-axis will show volume in the
unit that was used to create the model.

Warpage

Indicates the level of element distortion. Nodes that are in-plane with one another will produce an
element with small warpage. Nodes that make elements twisted or distorted will increase an element's
distortion, giving a high degree of warpage. The x- axis, which ranges from a Min of 0 to a Max of

90, is the degree of warpage that an element experiences.

A full list of pre-mesh quality Criteria is available in Pre Mesh Quality Options

Unstructured and Multi-block Structured Meshes

The hexa mesh can be output in either unstructured or multi-block structured format. The format decision
can be delayed until after you have finished the whole meshing process when the output file format
is selected.

Unstructured Mesh Output

The unstructured mesh output feature will produce a single mesh output file where all common
nodes on the block interfaces are merged, independent of the number of blocks in the model.

Multi-block Structured Mesh Output

Used for solvers that accept multi-block structured meshes, this output feature will produce a mesh
output file for every block in the topology model. For example, if the block model has 55 blocks,
there will be 55 output files created in the output directory.

Additionally, without merging any of the nodes at the block interfaces, the Output Block feature
enables you to minimize the number of output files generated with the multi-block structured ap-
proach. See Pre-Mesh > Output Blocks.

The mesh output file(s) is (are) created from the context-sensitive menu under Blocking > Pre-Mesh
in the Display tree.
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Checking and Improving the Mesh

There are tools available under the Edit Mesh menu for interactive mesh editing, where nodes can be
moved on the underlying CAD surfaces, merged or even deleted. Individual triangles of the mesh can
be subdivided or tagged with different names. You can perform quality checks, as well as local
smoothing.

Checking the Mesh

Quiality Metrics

Smoothing the Mesh Globally
Mesh Editing Tools

Checking the Mesh

Check the validity of the mesh using Edit Mesh > Check Mesh. ICEM CFD includes several checks for
Errors as well as Possible problems. The descriptions of each of these checks can be found in Check
Mesh in the Ansys ICEM CFD Help Manual.

You can opt to use the Create subsets feature for each of the problems so that they can be fixed later
or can opt to use the Check/fix each feature to check and fix each one of them. Using subset manipu-
lation and mesh editing techniques, you can diagnose the problem and resolve it through merging
nodes, splitting edges, swapping edges, delete/create elements, and so on.

For ease of use when working with subsets, it is usually helpful to add elements to the subset in order
to see what is happening around the problem elements. To do this, right-click the Subset name in the
Display tree and then add layers of elements to the subset. It is also useful to display the element nodes
and/or display the elements slightly smaller than actual size. Both of these features can be accessed by
right-clicking on Mesh in the Display Tree.

Note:

After mesh editing the diagnostics should be re-checked to verify that no mistakes were
made.

Quality Metrics

The Display Mesh Quality feature runs a diagnostic check of individual element quality and displays
the mesh quality as a histogram. The x-axis measures the quality, with 0 representing poor quality and
1 representing high quality. The y-axis measures the number of elements that belong within each
quality sub-range. Click a bar in the histogram to identify all the cells within that quality sub-range, in
the graphics display.
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For descriptions of all the quality metrics, refer to Display Mesh Quality in the Ansys ICEM CFD Help
Manual.

You can modify the display of the histogram by adjusting the values of Min, Max, Height, and Bars.
Right-click the histogram to access the following features for modifying its display attributes.

+ The Replot feature opens a small window that enables you to change the following parameters.
Clicking Accept replots the histogram to the newly set values.

Min X Value

This minimum value, which is located on the left-most side of the histogram's x-axis, represents
the worst quality elements.

Max X Value

This maximum value, which is located on the right-most side of the histogram's x-axis, rep-
resents the highest quality that elements can achieve.

Max Y height

You can adjust the number of elements that will be represented on the histogram's y-axis.
Usually a value of 20 is sufficient. If there are too many elements displayed, it is difficult to
discern the effects of smoothing.

Num bars

This represents the number of subdivisions within the range between the Min X and Max
X values. The default Bars have widths of 0.05. Increasing the number of displayed bars will
decrease their width.

« The Reset feature will return all of the values back to their original settings.

+ Show: Click the left mouse button on any of the bars in the histogram to select elements that
fall within that selected Quality range. If Show is enabled, the selected elements on the model
will become visible in the main viewing window. The following features control how the selected
elements are displayed.

+ Solid: Enabling this feature will display the elements as solid, rather than the default grid repres-
entation. (Show must be enabled.)

+ Color by Quality: If available, enabling this feature will display the elements in the same color
as the selected Quality bar in the histogram. (Show must be enabled.)

+ Highlight: If available, this feature enables you to display one or two additional layers adjacent
to the selected elements. (Show must be enabled.)

+ Subset: Allows you to create a Subset containing only the elements chosen from the Quality
histogram. The visibility of this subset is controlled by Subset in the Display Tree. The Add select
feature enables you to add elements to an already established subset.
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Smoothing the Mesh Globally

Smoothing the Mesh Globally

After eliminating errors/possible problems from a tetra mesh, you can improve the mesh quality using
Edit Mesh > Smooth Mesh Globally.

The smoother modifies the elements with quality below the specified Up to quality value, based on
the selection from the list of available quality criteria. Nodes can be moved and/or merged, edges are
swapped, and in some cases elements are deleted. This operation is then repeated on the improved
grid, up to the specified number of iterations. You can choose to smooth some element types while
freezing others.

The triangular surface mesh smoother operates independently of the volume mesh smoother. Initially,
all elements that are below the quality threshold of the specified criterion are marked, and then the
specified number of smoothing steps are run on those elements. Nodes movement is constrained to
the actual CAD surfaces during the smoothing process.

Smoothing iterations

This value is the number of times the smoothing process will be performed. Models with a more
complicated geometry will require a greater number of iterations to obtain the desired quality,
which is specified for Up to quality.

Up to quality

The Min value represents the worst quality, while the Max value represents the highest quality
elements. Usually, the Min value is set to 0.0 and the Max value is set to 1.0. The Up to quality
value gives the smoother a quality to aim for. Ideally, after smoothing, the quality of the elements
should be higher than or equal to this value. If this does not happen, you should employ other
methods of improving the quality, such as merging nodes and splitting edges. For most models,
the elements should all have ratios of greater than 0.3, while a ratio of 0.15 for complicated models
is usually sufficient.

Freeze

If the Freeze feature is selected for an element type, the nodes of this element type will be fixed
during the smoothing operation. As a result, this element type will not be displayed in the histogram.

Float

If the Float feature is selected, the nodes of the specified element type will be capable of moving
freely, enabling nodes that are common with another type of element to be smoothed. The quality
of elements set to float is not tracked during the smoothing process and so the quality is not dis-
played in the histogram.

Advanced Options for Smoothing the Mesh
Prism Warpage Ratio

Prisms are smoothed based on a balance between prism warpage and prism aspect ratio. Values
from 0.01 to 0.50 favor improving the prism aspect ratio, while those from 0.50 to 0.99 favor im-
proving prism warpage. A value of 0.5 favors neither. The farther the value is from 0.5, the
greater the effect.
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Stay on geometry

The default is, when a grid is smoothed, the nodes are restricted to the geometry -- surface, curves
and points -- and can be moved only along the geometrical entities to which they are associated.

Violate Geometry

Enabling this feature allows the smoothing operation to yield a higher quality mesh by violating
the constraints of the geometry. The nodes can be moved off the geometry to obtain better mesh
quality, as long as the movement remains within the absolute distance specified.

Relative Tolerance
This feature works much like Violate Geometry except that the distance is relative here.
Allow refinement

If the quality of the mesh cannot be improved through normal algebraic smoothing, the Allow
refinement feature will enable the smoother to automatically subdivide elements to obtain further
improvement. After smoothing with Allow refinement enabled, it may be necessary to smooth
further with the feature disabled. The goal is to reduce the number of elements that are attached
to one vertex by refinement in problem regions.

Laplace smoothing

This feature will solve the Laplace equation, which will generally yield a more uniformly spaced
mesh.

Note:

This can sometimes lead to a lower determinant quality of the prisms. Also, this
feature works only for the triangular surface mesh.

Allow node merging

This feature will collapse and remove the worst tetra and prism elements when smoothing in order
to obtain a higher quality mesh. This is enabled by default, and is often very useful in improving
the grid quality.

Not just worst 1%

This feature will smooth all of the geometry's elements to the assigned quality (specified under
Up to quality) not just focus on the worst 1% of the mesh. Typically, when a mesh is smoothed,
the smoother concentrates on improving the worst regions; this feature will allow the smoother
to continue smoothing beyond the worst regions until the desired quality is obtained.

Surface fitting

This feature will smooth the mesh, keeping the nodes and the new mesh restricted to the surface
of the geometry. Only Hexa models will use this feature.
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Mesh Editing Tools

Ignore PrePoints

This feature will allow the smoother to attempt to improve the mesh quality without being bound
by the initial points of the geometry. This feature is similar to the Violate geometry feature, but
works only for points located on the geometry. This feature is available only when there are
hexahedral elements in the model. Usually, the best way to improve the quality of grids that
cannot be smoothed above a certain level is to concentrate on the surface mesh near the bad
elements and edit this surface mesh to improve the quality.

Mesh Editing Tools

In addition to the automated mesh improvement options, there are several manual diagnostic and repair
tools that enable you to build mesh topology, remesh bad elements and fill holes easily. Also there are
tools for the detection of overlapping triangles and non-manifold vertices, as well as detection of
single/multiple edge and duplicate elements. Other tools allow you to merge or split the mesh, move
elements, convert mesh type, change density, or otherwise manipulate the mesh.

These are fully described at Edit Mesh.
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Using the Properties Menu

The Properties menu enables you to create different materials by specifying material or element
properties, such as type, the Young's Modulus, and Poisson's ratio. Once the material is created, you
can apply those properties to the elements.

Create Material Property

Enables you to define a material by specifying a name of the material, define whether isotropic,
enter in values for Young's Modulus, Shear modulus, Poisson's ratio, Mass Density, and Thermal
expansion coefficient.

Write Material File

Saves the material specification so that it can be reused whenever necessary. The material file will
be saved with the . mat extension.

Load Material From File
Opens a material file to be used in your design or to be modified and saved for future use.
Create Table

Enables you to create your material property by entering values for x and y. You can even graph
the property.

Define Element Properties

These features enable you to apply your material properties to their respective elements. Different
types of elements that can be defined include Point, Line, Shell, and Volume. After you choose the
part, the various properties are applied to its elements.
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Using the Constraints Tab

From the Constraints tab, you can define the motion restrictions on different entities such as points,
curves, surfaces, or subsets, as well as define other features such as Contact definition, Velocity, and
Rigid Wall.

Create Constraint / Displacement

Enables you to apply a directional or rotational constraint on an entity, in any direction.
Define Contact

Enables you to define contacts by Automatic Detection or Manual Definition.
Define Single Surface Contact

Enables you to define a surface contact. This is used mainly for LS-DYNA Solver, where you can pick
the contact surface.

Define Initial Velocity

Enables you to define initial nodal point velocities by specifying the translational and rotational
velocity for nodal sets.

Define Planar Rigid Wall

Enables you to define a Planar Rigid Wall by specifying the Head and Tail coordinates.
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Working with Loads

On the Loads tab, there are several features available for applying internal and external loads, such as
force, pressure, and temperature.

Force
Pressure

Temperature

How ICEM CFD treats the load depends on how the load is applied - to a curve, a surface, or a mesh.
In all cases, the load information is not calculated until you are creating the output files for one of the
supported "Common Structural" solvers: Ansys, Autodyn, LS-DYNA, ABAQUS, or NASTRAN. That is, the
output file is generated thru the Solve Options Tab, and at this time, the loads will be written out ac-
cording to the selected solver's published format.

Force

Using this feature, you can apply translational (force) or rotational (moment) loads on entities in all
three directions.

Forces can be applied by two different features. The Uniform feature applies the stated force at all se-
lected entities. For example with curves, the Uniform feature will apply the full force to all nodes attached
to the curve. The Total feature means that the force gets distributed among all the nodes of the selected
entities according to FEA concepts as described below.

Distributed Forces Theory
Total forces are distributed as described below, depending on the entity type.
+ By Curve

The total Force 'F; ' can be applied on a curve as shown below. Applying the load to a geometry

entity simplifies the process for you and keeps the load information at the geometry level so the
mesh can be regenerated without losing the setup information.

Figure 30: Force on a Curve
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Working with Loads

Nodes are numbered 0, 1, 2, and so on. Elements between the nodes have lengths L,, L, and so on.
The total length is Ly

Then the force on the Nodes, as per FEA concepts, is distributed linearly in proportion to the Element
length as shown in the figure below.

Figure 31: Linear Force Distribution
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For a Linear distribution, the load at each node is calculated as follows.
Node 0: F, = 0.5 * F+ * (L, / Ly)

Node 1: F; =05 *F; * (L, /Ly) + 0.5 * Fr * (L, / Ly)

Node 2: F, =05 *F; * (L, / Ly) + 0.5 * Fr * (L3 / Ly)

Node 3: F;=05*F; * (L3 /L) + 0.5 * F * (L, / Ly)

Node 4: F, =05 *F; * (L, / Ly)

In general, the force at any Node is: F; = Sum [Fy * (L; / Ly) * (1 / N;)], where i is the node number, j
is the element number, L; is the length of element j, and N; is the number of Nodes attached to element

j-
As a check, if you add the individual node forces, Fy + F; + F; + F3 + F4 , then the result equals Fy .

By Mesh Elements

You can also apply loads directly to the elements (select the elements directly rather than the geometry
entities). This can occur, for example, if you do not have the geometry in a particular model or area
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Force

of a model. In this case, the load is distributed element-by-element using a Quadratic distribution
as shown.

Figure 32: Force on Elements with mid-side nodes
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Node numbers and element lengths are defined as before. In addition, each element has a mid-side
node labeled m;, m,, and so on.

The Quadratic Load distribution, as per FEA concepts on an element-by-element basis is shown in
Figure 33: Quadratic Load Distribution (p. 53).

Figure 33: Quadratic Load Distribution
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The distribution of the Total Force, Fy, at the boundary nodes is as follows:
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Working with Loads

Node 0: Fo, = 1/6 * Fy * (L, / Ly)

Node 1: F; =1/6 * Fy * (Ly / Ly) + 1/6 * Fr * (L, / Ly)
Node 2: F,, = 1/6 * Fy * (L, / Ly) + 1/6 * Fr * (L3 / Ly)
Node 3: F3, = 1/6 * Fy * (L3 / Ly) + 1/6 * Fr * (L, / Ly)
Node 4: F,, = 1/6 * Fy * (Ls / Ly)

And the distribution at mid-side nodes is:

Node m: F,; =2/3 *Fr * (L, / Ly)

Node m,: F,, =2/3*F;* (L, / Ly)

Node m3: F 5 =2/3 *F: * (L3 / Ly)

Node my: F s =2/3 *Fr * (Ly / Ly)

As in the previous case of linear distribution, you can check the total Force by adding the individual
nodal forces:

*+ By Surface

If you choose to set a load on a surface entity, then the load distribution follows the Nine Node, Two
Dimension, Lagrange distribution. See the Figure 34: QUAD 9 Element (p. 54) for an illustration.

Figure 34: QUAD 9 Element
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Nine nodes are identified: N;-N, at the corners; N5-Ng at the mid-sides; and Ng in the middle. The

symbols £ and m define a local coordinate system for the development of the load distribution, and
vary from -1 to +1 over the surface of the element.

The Shape function for the distribution at a Corner Node is:
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1
N.(&m) =-&n(£-1)(n-1)
At a Mid-Side Node, the Shape function for the distribution is:
1 2
N.(€n) =37(1-8)-(n-1)
And finally, the Shape function for the Middle Node load distribution is:

N.(&.1m) =(1-8)-(1-77)

Suppose a Force F is uniformly distributed over the whole Area. Then the pressure is P = F / 4. (Because
in the £-1) coordinate system the area of the surface is 4.)

To find the Consistent Load at each Node, we must integrate the Shape function over the surface
area:

Consistent Load at Node 1 =L;:

&=1 =1
4P
L=p-f,_J _Ndédn=3¢
Consistent Load at Node 5 = Lg:
=1 =1
-p. _4p
L5—P J-fz_l.rrlz,lNSdgdn_ 9
Consistent Load at Node 9 = Lg:
=1 =1
16P
L9=P- J‘g;lj‘nz_ll\hdfdn:T

Now F = 4P.

Substituting this value in the above equations we get the Consistent Load as

L,=F/36

By symmetry, the Consistent Load on all corner nodes N;, N,, N3, and N, are equal.
Similarly, the Consistent Load on all mid-side nodes Ns, Ng, N5, and Ng are equal.

As with the Linear and Quadratic distributions, a check against the Total can be performed.

The sum of the Consistent Loads =4 *L; + 4 * Ls + Lg

—F/9+4F/9+4F/9
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=F;

Note:

A similar process for calculating the Consistent Load on a QUAD8 element load distribution
is available. Again, the output file is generated thru the "Solve Options" Tab, and during
output, the distributed load information will be written out according to the selected
solver's published format.

Pressure

You can apply pressure loads to Surfaces, Subsets, or Parts. Pressure loads may be uniformly applied
or described using a set of vectors. See Place Pressure for more detail.

Temperature

This feature enables you to apply temperature to Points, Curves, Surfaces, Bodies, Subsets or Parts.
Typically, the temperature load is applied uniformly to the selected entity. See Create Temperature
Boundary Condition for more detail.
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Sending Data to a Solver

The FEA Solve Options tab and Output Mesh tab have tools for selecting an output solver and then
specifying the type of analysis and other parameters necessary to compute a solution.

The FEA Solve Options tab is used to setup for structural analysis. Choose from one of the following
common solvers: Ansys, Nastran, ABAQUS, Autodyn, and LS-DYNA.

Setup Solver Parameters

Your choice of solver determines which additional parameters are required. ABAQUS and
Autodyn do not require additional solver parameters.

Setup Analysis Type

Depending on the selected solver, different features are available. For the Ansys solver, you
can select either Structural or Thermal. If Nastran solver is selected, then you can choose from
more Analysis types.

Setup Sub-Case

Enables you to create subcases to apply the load in different steps.
Write/View Input File

Enables you to create and view the input file generated for the solver.
Submit Solver Run

Enables you to send an input file to a particular solver.

The Output Mesh tab is used for CFD analysis and exporting the mesh in supported formats. Choose
from one of the supported Output Solvers, and then setup Boundary Conditions and other Parameters
before writing the solver input file.

More information about the supported solvers is available from the Help menu. The Output Interfaces
feature opens the Ansys ICEM CFD Output Interfaces information in a browser. For information about
a specific solver, refer to the Table of Supported Solvers and click the name of the solver.
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Workbench Integration

The data-integrated ICEM CFD component system, or "ICEM CFD Add-in", enables you to launch ICEM

CFD from Ansys Workbench and use it to build a project, with the option of adding upstream data from
Geometry, Mesh, Mechanical Model, or combined Geometry and Mesh system components. You can

also use ICEM CFD to provide data to downstream component systems, such as Ansys Fluent, Ansys
CFX, Ansys Polyflow, FENSAP-ICE, and Mechanical APDL.
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ICEM CFD

The additional features available through the ICEM CFD add-in are described in the following sections:
+ For a description of the ICEM CFD component, see Elements of the ICEM CFD Component.

* For instructions on how to initiate an ICEM CFD component, see Creating an ICEM CFD Component.

+ For a description of how an ICEM CFD component iteracts with the Workbench environment, see
Updating ICEM CFD Projects.
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Workbench Integration

+ For a description of the user interface is changed, see Interface Differences in the Data-Integrated
ICEM CFD.

+ For instructions on how to pass parameters into or out of an ICEM CFD component, see Setting
Parameters.

+ For an example of setting a user-defined input parameter, see User-Defined Parameters Example.

+ For special instructions on how to interface to Static Structural, see Transferring an ICEM CFD Project
to Static Structural.
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