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Chapter 1: Ansys TurboGrid Overview
Ansys TurboGrid is a powerful tool that lets designers and analysts of rotating machinery create high-
quality meshes, while preserving the underlying geometry. These meshes are used in the Ansys workflow
to solve complex blade passage problems.

The Ansys TurboGrid online product documentation is divided into five major areas:

1. Ansys TurboGrid Introduction

A brief introduction, listing of new features, and detailed information about the Ansys TurboGrid
Launcher

2. Ansys TurboGrid Tutorials

3. Ansys TurboGrid User's Guide

Information about the user interface and workflow

4. Ansys TurboGrid Reference Guide

Detailed information about menu items, command actions, syntax, and so on.

5. Installation and Licensing

Help on using Ansys TurboGrid in Ansys Workbench is provided in Ansys TurboGrid in Ansys Work-
bench (p. 9) and in the TurboSystem > Ansys TurboGrid section of the Ansys Workbench help.

This chapter describes:

1.1.Valid Decimal Separators

1.2. 3Dconnexion Product Support

1.3. Compatibility with File Hosting Services

1.1. Valid Decimal Separators

In Ansys TurboGrid, only a period is allowed to be used decimal delimiters in fields that accept floating-
point input. Depending on your system configuration, fields that accept numeric input will either accept
a comma but return an error, or not accept a comma at all.

5
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Ansys Workbench accepts commas as decimal delimiters, but translates these to periods when passing
data to Ansys TurboGrid.

Note:

TurboGrid will not function correctly on a Linux system with the environment variable
"LC_ALL" set to a locale which uses a comma delimiter. The environment variable "LANG"
can usually be used to set the locale instead.

1.2. 3Dconnexion Product Support

See the Platform Support section of the Ansys Website for a complete list of 3Dconnexion products
certified with the current release of Ansys applications.

Note:

Note: The 3D Viewer in CFX/CFD-Post/TurboGrid does not support the buttons of a 3Dcon-
nexion device. However it might be possible to use the software provided with the device
to configure the buttons so that they send key sequences that trigger 3D Viewer actions.

1.3. Compatibility with File Hosting Services

Files written by Ansys products do not support synchronization with Microsoft’s OneDrive file hosting
service.

Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
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Chapter 2: Using the Ansys TurboGrid Launcher
Ansys TurboGrid can be run in two modes:

• Ansys TurboGrid stand-alone, which refers to Ansys TurboGrid running as a stand-alone application
independent of the Ansys Workbench software.

• Ansys TurboGrid Workbench, which refers to Ansys TurboGrid running as a component inside of the
Ansys Workbench software. This is described in Ansys TurboGrid in Ansys Workbench (p. 9).

Note:

For CFX, TurboGrid and CFD-Post applications, the graphics viewer, which is based on OpenGL
4.5, will work with Microsoft Windows Remote Desktop Connection only if you are using
Nvidia Quadro graphics cards with appropriate drivers for Windows 10. If you see an empty
(black) viewer, try setting the environment variable QT_OPENGL=desktop on the remote
machine before starting the application. To work around this issue you may launch the CFX
application prior to making the remote connection, or use one of the other Ansys-supported
remote display methods.

Note:

If you are running CFX-Pre/CFD-Post/TurboGrid on a Linux machine that does not have a
compatible OpenGL driver installed, you can try starting the CFX application with software
rendering enabled by adding the command line parameter: -gr mesa.

Ansys TurboGrid stand-alone has the Ansys TurboGrid Launcher, which makes it easy to run all the
modules of CFX without having to use a command line. The launcher enables you to:

• Set the working directory for your project

• Start CFX and Ansys products

• Access various other tools, including a command window that enables you to run other utilities

• Access the online help and other useful information

• Customize the behavior of the launcher to start your own applications.

The launcher automatically searches for installations of CFX and Ansys products including the license
manager. Depending on the application, the search includes common installation directories, directories
pointed to by environment variables associated with CFX and Ansys products, and the Windows registry.
In the unlikely event that a product is not found, you can configure the launcher using the steps outlined
in Customizing the Ansys TurboGrid Launcher in the TurboGrid Reference Guide.

This chapter describes:

7
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2.1. Starting the Ansys TurboGrid Launcher

For more information about the launcher, see The Ansys TurboGrid Launcher Interface in the TurboGrid
Reference Guide and Customizing the Ansys TurboGrid Launcher in the TurboGrid Reference Guide.

2.1. Starting the Ansys TurboGrid Launcher

You can run the Ansys TurboGrid Launcher in any of the following ways:

• On Windows:

– From the Start menu, select Start > ANSYS 2021 R2 > Meshing > TurboGrid 2021 R2.

– In a Command Prompt that has its path set up correctly to run Ansys TurboGrid, enter cfxlaunch
(otherwise, you will need to enter the full pathname of the cfxlaunch command).

• On UNIX, enter cfxlaunch in a terminal window that has its path set up to run Ansys TurboGrid.

To run Ansys TurboGrid, start the launcher, set the working directory, then click TurboGrid 2021 R2.

Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
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Chapter 3: Ansys TurboGrid in Ansys Workbench

Note:

This chapter assumes that you are familiar with using Ansys TurboGrid in stand-alone mode,
as described in Using the Ansys TurboGrid Launcher (p. 7), and that you are familiar with
Ansys Workbench.

This chapter describes using Ansys TurboGrid in Ansys Workbench. The following topics are discussed:

3.1.The Ansys Workbench Interface

3.2. Example Workflow involving Ansys TurboGrid

3.3. Known Limitations of Ansys TurboGrid Running in Ansys Workbench

For an example workflow that includes the use of Ansys TurboGrid, see TurboSystem Workflows in the
TurboSystem User's Guide.

For information about using Ansys Workbench journaling and scripting with Ansys TurboGrid, including
a special note about playing older journal and session files, see Using Ansys Workbench Journaling and
Scripting with TurboSystem in the TurboSystem User's Guide.

3.1. The Ansys Workbench Interface

To launch Ansys Workbench on Windows, click the Start menu, then select All Programs > ANSYS
2021 R2 > Workbench 2021 R2.

Note:

For CFX, TurboGrid and CFD-Post applications, the graphics viewer, which is based on OpenGL
4.5, will work with Microsoft Windows Remote Desktop Connection only if you are using
Nvidia Quadro graphics cards with appropriate drivers for Windows 10. If you see an empty
(black) viewer, try setting the environment variable QT_OPENGL=desktop on the remote
machine before starting the application. To work around this issue you may launch the CFX
application prior to making the remote connection, or use one of the other Ansys-supported
remote display methods.

To launch Ansys Workbench on Linux, open a command line interface, type the path to "runwb2" (for
example, "~/ansys_inc/v212/Framework/bin/Linux64/runwb2"), then press Enter.

The Ansys Workbench interface is organized to make it easy to choose the tool set that will enable you
to solve particular types of problems. Once you have chosen a system from the Toolbox and moved
it into the Project Schematic, supporting features such as Properties and Messages provide orienting
information. These features and the status indicators in the system cells guide you through the completion
of the System steps.

9
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The figure that follows shows Ansys Workbench with a TurboGrid component system open and the
properties of cell A2 (Turbo Mesh) displayed:

The following sections describe the main Ansys Workbench features.

3.1.1.Toolbox

3.1.2. Project Schematic

3.1.3.View Bar

3.1.4. Properties View

3.1.5. Files View

3.1.6. Sidebar Help

3.1.7. Shortcuts (Context Menu Options)

3.1.8. Using Workbench Input Parameters and Workbench Output Parameters

3.1.1. Toolbox

The Toolbox shows the systems available to you:

Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
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Analysis Systems

Systems that match the workflow required to solve particular types of problems. For example,
the Fluid Flow (CFX) system contains tools for creating the geometry, performing the meshing,
setting up the solver, using the solver to derive the solution, and viewing the results.

Component Systems

Software elements upon which Analysis Systems are based. For example, the CFX component
system contains Setup (CFX-Pre), Solution (CFX-Solver Manager), and Results (CFD-Post). The
Results component system contains only Results (CFD-Post).

Custom Systems

Systems that combine separate analysis systems. For example, the FSI: Fluid Flow (CFX) > Static
Structural system combines Ansys CFX and the Mechanical application to perform a unidirectional
(that is, one-way) Fluid Structure Interaction (FSI) analysis.

Design Exploration

Systems that enable you to see how changes to parameters affect the performance of the system.

Note:

Which systems are shown in the Toolbox depends on the licenses that exist on your system.
You can hide systems by enabling View > Toolbox Customization and clearing the check
box beside the name of the system you want to hide.

To begin using a system, drag it into the Project Schematic area.

3.1.2. Project Schematic

The Project Schematic enables you to manage the process of solving your problem. It keeps track
of your files and shows the actions available as you work on a project. At each step you can select
the operations that process or modify the case you are solving.

When you move a system from the Component Systems toolbox to the Project Schematic, you will
see a set of tools similar to the following:

11
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Each white cell represents a step in solving a problem. Right-click the cell to see what options are
available for you to complete a step.

For example, in a TurboGrid system:

• Edit launches Ansys TurboGrid.

• Transfer Data To New > CFX adds a new CFX component system that uses the mesh from the
Turbo Mesh cell.

3.1.3. View Bar

You control which views are displayed by opening the View menu and setting a check mark beside
the view you want to display. If you minimize that view, it appears as a tab in the View Bar and the
check box is cleared from the View menu.

3.1.4. Properties View

The Properties view is a table whose entries describe the status of a system. These entries vary
between system cells and are affected by the status of the cell. Some entries in the Properties area
are writable; others are for information only.

To display the Properties for a particular cell, right-click the cell and select Properties. Once the
Properties view is open, simply selecting a cell in the Project Schematic will display that cell's
properties.

The properties specific to the Turbo Mesh cell of the TurboGrid system are documented in TurboGrid
in the TurboSystem User's Guide.

Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
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3.1.5. Files View

The Files view shows the files that are in the current project. The project files are updated constantly,
and any "save" operation from Ansys TurboGrid will save all files associated with the project.

3.1.6. Sidebar Help

In addition to having a visual layout that guides you through completing
your project, you can also access Sidebar Help by pressing F1 while the
mouse focus is anywhere on Ansys Workbench. Sidebar Help is a
dynamically generated set of links to information appropriate for helping
you with questions you have about any of the tools and systems you
currently have open.

3.1.7. Shortcuts (Context Menu Options)

You can access commonly used commands by right-clicking in most areas of Ansys Workbench. These
commands are described in the section Context Menu Options in the Ansys Workbench help. The only
context menu command that is specific to the Turbo Mesh cell is the Edit command, which opens
Ansys TurboGrid.

3.1.8. Using Workbench Input Parameters and Workbench Output Parameters

For information about using and managing Workbench input parameters and Workbench output
parameters in Ansys TurboGrid, see Object Editor in the TurboGrid User's Guide and Expression Editor
Dialog Box in the TurboGrid User's Guide.

3.2. Example Workflow involving Ansys TurboGrid

In Ansys Workbench, you can create a CFD simulation of a pump impeller that has the following Project
Schematic:
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In this example, the pump impeller is generated in BladeGen, has fillets added in BladeEditor, and is
meshed in Ansys TurboGrid. The pump diffuser is generated in BladeGen and is meshed in Ansys Tur-
boGrid. Both meshes are used in a CFD analysis.

To set up this schematic, you can follow this general procedure:

1. Launch Ansys Workbench.

2. Save the project to a new directory.

3. Add a BladeGen system by double-clicking BladeGen in the toolbox, under Component Systems.

Alternatively, you can drag a BladeGen system from the toolbox to the Project Schematic.

4. Add a Geometry system to the BladeGen system by any one of the following methods:

• Double-click a Geometry system in the toolbox to add a Geometry system to the schematic,
then drag from the Blade Design cell to the Geometry cell to connect the systems.

• Drag a Geometry system from the toolbox to the Project Schematic, then drag from the Blade
Design cell to the Geometry cell to connect the systems.

• Drag a Geometry system from the toolbox to the Blade Design cell.

• Right-click the Blade Design cell and select Transfer Data To New > Geometry.

5. Optionally rename the system.

You can enter a name for a system when you first create the system. You can also initiate a rename
operation by right-clicking the upper-left corner of the system and selecting Rename from the
shortcut menu.

6. Continue adding systems until the schematic is complete.

7. Edit each cell in sequence, starting from the upstream cell, and use the associated software to
provide the required data.
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For example, after editing the Blade Design cell to provide a geometry, edit the Turbo Mesh cell
to create a mesh in Ansys TurboGrid.

8. Save the project when finished.

Important:

Saving a project enables you to re-open the project on the machine that originally created
it. To make the project available on another machine, you need to use File > Archive to
create a project archive. To open the project on a different machine, run File > Restore
Archive on that machine.

3.3. Known Limitations of Ansys TurboGrid Running in Ansys Workbench

• The Units settings in the Ansys Workbench menu have no effect on the units used in Ansys TurboGrid.

• The mesh is always saved in the "Combined in one domain, one file" mode and in the user-preferred
length unit.

• Session playback is not supported in Ansys TurboGrid running in Ansys Workbench.

• Ansys TurboGrid in Ansys Workbench does not support the use of filenames or project names that
contain either the "$", "#", or "," characters anywhere in their filepath.

• If you play a journal file on a platform that is different from the one used to record it, you might en-
counter a problem. For example, a journal file recorded on Windows and played on Linux can result
in a different number of outlet points being generated. This can happen due to different amounts
of round-off error, and can lead to errors being generated.

• If an upstream or downstream adjacent blade is specified for computing inlet or outlet locations and
an error occurs while loading/refreshing the geometry then the inlet/outlet locations will not be
computed based on the adjacent blade. Once the cause of the original error is fixed, closing and re-
opening TurboGrid will fix this problem.

• If the number of blades in an upstream geometry is changed then TurboGrid may produce some er-
ror/warning messages when it is opened. This is not indicative of a real issue. Closing and re-opening
TurboGrid will result in everything being updated correctly.

• Although the names of design parameters can be modified using the Parameter Manager within
Ansys Workbench, this is not recommended, because the new names will not be reflected within the
TurboGrid application user interfaces.
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Chapter 4: Ansys TurboGrid Help and Conventions
This chapter describes:

4.1. Accessing Help

4.2. Document Conventions

4.1. Accessing Help

You can access the help in the following ways:

• Select the appropriate command from the Help menu of the Ansys TurboGrid Launcher or Ansys
TurboGrid to open the Ansys Help.

• Click a feature of the Ansys TurboGrid interface to make it active and, with the mouse pointer over
the feature, press the F1 key for context-sensitive help (that is, the online help opens at the appro-
priate page for the feature under the mouse pointer). Not every area of the interface supports context-
sensitive help.

4.2. Document Conventions

This section describes the conventions used in this document to distinguish between text, computer
file names, system messages, and input that you need to type.

4.2.1. File and Directory Names

File names and directory names appear in a plain fixed-width font (for example, /usr/lib). Note
that on Linux, directory names are separated by forward slashes (/) but on Windows, backslashes are
used (\). For example, a directory name on Linux might be /CFX/bin whereas on a Windows system,
the same directory would be named C:\CFX\bin.

4.2.2. User Input

Input to be typed verbatim is shown in the following convention:

mkdir /usr/local/cfx

4.2.3. Input Substitution

Input substitution is shown in the following convention:

cfx5 -def <def_file>

you should actually type cfx5 -def, and substitute a suitable filename for <def_file>.

17
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4.2.4. Optional Arguments

Optional arguments are shown using square brackets:

cfxlaunch [-help] [-verbose] [-display <display>]

Here the arguments -help, -verbose, and -display are optional, but if you specify -display,
you must then specify a suitable display server (represented by <display>).

4.2.5. Long Commands

Commands that are too long to display on a printed page are shown with "\" characters at the ends
of intermediate lines:

mount -r -F hsfs \
/dev/dsk/c0t6d0s0 /cdrom

On a Linux system, you may type the "\" characters, pressing Enter after each. However, on a Windows
machine you must enter the whole command without the "\" characters; continue typing if the
command is too long to fit in the command prompt window and press Enter only at the end of the
complete command.

4.2.6. Operating System Names

When we refer to objects that depend on the type of system being used, we will use one of the fol-
lowing symbols in the text:

<os> refers to the short form of the name which Ansys CFX uses to identify the operating system in
question. <os> will generally be used for directory names where the contents of the directory depend
on the operating system but do not depend on the release of the operating system or on the processor
type. Wherever you see <os> in the text you should substitute with the operating system name. The
correct value can be determined by running:

<CFXROOT>/bin/cfx5info -os

<arch> refers to the long form of the name which Ansys CFX uses to identify the system architecture
in question. <arch> will generally be used for directory names where the contents of the directory
depend on the operating system and on the release of the operating system or the processor type.
Wherever you see <arch> in the text you should substitute the appropriate value for your system,
which can be determined by running the command:

<CFXROOT>/bin/cfx5info -arch
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