
CFD EXPERTS 
Simulate the Future 

WWW.CFDEXPERTS.NET 

https://cfdexperts.net/
https://cfdexperts.net/


Ansys TurboGrid Tutorials

Release 2021 R2ANSYS, Inc.
July 2021Southpointe

2600 Ansys Drive
Canonsburg, PA 15317 ANSYS, Inc. and

Ansys Europe,ansysinfo@ansys.com
Ltd. are UL

http://www.ansys.com registered ISO
(T) 724-746-3304
(F) 724-514-9494

9001: 2015
companies.



Copyright and Trademark Information

© 2021 ANSYS, Inc. Unauthorized use, distribution or duplication is prohibited.

Ansys, Ansys Workbench, AUTODYN, CFX, FLUENT and any and all ANSYS, Inc. brand, product, service and feature
names, logos and slogans are registered trademarks or trademarks of ANSYS, Inc. or its subsidiaries located in the
United States or other countries. ICEM CFD is a trademark used by ANSYS, Inc. under license. CFX is a trademark
of Sony Corporation in Japan. All other brand, product, service and feature names or trademarks are the property
of their respective owners. FLEXlm and FLEXnet are trademarks of Flexera Software LLC.

Disclaimer Notice

THIS ANSYS SOFTWARE PRODUCT AND PROGRAM DOCUMENTATION INCLUDE TRADE SECRETS AND ARE CONFID-
ENTIAL AND PROPRIETARY PRODUCTS OF ANSYS, INC., ITS SUBSIDIARIES, OR LICENSORS. The software products
and documentation are furnished by ANSYS, Inc., its subsidiaries, or affiliates under a software license agreement
that contains provisions concerning non-disclosure, copying, length and nature of use, compliance with exporting
laws, warranties, disclaimers, limitations of liability, and remedies, and other provisions. The software products
and documentation may be used, disclosed, transferred, or copied only in accordance with the terms and conditions
of that software license agreement.

ANSYS, Inc. and Ansys Europe, Ltd. are UL registered ISO 9001: 2015 companies.

U.S. Government Rights

For U.S. Government users, except as specifically granted by the ANSYS, Inc. software license agreement, the use,
duplication, or disclosure by the United States Government is subject to restrictions stated in the ANSYS, Inc.
software license agreement and FAR 12.212 (for non-DOD licenses).

Third-Party Software

See the legal information in the product help files for the complete Legal Notice for Ansys proprietary software
and third-party software. If you are unable to access the Legal Notice, contact ANSYS, Inc.

Published in the U.S.A.



Table of Contents

1. Introduction to the Ansys TurboGrid Tutorials . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7
1.1. Setting the Working Directory and Starting Ansys TurboGrid .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7
1.2. Changing the Display Colors ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7
1.3. Editor Buttons .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8
1.4. Using Help .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8

2. Rotor 37 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9
2.1. Overview of the Mesh Creation Process .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 10
2.2. Preparing the Working Directory .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11
2.3. Defining the Geometry .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11
2.4. Creating the Topology and Mesh .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13
2.5. Reviewing the Mesh Data Settings .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14
2.6. Reviewing the Mesh Quality on the Hub and Shroud Tip Layers ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14
2.7. Looking at Mesh Data Values .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15
2.8. Analyzing the Mesh Quality ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15
2.9. Visualizing the Hub-to-Shroud Element Distribution .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 16
2.10. Observing the Shroud Tip Mesh .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17
2.11. Examining the Mesh Qualitatively .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18
2.12. Creating a Legend .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19
2.13. Saving the Mesh .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20
2.14. Saving the State (Optional) ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20

3. Steam Stator . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21
3.1. Preparing the Working Directory .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22
3.2. Defining the Geometry .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 23

3.2.1. Loading the Curves .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 23
3.2.2. Setting the Curve Type .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 24
3.2.3. Defining the Shroud Tip .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 24

3.3. Creating the Topology and Mesh .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 25
3.4. Reviewing the Mesh Data Settings .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 25
3.5. Reviewing the Mesh Quality on the Hub and Shroud Layers ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 26
3.6. Analyzing the Mesh .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 26

3.6.1. Examining the Mesh Qualitatively .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 26
3.6.1.1. Editing a Turbo Surface .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 26
3.6.1.2. Creating a Legend .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27

3.7. Saving the Mesh .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27
3.8. Saving the State (Optional) ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27

4. Radial Compressor . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 29
4.1. Preparing the Working Directory .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 30
4.2. Defining the Geometry .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31

4.2.1. Defining the Machine Data .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31
4.2.2. Defining the Hub .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 32
4.2.3. Defining the Shroud .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 32
4.2.4. Defining the Blade .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33
4.2.5. Defining the Splitter Blade .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 34
4.2.6. Defining the Shroud Tip .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 35

4.3. Creating the Topology and Mesh .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 35
4.4. Mesh Data Settings .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 35
4.5. Analyzing the Mesh .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 36
4.6. Saving the Mesh .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 36
4.7. Saving the State (Optional) ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 36

iii
Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.



5. Axial Fan . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 39
5.1. Preparing the Working Directory .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 40
5.2. Defining the Geometry .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 41
5.3. Creating the Topology and Mesh .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 42
5.4. Decreasing the Mesh Density .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 43
5.5. Observing the Mesh .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 44
5.6. Using the Locking Feature .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 46
5.7. The Y+ Functionality ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 46
5.8. Using Local Mesh Refinement .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 47
5.9. Analyzing the Mesh .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 49
5.10. Adding Inlet and Outlet Domains .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 49
5.11. Analyzing the New Mesh .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 49
5.12. Saving the Mesh .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 50
5.13. Saving the State (Optional) ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 50

6. Tandem Vane . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 51
6.1. Preparing the Working Directory .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 52
6.2. Defining the Geometry .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 53
6.3. Creating the Topology and Mesh .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 53
6.4. Setting the Mesh Density .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 53
6.5. Saving the Mesh .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 53
6.6. Saving the State (Optional) ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 54

7. Secondary Flow Path Meshing . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 55
7.1. Preparing the Working Directory .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 56
7.2. Preparing the Geometry in BladeEditor ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 57

7.2.1. Loading the Provided Project File ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 57
7.2.2. Creating Line Bodies and Curve Groups .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 58

7.3. Defining the Geometry in TurboGrid .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 61
7.3.1. Associating CAD Objects with Topology in TurboGrid’s Geometry Workspace .... . . . . . . . . . . . . . . . . . . . . . . 61
7.3.2. Completing the Geometry Definition in TurboGrid’s Mesh Workspace .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 62

7.4. Creating the Topology and Initial Mesh .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 63
7.5. Aligning Topology at the Upstream Shroud Interface .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 65
7.6. Reviewing the Shroud Interfaces .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 67
7.7. Secondary Flow Path Mesh Parameters ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 67

Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.iv

Tutorials



List of Figures

2.1. ATM Topology and 2D Mesh on the Hub .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14
2.2. Hub-to-Shroud Element Distribution .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17
2.3. Surface Group: Tip Near Trailing Edge .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18
3.1. Incorrect Hub and Shroud Representations .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 24
4.1. Hub and Shroud of Radial Compressor .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33
5.1. Mesh at Blade-Hub Intersection .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 45
5.2. Mesh at Blade-Hub Intersection After Y+ Specification .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 47
5.3. Edge to be Refined in Shroud Tip Layer .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 48
5.4. After Refinement .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 49
7.1. Passage Outlet at Downstream Edge of Shroud Cavity .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 63
7.2. Meridional View of Mesh (with Blade LE and TE) ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 65
7.3. Upstream Shroud Cavity Interface with Inlet Block - Misaligned Topology .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 66
7.4. Upstream Shroud Cavity Interface with Inlet Block - Aligned Topology .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 67

v
Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.



Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.vi



Chapter 1: Introduction to the Ansys TurboGrid
Tutorials
The Ansys TurboGrid tutorials are designed to introduce general mesh-generation techniques used in
Ansys TurboGrid.

Note:

Unless otherwise stated, each tutorial assumes that you are using Ansys TurboGrid in stand-
alone mode.

You should review the following topics before attempting to start a tutorial for the first time:

1.1. Setting the Working Directory and Starting Ansys TurboGrid

1.2. Changing the Display Colors

1.3. Editor Buttons

1.4. Using Help

1.1. Setting the Working Directory and Starting Ansys TurboGrid

Before you start Ansys TurboGrid, set the working directory.

1. Start the Ansys TurboGrid Launcher.

2. Select a working directory.

3. Click the TurboGrid 2021 R2 button.

1.2. Changing the Display Colors

If viewing objects in Ansys TurboGrid becomes difficult due to contrast with the background, the colors
can be altered for improved viewing. You can access the color options by going through the following
steps:

1. Select Edit > Options.

The Options dialog box appears.

2. Adjust the color settings under TurboGrid > Viewer.

3. Click OK.
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1.3. Editor Buttons

The Ansys TurboGrid interface uses editors to enter the data required to create a mesh. The editors
have standard buttons, which are described next:

• Apply applies the information contained within all the tabs of an editor.

• OK is the same as Apply, except that the editor automatically closes.

• Cancel and Close both close the editor without applying or saving any changes.

• Reset returns the settings for the object to those stored in the database for all the tabs. The settings
are stored in the database each time the Apply button is clicked.

• Defaults restores the system default settings for all the tabs of the edited object.

1.4. Using Help

To open the Ansys Help, select Help > Contents.

Context-sensitive help is provided for many of the object editors and other parts of the interface. To
invoke the context-sensitive help for a particular editor or other feature, ensure that the window is
active, place the mouse pointer over the feature, and press F1. Not every area of the interface supports
context-sensitive help.
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Chapter 2: Rotor 37
This tutorial includes:

2.1. Overview of the Mesh Creation Process

2.2. Preparing the Working Directory

2.3. Defining the Geometry

2.4. Creating the Topology and Mesh

2.5. Reviewing the Mesh Data Settings

2.6. Reviewing the Mesh Quality on the Hub and Shroud Tip Layers

2.7. Looking at Mesh Data Values

2.8. Analyzing the Mesh Quality

2.9.Visualizing the Hub-to-Shroud Element Distribution

2.10. Observing the Shroud Tip Mesh

2.11. Examining the Mesh Qualitatively

2.12. Creating a Legend

2.13. Saving the Mesh

2.14. Saving the State (Optional)

This tutorial demonstrates the basic workflow for generating a CFD mesh using Ansys TurboGrid. As
you work through this tutorial, you will create a mesh for a blade passage of an axial compressor blade
row. A typical blade passage is shown by the black outline in the figure below.
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The blade row contains 36 blades that revolve about the negative Z axis. A clearance gap exists between
the blades and the shroud, with a width of 2.5% of the total span. Within the blade passage, the max-
imum diameter of the shroud is approximately 51 cm.

You will save the mesh in a format that can be used by Ansys CFX in a CFD simulation.

If this is the first tutorial you are working with, it is important to review Introduction to the Ansys Tur-
boGrid Tutorials (p. 7) before beginning.

2.1. Overview of the Mesh Creation Process

Before Ansys TurboGrid can create a mesh, you must provide it with several pieces of information. Such
information includes the location of the geometry files (hub, shroud, and blades), the mesh topology
type, and the distribution of mesh nodes. All of the data that you provide is stored in a set of data objects
known as CCL objects.

The Ansys TurboGrid user interface organizes the CCL objects in a tree view known as the object selector.
You can use the object selector to select and edit the CCL objects; the objects are listed from top to
bottom in the standard order for creating a mesh. The user interface also has a toolbar for selecting
and editing the CCL objects; the icons are arranged from left to right in the standard order for creating
a mesh.
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Regardless of whether you use the object selector or the toolbar, you should generally follow this se-
quence when creating a mesh:

1. Define the geometry by loading files and changing settings as required.

2. Optionally choose a topology method, then unsuspend the Topology Set object if necessary.

3. Optionally modify the Mesh Data settings that govern the number and the distribution of nodes
in various parts of the mesh.

If you plan to make a fine (high-resolution) mesh, you can optionally set the mesh density at a
later time in order to minimize processing time while establishing other aspects of the mesh. Note
that changing the mesh density can affect the mesh quality.

4. Optionally add intermediate 2D layers that guide the 3D mesh in the spanwise direction. By default,
layers are added as required when you generate the topology or the 3D mesh.

5. Check the mesh quality. As required, make adjustments to the Mesh Data settings and the
number and distribution of layers.

6. Save the mesh and state as required.

2.2. Preparing the Working Directory

1. Create a working directory.

Ansys TurboGrid uses a working directory as the default location for loading and saving files for a
particular session or project.

2. Download the rotor37.zip file here.

3. Unzip rotor37.zip to your working directory.

Ensure that the following tutorial input files are in your working directory:

• BladeGen.inf

• profile.curve

• hub.curve

• shroud.curve

4. Set the working directory and start Ansys TurboGrid.

For details, see Setting the Working Directory and Starting Ansys TurboGrid (p. 7).

2.3. Defining the Geometry

The provided geometry files, which consist of a BladeGen.inf file plus three curve files, were created
using BladeGen. To load the information contained in those files, you will load the BladeGen.inf
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file. Ansys TurboGrid uses this file to set the axis of rotation, the number of blades, and a length unit
that characterizes the scale of the machine. It also uses this file to identify the curve files, which it then
loads to define the curvature of the hub, shroud, and a single blade. The geometric data from the input
files is processed to generate a geometric representation, an outline of which appears in the viewer.

After the geometry has been generated, you are invited to browse through the objects created under
the Geometry object in the object selector.

Initially, the blades extend from the hub to the shroud. After inspecting the geometry, you will create
the required gap between the blade and the shroud.

Load the BladeGen.inf file:

1. Click File > Load TurboGrid Init File.

2. Open BladeGen.inf from the working directory.

The progress bar at the bottom right of the screen shows the geometry generation progress. After
the geometry has been generated, the viewer in the Mesh workspace shows the hub, shroud, and
blade for one passage. Along the blade, you can see the leading and trailing edge curves (green
and red lines, respectively). An outline drawing (the Outline object) traces the 3D space that is
available for meshing; the latter consists of an inlet domain, passage, and outlet domain. In this
tutorial, you will generate a mesh for the passage only.

Note:

It is possible to adjust the upstream and downstream extents of the hub and shroud
surfaces (by changing the Inlet and Outlet geometry objects). It is also possible to
create an extended mesh that includes the inlet and outlet domains (by editing the
Mesh Data settings).

Examine the geometry in the 3D Viewer:

1. In the Mesh workspace, toggle the visibility check box next to each object in the object selector
and observe the change in the viewer.

Note the correlation between the geometry objects listed in the object selector and the locations
in the geometry.

2. In order to avoid cluttering the view, ensure that the visibility is turned on only for these objects:
Hub, Shroud, Blade 1, Outline.

Examine and set the machine type:

1. Open Geometry > Machine Data from the object selector by double-clicking Machine Data
in the object selector, or by right-clicking Machine Data and selecting Edit from the shortcut
menu that appears.

Here you can see basic information about the geometry. Note that the units specified for Base
Units represent the scale of the geometry being meshed; these units are not used for importing
geometric data nor do they govern the units written to a mesh file; they are used for the internal
representation of the geometry to minimize computer round-off errors.
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2. Set Machine Type to Axial Compressor.

Setting the machine type helps TurboGrid choose appropriate topology templates later in the mesh
creation process.

3. Click Apply.

Examine the hub:

1. Open Geometry > Hub.

Here you can see information about which file was used for hub data and how the file was inter-
preted. Similar information can be seen by opening the Shroud and Blade 1 objects. Note that,
for the Hub and Shroud objects, the Curve Type parameter is set to Piece-wise linear;
this is a result of loading a BladeGen.inf file.

2. Click Display all blade instances  to obtain a view of the entire geometry.

3. Click Display single blade instance  to show a single blade instance once again.

To complete the geometry, create a small gap between the blade and the shroud. The blade should
be shortened to 97.5% of its original span because the gap width, as specified in the problem description,
is 2.5% of the total span.

1. Open Geometry > Blade Set > Shroud Tip.

2. Set Tip Option to Constant Span.

3. Set Span to 0.975.

4. Click Apply.

The names of the objects in the Geometry branch of the object selector are shown in black non-italic
text, indicating that the Geometry objects are all defined. This completes the geometry definition.

2.4. Creating the Topology and Mesh

The Topology Set object is initially suspended in order to save computational effort while defining
the geometry. When you unsuspend the Topology Set object, the remaining computations are
performed, resulting in a 3D mesh.

• Right-click Topology Set and turn off Suspend Object Updates.

The Topology Set object name in the object selector changes to black non-italic text, indicating
that this object is generated. The topology appears on the hub and shroud as a structure of thick
lines. Thinner lines show where individual mesh elements are located.

The 3D mesh is also generated. The number of nodes and elements are displayed at the bottom
left.

Change the view to clearly show the topology on the hub:
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1. Click Hide all geometry objects .

2. Turn on the visibility of Layers > Hub to show the topology on the hub.

3. Click Hide all mesh objects .

4. Right-click a blank area in the viewer, and click Predefined Camera > View From +X from the
shortcut menu.

The heavy lines in Figure 2.1: ATM Topology and 2D Mesh on the Hub (p. 14) indicate the topology
lines; the thinner lines show the 2D mesh for the hub.

Figure 2.1: ATM Topology and 2D Mesh on the Hub

2.5. Reviewing the Mesh Data Settings

The Mesh Data settings control the number and distribution of mesh elements.

1. Open Mesh Data.

2. Note that Method is set to Global Size Factor and Size Factor is set to 1.

In the status bar in the bottom-left corner of Ansys TurboGrid, you can see that the number of
mesh nodes is on the order of 200000.

2.6. Reviewing the Mesh Quality on the Hub and Shroud Tip Layers

Layers are constant-span surfaces. You can display the topology on a layer. You have already seen the
hub layer in Figure 2.1: ATM Topology and 2D Mesh on the Hub (p. 14). At this point, there are two
layers: Layers > Hub, and Layers > Shroud Tip.

If the topology were grossly skewed or distorted on the hub or shroud tip layer, the Layers object
would be shown with red text in the object selector.

Now the topology is defined and the mesh quality is acceptable on all layers.
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The mesh is generated automatically after the Layers object is processed. Later in this tutorial, you
will check 3D mesh measures and inspect the mesh visually.

2.7. Looking at Mesh Data Values

The Mesh Data editor tabs display information about the mesh. In the following steps, you will examine
the number and distribution of elements from hub to shroud tip and from shroud tip to shroud.

1. Open Mesh Data.

2. Click the Passage tab.

Look in the Spanwise Blade Distribution Parameters frame. Method is set to Proportional
with a factor of 1.0. The other boxes in the frame are disabled, but show the current value for
each option that Ansys TurboGrid has calculated.

You can see that # of Elements is 25.

3. Click the Shroud Tip tab.

Look in the Shroud Tip Distribution Parameters frame. Method is set to Match Expansion
at Blade Tip. You can see that the number of elements from shroud tip to shroud is 16.

2.8. Analyzing the Mesh Quality

3D mesh measures are available. These are analogous to the 2D mesh measures that are calculated on
layers. As for the 2D mesh measures, the 3D mesh measures have quality criteria set in the Mesh
Analysis > Mesh Limits object.

Mesh measures of some mesh elements may fall outside the criteria. When any mesh measure fails to
meet the criteria, Mesh Analysis (Error) > Mesh Statistics (Error) will appear in red
text in the object selector. You can open Mesh Analysis (Error) to display the Mesh Statistics
dialog box. In the Mesh Statistics dialog box, you can select one of the items in red and click Display
to see the locations in the mesh where the statistics fail to meet the corresponding criterion.

Not all of the mesh measures carry the same importance. For example, it is necessary to have a mesh
with no negative volumes. Generally, poor angles should also be fixed, but the Maximum Element
Volume Ratio and Maximum Edge Length Ratio values should be judged based on your re-
quirements.

Check the 3D mesh statistics:

1. For a visual frame of reference, ensure that Layers > Hub and Layers > Shroud Tip are visible.

2. Open Mesh Analysis or Mesh Analysis > Mesh Statistics.

The Mesh Statistics dialog box appears, and shows that the mesh statistics are acceptable based
on the current quality criteria.

3. Close the Mesh Statistics dialog box.
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2.9. Visualizing the Hub-to-Shroud Element Distribution

To demonstrate the use of the 3D Mesh visualization objects, look at the mesh distribution from hub
to shroud as follows:

1. Click Unhide geometry objects .

2. Turn off the visibility of the following objects:

• Geometry > Blade Set > Blade 1

• Layers > Hub

• Layers > Shroud Tip

3. Turn on the visibility of the following objects under 3D Mesh:

• HIGHPERIODIC.

• LOWBLADE GEO HIGH

• LOWBLADE GEO LOW

4. Observe the element distribution from hub to shroud tip and from shroud tip to shroud.

See Figure 2.2: Hub-to-Shroud Element Distribution (p. 17).
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Figure 2.2: Hub-to-Shroud Element Distribution

2.10. Observing the Shroud Tip Mesh

A mesh interface exists in the shroud tip gap. In order to see this interface:

1. Turn on the visibility of 3D Mesh > SHROUD TIP.

2. Click Hide all geometry objects .

3. Zoom in to view the mesh on the shroud tip.

Figure 2.3: Surface Group: Tip Near Trailing Edge (p. 18) shows this mesh at the trailing edge of
the blade. Note how the nodes do not line up along the middle of the blade, due to the default
use of a general grid (GGI) interface along the shroud tip of the blade.
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Figure 2.3: Surface Group: Tip Near Trailing Edge

4. Turn off the visibility of 3D Mesh > SHROUD TIP.

5. Click Unhide geometry objects .

2.11. Examining the Mesh Qualitatively

You will now examine the mesh qualitatively using a turbo surface. Change the Show Mesh turbo
surface so that it appears on the hub, and color it to show the variation in Edge Length Ratio (a
variable that was computed at the time the mesh was generated):

1. Turn on the visibility of 3D Mesh > Show Mesh.

2. Open 3D Mesh > Show Mesh.

3. Leave Variable set to K.

K is equal to the node number in the spanwise direction, ranging from 1 at the hub to a positive
integer value at the shroud.

4. Set Value to 1.

This will cause the turbo surface to appear on the hub.

5. Click the Color tab.

6. Set Mode to Variable.

7. Set Variable to Edge Length Ratio.

8. Set Range to Local.

This will cause the range of colors in the color map to be distributed over the range of values found
on the turbo surface, rather that over the global range or a user-defined range.

9. Click the Render tab.

10. Ensure that Draw Faces is selected.

11. Click Apply.
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12. To avoid visual conflicts between the turbo surface and the hub, which are coincident, turn off the
visibility of Geometry > Hub.

Note that you can edit the rendering properties of the hub to achieve a similar result. The advantage
of using a turbo surface is that you can redefine its location. For example, you could change the value
of K in the current turbo surface to see Edge Length Ratio on a different nodal plane.

Note:

You can create new turbo surfaces. To begin the process of creating a new turbo surface,
click Insert > User Defined > Turbo Surface.

Note:

To show distinct color bands, you could make a contour plot object that applies to an existing
locator (geometric surface, turbo surface, or other graphic objects that involve surfaces). To
begin the process of creating a contour plot, ensure that you have a suitable locator already
defined, then click Insert > User Defined > Contour.

Tip:

For objects that are colored by a variable, it is best to view them with lighting turned off so
that the colors are not altered according to the angle of view. The lighting is controlled by
a setting on the Render tab.

2.12. Creating a Legend

In the previous section, you modified a turbo surface by coloring it according to Edge Length Ratio.
To reveal the color map used to match values of Edge Length Ratio with particular colors, create
a legend for the turbo surface:

1. Click Insert > User Defined > Legend.

2. Click OK to accept the default name.

3. Set Plot to TURBO SURFACE:Show Mesh.

4. Set Title Mode to Variable and Location.

5. Click Apply.

A legend appears in the viewer, showing the correspondence between values of Edge Length
Ratio and colors for the Show Mesh object.

You may want to modify 3D Mesh > Show Mesh to plot it on different locations, or to color it by
different variables. The legend will be updated automatically whenever you make changes to the turbo
surface.
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2.13. Saving the Mesh

Save the mesh:

1. Click File > Save Mesh As.

2. Ensure that Files of type is set to Ansys CFX Mesh Files.

3. Set Export Units to cm.

4. Set File name to rotor37.gtm.

5. Ensure that your working directory is set correctly.

6. Click Save.

2.14. Saving the State (Optional)

If you want to revisit this mesh at a later date, save the state:

1. Click File > Save State As.

2. Enter an appropriate state filename.

3. Click Save.
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Chapter 3: Steam Stator
This tutorial includes:

3.1. Preparing the Working Directory

3.2. Defining the Geometry

3.3. Creating the Topology and Mesh

3.4. Reviewing the Mesh Data Settings

3.5. Reviewing the Mesh Quality on the Hub and Shroud Layers

3.6. Analyzing the Mesh

3.7. Saving the Mesh

3.8. Saving the State (Optional)

This tutorial teaches you how to:

• Import hub, shroud, and blade geometry from individual curve files.

• Change the method of constructing the hub and shroud curve types.

• Make colored surfaces to show variations in mesh measures (such as Minimum Face Angle).

As you work through this tutorial, you will create a mesh for a blade passage of a steam stator. A typical
blade passage is shown by the black outline in the figure below.
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The stator contains 60 blades distributed about the Z axis. A clearance gap exists between the blades
and the shroud, with a width of 2% of the total span. Within the blade passage, the maximum diameter
of the shroud is approximately 97.5 cm.

If this is the first tutorial you are working with, it is important to review Introduction to the Ansys Tur-
boGrid Tutorials (p. 7) before beginning.

3.1. Preparing the Working Directory

1. Create a working directory.

TurboGrid uses a working directory as the default location for loading and saving files for a partic-
ular session or project.

2. Download the stator.zip file here.

3. Unzip stator.zip to your working directory.

Ensure that the following tutorial input files are in your working directory:

• BladeGen.inf

• shroud.curve
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• hub.curve

• profile.curve

4. Set the working directory and start TurboGrid.

For details, see Setting the Working Directory and Starting Ansys TurboGrid (p. 7).

3.2. Defining the Geometry

In the first tutorial, you loaded a BladeGen.inf file in order to specify the machine data (# of blade
sets, rotation axis, and units) and curve files. In this tutorial, you will enter such data manually using
the Load Profile Points command.

3.2.1. Loading the Curves

Load the curve files for the steam stator as follows:

1. Click File > Load Profile Points.

The geometry browser (the main object editor of the Geometry workspace) appears. TurboGrid
fills in the names of the curve files based on the files that are present in the working directory;
The first .crv or .curve file found that has a name containing “hub”, ”shroud”, or
“blade”/”profile” is selected as the hub, shroud, or blade file, respectively.

2. Ensure that, under Point Data Definition > TurboGrid Curve Files, Hub is set to ./hub.curve,
Shroud is set to ./shroud.curve, and Blade is set to ./profile.curve.

3. Set Point Data Definition > Coordinates and Units > Coordinates to Cartesian and Length
Units to cm.

These units are used to interpret the data in the curve files.

4. Set Geometry Setup > Rotation > Method to Principal Axis and Axis to Z.

5. Set Geometry Setup > # of Bladesets to 60.

6. Click Apply to save the settings.

7. Return to the Mesh tab to view the geometry.

The progress bar at the bottom right of the screen shows the geometry generation progress. After
the geometry has been generated, you can see the hub, shroud, and blade for one passage. Along
the blade, you can see the leading and trailing edge curves (green and red lines, respectively). Near
the blade, you can see the inlet and outlet markers (white octahedrons).

• Rotate the geometry into the position shown in Figure 3.1: Incorrect Hub and Shroud Representa-
tions (p. 24).
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Figure 3.1: Incorrect Hub and Shroud Representations

As shown in Figure 3.1: Incorrect Hub and Shroud Representations (p. 24), the hub and shroud are
greatly distorted. This is the result of using spline curves to construct the hub and shroud based on
relatively few data points. This problem will be corrected in the next section.

3.2.2. Setting the Curve Type

Set the method of constructing the hub and shroud as follows:

1. Open Geometry > Hub.

2. Set Geometric Representation > Curve Type to Piece-wise linear.

3. Click Apply.

4. Set Shroud in the same way.

3.2.3. Defining the Shroud Tip

To complete the geometry, create a small gap between the blade and the shroud. The blade should
be shortened to 98% of its original span because the gap width is 2% of the total span, as specified
in the problem description.

1. Open Geometry > Blade Set > Shroud Tip.

2. Set Tip Option to Constant Span.

3. Set Span to 0.98.

4. Click Apply.

This completes the geometry definition.
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3.3. Creating the Topology and Mesh

1. Click Hide all geometry objects  to turn off the visibility of the geometry.

2. Right-click Topology Set and turn off Suspend Object Updates.

3. Turn on the visibility of Layers > Hub to show the topology on the hub.

4. Turn on the visibility of Layers > Shroud Tip to show the topology on the shroud tip.

The topology and 3D mesh are generated.

Note:

It may be useful to keep the same topology when studying a range of blade geometries, or
the same blade on different computers. To keep the same topology, use the Manual (Ad-
vanced) setting for the topology. This setting is available after clicking Edit > Options and
selecting Enable Advanced Features.

3.4. Reviewing the Mesh Data Settings

TurboGrid automatically computes a default mesh and sets the base mesh dimensions.

Each unique mesh dimension has an edge refinement factor that is multiplied by the base mesh dimen-
sion and global size factor to determine the final mesh size. The overall mesh size is controlled using
the Method setting in the Mesh Data object editor on the Mesh Size tab. Setting the Method to
Target Passage Mesh Size enables you to specify a Node Count. Using this method specifies
an approximate mesh size (in nodes) and lets TurboGrid compute the mesh dimensions automatically.
Setting the Method to Global Size Factor enables you to specify a Size Factor. Increasing this
factor will increase the overall mesh size, and decreasing it will decrease the overall mesh size. The
change is nonlinear.

The Boundary Layer Refinement Control settings affect the mesh in the O-Grid region around the
blade:

• Note that, when Boundary Layer Refinement Control > Method is set to Proportional to
Mesh Size, the number of elements across the boundary layer is calculated as Base Count * Global
Size Factor * (Factor Base + Factor Ratio * Global Size Factor). The default values of Factor Base and
Factor Ratio are 3 and 0 respectively.

• The Target Maximum Expansion Rate setting affects the expansion rates that are used just outside
the blade profile.

• The Near Wall Element Size Specification settings control the method by which the near-wall node
spacing is specified on the Passage, Hub Tip, and Shroud Tip tabs. The near-wall node spacing is
the distance between a wall (for example, hub, shroud, or blade) and the first layer of nodes from
the wall. The Method setting has these options:

– Y Plus — The y+ method sets the near-wall spacing to a target value, y+, in relation to a set
Reynolds number.
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– Absolute — The Absolute method enables you to set the near-wall spacing directly on the Pas-
sage, Hub Tip, and Shroud Tip tabs.

• The Inlet Domain and Outlet Domain check boxes enable you to generate the inlet and outlet do-
mains as part of the mesh. Settings that affect these grid regions are found on the Inlet/Outlet tab.

Selecting the Lock mesh size check box forces the total number of nodes and elements to remain
constant.

On the Shroud Tip tab, you can use the Blade Tip > Override Target Maximum Expansion Rate
setting to override the Target Maximum Expansion Rate value set on the Mesh Size tab, to govern
the expansion rate of elements that cross the tip mesh.

3.5. Reviewing the Mesh Quality on the Hub and Shroud Layers

If the topology were grossly skewed or distorted on the hub or shroud layer, the Layers object would
be shown with red text in the object selector. Since the Layers object is shown in black text, the mesh
contains no regions with high skew on the hub or shroud.

By default, TurboGrid automatically generates the recommended number of layers before the mesh is
generated. This default behavior can be disabled by editing the Layers object so that Insertion Mode
is not set to Automatic - Adaptive.

A turbo surface of constant "K" (a nodal coordinate) appears. This surface is listed in the object selector
as 3D Mesh > Show Mesh. You can change the location and coloring of this surface to explore the
mesh.

3.6. Analyzing the Mesh

Check the 3D mesh statistics:

1. Open Mesh Analysis.

The mesh statistics are acceptable based on the current quality criteria.

2. Close the Mesh Statistics dialog box.

3.6.1. Examining the Mesh Qualitatively

The predefined surfaces found under the 3D Mesh object in the object selector are useful for
showing variations in the mesh statistics.

In the following section, you will color 3D Mesh > Show Mesh by Minimum Face Angle. You
will then create a legend for that object.

3.6.1.1. Editing a Turbo Surface

Turbo Surfaces can be created by selecting Insert > User Defined > Turbo Surface. In this case,
you will simply edit the predefined turbo surface.

1. Open 3D Mesh > Show Mesh.
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2. Leave Variable, and Value unchanged.

3. Click the Color tab and set Mode to Variable.

4. Set Variable to Minimum Face Angle.

5. Set Range to Local.

This will cause the range of colors in the color map to be distributed over the range of values
found on the turbo surface, rather that over the global range or a user-defined range.

6. Click the Render tab.

7. Ensure that Draw Faces is selected.

8. Click Apply to apply the changes to the turbo surface.

3.6.1.2. Creating a Legend

To illustrate the scale of the Minimum Face Angle variable, create a legend for the turbo surface:

1. Click Insert > User Defined > Legend.

2. Click OK to accept the default name.

3. Set Plot to TURBO SURFACE:Show Mesh.

4. Set Title Mode to Variable and Location.

5. Click Apply to create the legend.

3.7. Saving the Mesh

Save the mesh:

1. Click File > Save Mesh As.

2. Ensure that Files of type is set to Ansys CFX Mesh Files.

3. Set Export Units to cm.

4. Set File name to steam_stator.gtm.

5. Ensure that your working directory is set correctly.

6. Click Save.

3.8. Saving the State (Optional)

If you want to revisit this mesh at a later date, save the state:

1. Click File > Save State As.
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2. Enter an appropriate state filename.

3. Click Save.
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Chapter 4: Radial Compressor
This tutorial includes:

4.1. Preparing the Working Directory

4.2. Defining the Geometry

4.3. Creating the Topology and Mesh

4.4. Mesh Data Settings

4.5. Analyzing the Mesh

4.6. Saving the Mesh

4.7. Saving the State (Optional)

This tutorial teaches you how to:

• Set machine data and load curve files independently.

• Specify a “cut-off or square” edge on a blade.

• Choose an appropriate topology family under ATM Topology.

• Change the distribution of mesh elements along a cut-off edge.

As you work through this tutorial, you will create a mesh for a blade passage of a radial compressor
blade row. A typical blade passage is shown by the black outline in the figure below.
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The blade row contains 9 main blades and 9 splitter blades that revolve about the negative Z axis. The
blades have cut-off trailing edges. A clearance gap exists between the blades and the shroud, with a
width of 5% of the total span. Within the blade passage, the maximum diameter of the shroud is ap-
proximately 125 mm.

If this is the first tutorial you are working with, it is important to review Introduction to the Ansys Tur-
boGrid Tutorials (p. 7) before beginning.

4.1. Preparing the Working Directory

1. Create a working directory.

Ansys TurboGrid uses a working directory as the default location for loading and saving files for a
particular session or project.
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2. Download the radcomp.zip file here.

3. Unzip radcomp.zip to your working directory.

Ensure that the following tutorial input files are in your working directory:

• BladeGen.inf

• profile.crv

• hub.crv

• shroud.crv

4. Set the working directory and start Ansys TurboGrid.

For details, see Setting the Working Directory and Starting Ansys TurboGrid (p. 7).

4.2. Defining the Geometry

In the Rotor 37 tutorial, you loaded a BladeGen.inf file in order to specify the machine data (# of
blade sets, rotation axis, and units) and the hub, shroud, and blade curve files. In the Steam Stator tu-
torial, you entered the same data using the Load Profile Points command. In this tutorial, you will
define the machine data and curve files individually, by editing the corresponding geometry objects.

4.2.1. Defining the Machine Data

Set up the Machine Data object, which contains basic information about the geometry:

1. In the Mesh workspace, open Geometry > Machine Data.
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2. Set # of Bladesets to 9.

3. Set Base Units to mm.

4. Click Apply to save the settings.

4.2.2. Defining the Hub

1. Open Geometry > Hub.

2. Set Length Units to mm.

3. Ensure that File Name is set to ./hub.crv from your working directory.

4. Click Apply.

4.2.3. Defining the Shroud

1. Open Geometry > Shroud.

2. Set Length Units to mm.
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3. Ensure that File Name is set to ./shroud.crv from your working directory.

4. Click Apply.

Note:

If you had loaded the BladeGen.inf file, the Curve Type settings for the Hub and
Shroud objects would have been set to Piece-wise linear instead of the default:
Bspline. Either setting will work for this geometry.

At this point, the entire hub and shroud surfaces are shown. After a blade is defined (in the next step),
the hub and shroud will be trimmed to show only one passage.

Figure 4.1: Hub and Shroud of Radial Compressor

4.2.4. Defining the Blade

1. In the Mesh workspace, open Geometry > Blade Set > Blade 1.

2. Ensure that File Name is set to ./profile.crv.

3. Set Length Units to mm.

4. Set Geometric Representation > Method to Specify.

5. Set Geometric Representation > Lofting to Spanwise.

6. Set Geometric Representation > Curve Type to Piece-wise linear.

7. Set Geometric Representation > Surface Type to Ruled.
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8. Under Trailing Edge Definition, select Cut-off or square.

9. Click Apply.

The progress bar at the bottom right of the screen shows the geometry generation progress. After
the geometry has been generated, you can see the hub, shroud, and blade for one passage. Along
the blade, you can see the leading and trailing edge curves (green and red lines, respectively).

4.2.5. Defining the Splitter Blade

1. Right-click Geometry > Blade Set and select Insert > Blade.

2. Click OK to accept the default name.

3. Set Blade Number to 2.

4. Click Apply.
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4.2.6. Defining the Shroud Tip

To complete the geometry, create a small gap between the blade and the shroud. The blade should
be shortened to 95% of its original span because the gap width is 5% of the total span, as specified
in the problem description.

1. Open Geometry > Blade Set > Shroud Tip.

2. Set Tip Option to Constant Span.

3. Set Span to 0.95.

4. Click Apply.

4.3. Creating the Topology and Mesh

In this tutorial, you will manually choose a set of ATM topology templates, called a topology family.

1. Click the Topology Viewer tab.

2. Open Topology Set.

3. Browse through ATM Topology > Method.

ATM Topology > Method provides a list of topology families from which you can manually choose.
When you mouse over or cursor through the list, the Topology Viewer shows a picture of the
highlighted topology family and a description of the type of blade that the family best fits.

4. Set ATM Topology > Method to Single Splitter.

5. Click Apply to set the topology.

6. Right-click Topology Set and turn off Suspend Object Updates.

The topology and 3D mesh are generated.

4.4. Mesh Data Settings

The Mesh Data object indicates that there is a problem with mesh quality.

1. Click the 3D Viewer tab.

2. Expand the Mesh Data object in the object selector.

3. Open one of the Boundary Layer Control objects under Mesh Data.

Note that the near wall expansion rate is outside the established limit within the boundary layer region.
The affected mesh regions are colored red in the viewer.

Add more elements to the boundary layer region as follows:

1. Open the Mesh Data object.
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2. On the Mesh Size tab, ensure that Boundary Layer Refinement Control > Method is set to
Proportional to Mesh Size.

3. Set Boundary Layer Refinement Control > Parameters > Factor Base to 4.0.

4. Click Apply.

The Mesh Data object no longer indicates that there is a problem with mesh quality.

As an exercise, change the distribution of elements across the cut-off edge as follows:

1. Set Cutoff Edge Split Factor > Trailing to 0.9.

2. Click Apply.

Note that, for a blade that has one rounded edge and one cut-off edge, the distribution of elements
across the blade tip mesh is governed by the distribution across the cut-off edge.

4.5. Analyzing the Mesh

Check the 3D mesh statistics:

1. Open Mesh Analysis.

The mesh statistics are acceptable based on the current quality criteria.

2. Close the Mesh Statistics dialog box.

4.6. Saving the Mesh

Save the mesh:

1. Click File > Save Mesh As.

2. Ensure that Files of type is set to Ansys CFX Mesh Files.

3. Set Export Units to cm.

4. Set File name to radial_compressor.gtm.

5. Ensure that your working directory is set correctly.

6. Click Save.

4.7. Saving the State (Optional)

If you want to revisit this mesh at a later date, save the state:

1. Click File > Save State As.

2. Enter an appropriate state filename.
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3. Click Save.
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Chapter 5: Axial Fan
This tutorial includes:

5.1. Preparing the Working Directory

5.2. Defining the Geometry

5.3. Creating the Topology and Mesh

5.4. Decreasing the Mesh Density

5.5. Observing the Mesh

5.6. Using the Locking Feature

5.7.The Y+ Functionality

5.8. Using Local Mesh Refinement

5.9. Analyzing the Mesh

5.10. Adding Inlet and Outlet Domains

5.11. Analyzing the New Mesh

5.12. Saving the Mesh

5.13. Saving the State (Optional)

This tutorial teaches you how to:

• Switch to a Meridional (A-R) projection in the viewer.

• Change the shape and position of the Inlet and Outlet geometry objects that bound the blade
passage in the streamwise direction.

• Use Local Mesh Refinement

• Extend the mesh by adding inlet and outlet domains.

As you work through this tutorial, you will create a mesh for a blade passage of a fan. A typical blade
passage, inlet domain, and outlet domain, are shown by the black outline in the figure below.
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The fan contains 10 blades that revolve about the negative Z axis. A clearance gap exists between the
blades and the shroud, with a width of 2% of the total span. The shroud diameter is approximately 26.4
cm.

Let the mesh contain an inlet domain and an outlet domain.

If this is the first tutorial you are working with, it is important to review Introduction to the Ansys Tur-
boGrid Tutorials (p. 7) before beginning.

5.1. Preparing the Working Directory

1. Create a working directory.

Ansys TurboGrid uses a working directory as the default location for loading and saving files for a
particular session or project.

2. Download the fan.zip file here.

3. Unzip fan.zip to your working directory.

Ensure that the following tutorial input files are in your working directory:

• BladeGen.inf

• shroud.curve
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• hub.curve

• profile.curve

4. Set the working directory and start Ansys TurboGrid.

For details, see Setting the Working Directory and Starting Ansys TurboGrid (p. 7).

5.2. Defining the Geometry

To obtain the basic geometry, you will load a BladeGen.inf file. After inspecting the geometry and
improving the shape of the inlet and outlet, you will finish defining the geometry by creating the required
gap between the blade and the shroud.

Load the BladeGen.inf file, then inspect the geometry by viewing it in axial-radial coordinates:

1. Click File > Load TurboGrid Init File.

2. Open BladeGen.inf from the working directory.

3. In the Mesh workspace, right-click a blank area in the viewer, and click Transformation > Meridi-
onal (A-R) from the shortcut menu.

The passage inlet, which appears in the object selector as Geometry > Inlet, is the upstream end
of the blade passage (but not necessarily the upstream end of the mesh, since, as you will see in this
tutorial, you can add an inlet domain upstream of the passage inlet). The passage inlet is generated by
revolving a curve, which is defined in an axial-radial plane, about the machine axis. That curve, in turn,
is generated according to a set of points, known here as inlet points. These points appear as white oc-
tahedrons in the viewer. The passage outlet is analogous to the passage inlet, and is downstream of
the blade passage.
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Notice that, in this case, there are two inlet points and they are located at different distances from the
blade. In order to obtain a high-quality mesh topology for the blade passage, the inlet points should
be repositioned.

Reposition the inlet and outlet points as follows, and observe the movement of the inlet and outlet
points in the viewer:

1. Open Geometry > Inlet.

2. Select Interface Specification Method > Points.

3. Select Low Hub Point, then set Method to Set A and Location to -0.008.

4. Click Apply.

5. Select Low Shroud Point, then set Method to Set A and Location to 0.002.

6. Click Apply.

7. Open Geometry > Outlet.

8. Select Interface Specification Method > Points.

9. Select Low Hub Point, then set Method to Set A and Location to 0.03.

10. Click Apply.

11. Select Low Shroud Point, then set Method to Set A and Location to 0.03.

12. Click Apply.

To complete the geometry, create a small gap between the blade and the shroud. The blade should
be shortened to 98% of its original span because the gap width is 2% of the total span, as specified in
the problem description.

1. Open Geometry > Blade Set > Shroud Tip.

2. Set Tip Option to Constant Span.

3. Set Span to 0.98.

4. Click Apply.

5.3. Creating the Topology and Mesh

1. Right-click a blank area in the viewer and select Transformation > Cartesian (X-Y-Z) from the
shortcut menu.

2. Click Hide all geometry objects .

This gives you an unobstructed view of the topology, and later the mesh.

3. Right-click Topology Set and turn off Suspend Object Updates.
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4. Turn on the visibility of Layers > Hub to show the topology on the hub.

5. Turn on the visibility of Layers > Shroud Tip to show the topology on the shroud tip.

The topology and 3D mesh are generated.

Note:

Mesh quality issues are discussed later in this tutorial.

5.4. Decreasing the Mesh Density

There are several ways to control the mesh size:

• Changing the global size factor.

• Using proportional refinement in the boundary layer.

• Changing the number of mesh elements in the spanwise direction in the passage.

• Changing the edge refinement on a specific edge, including within the boundary layer.

Begin by changing the global size factor and the amount of refinement in the boundary layer:

1. Open Mesh Data.

2. On the Mesh Size tab, set Method to Global Size Factor.

3. Set Size Factor to 0.9.

An overall decrease in mesh size can be useful in reducing the computational resources required
for simulation.

4. Ensure that Boundary Layer Refinement Control > Method is set to Proportional to Mesh
Size.

5. Set Factor Base to 2.6.

6. Click Apply.

Observe that the number of nodes has been reduced and the element size has increased in the
boundary layer mesh. With proportional refinement enabled, the relationship between the height
of the first element in the boundary layer and the global size factor should be approximately in-
versely proportional (that is, an increase in the global size factor will cause a decrease in the element
height).

7. Right-click a blank area in the viewer, and select Predefined Camera > Isometric View (X Up).
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5.5. Observing the Mesh

A K-Plane is displayed by default. This shows the 2D mesh on a layer. The plane can be moved in the
spanwise direction by holding Ctrl + Shift and dragging using the left mouse button.

1. Turn on the visibility of the following objects under 3D Mesh:

• HIGHBLADE GEO HIGH

• HIGHBLADE GEO LOW

• HUB

• LOWBLADE GEO HIGH

• LOWBLADE GEO LOW

• SHROUD

• Show Mesh

2. Note that the mesh element density is higher near the blade and hub, as can be seen in Fig-
ure 5.1: Mesh at Blade-Hub Intersection (p. 45).

Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.44

Axial Fan



Figure 5.1: Mesh at Blade-Hub Intersection

The number of mesh elements in the spanwise direction is automatically changed depending on
the global size factor and the mesh element size at the boundary layer.

Next, increase the mesh size in the spanwise direction by a factor of 1.5:

3. Open Mesh Data.

4. On the Passage tab, set Spanwise Blade Distribution Parameters > Method to Proportional
and Factor to 1.5.

Note that the disabled # of Elements field indicates the total number of elements in the spanwise
direction. This will now increase.

5. Click Apply.

The number of elements has increased.
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5.6. Using the Locking Feature

Note:

This section is for information only. Do not use the locking feature in this tutorial.

When you are using Ansys Workbench, Ansys TurboGrid enables you to use the Lock mesh size feature.
Once activated, the total number of nodes and elements will remain constant. This holds true even if
the geometry of the blade is changed. The size of the mesh elements will be readjusted, but the total
number will not be changed. The Lock mesh size check box is in the Mesh Data object editor on
the Mesh Size tab.

5.7. The Y+ Functionality

Another method of controlling the mesh size at the boundary layer is specifying the y+ height and
Reynolds number. This option lets you specify the maximum y+ height for the blade, which is then
used to calculate the edge refinement factor. The actual first element offset will not be consistent across
the boundary layer, although it should be equal or less than the maximum specified. The edge refinement
calculation is only an approximation.

You will enable the option for y+, then set the offset to 15. You will also set the Reynolds number to
500,000.

1. Open Mesh Data.

2. On the Mesh Size tab, set Boundary Layer Refinement Control > Near Wall Element Size Spe-
cification > Method to y+.

3. Set Reynolds No. to 5e5.

4. Change Boundary Layer Refinement Control > Method to First Element Offset.

The field for specifying Offset Y+ is enabled.

5. Set Parameters > Offset Y+ to 5.

6. Click Apply.

You should see an increase in the mesh density at the boundary layer.

The mesh now has smaller elements near the boundary layer, as shown in in Figure 5.2: Mesh at
Blade-Hub Intersection After Y+ Specification (p. 47).
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Figure 5.2: Mesh at Blade-Hub Intersection After Y+ Specification

5.8. Using Local Mesh Refinement

Local mesh refinement is especially useful when attempting to manipulate the mesh near a specific
boundary without tampering with the surroundings. Once local mesh refinement has been implemented,
changing the global size factor will affect the localized area as well. However, the locally refined mesh
will remain discernible from its surroundings. You will implement this feature at the shroud boundary,
upstream of the blade as indicated in the figure below. The local mesh size will be increased by 100%.

1. Click Hide all mesh objects .

To be able to see which boundary to modify, it is best to hide the currently generated mesh. Ulti-
mately, only the topology will be visible when refinements are made.

2. Right-click a blank area in the viewer and select Predefined Camera > View from +X from the
shortcut menu.

3. Turn off the visibility of Layers > Hub.

4. Right-click the edge of the shroud tip layer, marked A in Figure 5.3: Edge to be Refined in Shroud
Tip Layer (p. 48), and select Increase Edge Refinement > 100%.
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After a few seconds of processing, you should observe the mesh size increasing by a factor of 2 at
the edge you selected. Only topologically parallel edges are affected by this change.

Figure 5.3: Edge to be Refined in Shroud Tip Layer
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Figure 5.4: After Refinement

5.9. Analyzing the Mesh

Inspect the mesh quality of the 3D mesh:

1. Open Mesh Analysis.

The mesh statistics are acceptable based on the current quality criteria.

2. Close the Mesh Statistics dialog box.

5.10. Adding Inlet and Outlet Domains

As specified in the problem description, the mesh should contain an inlet domain and an outlet domain.

1. Open Mesh Data.

2. On the Mesh Size tab, ensure that Inlet Domain and Outlet Domain are selected.

3. Click Apply.

5.11. Analyzing the New Mesh

1. Open Mesh Analysis.
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Note that the Maximum Edge Length Ratio mesh measure is extremely large. By displaying
this mesh measure, you will see that some of the mesh elements that exceed the criterion are at
the inlet where the mesh meets the rotation axis. This is to be expected wherever the hub reaches
the axis of rotation because at these locations the element edges have zero length.

2. View the mesh on the inlet and outlet (not the passage inlet and outlet, but the inlet and outlet
of the entire mesh) by turning on the visibility of the corresponding 3D Mesh objects.

5.12. Saving the Mesh

Save the mesh:

1. Click File > Save Mesh As.

2. Ensure that Files of type is set to Ansys CFX Mesh Files.

3. Set Export Units to cm.

4. Set File name to fan.gtm.

5. Ensure that your working directory is set correctly.

6. Click Save.

5.13. Saving the State (Optional)

If you want to revisit this mesh at a later date, save the state:

1. Click File > Save State As.

2. Enter an appropriate state filename.

3. Click Save.

Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.50

Axial Fan



Chapter 6: Tandem Vane
This tutorial includes:

6.1. Preparing the Working Directory

6.2. Defining the Geometry

6.3. Creating the Topology and Mesh

6.4. Setting the Mesh Density

6.5. Saving the Mesh

6.6. Saving the State (Optional)

This tutorial teaches you how to:

• Create a mesh involving tandem vanes using a topology template.

As you work through this tutorial, you will create a mesh for a blade set of a radial machine component
that has tandem vanes. A typical blade set is shown by the black outline in the figure below.
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The component has 16 blade sets, each containing one main blade and one tandem vane. Within the
blade passages, the maximum diameter of the shroud is approximately 52.2 cm.

You will begin by loading the geometry from a BladeGen.inf file. You will then select a topology
template and set the mesh density.

If this is the first tutorial you are working with, it is important to review Introduction to the Ansys Tur-
boGrid Tutorials (p. 7) before beginning.

6.1. Preparing the Working Directory

1. Create a working directory.

Ansys TurboGrid uses a working directory as the default location for loading and saving files for a
particular session or project.

2. Download the tandem.zip file here.

3. Unzip tandem.zip to your working directory.

Ensure that the following tutorial input files are in your working directory:

• BladeGen.inf
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• shroud.curve

• hub.curve

• profile.curve

4. Set the working directory and start Ansys TurboGrid.

For details, see Setting the Working Directory and Starting Ansys TurboGrid (p. 7).

6.2. Defining the Geometry

1. Click File > Load TurboGrid Init File.

2. Open BladeGen.inf from the working directory.

6.3. Creating the Topology and Mesh

While TurboGrid can automatically generate acceptable meshes for basic turbomachinery, you may
need to specify topology templates for complex blade configurations, such as tandem vanes.

Select the appropriate template as follows:

1. In the Mesh workspace, open Topology Set.

2. Set ATM Topology > Method to Tandem Vane Aligned High.

3. Click Apply.

4. Right-click Topology Set and turn off Suspend Object Updates.

The topology and 3D mesh are generated.

The error indicated for Mesh Data > Main Blade Boundary Layer Control is caused by the
near-wall expansion rates. This will be resolved in the next section.

6.4. Setting the Mesh Density

1. Open Mesh Data.

2. On the Mesh Size tab, set Method to Global Size Factor.

3. Set Size Factor to 1.35.

4. Click Apply.

6.5. Saving the Mesh

Save the mesh:
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1. Click File > Save Mesh As.

2. Ensure that Files of type is set to Ansys CFX Mesh Files.

3. Set Export Units to cm.

4. Set File name to tandemvane.gtm.

5. Ensure that your working directory is set correctly.

6. Click Save.

6.6. Saving the State (Optional)

If you want to revisit this mesh at a later date, save the state:

1. Click File > Save State As.

2. Enter an appropriate state filename.

3. Click Save.
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Chapter 7: Secondary Flow Path Meshing
This tutorial includes:

7.1. Preparing the Working Directory

7.2. Preparing the Geometry in BladeEditor

7.3. Defining the Geometry in TurboGrid

7.4. Creating the Topology and Initial Mesh

7.5. Aligning Topology at the Upstream Shroud Interface

7.6. Reviewing the Shroud Interfaces

7.7. Secondary Flow Path Mesh Parameters

This tutorial demonstrates the basic workflow for generating a CFD mesh for a shrouded centrifugal
compressor using Ansys BladeEditor and Ansys TurboGrid. Part of the shroud is attached to the blades.
An axisymmetric shroud cavity separates the stationary parts of the shroud from the rotating part. As
you work through this tutorial, you will use BladeEditor to outline a cross section of the shroud cavity
on an axial-radial plane. You will then use TurboGrid to produce a mesh that includes a secondary flow
path. The resulting mesh is usable by Ansys CFX in a CFD simulation.

A schematic diagram of the case is shown below.
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If this is the first tutorial you are working with, it is important to review Introduction to the Ansys Tur-
boGrid Tutorials (p. 7) before beginning.

7.1. Preparing the Working Directory

1. Create a working directory.

Ansys TurboGrid uses a working directory as the default location for loading and saving files for a
particular session or project.

2. Download the secondary_path.zip file here.

3. Unzip secondary_path.zip to your working directory.

Ensure that the following tutorial input file is in your working directory:

• shrouded impeller with cavity.wbpz
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Alternatively, if you want to run TurboGrid in stand-alone mode (without having to run DesignModel-
er/BladeEditor), the following files are needed:

• secondarypath_turbogrid.tginit

• secondarypath_turbogrid.x_b

If running in stand-alone mode:

1. Launch TurboGrid.

2. Load the .tginit file.

You can expect a message stating "Geometry filepath was not specified". Click OK to dismiss it.

3. Continue this tutorial from Associating CAD Objects with Topology in TurboGrid’s Geometry
Workspace (p. 61).

7.2. Preparing the Geometry in BladeEditor

In the following sections, you will load an Ansys Workbench project file that contains the Ansys
BladeEditor geometry, then in Ansys BladeEditor, you will define line bodies and curve groups that will
be used by TurboGrid in creating a mesh.

7.2.1. Loading the Provided Project File

7.2.2. Creating Line Bodies and Curve Groups

7.2.1. Loading the Provided Project File

1. Start Ansys Workbench.

• To launch Ansys Workbench on Windows, click the Start menu, then select All Programs >
ANSYS 2021 R2 > Workbench 2021 R2.

• To launch Ansys Workbench on Linux, open a command line interface, type the path to runwb2
(for example, ~/ansys_inc/v212/Framework/bin/Linux64/runwb2), then press
Enter.

2. From the main menu, select File > Open.

The Open dialog box appears.

3. Browse to the working directory, set File name to shrouded impeller with cavity.wbpz,
and click Open.

The Save As dialog box appears.

4. Accept the default name and click Save.
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7.2.2. Creating Line Bodies and Curve Groups

The true secondary flow path has an axisymmetric geometry. In this section, you will use BladeEditor
to create a 2D closed loop, consisting of line bodies, that outlines the secondary flow path on an
axial-radial plane. A 2D sketch of the secondary flow path is provided with the project just opened.

A secondary flow path can have one or more interfaces to the shroud or hub. In this tutorial, there
are two interfaces to the shroud. In order to define any given interface to the shroud, the outline
must not simply run closely along the shroud curve for the extent of the interface. Instead, to avoid
an ill definition (sensitive to numerical round-off ) of the interface location, the outline is required to
cross the shroud curve into the main passage at one end of the interface, then cross back over the
shroud curve at the other end of the interface. For meshing purposes, the outline will be, in effect,
trimmed by the shroud curve. For an interface of a secondary flow path to the hub, a similar require-
ment applies.

A Geometry system is visible in the Project Schematic view.

1. Right-click the Geometry cell, and select Edit Geometry in DesignModeler... to launch Design-
Modeler.

You are now ready to edit the geometry using BladeEditor (which is accessed via DesignModeler).

2. In DesignModeler, select Concept > Lines From Sketches.

The details view shows the properties for a new line object. The Base Objects property is ready
to be defined.

3. In the tree view, select A:Shrouded Impeller > MerPlane1 > S1_ShroudCavity.

4. In the details view, beside Base Objects, click Apply.

Property Base Objects is now set to 1 Sketch. The selected sketch, S1_ShroudCavity, will appear
in the tree view under the line object after you generate the latter.

5. Click Generate.

6. Select Tools > Attribute.

The details view shows the properties for a new attribute object.

7. Set Attribute Feature Name to ImpellerShroudGroup.

8. Set Attribute Name to NamedSelection:ImpellerShroud2D.

Note that the prefix "NamedSelection:" is required.

9. For property Geometry, select all 12 of the curves (edges) of the sketch for the secondary passage
(S1_ShroudCavity) that are between the shroud interfaces and that are on the main passage side
of the cavity, as shown below.
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a. Start by clicking the field, beside property Geometry, that currently states "None (Document
Level Attribute)".

The field will change into two buttons: Apply and Cancel.

b. Click Single Select  to start preparing for the selection of curves
from the viewer.

c. Click the selection filter for edges  to finish preparing for the selection of curves from
the viewer.

d. Click a curve in the viewer, then, while holding Ctrl, click each of the other 11 curves to add
them to the selection.

With the appropriate curves selected for property Geometry, click Apply, then click Generate.

10. Create three other attribute objects as follows:

a. Attribute Feature Name=InterfaceLEGroup; Attribute Name=NamedSelection:InterfaceLE2D;
Geometry=curve shown
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b. Attribute Feature Name=InterfaceTEGroup; Attribute Name=NamedSelection:InterfaceTE2D;
Geometry=curve shown

c. Attribute Feature Name=CasingGroup; Attribute Name=NamedSelection:Casing2D; Geo-
metry=36 curves shown
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7.3. Defining the Geometry in TurboGrid

1. Right-click the Geometry cell, and select Transfer Data To New > TurboGrid.

A new TurboGrid system appears with a link from the upstream Geometry system.

2. Right-click the Turbo Mesh cell, and select Edit to launch TurboGrid.

Before a mesh can be generated in TurboGrid, the geometry must be defined as per the following
sections:

7.3.1. Associating CAD Objects with Topology in TurboGrid’s Geometry Workspace

7.3.2. Completing the Geometry Definition in TurboGrid’s Mesh Workspace

7.3.1. Associating CAD Objects with Topology in TurboGrid’s Geometry
Workspace

1. In TurboGrid, click the Geometry tab to switch to the Geometry workspace.

2. In the object selector, right-click Topological Entity Instances > Secondary Flow Paths and
select Insert Secondary Passage.

The Create New Secondary Passage Topology dialog box appears.

3. Set Name to Shroud Cavity and click OK.

Incomplete secondary flow path object Shroud Cavity appears in the tree under Secondary
Flow Paths. This object requires boundary entity definitions. In this case, you will add four
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boundary entity definitions: one for each of the two interfaces with the shroud, and one for each
side of the cavity (casing side and shroud side).

4. Right-click CAD Families > CASING2D and select Create Entity and Assign Family > Shroud
Cavity.

The Create New Secondary Passage Boundary dialog box appears.

5. Accept the default name (CASING2D1) and click OK.

Boundary entity CASING2D1 is listed in the tree under Shroud Cavity. Incomplete secondary
flow path object Shroud Cavity indicates an error (via red text) because it does not currently
represent a closed loop.

6. Using the same technique as for the previous two steps, create three other boundary entities
under Shroud Cavity: IMPELLERSHROUD2D1, INTERFACELE2D1, INTERFACETE2D1.

For example, create boundary entity IMPELLERSHROUD2D1 using CAD Family IMPELLER
SHROUD2D.

When you are finished this step, secondary flow path object Shroud Cavity will represent a
closed loop and will no longer indicate an error.

7.3.2. Completing the Geometry Definition in TurboGrid’s Mesh Workspace

Set the type for each of the four boundaries of the shroud cavity:

1. In TurboGrid, click the Mesh tab to switch to the Mesh workspace.

2. In the object selector, under Geometry > Secondary Flow Paths > Shroud Cavity:

a. Open CASING2D1 and ensure that its Boundary Type is set to Wall.

b. Open IMPELLERSHROUD2D1 and ensure that its Boundary Type is set to Wall.

c. Open INTERFACELE2D1, set its Boundary Type to Shroud Interface and click Apply.

d. Open INTERFACETE2D1, set its Boundary Type to Shroud Interface and click Apply.

Switch to the axial-radial view so that you can better see the location of the cavity with respect to
the main passage:

• In the upper-left corner of the 3D Viewer, select View 3, then click Fit View .

The inlet and outlet blocks should preferably contain the interfaces to the cavity:

• This is the case for the inlet block, which contains INTERFACELE2D1. As a result, the shroud can
be (and will be, later in this tutorial) automatically divided into regions that align with the edges
of INTERFACELE2D1. Such alignment helps to improve mesh quality near the interface.

• This is not the case for the outlet block, which fails to contain INTERFACETE2D1. In this case, the
upstream edge of INTERFACETE2D1 is already aligned with the topology in the main passage
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(the cut-off trailing edge). In order to create topological alignment between the other edge of
INTERFACETE2D1 and the topology in the main passage, you will next move the passage outlet
to that edge.

Move the passage outlet as follows:

1. Open Geometry > Outlet.

2. Select Interface Specification Method > Points.

3. Select Low Hub Point, then set Method to Set R and Location to 0.054.

4. Click Apply.

5. Select Low Shroud Point, then set Method to Set R and Location to 0.054.

6. Click Apply.

The passage outlet should now be located as shown by Figure 7.1: Passage Outlet at Downstream
Edge of Shroud Cavity (p. 63).

Figure 7.1: Passage Outlet at Downstream Edge of Shroud Cavity

This completes the geometry definition.

7.4. Creating the Topology and Initial Mesh

The Topology Set object is initially suspended in order to save computational effort while defining
the geometry. When you unsuspend the Topology Set object, the remaining computations are
performed, resulting in a 3D mesh.

Make changes to the Topology Set, Layers, and Mesh Data objects as follows:
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1. Open Topology Set.

2. Select Split Mesh Regions At Trailing Edge and click Apply.

This causes the shroud region in the main passage to be subdivided so that the cavity can be
joined downstream of the cut-off trailing edge to a mesh region called "SHROUD DOWNSTREAM".

3. Open Layers.

4. Set Insertion Mode to Manual - Uniform.

5. Set Count to 1.

6. Click Apply.

7. Open Mesh Data.

8. On the Mesh Size tab, set Method > Size Factor to 1.3 and Parameters > Factor Base to 4.0.

9. Ensure that Inlet Domain and Outlet Domain are selected.

10. Click Apply.

Next, generate the mesh:

• Right-click Topology Set and turn off Suspend Object Updates.

The 3D mesh is generated. The number of nodes and elements are displayed at the bottom left.

Figure 7.2: Meridional View of Mesh (with Blade LE and TE) (p. 65) shows the current mesh.

Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information
of ANSYS, Inc. and its subsidiaries and affiliates.64

Secondary Flow Path Meshing



Figure 7.2: Meridional View of Mesh (with Blade LE and TE)

7.5. Aligning Topology at the Upstream Shroud Interface

As shown in Figure 7.3: Upstream Shroud Cavity Interface with Inlet Block - Misaligned Topology (p. 66),
the cavity and main passage meshes are not topologically aligned at the edges of the interface.

65
Release 2021 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information

of ANSYS, Inc. and its subsidiaries and affiliates.

Aligning Topology at the Upstream Shroud Interface



Figure 7.3: Upstream Shroud Cavity Interface with Inlet Block - Misaligned Topology

1. Open Geometry > Secondary Flow Paths > Shroud Cavity > INTERFACELE2D1.

2. Select Automatically Manage Opening Region and click Apply.

A new shroud region, AUTO INTERFACELE2D1, is generated and can be reviewed in the Geo
metry > Shroud object editor on the Shroud Regions tab.

As shown in Figure 7.4: Upstream Shroud Cavity Interface with Inlet Block - Aligned Topology (p. 67),
the cavity and main passage meshes are now topologically aligned at the edges of the interface.
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Figure 7.4: Upstream Shroud Cavity Interface with Inlet Block - Aligned Topology

7.6. Reviewing the Shroud Interfaces

The interface connecting regions are listed under 3D Mesh:

• Leading edge interface regions:

– AUTO INTERFACELE2D1

– Shroud Cavity > Shroud Cavity INTERFACELE2D1

• Trailing edge interface regions:

– SHROUD DOWNSTREAM

– Shroud Cavity > Shroud Cavity INTERFACETE2D1

7.7. Secondary Flow Path Mesh Parameters

Adjust the mesh for the secondary flow path as follows:

1. Open Mesh Data > Shroud Cavity.
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2. Increase the overall mesh refinement by increasing Default Boundary Edge Refinement
Factor to 2.

3. Increase boundary layer refinement and decrease the height of the first layer of elements along
all shroud cavity boundaries by increasing Inflation Options > Default Number Of Boundary
Layers to 6.

You can review the height of the first layer of elements along a shroud cavity boundary by looking
in the object editor for Mesh Data > Shroud Cavity > [Boundary name].

4. Decrease the boundary layer element growth rate by decreasing Inflation Options > Default In-
flation Growth Ratio to 1.3.

5. Increased refinement in the labyrinth seal tooth gaps by increasing Advanced Options > Default
Cells Per Gap (Proximity Refinement) to 6.

6. Click Apply.

The current design only requires a thin mesh. For cases that require a mesh that is thicker in the circum-
ferential direction, 3D options are available.
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